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Cautions

Keep safety first in your circuit designs!

1

Renesas Technology Corp. puts the maximum effort into making semiconductor products better and more reliable, but
there is always the possibility that trouble may occur with them. Trouble with semiconductors may lead to persona
injury, fire or property damage.

Remember to give due consideration to safety when making your circuit designs, with appropriate measures such as (i)
placement of substitutive, auxiliary circuits, (ii) use of nonflammable material or (iii) prevention against any
malfunction or mishap.

Notes regarding these materials

1

These materials are intended as a reference to assist our customers in the selection of the Renesas Technology Corp.
product best suited to the customer's application; they do not convey any license under any intellectual property rights,
or any other rights, belonging to Renesas Technology Corp. or athird party.

Renesas Technology Corp. assumes no responsibility for any damage, or infringement of any third-party'srights,
originating in the use of any product data, diagrams, charts, programs, algorithms, or circuit application examples
contained in these materials.

All information contained in these materials, including product data, diagrams, charts, programs and algorithms
represents information on products at the time of publication of these materials, and are subject to change by Renesas
Technology Corp. without notice due to product improvements or other reasons. It is therefore recommended that
customers contact Renesas Technology Corp. or an authorized Renesas Technology Corp. product distributor for the
latest product information before purchasing a product listed herein.

The information described here may contain technical inaccuracies or typographical errors.

Renesas Technology Corp. assumes no responsibility for any damage, liability, or other loss rising from these
inaccuracies or errors.

Please also pay attention to information published by Renesas Technology Corp. by various means, including the
Renesas Technology Corp. Semiconductor home page (http://www.renesas.com).

When using any or all of the information contained in these materials, including product data, diagrams, charts,
programs, and agorithms, please be sure to evaluate all information as atotal system before making afinal decision on
the applicability of the information and products. Renesas Technology Corp. assumes no responsibility for any
damage, liability or other loss resulting from the information contained herein.

Renesas Technology Corp. semiconductors are not designed or manufactured for usein a device or system that is used
under circumstancesin which human lifeis potentially at stake. Please contact Renesas Technology Corp. or an
authorized Renesas Technology Corp. product distributor when considering the use of a product contained herein for
any specific purposes, such as apparatus or systems for transportation, vehicular, medical, aerospace, nuclear, or
undersea repeater use.

The prior written approval of Renesas Technology Corp. is necessary to reprint or reproduce in whole or in part these
materias.

If these products or technol ogies are subject to the Japanese export control restrictions, they must be exported under a
license from the Japanese government and cannot be imported into a country other than the approved destination.

Any diversion or reexport contrary to the export control laws and regulations of Japan and/or the country of destination
is prohibited.

. Please contact Renesas Technology Corp. for further details on these materials or the products contained therein.







IMPORTANT INFORMATION
READ FIRST

* READ thisuser's manual before using thisemulator product.
« KEEP the user's manual handy for futurereference.

Do not attempt to use the emulator product until you fully under stand its mechanism.

Emulator Product:
Throughout this document, the term "emulator product” shall be defined as the following
products produced only by Renesas Technology Corp. excluding all subsidiary products.

e Emulator station

e User system interface cables

* PCinterface board

e Optional SIMM memory module
e Optiona board

The user system or a host computer is not included in this definition.

Purpose of the Emulator Product:

This emulator product is a software and hardware development tool for systems employing the
Renesas microcomputer (hereinafter referred to asthe MCU). This emulator product must only be
used for the above purpose.

Limited Applications:

This emulator product is not authorized for usein MEDICAL, atomic energy, aeronautical or
space technology applications without consent of the appropriate officer of a Renesas sales
company. Such useincludes, but isnot limited to, use in life support systems. Buyers of this
emulator product must notify the relevant Renesas sales offices before planning to use the product
in such applications.

Improvement Policy:

Renesas Technology Corp. (including its subsidiaries, hereafter collectively referred to as
Renesas) pursues a policy of continuing improvement in design, performance, and safety of the
emulator product. Renesas reserves the right to change, wholly or partialy, the specifications,
design, user's manual, and other documentation at any time without notice.

Target User of the Emulator Product:

This emulator product should only be used by those who have carefully read and thoroughly
understood the information and restrictions contained in the user's manual. Do not attempt to use
the emulator product until you fully understand its mechanism.

It is highly recommended that first-time users be instructed by usersthat are well versed in the
operation of the emulator product.
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LIMITED WARRANTY

Renesas warrants its emulator products to be manufactured in
accordance with published specifications and free from defectsin
material and/or workmanship. Renesas, at its option, will repair or
replace any emulator products returned intact to the factory,
transportation charges prepaid, which Renesas, upon inspection,
determine to be defective in material and/or workmanship.

The foregoing shall constitute the sole remedy for any breach of
Renesas warranty. See the Renesas warranty booklet for details on
the warranty period. Thiswarranty extends only to you, the original
Purchaser. It isnot transferable to anyone who subsequently purchases
the emulator product from you. Renesasis not liable for any claim
made by athird party or made by you for athird party.

DISCLAIMER

RENESAS MAKES NO WARRANTIES, EITHER EXPRESS OR
IMPLIED, ORAL OR WRITTEN, EXCEPT AS PROVIDED
HEREIN, INCLUDING WITHOUT LIMITATION THEREOF,
WARRANTIESASTO MARKETABILITY, MERCHANTABILITY,
FITNESS FOR ANY PARTICULAR PURPOSE OR USE, OR
AGAINST INFRINGEMENT OF ANY PATENT. IN NO EVENT
SHALL RENESASBE LIABLE FOR ANY DIRECT, INCIDENTAL
OR CONSEQUENTIAL DAMAGES OF ANY NATURE, OR
LOSSES OR EXPENSES RESULTING FROM ANY DEFECTIVE
EMULATOR PRODUCT, THE USE OF ANY EMULATOR
PRODUCT, OR ITSDOCUMENTATION, EVEN IF ADVISED
OF THE POSSIBILITY OF SUCH DAMAGES. EXCEPT AS
EXPRESSLY STATED OTHERWISE IN THISWARRANTY,
THISEMULATOR PRODUCT ISSOLD "ASIS", AND YOU
MUST ASSUME ALL RISK FOR THE USE AND RESULTS
OBTAINED FROM THE EMULATOR PRODUCT.
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State Law:

Some states do not allow the exclusion or limitation of implied warranties or liability for
incidental or consequential damages, so the above limitation or exclusion may not apply to you.
Thiswarranty gives you specific legal rights, and you may have other rights which may vary from
State to state.

The Warranty is Void in the Following Cases:

Renesas shall have no liability or legal responsibility for any problems caused by misuse,
abuse, misapplication, neglect, improper handling, installation, repair or modifications of the
emulator product without Renesas' prior written consent or any problems caused by the user
system.

All Rights Reserved:

This user's manual and emulator product are copyrighted and all rights are reserved by
Renesas. No part of this user's manual, all or part, may be reproduced or duplicated in any form,
in hard-copy or machine-readable form, by any means available without Renesas prior written
consent.

Other Important Things to Keep in Mind:

1. Circuitry and other examples described herein are meant merely to indicate the characteristics
and performance of Renesas' semiconductor products. Renesas assumes no responsibility for
any intellectual property claims or other problems that may result from applications based on
the examples described herein.

2. Nolicenseisgranted by implication or otherwise under any patents or other rights of any third
party or Renesas.
Figures:

Some figures in this user's manua may show items different from your actual system.

Limited Anticipation of Danger:

Renesas cannot anticipate every possible circumstance that might involve a potential hazard.
The warnings in this user's manual and on the emulator product are therefore not all inclusive.
Therefore, you must use the emulator product safely at your own risk.

m
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SAFETY PAGE
READ FIRST

* READ thisuser's manual before using this emulator product.

« KEEP the user's manual handy for futurereference.

Do not attempt to use the emulator product until you fully understand its mechanism.

DEFINITION OF SIGNAL WORDS

A This is the safety alert symbol. Itis used to alert you to potential personal
injury hazards. Obey all safety messages that follow this symbol to avoid
possible injury or death.

A DANGER DANGER indicates an imminently hazardous situation which, if not

avoided, will result in death or serious injury.

A WARNING WARNING indicates a potentially hazardous situation which, if not
avoided, could result in death or serious injury.
A CAUTION CAUTION indicates a potentially hazardous situation which, if not
avoided, may result in minor or moderate injury.
CAUTION CAUTION used without the safety alert symbol indicates a

potentially hazardous situation which, if not avoided, may result
in property damage.

NOT E emphasizes essentia information.
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AWARNING

Observe the precautions listed below. Failure to do so
will result in a FIRE HAZARD and will damage the user
system and the emulator product or will result in
PERSONAL INJURY. The USER PROGRAM will be
LOST.

1. Do not repair or remodel the emulator product by
yourself for electric shock prevention and quality
assurance.

2. Always switch OFF the E6000 emulator and user system
before connecting or disconnecting any CABLES or
PARTS.

3. Always before connecting any CABLES, make sure that
pin 1 on both sides are correctly aligned.

4. Supply power according to the power specifications and
do not apply an incorrect power voltage. Use only the
provided power cable.
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CAUTION

This equipment has been tested and found to comply
with the limits for a Class A digital device, pursuant to part 15
of the FCC Rules. These limits are designed to provide
reasonable protection against harmful interference when the
equipment is operated in a commercial environment. This
equipment generates, uses, and can radiate radio frequency
energy and, if not installed and used in accordance with the
instruction manual, may cause harmful interference to radio
communications. Operation of this equipment in a residential
area is likely to cause harmful interference in which case the
user will be required to correct the interference at his own
expense.

A
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I ntroduction

The E6000 emulator is an advanced realtime in-circuit emulator, which allows programs to be developed and debugged
for the H8S family microcomputers.

The E6000 emulator can either be used without a user system, for developing and debugging software, or connected viaa
user system interface cable to auser system, for debugging user hardware.

High-performance Embedded Workshop (hereafter referred to as HEW) is a Graphical User Interface intended to ease the
development and debugging of applications written in C/C++ programming language and assembly language for Renesas
microcomputers. Itsaim isto provide a powerful yet intuitive way of accessing, observing and modifying the debugging
platform in which the application is running.

HEW is apowerful development environment for embedded applications targeted at Renesas microcontrollers. The main
features are:

* A configurable build engine that allows you to set-up compiler, assembler and linker options via an easy to use
interface.

* Anintegrated text editor with user customizable syntax coloring to improve code readability.
* A configurable environment to run your own tools.

» Anintegrated debugger which allowsyou to build and debug in the same application.

* Version control support.

HEW has been designed with two key aims; firstly to provide you, the user, with a set of powerful development tools and,
secondly, to unify and present them in away that is easy to use.
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About This Manual

Thismanual is comprised of two parts: HEW Part and Emulator Debugger Part.

HEW Part: Information on the basic “look and feel” of the HEW and customizing the HEW environment,
and detail of the HEW’ s build function.

Emulator Debugger Part: Preparation before use, EG000 emulator functions, debugging function, tutorial, and hardware
and software specifications of the E6000 emulator.

This manual does not intend to explain how to write C/C++ or assembly language programs, how to use any particular

operating system or how best to tailor code for the individua devices. These issues are left to the respective manuals.

Microsoft®, MS-DOS, Windows®, Windows NT® are registered trademarks of Microsoft Corporation.
Visual SourceSafeisatrademark of Microsoft Corporation.
IBM isaregistered trademark of International Business Machines Corporation.

All brand or product names used in this manual are trademarks or registered trademarks of their respective companies or
organizations.

Document Conventions
This manual uses the following typographic conventions:

Tablel Typographic Conventions

Convention Meaning
[Menu->Menu Option] Bold text with *->’ is used to indicate menu options
(for example, [File->Save As...]).
FILENAME.C Uppercase names are used to indicate filenames.
“enter this string” Used to indicate text that must be entered (excluding the “” quotes).
Key + Key Used to indicate required key presses. For example, CTRL+N means

press the CTRL key and then, whilst holding the CTRL key down,
press the N key.

) When this symbol is used, it is always located in the left hand margin.
It indicates that the text to its immediate right is describing “how to”

(The “how to” symbol) .
do something.

Components

Check all the components described in the component list unpacking. If the components are not complete, contact a
Renesas sdles office.
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1. Overview

This chapter describes the fundamental concepts of the High-performance Embedded Workshop. It isintended to
give users who are new to Windows® extra help, filling in the details that are required by later chapters.

11 Workspaces, Projectsand Files

Just as aword processor allows you to create and modify documents, the High-performance Embedded
Workshop allows you to create and modify workspaces. A workspace can be thought of as a container of
projects and, similarly, a project can be though of as a container of project files. Thus, each workspace contains
one or more projects and each project contains one or more files. Figure 1.1 illustrates this graphically.

c

PROJECT

c

PROJECT

PROJECT

WORKSPACE

Figure 1.1: Workspaces, Projectsand Files

Workspaces allow you to group related projects together. For example, you may have an application that needs
to be built for different processors or you may be developing an application and library at the same time. Projects
can also belinked hierarchically within aworkspace, which means that when one project is built al of its“child”
projects are built first.

However, workspaces on their own are not very useful, we need to add a project to a workspace and then add
filesto that project before we can actually do anything.
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1.2 The Main Window

The HEW main window appears as shown in figure 1.2.

@demu - High-performance Embedded Workshop - [1esetprg.c] |_ (O] x|
<7 File Edit “iew Project Options Buld Tools 'window Help 1= x|
SR R T = — Y e —-
e noer ||[PEaaEb-.  FxEslEaessal|omE
= zl
void PowerON_Reset_PC{void)
E!@ demo i
E"@ demo set_vbr{{void =) (INT VYectors — INT_COFFSET)):
Ea Assembly source file _INITSCT():
+] stacksctsrc )
£3 C sourcs file s _CALL_INIT{): < Remowe ths comment when you use
< _INIT_IOLIE(}: s T=e SIM I-0
< errno=0; </ Remowe ths comment when you use
< srand(l): ## Remove the comment when you use
s _=lptr=HULL: <7 Remowe the comment when you use
wvectthl.c < HardwarsSetup(): A+ Uze Hardware Setup
a Dependencies set_cri{SE_Init):
sbrk.h .
: wecth naing):
##  _CLOSEALLL): s T=e SIM I-0
- < _CALL_END(}: < Remove the comment when you use|,
ProieclslNavigatmn | 4| »
E-|
IZ|
Build £ Debug A Find in Files }, Yersion Contral 7
Ready |Fiead-write: |14/88 |1 INS s

Figure1.2: HEW Main Window

There are three main windows; the workspace window, the editor window and the output window. The
workspace window shows the projects and files which are currently in the workspace, the editor window
provides file viewing and editing facilities and the output window shows the results of a various processes (e.g.
build, version control commands and so on).

121 TheTitle Bar

Thetitle bar displays the name of the currently open workspace, project and file. It aso contains the standard
minimize, maximize and close buttons. Click the minimize button to minimize the HEW on the windows start
bar. Click the maximize button to force HEW to fill the screen. Click the close button to close the HEW (this has
the same effect as selecting [File->EXxit] or pressing AL T+F4).

122 The Menu Bar

The menu bar contains nine menus: File, Edit, View, Project, Options, Build, Tools, Window and Help. All of
the menu options are grouped logically under these headings. For instance, if you wanted to open afile then the
file menu iswhere you will find the right menu option, if you wanted to set-up atool then the tools menu isthe
correct selection. The following sectionswill cover the functions of the various menu options, as they become
relevant. However, at this stage, it is worth taking a few moments to familiarize yourself with the options that
each menu provides.
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123 TheToolbars

The toolbars provide a shortcut to the options, which you will use the most often. There are eight default
toolbars: Bookmarks, Debug, Debug Run, Editor, Search, Standard, Templates, and VVersion Control (as shown
in figure 1.3 to 1.10). Toolbars can be created, modified and removed viathe [Tools->Customize...] menu
option (see chapter 5, “Customizing the Environment”, for further information).

Mext Bookmark  Previous Bookmark

Toegle Bookmark Glear All Bookmarks

n&a®

Figure 1.3: Bookmarks T oolbar

Toeele Breakpoint Command Line

Enable/Dizable Breakpoint
View Dizaszembly

| Radix
|

o6l 6 08 2

Figure 1.4: Debug Toolbar

Feset GPU Step QOver

Go to Cursor Step QOut

Feset Go Set PG to Gursor

Step Halt
| 1

ETELEEL & O P D L

Go
|

Figure 1.5: Debug Run Toolbar

Mew File Print Find Toegle Bookmark
Open File Cut Find in File
\Save File Copy Match Braces
\ Save ‘

Palste | Ihzert Template

|
DERHG S 2| Mm% {1 To

Figure 1.6: Editor Toolbar

Find in Files Find Mext

| Search String Find ‘ Find Previous
| | |

Cay Istring vl Tt

Figure 1.7: Search Toolbar
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Build Build & Current Congifuration current Session | —PMneh Elave Hew s Warkspace
EluildI File Sltl:lp Launch Debugger Wiewy Cutput

| |
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Figure 1.8: Standard Toolbar

Template Selection
Define Template Ihzert Template

| |
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Figure 1.9: Templates Toolbar

fidd File (=) Check Out Filels)

Remove Fileis) Check In File(z)
\Get File (=) STDW Status
|

BE &S a @

Figure 1.10: Version Control Toolbar

When the Standard toolbar or atoolbar is docked, it has a control bar as shown in figure 1.11 (i). If you want to
move the docked Standard toolbar, click and drag its control bar to the new location. Figure 1.11 (i) showsthe
Standard toolbar when it is docked and figure 1.11 (ii) shows the Standard toolbar when it is floating.

» |[SE & o dalmm|

Standard

W @

B3 % |[Debug sl o=

Figure 1.11: Standard Toolbar, Docked and Floating

2 To dock the menu bar or atoolbar:
1. Double-click on thetitle bar of afloating menu bar or toolbar.
or:

2. Dragthetitle bar of afloating menu bar or toolbar and draw it toward an edge of a docked window, menu
bar, toolbar or the HEW main frame, on whose edge you would like to dock the window, until the shape
of the floating bar changes.

2 Tofloat the menu bar or atoolbar:
1. Double-click on the control bar of a docked menu bar or toolbar.
or:

2. Drag the control bar of adocked menu bar or toolbar and draw it away from the edge of the HEW main
frame and from an edge of the other docked windows, menu bar or toolbar.
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124 The Workspace Window

The “Workspace” window when the HEW is launched only hasa single pane. Thisisthe “Projects’ tab. If a
workspace is opened then the workspace window displays two default tabs. The “Projects’ tab shows the
current workspace, projects and files (figure 1.12). Y ou can quickly open any project file or dependent file by
double clicking on its corresponding icon.

E@ dema

E@ Projectl
Ea Praject Files
| ! cl.=rc
main.c
sh_hwefe.c
sh_intv.sre
= a Dependenmes
H f||e1 h

S . file2h

Mavigation tab

Projects tab ——|

@ Projects l =] Mawigation I

Figure 1.12: Workspace Window Projects Tab

The “Navigation” tab provides jumpsto various textual constructs within your project’ s files. What is actually
displayed within the navigation tab depends upon what components are currently installed. Figure 1.13 shows
ANSI C functions. See chapter 2, “Build Basics’, for more information on the “Workspace” window.

..... an[]
----- a hw ' initializel)
----- ] Ing_ennl[WElFiD e

""" %] SCI0_ISR_ERI)
""" ] SCI0ISR_RAI)
""" ] SCI0_ISR_TEN)
""" ] SCI0_ISR_T=I)
----- ] SCI_ClearBuffers()
""" %] SCI_GetBlock()

----- “1 50 GetF!:-tE!ueSlze[]
@pmje.;ts QNawgahun I

Figure 1.13: Workspace Window Navigation Tab

2 Toalow the “Workspace” window or the “Output” window docking:
Click the right mouse button anywhere inside the “Workspace” window or the “ Output” window. Then a
pop-up menu will be displayed. If [Allow Docking] is checked, docking is allowed; otherwise, docking is not
allowed. Select [Allow Docking] to check or uncheck it.

When [Allow Docking] is checked, you can dock awindow, atoolbar or amenu bar to the edge of the HEW
main window or to the edge of another docked window. Alsoif [Allow Docking] is checked, you can float them
“above’ the other HEW windows or outside the HEW main window. Figure 1.14 (i) shows a docked
“Workspace” window, and figure 1.14 (ii) shows a floating “Workspace” window.
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Figure 1.14: Workspace Window, Docked and Floating

When the “Workspace” window or the “Output” window is docked, it has a control bar as shown in figure 1.15.
If you want to move a docked window, click and drag its control bar to the new location.

'Close’ butten

-1 |

Figure 1.15: Control Bar of Docking Window

2 Todock the “Workspace’ window or the “ Output” window:
[Allow Docking] must be checked on the pop-up menu of the window to dock the “Workspace” window or
the “Qutput” window. (The pop-up menu will be displayed when you click the right mouse button anywhere
insde the window.) Then you have two ways to dock the window.

1. Double-click on the control bar of afloating window.
or:

2. Dragthetitle bar of afloating window and draw it toward an edge of a docked window, menu bar or
toolbar, or the HEW main frame, on whose edge you would like to dock the window, until the shape of
the floating window changes.
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2 Tofloat the “Workspace” window or the “ Output” window:
[Allow Docking] must be checked on the pop-up menu of the window to float the “Workspace” window or
the “QOutput” window. (The pop-up menu will be displayed when you click the right mouse button anywhere
insde the window.) Then you have two waysto float the window.

1. Double-click on the control bar of a docking window.
or:
2. Drag the control bar of adocked window and draw it away from the edge of the HEW main frame and
from an edge of the other docked windows, menu bar or toolbar.
2 To hide the “Workspace” window or the “Output” window:
Click on the close button, which islocated in the top right corner of the window. Or push the right mouse
button anywhere inside a floating window and select [Hide] on the pop-up menu.

2 Todisplay the “Workspace” window or the “Output” window:
Select [View->Workspace] or [View->Output], respectively.

125 The Editor Window

The editor window is where you will work with the files of your project. The HEW allows you to have many
files open at one time, to switch between them, to arrange them and to edit them in whichever order you want to.
By default, the editor window is displayed in a notebook style, where each text file has a separate tab (as shown
in figure 1.16).

The editor contains a gutter on the left-hand side of the window. The gutter in HEW can be configured to
contain many columns. Each column can refer to a different component’s capability. Infigure 1.16 the editor is
displayed with the debugger address column and the standard column. The standard column allows the user to
configure the position of bookmarks and software breakpoints quickly and easily.

] —
F w) I
4 FILE isbrk.c wy
e DATE tThu, Auz 16, 2001 #/
J#  DESCRIPTION :Program of shrk wy
f#  CPU TYPE TEHTO20 wy
f L2
i* This file is generated by Hitachi Project Generator (¥er.2.1). *i
£ £
i !

tinclude <stddef.h>
finclude <stdio.h>
tinclude “sbrk.h”

extern char #_slptr;
extern void srand{unsizned int}; b

static wunion |

long  dummy : S Dummy for 4-byte boundary #/
char heap[HEAPSIZE]; /# Declaration of the area manazed %/
i by shrk #/
theap_area ;
static char #brk={char #)kheap_area;/#% End address of area assizned wy
i i
KN | »

< resetprgcl-::'}' dbsctc <+ shrkc I

Figure 1.16: Editor Window
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The editor window can be customized viathe “Format Views’ diaog box, which can be invoked viathe [Tools-
>Format Views...] menu option. Thisdialog alows you to configure fonts, colors, tabs and so on for the editor
window. It also allowsthe user to change the look of other views, which have been installed by HEW. If you
would prefer to use your favorite editor rather than the HEW internal editor then specify your aternativein the
“Options’ dialog box, which can be invoked via the [Tools->Option...] menu option. For further details on how
to use and configure the editor, refer to chapter 4, “Using the Editor”.

126 The Output Window

The “Output” window by default hasfour tabs on display. The “Build” tab shows the output from any build
process (e.g. compiler, assembler and so on). If an error is encountered in a source file then the error will be
displayed in the build tab along with the source file name and line number. To quickly locate a problem, double
click on the error to jump to the source file and line.

ES|

=z

A > Build 4 Debug A Find in Files & Version Control /

Figure 1.17: Output Window

The “Debug” tab shows the output from any debugger process. Any debug component that needs to display
information will send its output to this window.

The“Find in Files’ tab displaysthe results of the last “Find in Files” action. To activate find in files, select the
[Edit->Find in Files...] menu option, the toolbar button. For further details on how to use find in files, refer to
chapter 4, “Using the Editor”.

The“Version Control” tab displays the results of version control actions. The tab isonly displayed if aversion
control systemisin use. For further details on version control, refer to chapter 7, “Version Control”.

127 The Status Bar

The status bar displays information as to the current state of the HEW. Figure 1.18 shows the seven sections of
the status bar.

Displ HE statur .
ISpiays 5 Messages Readonly staius  Line number. Column number.

Ingerion hoce.

Ready |Read-'write 214 1 s . | 4
|

GCaps lock. Mur lock

Figure 1.18: StatusBar
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13 TheHelp System

The help menu is the rightmost menu on the HEW menu bar. It contains the menu option “ Contents” which,
when sdlected, takes you to the main HEW help window.

To obtain help on specific dialogs click on the context sensitive help button, which islocated in the top right-
hand corner of each dialog box (as shown in figure 1.19).

jﬂ
Context sensitive help butten

Cancel butten

Figure 1.19: Help Button

When thisis clicked, the mouse pointer will change to a pointer with a question mark above it. Whilst the mouse
pointer isin this state, click on the part of the dialog box that you require assistance on.

Alternatively, select the control that you require help for and then press the F1 key.
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14 Launching the HEW

To run the HEW, open the “ Start” menu of Windows®, select “Programs’, select “High-performance Embedded
Workshop” and then select the shortcut of the “ High-performance Embedded Workshop 2”. By defaullt, the
“Welcome!” dialog box shown in figure 1.20 will be displayed.

Welcome!

— Optiorns;

& ‘Create a new project workspace

ak.
Cancel

Administration...

4

% ' Dpen a recent project workspace:

=

2 Browse to another project warkspace

IE:'\Hew\demn'\demo.hws j

Figure 1.20: Welcome! Dialog

To create a new workspace, select “ Create a new project workspace”, and click “OK”. To open one of recent
project workspaces, select “Open arecent project workspace”, select a workspace from the drop-down list, and
click “OK”. The recent project workspace list displays the same information as that seen in the workspace most
recently used filelist. Thislist appears on the file menu. To open aworkspace by specifying aworkspace file
(.HWSfile), select “Browse to another project workspace”, and click “OK”. To register atool to or unregister a
tool from the HEW, click the “ Administration...” button (see chapter 5, “Tool Administration” for details).
Click the “Cancel” button to use the HEW without opening a workspace.

15 Exiting the HEW

The HEW can be exited by selecting [File->EXxit], pressing AL T+F4 or by selecting the close option from the
system menu. (To open the system menu, click the icon at the upper-left corner of the HEW title bar.) If a
workspace is open then the same workspace closedown procedure is followed as described in the previous
section.

16 Component System Overview

The HEW allows the user to extend the HEW functionality by adding additional components to the system. This
is achieved by registering the component in the Tools Administration dialog box. These components can add
windows, menus and toolbars to the HEW system. Examples of the components are the debugger and builder
components of HEW. The debugger component adds all of the menus and toolbars associated with the debugger
and the builder component does the same for the build functionality. The components you have registered in the
system will modify the look and feel of HEW. In some cases you may not have some of the menus which you
can seeinthismanual. For instance if the debugger component is not installed you will not have the “Debug”
menu in the HEW main window.

10
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2. Build Basics

This chapter explains the general functions of the HEW whilst the more advanced features can be found in
chapter 3, “ Advanced Build Features’.

2.1 The Build Process

Thetypical build processisoutlined in figure 2.1. This may not be the exact build process, which your
installation of HEW will use asit depends upon the tools that were provided with your installation of HEW (e.g.
you may not have a compiler for instance). In any case, the principles are the same - each step or phase of the
build takes a set of project files and then builds them, if al succeeds then the next step or phase is executed.

E BUILD E
ﬂ/’ COMPILER
C
Source Files
ﬂ_' ASSEMBLER
Assembler
Source Files
LINKER Object
Files
Library
Files ‘
Load
Module

Figure 2.1: Typical Build Process

In the example shown in figure 2.1 the compiler is the first phase, the assembler is the second phase and the
linker isthe third and final phase. During the compiler phase, the C source files from the project are compiled in
turn, during the assembler phase, the assembler source files are assembled in turn. During the linker phase all
library files and output files from the compiler and assembler phases are linked together to produce the load
module. This module can then be downloaded and used by the debugger functionality in HEW.

The build process can be customized in several ways. For instance, you can add your own phase, disable a phase,
delete phases and so forth. These advanced build issues are left to chapter 3, “ Advanced Build Features’. In this
chapter, only the general principles and basic features will be detailed.

11
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2.2 Project Files

In order for the HEW to be able to build your application, you must first tell it, which files should be in the
project, and how each file should be built (figure 2.2).

Add Project Files

Remove Project Files

Debug: ON . )

Optimize: OFF Set Compiler Options

List File: YES

Debug: OFF

Optimize: OFF Set Assembler Options

List File: YES Assembler
Source Files

Debug: ON ) ) —

Silent  YES Set Linker options -

Map File: YES Library

Files

Figure 2.2: Editing a Project
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221 Adding Filesto a Project

Before you can build your application you must first inform the High-performance Embedded Workshop, which
filesit, is composed of.

2 Toadd filesto aproject:

1. Select [Project->Add Files...], select [Add Files...] from the “Workspace” window’ s pop-up menu (see
figure 2.3), or press | NS when the “Workspace” window is selected.

Figure 2.3: Project Pop-up Menu

2. The“Add" diaog will be displayed.
3. Select thefile(s), that you want to add and then click “Add”.

13
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There are anumber of other waysto add new files to the project. These are described below:

»  Clicking right button on an open file in the editor window displays a pop-up menu option (figure 2.4). If the
fileisalready in the project then the “Add File to Project” menu option isdisabled. Selecting the “Add File
to Project” then adds the file to the current project.

Build File “dbsetc”

Cut Citr[+3
Copy Citrl+C
Paste Cirl+\

Gdd! Eile o) Froject

Eind.. Cirl+F
Find In Files.. F4
Feplace Citrl+H
Goto Line Citrl+G
Match Braces Citr [+
Book marks 3
Templateg 3
Toeele Breakpoint Fa

Efiatle/Disatle Breaknaint. Gl

Figure 2.4: Editor Window Pop-up Menu

e Inthe HEW itisalso possibleto “Drag and Drop” files from Windows Explorer onto the workspace
window. These fileswill be automatically added to the project and are displayed in the folder in which they
were dragged to.

Note: If you add afileto a project when it isan unrecognized file type then it will still be added to the project.
Certain functions will be disabled with reference to thisfile. When thisfile is double clicked in the workspace
window instead of opening the file in the editor the open operation is passed to Windows operating system. The
default open operation isthen carried out asiif the file was opened in Windows Explorer. To view the current
defined extensions use the “ File Extensions” dialog (see the section on file extensions later in this chapter).

14
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222 Removing Filesfrom a Project

Files can be individually removed from a project, selections of files can be removed or dl files can be removed.

2 Toremove files from aproject:

1. Select [Project->RemoveFiles...], or select [Remove Files...] from the “Projects’ tab’s pop-up menu in
the Workspace window (see figure 2.5). The “Remove Project Files’ dialog will be displayed (figure 2.6).

Open dbzect.c

@ Build dbscte

Hitachi SuperH RISC eneine Standard Toolchain..

fdd Files.. NS
Femove Files..

Exclude Build dbscte

(o it o WS

[@, BEmoyve framm Vs
% (et from VEE

g hiect aut o Vs
2 et i o YisE
@ (et Vb status

Configure Wiew..

| v &llow Dockine
Hide

Properties

Figure 2.5: Projects Tab Pop-up Menu

Remove Project Files

Project files: ok

Uil

‘demo.c W demotde Cancel

initect, o o \hewidemotdema]

intprg. src [ \hewtdemnoderno] Eemave

rezetprg.arc [=:Shewhdemohdemo] —

shrk.c [z:\hewhdema'.demo]

stacksct zc [=:Shewhdemohdemo] Remave Al
vectthbl zrc [z:\hewhdema'.demo]

| i

Figure 2.6: Remove Project Files Dialog
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2. Select thefile or files which you want to remove from the “Project files” list.
3. Click the “Remove” button to remove the selected files or click “Remove All” to remove al project files.
4. Click “OK” to remove the files from the project.

2 Toremove selected files from a project:

1. Select thefiles, which you want to remove, in the “ Projects’ tab of the “Workspace” window. Multiple
files can be selected by holding down the SHIFT or CTRL key.

2. Pressthe DEL key. Thefileswill be removed.

16
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223 Excluding a Project File from Build
A filein aproject can beindividually excluded from build on a configuration by configuration basis.

2 Toexclude afilein aproject from build:
1. Pushtheright mouse button on afile, which you want to be excluded from build, in the “Projects’ tab of
the “Workspace” window.
2. Select [Exclude Build file], where <file> is the selected file, from the pop-up menu (figure 2.5). Then a
red crosswill be put on the file'sicon, and the file will be excluded from build.

224 Including a Project Filein Build
An excluded file can be included in the project again.

2 Toinclude afile which has been excluded from build:
1. Push theright mouse button on afile, which has been excluded from build, on the “Projects’ tab of the
“Workspace” window.
2. Select [Include Build file ], where <file> is the selected file, from the pop-up menu. Then ared cross will
be removed from the file’sicon, and the file will be included in build.

23 File Extensions and File Groups

The HEW can identify files by their extension. The system defines certain extensions depending upon the tools,
which are being used. For example, if you are using a compiler then the .c extension will bein the “C source
file” group and be used as input to the compiler phase (figure 2.1, Typica Build Process). Additionally, the
HEW allows you to define your own extensions. For example, if the project you are devel oping uses assembler
source files the default extension may be .src. If you would like to use a different extension instead of .src

(e.g. .asm) then you can define a new extension and request that the HEW treatsit in the same way asa.srcfile.

File extensions and file groups can be viewed and modified viathe “File Extensions’ dialog (figure 2.7). Thisis
invoked by selecting [Project->File Extensions...]. Thisdialog displays all of the extensions and file groups,
which are defined within the current workspace.

Extension | Group - Ok I

D *.abs Absalute file

*.inc Aszsembly include file Cancel |

#lis Assembly list file

WSt Azzembly source file fdd.
SE C header file Remove |
[EEAE G list file =

*.c G source file Open with...
*hpp G+t header file

Gt list file
CH+ =zource file

CPU information file

e e T e mal _Ij
3

Figure 2.7: File Extensions Dialog

17
RENESAS




The “File Extensions’ list shown in figure 2.7 is divided into two columns. On the left are the file extensions
themselves, whilst on the right are the file groups. Many file extensions can belong to the same group. For
example, assembler source files may have several extensionsin asingle project (e.g. .src, .asm, .mar €tc) as
shown in figure 2.8.

CIC L] ]

.SRC .ASM MAR LB LPF

Assembler source files C source files Library files

Figure 2.8: File Extensionsand Groups

When creating a new extension you should consider whether the extension belongs to a group, which is already
defined, or whether you need to create a new file group. If you are adding a completely new type of file then you
will want to create anew file group. This process is described below.
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2 Tocreate anew file extension in anew file group:

1. Select [Project->File Extensions...] from the menu bar. The “File Extensions’ dialog will be displayed
(figure 2.7).

2. Click the“Add...” button. The “Add File Extension” dialog will be displayed (figure 2.9).

3. Enter the extension, which you want to define into the “File extension” field. It is not necessary to type
the period ( . ) character. The drop list contains all extensions that are undefined in the current project.
Selecting one of these extensions will add the text to the file extension field automatically.

4. Select the “Extension belongsto anew group” option and enter a description, which definesthis new file
group.

5. Atthisstageit ispossible to change the associated application. There are four available choicesin the

“Open” with drop list. These are listed below:

e Editor
* None
e Other

*  Windows default
If the editor is selected, the open file function in the workspace window causes the file to be opened in the
HEW editor. If noneis selected then the open operation is disabled when the open file function is
attempted. Selecting “Other” allows you to configure an another tool for the open file operation. See“To
associate an application with a file group” for more details. If the “Windows default” option is selected
then the open file function in the workspace window passes the open file to the Windows operating
system. Thisthen selects the default behavior for this file extension as defined in Windows Explorer.

6. Click “OK” to add the extension to the “File Extensions’ list.

—File extension:

Cancel

i

—File group:

& Extension kelongs to an existing group:

[Absolute file =l

" Extension belongs to a new group:

—Associated application:
Open " Absolute file™ with:
Windows default j

TlEalifie.

I

Bemuye

Figure 2.9: Add File Extension Dialog (New Group)
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If you want to create a new extension because your project uses a different extension from those accepted by the
HEW. For example, aphase might by default use the extension .asm but the HEW only recognizes .src.  Then
you need to create a new extension and add it to an existing file group. This processis described below.

= To create anew file extension in an exigting file group:

1. Select [Project->File Extensions...] from the menu bar. The “File Extensions” dialog will be displayed
(figure 2.7).

2. Click the“Add...” button. The“Add File Extension” dialog will be displayed (figure 2.10).

3. Enter the extension, which you want to define into the “File extension” field. It is not necessary to type
the period ( . ) character. The drop list contains all extensions that are undefined in the current project.
Selecting one of these extensions will add the text to the file extension field automatically.

4. Select the “Extension belongs to an existing group” option and select which group you would like to add
this new extension.

5. Click “OK” to add the extension to the “File Extensions’ list.

—File extension:

®-  |asm A
Cancel

i

—File group:

& Extension kelongs to an existing group:

IAssemny source file j

" Extension belongs to a new group:

—Associated application:

DOpen " Assermbly source file™

EETETA—

TlEalifie.

Bemuye

It

Figure 2.10: Add File Extension Dialog (Existing Group)

In addition to opening a file with the editor, the “ File Extensions” dialog allows you to associate any application
with any file group so that when you double click on afilein the “ Projects” tab of the “Workspace® then the
appropriate application islaunched with the file. Figure 2.11 shows the association between a word processor
and the extension .DOC.
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* Ipp Co+ list file

Texteditor —= % cpp O+ source file Cancel |

D*.cpu CPU information file

Word processor —EF +.doc Documents il
*.exp Expanded assembly source file Remaove |
Librarian -@*.Iib Library file =
EEAE] Library list file Opeer with.,
*.sct Library section list file
*.rnap Lirkage map filz
*.fsy Linkage symbal file
Mo applization —— ] #.0bj Object file

S Bvoremraccad M coivna fils i
1 |

Figure 2.11: File Groupsand Applications

2 To associate an application with afile group:
1. Select thefile group to be associated from the “File Extensions’ dialog (figure 2.11).
2. Click the “Open with...” button. The “Modify File Extension” dialog will be displayed (figure 2.12).

Group:

Linkage map file

—Associated application: Cancel |

Open " Linkage map file™ with:

Mane j

Edlitor

Other

YWindows default

Figure 2.12: Modify File Extension Dialog

3. Select “None’ to remove any association, select “Editor” to open thistype of file in the internal/external
editor or select “ Other” if you want to open thistype of file with a specific application. If you select
“Other” then you can select from any previousy defined application from the drop-down list or specify a
new application.

4. Click “Add..."” to define anew application. The “Add Application” dialog will be displayed (figure 2.13).
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Hame:
I Cancel |
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| il
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I
I Ll Browze. . |

22

Figure 2.13: Add Application Dialog

5. Enter the name of the tool into the “Name” field. Enter the full path to the tool in the “Command” field
(do not include any parameters). Enter the parameters that are required to open afilein the “ Parameters’
field. Be sure to use the $(FULLFILE) placeholder to specify the location file (see appendix C,
“Placeholders’, for more information on placeholders and their uses). Enter theinitial directory, in which
you would like the application to run, into the “Initial directory” field. Click “OK” to create the
application.

6. Click “Modify..."” to modify an application. The “Modify Application” dialog will be displayed. This
dialog isthe same asthe “Add Application” dialog described above except that the “Name” field isread
only. Modify the settings as desired and then click “OK".

7. Click “OK" to set the application for the selected file group.
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24 Specifying How to Build a File

Once you have added the necessary files to the project the next step isto instruct the HEW on how to build each
file. To do this, you will need to select a menu option from the “ Options” menu. The contents of this menu
depend upon which tools you are using. For example, if you are using a compiler, assembler and linker then
there will be three menu options, each one referring to one of the tools.

2 To set options for abuild phase:
1. Select the options menu and find the phase whose options you would like to modify. Select this option.
2. A dialog will be invoked which allows you to specify the options.
3. After making your selections, click “OK” to set them.

To obtain further information, use the context sensitive help button or select the areain which you need
assistance and then press F1.
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25 Build Configurations

The HEW allows you to store dl of your build optionsinto a build configuration (figure 2.14). This means that
you can “freeze” all of the options and give them a name. Later on, you can select that configuration and all of
the options for all of the build phaseswill be restored. These build configurations also alow the user to specify
debugger settings for a build configuration. This means that each configuration can be targeted at a different end
platform. (See Emulator Debugger Part in this manual, for further information).

Figure 2.14 shows three build configurations; “ Default”, “MyDebug” and “MyOptimized”. In thefirst
configuration, “ Default”, each of the phases (compile and assemble) are set to their standard settings. In the
second configuration, “MyDebug”, each of the files are being built with debug information switched on. In the
third configuration, “MyOptimized”, each of the files are being built with optimization on full and without any
debug information. The devel oper of this project can select any of those configurations and build them without
having to return to the options dialogs to set them again.

"Default” "MyDebug" "MyOptimized"
Configuration Configuration Configuration
=S Debug: ON Debug: ON Debug: OFF
'Optimize: OFF Optimize: OFF Optimize: ON
List File: YES | List File: NO | [ List File: NO | [
C
Source Files
— Debug: OFF Debug: ON Debug: OFF
Optimize: OFF Optimize: OFF Optimize: ON
List File: YES | List File: NO | H ListFile: NO | H
Assembler
Source Files
C:\MyProject\Default C:\MyProject\MyDebug C:\MyProject\MyOptimized

Figure 2.14: Configurationsand File Options
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251 Selecting a Configuration
The current configuration can be set in two ways:
Either:

1. Select it from the drop down list box (figure 2.15) in the toolbar.

IHeIease

LI
Release

Figure 2.15: Toolbar Selection
or:

1. Select [Options->Build Configurations...]. Thiswill invoke the “Build Configurations’ Dialog (figure
2.16).

Build Configurations

Build configurations: 0k

Debug
Release Cancel

Add

e

HEmove

Current configuration:

Debug j

Figure 2.16: Build Configurations Dialog

2. Select the configuration that you want to use from the “ Current configuration” drop down list.
3. Click “OK” to set the configuration.
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252 Adding and Deleting Configurations

Y ou can add a new configuration by copying settings from another configuration or delete a configuration. These
three tasks are described below.

2 Toadd anew configuration:
1. Select [Options->Build Configurations...] to display the “Build Configurations’ dialog (figure 2.16).
2. Click the“Add...” button. The “Add Configuration” dialog will be invoked (figure 2.17).

Add Configuration

Configuration name: IMPCDHHQ
Cancel
Bazed on configuration: IDehug j —l

Configuration directary: c:whew' demaokdema’dyConfig

Figure2.17: Add Configuration Dialog

3. Enter the new configuration name into the “Configuration name” field. Asyou enter the new
configuration name, the directory underneath changes to reflect the configuration directory that will be
used. Select one of exigting configurations, from which you want to copy a configuration, out of the drop-
down list of the “Based on configuration” field. Click “OK" on both dialogs to create the new
configuration.

2 To remove aconfiguration:
1. Select [Options->Build Configurations...] to display the “Build Configurations® dialog (figure 2.16).
2. Select the configuration that you want to remove and then click the “Remove” button.
3. Click “OK” to close the “Build Configurations” dialog.
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2.6 Building a Project

The outline of the build processis shown in figure 2.1.

26.1 Building a Project

The build option only compiles or assembles those files that have changed since the last build. Additionally, it
will rebuild source files if they depend upon afile that has changed since the last build. For instance, if the file
“test.c” #include' sthe file “header.h” and the latter has changed since the last build, the file “test.c” will be
recompiled.

2 To perform abuild:
Select [Build->Build] or click the build toolbar button () or press F7 or click the right mouse button on a
project icon in the “ Projects’ tab of the “Workspace” window and select [Build] from the pop-up menu.

The build al option compiles and assembles all source files, irrespective of whether they have been modified or
not, and links all of the new object files produced.

2 To perform abuild all:
Select [Build->Build All], or click the build al toolbar button (&), or click the right mouse button on a
project icon in the “ Projects’ tab of the “Workspace” window and select [Build All] from the pop-up menu.

Both the build and the build al will terminate if any of the project files produce errors.

262 Building Individual Files
The High-performance Embedded Workshop |ets you build project filesindividually.

2 Tobuild anindividual file:
1. Select the file which you want to build from the project window.
2. Select [Build->Build File], click the build file toolbar button (8) or press CTRL +F7 or click the right
mouse button on afileicon in the “Projects’ tab of the “Workspace” window and select [Build <file>]
from the pop-up menu.
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26.3 Stopping a Build
The High-performance Embedded Workshop allows you to halt the build process.

2 To stop abuild:
1. Select [Build->Stop Build] or click the stop build toolbar button (Z%). The build will be stop after the
current file has been built.

2. Wait until the message “Build Finished” appearsin the “Output” window before continuing.
2 Toforcibly terminate a current tool
1. Select [Build->Terminate Current Tool]. The HEW will attempt to stop the tool immediately.

Note: Do NOT assume that any output from the tool you terminated isvalid. It is recommended that you delete
any output files produced and ensure that the phase is executed again.

264 Building Multiple Projects
The High-performance Embedded Workshop |ets you build multiple projects and configurations at once.

2 To build multiple projects:

1. Select [Build->Build Multiple]. Thefigure displayed in figure 2.18.

2. Thebuild multiple gives you the choice of which projects and configurations should be built. To select
which projects and configurations need to be built select the check box next to the project —
configuration combination you want to build. For example, in figure 2.18 if you wanted to build the
entire “hewtest2” project you would check the “hewtest2-Debug” and the “ hewtest2-Release” selections
and leave all other check boxes unchecked.

3. When you are happy with your chosen selection click the build button and the HEW will then build the
projects and configurations you have chosen.

4. If youwant to build all the projects which you choose, you click the build all button.

5. Results from the build are displayed in the build window in the same way as the normal build process.

Build Multiple E3

[ Thevatest]-Debug -
[ hevatest]-Release

[ hevatests-Debug Build Al
[ hevatests-Release
[ hevatest3-Debug

C | |
[ 1hevatest3-Release nee
[ 1hevatestd-Debug
[ hevatestd-Release
[ 1hevatest5-Debug

[Jhewtest5-Release _ILI
4 I I 3

Figure 2.18: Build Multiple Dialog

26.5 The Output Window

When atool executes (i.e. compiler, assembler, linker etc.) its output is displayed in the “ Output” window. If any
of the tools produce any errors or warnings then they are displayed along with the source file name and the line
number at which the error islocated. To quickly locate a specific bug, double click on agiven error/warning to
invoke the current editor.
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2.6.6 Controalling the Content of the Output Window

It is often useful to display low-level information (such as the command line options that are being applied to a
file) during abuild. The HEW allows you to specify whether or not you want such options displayed in the
“Output” window during a build, build @l or build file operation viathe “ Tools Options’ diaog.

2 Toview or hide extrainformation during a build:

1. Select [Tools->Options...]. The“Options’ dialog will be displayed.

2. Select the“Build” tab (figure 2.19).

3. Set the three check boxesin the “ Show” group as follows. “Command line” controls whether the
command line is shown as each toal is executed. “Environment” controls whether the environment is
shown as each tool is executed. “Initial directory” controls whether the current directory is shown as each
tool is executed.

Options EHE3
Build |Editnl | Workspace | Confimation |

— Errarg and warnings:

[ Stop build if the no. of ermors exceed:

™ Stop build if the no. of warnings exceed:

o
o

 Shaw:

[ Command line
[ Enwironment

[ Initial directom

ak. I Cahicel

Figure 2.19: Options Dialog Build Tab
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2.7 File Dependencies

A typical project will contain dependencies between files, for example, one C file may “#include’ one or more
header files. In complex projects, source files will include (or depend upon) others and this can quickly become
difficult to manage. However, the HEW provides a dependency scanning mechanism whereby all filesin a
project are checked for dependencies. Once compl ete, the project window will display an up-to-date list with dl
the project file dependencies.

2 To update aproject’s dependencies:
Select [Build->Update All Dependencies] or click the right mouse button on a project icon in the “ Projects’
tab of the “Workspace” window and select [Update All Dependencies] from the pop-up menu.

Initially, the dependencies for all files are contained within the “ Dependencies’ folder (figure 2.20.i).

2.8 Configuring the Workspace Window

If you click the right mouse button anywhere inside the “ Projects’ tab of the “Workspace’ window, a pop-up
menu will be invoked. Select the “Configure View...” menu option to modify the way in which information is
displayed. The following four sections detail the effect of each option on the “Configure View” diaog.

281 Show Dependencies under Each File

If you select “ Show dependencies under each file”, the dependent files are shown under the including source file
as aflat structure, i.e. the files themselves become folders (figure 2.20.ii). If this option is not selected then a
separate folder contains all dependencies (figure 2.20.i).

L El@ dema e E@ dema
El@ Projectl E@ Projectl
Ela Project Files e cl.=rc
cllzre E| main.c
main.c filelh
shrk.c L [E] tilezh
sh_hwcfe.c = shrk.c
sh_intw.src sh_hwefe.c
Ela Dependencies i sh_intw.src
filalh
------ =] fileZh
@ijectx l@:INavigaﬁun I @ Projects l =] Mawigation I

Figure 2.20: Dependencies under Each File
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282 Show Standard Library Includes

By default, any dependent files found in standard include paths will not be shown (figure 2.21.i). For example, in
C code, if you write an include statement such as “#include <stdio.h>" then stdio.h will not be listed asa

dependent file. To view such system include files, select the “ Show standard library includes’ option (figure
2.21ii).

L E@ demo . E@ demo
E@ Projectl E@ Projectl
Ea Project Files Ea Project Files
cl.sre cl.src
main.c =] mainc
shrk.c =] sbrke
sh_hwefec E] sh_hweifec

s sh_intw.src

sh_intv.src
Dependencies
stddefh

=] stdich

N ) Projects l =] pavigation I N 2] Projects l “a_| Mavigation I

Figure2.21: Standard Library Includes

283 Show File Paths

If “Show file paths” is selected, all of the filesin the project window are shown with their full path, i.e. from a
drive letter (figure 2.22).

B3 oihewhdemademo hws
= [Project]
B4 Project Files

' C:\HewtdemohdernotcO.src

=] C:‘Hewtdemo'demotmain.c
C:s\Hewhdemohdemat.shirk. o
C:\Heswhdemo'dermaohsh_hwefg
------ C:\Hesdemohdernohsh_inky. sre

N Z Projects l | Mavigation I

Figure 2.22: File Paths Shown
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2.9 Setting the Current Project

A workspace can contain more than one project but only one of the projects can be active at any time.  This
active project is the one which build actions and debug operations can be performed on. It is possible to change
the builder or debugger options for the project. An active project is displayed in bold.

2 To set aproject asthe current project:
1. Select the project from the “Projects’ tab of the “Workspace” window.
2. Click the right mouse button to display the pop-up menu and select the [Set as Current Project] option.
or:

1. Select the project, which you want to make active from the [Project->Set Current Project] sub-menu.

210 InsertingaProject into a Workspace

When aworkspace is created, it contains only one project but, after it is created, you can insert new or existing
projects into a workspace.

2 Toinsert anew project into a workspace:
1. Select [Project->Insert Project...]. The “Insert Project” dialog will be displayed (figure 2.23).
2. Setthe“New Project” option.
3. Click OK. The “Insert New Project” dialog will be invoked.
4. Enter the name of the new workspace into the “Name” field. This can be up to 32 charactersin length and

contain |etters, numbers and the underscore character. Asyou enter the project name the HEW will add a
subdirectory for you automatically. This can be deleted if desired.

5. Click the “Browse...” button to graphically select the directory in which you would like to create the
project. Alternatively, you can type the directory into the “Directory” field manually.

6. The“Project type” list displaysall of the available project types (e.g. application, library etc.). Select the
type of project that you want to create from thislist.

7. Click “OK" to create the project and insert it into the workspace.

Note:  When anew project is being inserted, the CPU family and tool chain cannot be specified asthese

properties are aready defined by the workspace (i.e. al projects within the same workspace target the
same CPU family and toolchain).

Insert Project E E2
Inser
o zﬂ E Cancel |

" Esisting project:

Erawse.. |

Figure2.23: [Insert Project] Dialog
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2 Toinsert an existing project into a workspace:
1. Select [Project->Insert Project...]. The “Insert Project” dialog will be displayed.
2. Set the “Existing Project” option.
3. Enter the full path of the project database file ((HWPfile) into the edit field or click “Browse...” to
search for it graphically.
4. Click “OK” to insert the existing project into the workspace.

Note: When an existing project is being inserted into a workspace, the CPU family and tool chain upon which
that project is based must match those of the current workspace. If they do not then the project cannot be
inserted into the workspace.

211  Specifying Dependencies between Projects

The projects within aworkspace can be dependent upon one another so that when one project is built, all its
dependent projects are built first. Thisis useful if another project uses one of the othersin the workspace. For
example, imagine that a workspace contains two projects. Thefirst project isalibrary that is included by an
application project. In this case the library must have been built and up to date before the second application can
build correctly. To achieve this situation we can specify the library as a dependent (i.e. child) project of the
application project. Thiswould then alow the library to be built first if it is out-of-date.

When a dependent project is built the HEW attempts to match the configuration in the dependent project with
that of the current project. This meansthat if the current configuration is “Debug” then the HEW will attempt to
build the “Debug” configuration in the dependent project. If this matched configuration does not exist then the
HEW will use the configuration that was last used in the dependent project.

2 To make projects depend upon another:
1. Select [Project->Dependent Projects]. The“ Dependent Projects’ dialog will be displayed.(figure 2.24)
2. Select the project to which you would like to add dependents to. When you do this, the “ Dependent
projects’ list will display al of the projectsin the workspace (excluding the selected project).
3. The*“Dependent projects’ list has a check box for each project listed. Set the associated check boxes to
make those projects depend upon the selected project.

4. Click “OK" to confirm the new project dependencies.

Dependent Projects EHE
Froject: QK

I main_project j
Cancel |

|

Figure 2.24Dependent Proj ects dialog
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212  Removing a Project from a Workspace

2 To remove aproject from aworkspace:

1. Select the project from the “Projects’ tab of the “Workspace” window and click the right mouse button to

invoke a pop-up menu.
2. Select the [Remove Project] option.
or:
1. Select the project from the “Projects’ tab of the “Workspace” window.
2. Pressthe DEL key.

Note: You cannot remove the current project from the workspace.

213  Loading/Unloading a Project to/from a Wor kspace

2 Toload aproject to a workspace:
1. Select the project that has been unloaded from the “ Projects’ tab of the “Workspace” window.
2. Click the right mouse button to invoke a pop-up menu and select the [L oad Project] option.

2 Tounload a project from aworkspace:
1. Select the active project from the “Projects’ tab of the “Workspace” window.
2. Click the right mouse button to invoke a pop-up menu and select the [Unload Pr oj ect] option.

Note: Itispossibleto select several projects at the same time and load or unload al of them. Thisis more
efficient than loading or unloading each of the projectsindividually.
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214  Relative Projects Pathsin the Workspace

In the High-performance Embedded Workshop when you add a project to the workspace you can choose to add
the project to the workspace using arelative path. This allows you to position a project above the workspace
directory and it will still be relocated correctly if you relocate the HEW workspace. The project is aways
relative to the workspace so if the project is one directory above the workspace before it is moved the HEW will
try to find the project in the same relative location after the relocation procedure. Thisis especialy useful if you
are using a project shared between more than one workspace.

In older versions of the HEW this project would not have been relocated and would have still tried to access the
original project path. The older version of the HEW could only relocate the projects, which werein a
subdirectory of the workspace directory. Thisis till the standard behavior for the High-performance Embedded
Workshop.

2 To change aprojects relative path flag:
1. Select the project in the workspace window.
2. Right click and then select properties.

3. Click the“Project relative file path” checkbox to switch on or off the relative file path feature. (figure
2.25)

4. Click “OK”".

opertiss 2=
M arne: demo oK I
__ Carcel |

Location: C:YHew2\demohdema'demo. hwp
Cahicel
Last modified: 21:47:43, Thursday, February 27, 2003
CPU Farnily: H85 H8/300
Tool chain: Hitachi HES H8/300 Standard Toalchain
Yersion; R0.20

¥ Froject relative file path

Figure 2.25: Properties Dialog
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3.  Advanced Build Features

This chapter explains the more advanced build concepts.

31 The Build Process Revisited

Chapter 2, “Build Basics” began by describing the build process in terms of a compiler, an assembler and a
linker (figure 2.1). Thiswill be the case for most installations of the HEW. However, if you want to begin
changing the build process (e.g. adding and removing phases) then it isimportant to understand more about the
way in which abuild functions.

311 What isa Build?

Building a project means applying a set of tools upon certain input filesin order to produce the desired output.
Thus, we apply a compiler upon C/C++ source filesin order to create object files, we apply an assembler upon
assembler source filesin order to create object files and so forth. At each step or “phase” of the build, we apply a
different tool upon adifferent set of input files. Figure 3.1 presents another view of the build process.

B seon BB

_ prinsE 1 %

Phase 1 Input Files ’ Phase 1 Output Files
B
Phase 2 Input Files ‘ Phase 2 Output Files

=T

Phase 3 Output Files

Phase 3 Input Files

e L

_ wsex > |

Phase X Input Files ' Phase X Output Files

Figure 3.1: Build Process

37
RENESAS




The High-performance Embedded Workshop provides the ability to change this build process viaits“Build
Phases” dialog, which can be, accessed via the [Options->Build Phases...] (figure 3.2). On the left-hand side
are the phases that are defined in the current project (Figure 3.2 shows a standard set of build phases). The
remainder of this chapter details the various functions that the “Build Phases’ dialog provides.

Build Phazes

Build et | Build File Order | File Mappings |

Build phase order:

[w|SH C/C++ Library Generator d
[w]SH CAC++ Cannpiler

(w|SH Azzembler T adifin.
[w|OptLirker

HEemayve
e

[t B

P I I _,I Import...

(L

Ok | Cancel |

Figure 3.2: Build Phases Dialog
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3.2 Creating a Custom Build Phase

If you want to execute another tool before, during or after a standard build process then this can be achieved by
creating your own (i.e. custom) build phase.

Select [Options->Build Phases...] to invoke the “Build Phases’ diaog (figure 3.2) and then click the“Add...”
button. This will invoke the new build phase wizard dialog (figure 3.3a).

Thefirst step (as shown in figure 3.3a) asks whether you want to create an entirely new phase or whether you
want to add a system phase. A system phaseisa“ready made” phase which is aready defined within the
toolchain you are using (e.g. compiler, assembler, linker, librarian, etc.) or a utility phase (e.g. file copy,
complexity analyzer etc.).

The “Add an existing system phase” button isinactive if no more system phases are available. Select the “ Create
anew custom phase” button to create your own build phase.

Mew Build Phase - Step 1 of 4 HE

wihat type of phaze would you like ta add

* Create a new custom phasze

€0 fedld | & existing epsten phase:

Syztem Phaze | Wergion |

< Each | Hewt » | Cancel

Figure 3.3a: New Build Phase Dialog (Step 1)
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The second step (figure 3.3b) asks what type of phase you would like to create. There are two choices: multiple
or single. When amultiple phase is executed, the command is applied to each file in the project of acertain file
group. For example, if you set the input file group to be C source files then the command will be executed once
for each C sourcefilein the project. A single phase is executed once a most during a build.

New Build Phase - Step 2 of 4
)
Wwhat tppe of phaze would vou like to create?

& Multiple phase:

The cammand is applied ta each file in a file group.
An example of this type of toal iz a compiler or assembler.

Select input file group:

' Single phase:

The command iz only ever executed once per build.
An example of this type of toal iz a linker.

< Back | Heut » | Cancel

Figure 3.3b: New Build Phase Dialog (Step 2)

Theinput file group list contains the current file groups defined for the project. It is possible to define multiple
input file groups by selecting the “Multiple Groups...” entry in theinput file group list. Selecting thislist entry
displaysthediaog in figure 3.3c.

Select Groups

[ ssembly source file =] ok
[ |Binary file

[ 1C header file Cancel
[1C list file

(w|C zource file

[ |C++ header filz
[ 1C++ list file

;i:i++ E File:
[ |CPU infarmation file

[ |Expanded azsembly zource file _Ij
4 | | »

Figure 3.3c: Modify multiple input file groups
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Once this choice has been made the input file group selection is displayed as “Multiple Groups...” Thisdialog
allows the user to choose multiple input file groups for the custom phase being added to the project. To select a
file group check the box next to the file groups name. One or more file groups can be selected in this dialog.

The third step (figure 3.3d) requests the fundamental information about the new build phase. Enter the name of
the phase into the “ Phase name” field. Enter the location of the program file into the “Command” field (do not
insert any command line options as these options are specified viathe [Options] menu of the HEW menu bar).
Specify the default options for the phase (i.e. what options you would like new files to take when added to the
project) into the “Default options” field. If you have a preferred directory in which you would like this program
to run from (i.e. where you want the current working directory to be set to before the tool is executed) then enter
it into the “Initial directory” field.

Mew Build Phase - Step 3 of 4 HE
o

Phaze name:
IMyF‘hase

Command [exchuding parameters):
Ic:'\tnnls\mytnnl.er:e{ [ 3 | Browsze... |

Default options:

[${FULLFILE] Ll

Initial directan:

[$CONFIGDIR) Ll Erowse... |

< Back | Hewt » | Cancel |

Figure 3.3d: New Build Phase Dialog (Step 3)
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The fourth and final step (figure 3.3e) allows you to specify any environment variables, which the phase requires.

Mew Build Phase - Step 4 of 4
o

Does the command require any ervironment vaniables to be sety

If =0, enter them into the: lizk below:

ENv=1024
i |
e |
KN 0

[ Eead Output On Fly

< Back | Finish | Cancel |

Figure 3.3e: New Build Phase Dialog (Step 4)

To add anew environment variable click the“Add...” button (the dialog shown in figure 3.4 will be invoked).
Enter the variable name into the “Variable” field and the variable’' s value into the “Value” field and then click
“OK” to add the new variable to thelist of the fourth step. To modify an environment variables select the
variablein the list and then click the “Modify..."” button. Make the required changes to the “Variable” and
“Value’ fields and then click “OK” to add the modified variable to the list. To remove environment variables
select the variable that you want to remove from the list and then click the “Remove” button.

Environment ¥arnable EHE

Wariable:
T
Cancel |

Walue:

Placehelder
PopUp MEnu

Ic: wdos e mytools o windowes o temp [ 3 I|

Figure 3.4: Environment Variable Dialog

If the tool you are adding can display its output as the tool is running then use the ‘ Read Output On Fly’ option.
Thiswill display the tool output as each line of output happens. If this option is set to off then the HEW will
store al output, which is being displayed by the tool, and display it in the output window when the tool has
finished its operation. This can be a problem when the toal is running an operation that might take many
minutes, asit is difficult to see the progress of the current execution.

Note: Using ‘Read Output On Fly’ can cause problems when using certain tools on certain operating systems.
If you are having problems with tools locking up or freezing in HEW then uncheck the ‘Read Output On
Fly’ option.

Click the “Finish” button to create the new phase. By default the new phase is added to the bottom of the “Build
Phase Order” list in the “Build Order” tab of the “Build Phases’ dialog (Figure 3.2).
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33 Ordering Build Phases

In astandard build (shown in figure 3.5), you could add a phase at four different positions: before the compiler,
before the assembler, before the linker or after the linker. Y ou may place your own custom phases or move
system phases to any position in the build order. It isimportant to remember that if the output of your custom
phase can be input into another phase then the phase order must be correct if the build isto behave as intended.

Eﬂ BEGIN Eﬂ

I1‘

COMPILE
| «
| «

®

(<]

Figure 3.5: Typical Build Process

The build phase dialog provides facilities for ordering build phases via the “Build Phases’ dialog. It has two tabs,
which are concerned with the ordering of phases: “Build Order” and “Build File Order”.
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331 Build Phase Order
The “Build Order” tab (figure 3.6) displays the current order in which phases will be executed when the build

currently enabled. By clicking this box, the phase can be toggled on or off.

Build Phazes
Build et | Build File Order | File Mappings |
Build phase order:
[w]SH CAC++ Library Generator Add... |
[w]SH CAC++ Cannpiler -
WISH Assembler &'
B
HEemayve
e |
[t B |
P I I _,I Import... |

Ok | Cancel |

Figure 3.6: Build Phases Dialog Build Order Tab
In addition the following operations can be performed:

2 Toremove aphase:
1. Select the phase that you would like to remove.
2. Click the “Remove” button.
2 Toview the properties of a system phase:
1. Select the system phase that you would like to examine.
2. Click the“Modify..."” button.
2 To move aphase:
1. Select the phase that you would like to move.
2. Click the“Move Up” or “Move Down” button.
2 Toimport aphase:
1. Click theimport button. A dialog isdisplayed which allows the user to browse to an existing project to
import a custom phase from.
2. Choose the location of the project you wish to import a custom phase from. Once selected adialogis
displayed which lists the custom phases in the imported project.
3. Selecting a phase name and then clicking properties displays the custom phase details. This alowsyou
to decide whether the phase does the functionality you require.
4. Onceyou have decided which phase to import highlight it in the list and then click OK. The phase will
then be added to the build phases dialog at the bottom of the build order.
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2 To modify acustom phase:
1. Select the custom phase that you would like to modify.
2. Click the “Modify..."” button. The modify phase dialog will be invoked with the “Command” tab selected
(figure 3.7).
3. Change the contents of the fields as appropriate.

4. Setthe“Don’'t check for input file(s) existence before executing” check box if you don’'t want the HEW
to abort the execution of the phaseif any of the input files don’t exist.

Modify MyPhase

Command | Enviromment I

LCommand [excluding parameters]:
IE:\tnnIs\mytnnl.eHe [ 3 | Browsze... |

Initial directong:

[$ICONFIGDIR] | Browse. |

™ Don't check for input filefs) existence before executing

[ Bead Dutput On Fly

Ok I Cancel

Figure 3.7: Modify Phase Dialog Command Tab

5. Select the “Environment” tab (figure 3.8) to edit the environment settings for the phase.

6. Usethe“Add...”, “Moadify...” and “Remove’ buttons to add, modify and remove environment variables.
The operation is the same as discussed in the previous section.
7. Click “OK” when al modifications have been made.

Modify MyPhase
Command ~ Environment |
Environment settings:

PaTH=c: \dos;c: ools
SHOWALL=FALSE

EMv=1024 e |
Eemnowe |

ak | Cancel |

Figure 3.8: Modify Phase Dialog Environment Tab
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332 Build File Phase Order

If you were to select a C source file from the “Workspace” window and then activate [Build->Build File] (or
press &) you would expect the file to be compiled. Likewise, if you were to select an assembly source file from
the workspace window and then activate [Build->Build File] you would expect the file to be assembled. The
connection between file group and which phase(s) to execute is managed by the “Build File Order” tab of the
“Build Phases’ diaog (figure 3.9).

Build Phases EHE3
Build Order  Build File Qrder | File Mappingz I
File group: Phasze arder:
Aszembly source file [w] Carnpiler ®
. [w]tdvPhase : $
C++ source file X
|
|
1
|
1
|
|
|
¥
| il

ak. I Cancel |

Figure 3.9: Build Phases Dialog Build File Order Tab

Thelist displaysall of the current phases that will be executed when the build file operation is selected upon the
file group shown in the “File group” list box. In figure 3.9 the “C source file” file group is selected and the
“Compiler” and “MyPhase” phases are associated with it.

Entriesin the “Phase order” ligt, of the “Build File Order” tab, are added automatically as new entries are added
to the “Build Order” tab. For example, if you were to add a phase which takes C source files asinput then this
phase will be automatically added to the list of phases to execute when a build file operation is appliedtoa C
source file. If you don’'t want a certain phase to execute when [Build->Build Fil€] is selected then clear the
check box to theleft of the phase name in the “Phase order” list.
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34 Setting Custom Build Phase Options

Once you have defined a custom phase, you will want to specify the command line options that should be used
when it is executed. Each defined phase has a menu option on the [Options] menu. To specify options for that
phase select it. The dialog that will be invoked depends upon whether the custom phase selected was a multiple
or single phase (according to the selection of phase typein figure 3.3b).

Phasel... Options e |
IDebug j Dptians |Dutput Filez | Dependent Files
- hewtest = Command;
=9 C source file Ip:\_hew-files\Dns&windows executables\CMDLINE EXE

hewtest.
initsct Telime

h Ophons:
$IFULLFILE]
vecthl.c

fu]

T

fu]

B C source file

Placeholder:

hewtestd o
initsct o [ IFiIe path + name j Inzert |
intprg.c

shrk.c -
1| ' | v

Ok I Cancel |

Figure 3.10: Custom Options Dialog

Thedialogin figure 3.10 isacustom phase options dialog. Theimplementation of which is dightly different
depending on whether you are using amultiple or single shot phase. On the left-hand side is the project and file
list. Itispossibleto select multiple projects and filesin the same way as Windows explorer to modify the
options for more than one selection. On the right-hand side are the 3 optionstabs. Thisiswhere you set the
options that you want to apply to the selected file(s). You can aso choose which configuration information is
being viewed from the configuration list on the upper left of the dialog box. Each configuration islisted along
with aspecial entry named “Multiple configurations...”. If you select multiple configurationsthen adialog is
displayed which allows you to select more than one configuration. This method is used throughout HEW for
modifying multiple configurations at once.
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341 Options Tab

The “Options’ tab (figure 3.11) alows you to define the command line options that will be passed to the phase.
The “Command” field displays the command, which was entered when you defined the phase (figure 3.3d).
Enter into the “Options’ field the command line arguments that you would like to pass to the command. If you
want to insert a placeholder, select the relevant placeholder from the “Placeholder” drop-down list box and then
click the “Insert” button. For a detailed description of placeholders see appendix C, “Placeholders’.

Option:s | Cutput FiIesI Diependent FiIesI

Cammand:
IC: YHewh ToolchaingHitachivSHYA1 DAEIM L br.exe

Options:
-sub=$[COMFIGDIRMbuildlib.zub

Placeholder:

" - - | rt bt
Configuration directan j Inzert :I—— fzf.zlaceho:;er

ak. I Cahicel |

Figure 3.11: Custom Options Options Tab
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34.2 Output FilesTab

The “Output Files” tab (figure 3.12) is where you can specify the output file or filesthat will be produced by the

phase. Before each file is passed into this phase, the HEW checks that the output files are of aless recent date
than the input file. If so, the phase will be executed for that file (i.e. input files have been modified since the

output file or files were last produced). If the files are up to date then the phase will not be executed.

Note: If no output files are specified, the phase will execute regardless.

Options  Output Files | Dependent Files I

Output files:

KN [

Add...

Madify... |
_Benore |

Bemove

o]

Cancel

Figure 3.12: Custom Options Output FilesTab

2 Toadd an output file:

1. Click “Add...”. The“Add Output File" dialog will be invoked (figure 3.13).

2. Enter the file path or browseto it using the “Browse...” button.
3. Click “OK” to add this output file to the list.

Flaceholder popup menu

fidd Output File

Ll Bromsze..

Cancel |

Figure 3.13: Add Output File Dialog
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2 To modify an output file:
1. Select the output file that you would like to modify.

2. Click “Madify..."”. The“Modify Output File" diaog, which isthe same as figure 3.13 except the title,
will be invoked.

3. Modify thefields as required and then click the “OK” button to add the modified entry back to the list.
2 Toremove an output file:

1. Select the output file that you would like to remove.

2. Click the “Remove” button.

343 Dependent Files Tab

The “Dependent Files” tab (figure 3.14) iswhere you can specify the dependent files that are needed by the
phase. Before each file is passed into this phase, the HEW checks that the dependent files are of a more recent
date than the input file. If so, the phase will be executed for that file (i.e. dependent files have been modified
since the input file or files were last modified). If not, the phase is not executed for thefiles.

Dptinnsl Output Files  Dependent Files |

HCONFIGDIHT 5.
$[COMFIGDIR ) Filek. obj
FICONFIGDIR ] File?. obj ;
${CONFIGDIR]WFilsS obi Madiy... |
oW Hewbwork zphProjecthDebughFileT. obj

c:WHewWwfork sphProject\Debug'File2. obj Remove |
oW Hewbwork zphProjecthDebughFile3.obj

c:WHewWwfork sphProject\Debug'Filed. abj

Add...

Figure 3.14: Dependent Files Tab in Custom Options
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To add adependent file:

1. Click “Add...”. The“Add Dependent File" dialog will be invoked (figure 3.15).
2. Enter thefile path or browseto it using the “Browse...” button.

3. Click “OK” to add this output fileto the list.

Placeholder popup menu

fdd Dependent File

21x
Ll Browsze.. | Cance| |

Figure 3.15: Add Dependent File Dialog

To modify adependent file:
1. Select the dependent file that you would like to modify.

2. Click “Moadify..."”. The“Modify Dependent File” dialog, which is the same as figure 3.15 except the title,

will be invoked.
3. Modify thefields as required and then click the “OK” button to add the modified entry back to the list.
To remove a dependent file:
1. Select the dependent file that you would like to remove.
2. Click the“Remove” button.
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35 File Mappings

By default, the filesinput to a phase are only taken from the project, i.e. al project files of the type specified in
the “ Select input file group” drop-down list on the “New Build Phase” dialog (figure 3.3b). If you would like a
phase to take files output from a previous phase (i.e. intermediate files) then you must define thisin the “File
Mappings’ tab of the “Build Phases’ dialog (figure 3.16).

Build Phaszes E E2

Build Order I Build File Order  File Mappings |

Intermmediate file mappingz for build;

Source | Destination | File Group | Add. . I

Agzembler Linker Object file
Campiler Linker Object file ladifi..

HEmove |

ak Cancel

Figure 3.16: Build Phases Dialog File M appings Tab
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A file mapping states that you would like the HEW to pass output files of a certain type produced by one phase
(referred to as the source phase) to another phase (referred to as the destination phase). Such intermediate files
are passed in addition to the project files.

2 Toadd afile mapping:

1
2.

Click “Add..."”. The “Define File Mapping” dialog will beinvoked (figure 3.17).

Select the file group, which you want to pass between the phases from the “File group” drop-down list
box.

Select the source phase (i.e. which phase generates the files) from the “ Source phase” drop-down list box.

Select the destination phase (i.e. which phase takes these files) from the “ Destination phase” drop-down
list box.

Click “OK” to create the new mapping.

Define File Mapping

i,

File group:

| Object file I e
Source phase:

I.t’-‘n.ssembler j

Destination phaze:

Figure 3.17: Define File Mapping Dialog

To modify afile mapping:
1

Select the mapping to be modified.

2. Click “Modify..."” button. The “Define File Mapping” dialog will be invoked (figure 3.17).
3.
4. Click “OK” to commit the changes.

Modify the options as necessary.

53
RENESAS




3.6 Controlling the Build

By default, the High-performance Embedded Workshop will execute al of the phasesin abuild and only stop if
afatal error is encountered. You can change this behavior by setting the controls on the “Build” tab of the
“Options’ dialog (figure 3.18).

Options EHE3

Build |Editnl | Workspace | Confimation |

— Errarg and warnings:

[ Stop build if the no. of ermors exceed:

I 1]
¥ Stop build if the no. of warnings exceed: I 10

 Shaw:

[ Command line
[ Enwironment

[ Initial directom

ak. I Cahicel

Figure 3.18: Options Dialog Build Tab

Select [Tools->Options...] to invoke the dialog. If you want to stop the build when a certain number of errors
are exceeded then set the “ Stop build if the no. of errors exceed” check box and then specify the error count limit
in the edit field to the right. If you want to stop the build when a certain number of warnings are exceeded then
set the “ Stop build if the no. of warnings exceed” check box and then specify the warning count limit in the edit
field to theright.

Note: Irrespective of what these controls are set to, the build will always halt if afatal error is encountered.

In addition to specifying error and warning count limits, the “Build” tab also alows you to request that the
command line, environment and initial directory of each execution should be displayed. Check the appropriate
check boxes as necessary.
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3.7 L ogging Build Output

If you would like to write the results of each build to file then invoke the “ Customize” dialog by selecting
[Tools->Customize...] and select the“Log” tab (figure 3.19). Set the “Generate log file” check box and then

enter the full path of the log fileinto the “Path” field or browse to it graphically by clicking the “Browse...”
button.

Customize EHE

Toolbarsl Cnmmandsl tdenu I Debugger Log |Hel|:| I

¥ Generate log fils:

Path:

|$[WDF|KSF'DIH]\$MDHKSPNAME].IDd Ll Browse... |

QK. I Cancel

Figure 3.19: Tools Customize Dialog L og Tab
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3.8 Changing Toolchain Version

If two or more versions of the same toolchain are registered in the HEW, you can choose a version of the
toolchain on the “Change Toolchain Version” didog shown in Figure . To invoke the diaog, select [T ools-

>Change Toolchain Version...]. Choose one of the versions from the “ Available versions’ drop-down list and
click the “OK” button to enforce your choice.

Change Toolchain Yersion EHE
Toolchain name: Hitachi SuperH RISC engine
Current version: B.0.4

Cancel

I

Available versions: IB 02 j
. . Irtermeatien

Toalchain build phazes:

Build phase | Wergion |
OptLinker 70
SH Azzembler 5.0B
SH CAC++ Compiler .04
SH CAC++ Librany Generator 1.0

Figure 3.20: Change Toolchain Version Dialog

To show information of toolchain components select atool from the “Toolchain build phases’ list on the
“Change Toolchain Version” dialog and click the “Information” button. Then atool information dialog (figure
3.21) will show you the information of the tool. Click the “Close” button to close the dialog.

SH C/C++ Compiler Information EHE
Infiormation:
SuperH RISC engine CAC++ Compiler Wer, 7.0 ;I

Copyright [C] 1992,2007 Hitachi,Ltd. Hitachi Software Enginesring Co. Ltd.
Lizensed Materal of Hitachi Ltd. Hitachi Software Engineering Co..Ltd]

Figure 3.21: Toolchain Information Dialog
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3.9 Using an External Debugger

The High-performance Embedded Workshop can launch an external debugger tool. |f you want to use another
debugger then you must add it to the Tools menu (as described in chapter 6, “Customizing the Environment”.

The “Debugger” tab of the “Customize” dialog (figure 3.22) is where the HDI-related information is configured.
Y ou may wish to use an older version of the debugger if certain targets are not currently supported in the new
environment. Invoke it by selecting [T ools->Customize...] and then selecting the “ Debugger” tab.

Toolbarsl Cnmmandsl Menu  Debugger |Lng I Help I

¥ Use external debugger

HO location [W4.0 or greater):

IEZ\HEW'\HD|5'\S|M'\SH'\Hdi.EHE [ 3 | Browse. . |

Seszsion file:
|$[I:EINFIGDIFH]'\$[F'FEEIJECTNAME].hds Ll Browse. .. |

Cownload module;

I$[I:EINFIGDIFH]'\$[F'FHEIJECTNAME].ahs{ Ll Browse... |

ak. I Cahicel

Figure 3.22: Customize Dialog Debugger Tab

When an external debugger is used, check ‘Use external debugger’ and then set the following items. Firstly, the
location of the HDI executable must be specified. This must be version 4.0 or greater otherwise the behavior is
not guaranteed. The second item of dataisthe session file. Thistells HDI which session to load when it is
launched. Finally, the location of the download moduleis required. This allows the HEW to automatically
switch to HDI when the download modul e changes after abuild.

Click the “Launch Externa Debugger” toolbar button to invoke HDI with the specified session file:
e

After abuild, if the download module has been updated, the HEW will switch back to HDI to enable immediate
debugging. Whilst using HDI, double clicking in any source window will switch back to the HEW with the
source file open at the line which was double clicked.
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310 Generating a Makefile

The HEW allows you to generate a makefile, which can be used to build parts of your workspace without HEW.
Thisis particularly useful of you want to send a project to a user who does not have the HEW or if you want to
version control an entire build, including the make components.

2 To generate amakefile:

1. Ensurethat the project, which you want to generate a makefile for, is the current project.

2. Ensure that the build configuration that you want to build the project with is the current configuration.
3. Select [Build>Generate Makefile].
4

Once this menu has been selected adialog is displayed which asks the user what parts of the workspace
need to be added to the makefile. (See figure 3.23.)

5. Select the radio button which is relevant for your make file and then click OK.

Generate make file

f+ Far the current configuration in the currently active project

= Far all configurations in the currently active project Cancel |

" For all confisurations in all loaded projects in the current workspace

[¥ Scan dependencies befare make file eeneration

Figure 3.23: Generate makefile Dialog

The HEW will create a subdirectory “make” within the current workspace directory and then generate the
makefileinto it. It is named after the selection, with a.mak extension for example the current project and
configuration(e.g. project_debug.mak). The executable HMAKE.EXE, located in the HEW installation directory,
is provided for you to execute the makefiles generated by the HEW. It is not intended to execute makefiles,
which have been user modified.

2 To execute amakefile:
1. Open acommand window and change to the “make” directory where the makefile was generated.
2. Execute HMAKE. Itscommand lineis HMAKE.EXE <makefile>.

Note: The degree portability of agenerated makefileis entirely dependent upon how portable the project itself
is. For example, any compiler options, which include full paths to an output directory or include file
directory, will mean that, when given to another user with adifferent installation, the build will probably
fail. In general use placeholders wherever possible —using a full, specific path should be avoided when
possible.
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4. Using the Editor

This chapter describes how to use the editor that is provided with the High-performance Embedded Workshop.

41 The Editor Window

The editor window (figure 4.1) contains the file windows that are being viewed or edited. Only one window is
active at anytime. Thiswindow is called the active window (or current window) and itstitle bar will appear a
different color from that of the others (“dbsct.c” is the active window in figure 4.1). All text operations such as
typing, pasting text and so forth only affect the active window. To switch to another source file window (i.e. to
make some other window the active window) there are a number of methods:

e Clickonitifitisvisible.

e PressCTRL+TAB to cycle through the windows one after another.

e Select the window by name from the “Window” menu.

*  Sdectitstab at the bottom of the editor window.

When afile has been edited, an asterisk (*) is appended to the window’ stitle bar. The asterisk remains there
until thefileis saved. The asterisk isalso removed if dl of the edited changes are undone in the current window.

o
e 3
o
e 3
o
e 3
o
e 3

FILE ‘db=ct o

DATE :Thu, Aug 1e, 2001
DESCRIPTION :Setting of B.R Section
CFT TYFE JSHY0Z20

Thi= file i= generated by Hitachi Project Generator (Ver. 2.1).

Ffpragmna section SDSEC
=tatic const struct

char #rom_=; % Start address of the initialized data ==
char *rom_e: <% End addres=s of the initialized data =zect
char #*ram_=: % Start address of the initialized data =e=
IDTBL[ 1= 4 A
4 3
olF resetprgc ¢ dbscte ol shrk.c

Figure 4.1: Editor Window
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4.2 Working with Multiple Files

Thefile areais where you will work with the files of your project. The editor alows you to have many files open
at one time, to switch between them, to arrange them in different configurations and to edit them in whichever
order you want to. The operations that you can perform upon the windows are typical of most Windows®
applications and they can be found under the [Window] menu:

e [Window->Cascade]
Arrange all open windows so that they overlap, with the top | eft of each window visible.
e [Window->Tile Horizontally]
Arrange al open windows in sequence (horizontally) so that they occupy the entire editor window with no
overlapping edges.
e [Window->Tile Vertically]
Arrange all open windows in sequence (vertically) so that they occupy the entire editor window with no
overlapping edges.
e [Window->Arrange | cons]
Line up al minimized windows at the bottom of the editor window.
e [Window->Close All]
Close all open editor windows.

Thefiles within the editor can be displayed in a*“notebook” style. This means that each file has a separate tab
associated with it to aid in navigating between files.

2 To show filesin notebook:
1. Select [Tools->Options...]. The “Tools Options’ dialog box will be displayed. Select the “Editor” tab.
2. Set the “Show filesin notebook” check box as appropriate.
3. Click “OK” for the new settings to take effect.

421 The Editor Toolbars

The editor has four related toolbars: Editor, Search, Bookmarks and Templates. They provide a shortcut to the
functions of the editor, which you will use most often. The following sections describe each buttons function.
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4.2.2 Editor Toolbar Buttons

O New File

The new file button creates a new source file window with a default name. When you save the file, you can
specify your own filename.

(== Open File

Click this button if you want to open afile. It invokes a standard file chooser - select the file which you want to
open and then click “Open”.

= Save File
Saves the active sourcefile.
=] Save All Files

Saves dl of the filesin the editor.

=] Print File
To print the contents of the current window, click this button.
¥ Cut

Clicking this button will remove the current text selection and place a copy of it onto the Windows® clipboard
(it can be pasted back to afile with a paste operation).

Copy
This button allows you to copy the current text selection into the Windows® clipboard.
=) Paste

The paste button copies the contents of the clipboard into the active window at the position of the insertion
Ccursor.

LT Find

Click thisbutton if you want to find a certain text string in the current file. It invokes afind dialog box where
you can specify the search parameters.

iy Find in Files

To search severa filesfor atext string then click this button. All find results are displayed inthe “Find in Files’
tab of the “Output” window. For further information, refer to the “ Searching and Navigating Through Files’
section later in this chapter.

i Match Braces

The match braces button highlights text between braces of type{ }, [] and (). Thisis particularly useful when
attempting to find out the structure of C/C++ code blocks which are opened with { and closed with }. To useiit,
select the open brace to match from, or place the cursor before it, and then click this button. For further
information on brace matching, refer to the “Brace Matching” section later in this chapter.
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ar Insert Template

To insert a pre-defined template at the current cursor position, click thistoolbar button. The “Insert Template’
dialog box will be invoked. Select atemplate name and then click OK. For further information on templ ates,
refer to the “ Templates’ section later in this chapter.

) Toggle Bookmark

The High-performance Embedded Workshop editor provides standard bookmark capabilities. To set a bookmark,
select the line to mark and click this button (a green mark will then appear in the blank on the left side of the
editor window). To remove a bookmark, select the line to remove abookmark and click this button (the mark in

the blank on the | eft side of the editor window will disappear). For further information on bookmarks, refer to the
“Bookmarks” section later in this chapter.

423  Search Toolbar Buttons

= Find in Files

To search severa filesfor atext string then click this button. All find results are displayed inthe “Find in Files’
tab of the “QOutput” window. For further information, refer to the “ Searching and Navigating Through Files’
section later in this chapter.

iy Find

Click thisbutton if you want to find a certain text string in the current file. It invokes a find dialog box where
you can specify the search parameters.

& Find Next
Finds the next occurrence of the current search string.

?ﬂ Find Previous

Finds the previous occurrence of the current search string.

424 Bookmarks Toolbar Buttons

mm) Toggle Bookmarks

Sets a bookmark at the current line or clears a bookmark at the current line.
& Next Bookmark

Jumps to the next bookmark in the current file from the current line.

ma Previous Bookmark

Jumps to the previous bookmark in the current file from the current line.
2 Clear All Bookmarks

Clears al bookmarksin the current file.
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425 Templates Toolbar Buttons

*U"_" Define Template

Specify template text for subsequent insertion.
T Insert Template

Insert the template selected in the drop-down list at the current cursor position.
4.3 Standard File Operations

431 Creating a New File

2 To create anew editing window:
Select [File->New] or click the new file toolbar button (L) or press CTRL +N.

The window will be given an arbitrary name by default. Y ou can provide a new name when you save the file.

432 Saving a File

2 To save the contents of an editing window:
1. Ensure that the window, whose contents you want to save, is the active window.
2. Select [File->Save] or click the save file toolbar button (i) or press CTRL +S.

3. If thefile has not been saved before, afile save dialog box will be displayed. Enter afilename, specify a
directory and then click OK to create the file with the name given, in the directory specified.

4. If the file has been saved before, then the file will be updated (no dialog box will be displayed).
2 To save the contents of an editing window under a new name:

1. Ensure that the window, whose contents you want to save, is the active window.

2. Select [File->Save As...].

3. Afilesavediaog box will be displayed. Enter afilename, specify a directory and then click OK to create
the file with the name given, in the directory specified.

433 Saving all Files

2 To save the contents of every open editor window:

1. Select [File>Save All] or click the save all filestoolbar button (i)

2. If any of thefiles has not been saved before, afile save didog box will be displayed. Enter a filename,
specify adirectory and then click OK to create the file with the name given, in the directory specified.

3. If any of the files have been saved before, then the file will be updated (no dialog box will be displayed).
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434 Opening a File

2 Toopenafile:

1. Select [File->Open...] or click the open file toolbar button (&) or press CTRL +O.

2. Anopen file dialog box will be displayed. Use the directory browser (on the right) to navigate to the
directory in which the file you want to open islocated. Use the “Files of type” combo box to select the
type of file you want to open (or set it to “All Files (*.*)” to see every filein adirectory).

3. Onceyou have located the file select it and click “ Open”.

The High-performance Embedded Workshop keeps track of the last five files that you have opened and adds
them to the file menu under the “Recent Files’ sub-menu. This gives you a shortcut to opening files which you
have used recently.

2 To open arecently used file:
Select the [File->Recent Files] menu option and from this sub-menu select the desired file.

Y ou can aso open afileviathe “Projects’ tab of the “Workspace” window. Either double click the file you want
to open or select it, click the right mouse button (to invoke a pop-up menu) and then choose the [Open <file>]
menu option (where <file> isthe name of the file selected).

435 Closing Files

2 Tocloseindividual files select one of the following methods:
O Double click on the editor window’ s system menu (located at the top left of each window when not
maximized).
O Click on the editor window’s system menu (located at the top left of each window when not maximized)
and select the “ Close” menu option.
0 Ensurethat the window that you want to closeis the active window and then press CTRL +F4.
O Ensurethat the window that you want to closeis the active window and then select
[File->Close].
0 Click on the close button (located at the top right of each window when not maximized).
2 Tocloseal windows at once:
Select [Window->Close All].
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44 Editing a File

The High-performance Embedded Workshop editor supports standard editing functionality. Thisis available
through the usual methods (i.e. the menu, toolbar and keyboard shortcuts) and is additionally supported viaa
pop-up menu (or local menu) that islocal to each editor window. To invoke it, place the pointer in an open

window and click the right mouse button. Table 4.1 outlines the basic operations that are provided by the editor.

Table4.1 Basic Editing Operations
Operation Effect Action
Cut Removes highlighted text and places it on the Click the cut toolbar button
Windows® clipboard Select [Edit->Cut]
Select [Cut] - local menu
Press CTRL+X
Copy Places a copy of the highlighted text into the  Click the copy toolbar button
Windows® clipboard Select [Edit->Copy]
Select [Copy] - local menu
Press CTRL+C
Paste Copies the contents of the Windows® Click the paste toolbar button
clipt_)gard into t_he ac_tive window at the Select [Edit->Paste]
position of the insertion cursor
Select [Paste] - local menu
Press CTRL+V
Delete Removes highlighted text (it is not copied to  Select [Edit->Clear]
the Windows® clipboard) Select [Clear] - local menu
Press Delete
Select All Selects (i.e. highlights) the entire contents of  Select [Edit->Select All]
the active window Select [Select All] - local menu
Undo Reverses the last editing operation Select [Edit->Undo]
Select [Undo] - local menu
Press CTRL+Z
Redo Repeats the last “undone” editing operation Select [Edit->Redo]

Select [Redo] - local menu
Press CTRL+Y
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45

Sear ching and Navigating through Files

The High-performance Embedded Workshop editor provides find, replace and file navigation functionality. The
following three sections detail how to use these features.

45.1

Finding Text

9 To search for text in the current file:

1
2.

3.

Ensure that the window, whose contents you want to search, is the active window.
Position the insertion cursor at the point from which you want to start your search.

Select [Edit->Find...], press CTRL +F, sdlect [Find...] from the editor window’sloca menu or click the
find toolbar button (#}). The “Find” dialog box will be displayed (figure 4.2).

Find EE

Find what: Istring ﬂ Fitnd Mext |
™ Match whole word only Direction——— Cancel |

™ Match case ' Up
£ Dawn

™ Fegular expression

9.

Figure 4.2: Find Dialog

Enter the text that you want to search for into the “Find what” field, or select a previous search string
from the drop-down list box. If you select text before invoking the find operation, the selected text will be
automatically placed into the “Find what” field.
If you would like to search for character string as awhole word then check the “Match whole word only”
check box. When this option is not selected, the search will be for any string that is matched by the search
string.
If you would like your search to be case sensitive (i.e. to distinguish between upper and lower case
letters) then check the “Match case” check box.
If your search string uses regular expressions then check the “Regular expressions” check box. Refer to
Appendix B, “Regular Expressions’ for further information.
The “Direction” radio buttons allow you to select the direction of the search. Selecting “Down” means
that the search will be performed from the insertion cursor towards the bottom of the file. Selecting “Up”
means that the search will be performed from the insertion cursor towards the top of the file.
Click the “Find Next” button to begin the search. Click “Cancel” to stop the find action.

The High-performance Embedded Workshop editor also allows you to search for a string across many files.
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452

Finding Text in Multiple Files

2 To search for text in many files:

1

Select [Edit->Find in Files...], select [Find in Files...] from the editor window’s local menu or click the
find in files toolbar button (Egl4). The “Find in Files’ dialog box will be displayed (figure 4.3).

Find In Files EHE3
Find: IMyStruct j e

In files/types: I“.c:;“.cpp;“.e:-tp;".fsy;“.h;“.hpp;“.inc;“.lis;".lp -

Cancel

Pl

Diirectomy Ic:'\hewkdemn'\demo ﬂ Browse. .

™ Match case ¥ Search sub directories

™ Fegular expressions

Figure4.3: Find in Files Dialog

Enter the text that you want to search for into the “Find” field, or select a previous search string from the
drop-down list box. If you select text before invoking the find operation, the selected text will be
automatically placed into the “Find” field.
Enter the file extensions of the files you would like to search into the “In files/types’ field. If severd
extensions are specified be sure to separate them with acomma (e.g. *.c,*.h).
Enter the directory in which you would like to search files into the “ Directory” field. Alternatively you
may browse to the desired directory graphically if you click the “Browse...” button.
If you would like to search the directory specified and all directories below it then check the “ Search sub
directories’ check box. If you just want to search the single directory specified in the “ Directory” field
then ensure that this check box is not checked.
If you would like to search for character string as awhole word then check the “Match case” check box.
When this option is not selected, the search will be for any string that is matched by the search string.
I1f you would like your search to be case sensitive (i.e. to distinguish between upper and lower case
letters) then check the “Match case” check box.
Click “Find” to begin the search. Any matches found will be displayed in the “Find in Files’ tab of the
“Output” window. To jump to an instance of the string, double click on the desired entry in the “Output”
window.
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Replacing Text

Replacing text is similar to finding text, as discussed in the previous section. The difference is that when the text
is found you have the option to replace it with other text.

2 Toreplacetextin afile:

1
2.
3.

Ensure that the window, whose contents you want to replace, is the active window.

Position the insertion cursor at the point from which you want to start your search.

Select [Edit->Replace...], press CTRL +H or select [Replace...] from the editor window’s local menu. A
replace dialog box will be displayed (figure 4.4).

Enter the text that you want to search for into the “Find what” field, or select a previous search string
from the drop-down list box. If you select text before invoking the replace operation, the selected text will
be automatically placed into the “Find what” field.

Enter the text that you want to replace the search string with into the “ Replace with” field, or select a
previous replace string from the drop-down list box.

Replace 2xl

Find what: |string LI Find Mext I
Replace: with: frumeric =l Replace |
[~ Match whole word only Replace h———— Replace &ll |

[~ Match case (" Selection

[~ Reeular expreszion f+ Whale file Cancel |

&l open files

©
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Figure 4.4: Replace Dialog

. If you would like to search for character string as a whole word then check the “Match whole word only”

check box. When this option is not selected, the search will be for any string that is matched by the search
string.

. If you would like your search to be case sensitive (i.e. to distinguish between upper and lower case

letters) then check the “Match case” check box.

. If your search string uses regular expressions then check the “Regular expressions’ check box. Refer to

appendix B, “Regular Expressions’ for further information.
If you clicked “Find Next”, the editor will search for the first occurrence of the search string. Click
“Replace” if you want to replaceit. Click “Replace All” to replace al occurrences or click “Cancel” to
stop the replace action. If you select “Selection” in “Replace In”, selected range of the text is replaced. If
you select “wholefile”, the whole files are replaced. If you select al open files, al filesthat are
currently open in the editor have the replace operation carried out on them.
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Jumping to a Specified Line

2 Tojumptoalineinafile

1
2.

Ensure that the window, whose contents you want to replace, is the active window.

Select [Edit->Goto Line...], press CTRL+G. or select [Goto Line...] from the editor window’s local
menu. A goto line dialog box will be displayed (figure 4.5).

Enter into the dialog box the number of the line that you want to go to, and then click “OK”.
The insertion cursor will be placed at the start of the line number specified.

Line number |1
ak. I Cancel |

Figure 4.5: Goto Dialog
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4.6

Bookmarks

When working with many large files at atime, it can become difficult to locate specific lines or areas of interest.
Bookmarks enable you to specify lines that you want to jump back to at a subsequent time. One example of its
useisin alarge C file where you may want to set a bookmark on each function definition. Once a bookmark has
been set, it exists until it isremoved or the fileis closed.

2 To set abookmark:

1
2.

3.

Place the insertion cursor on the line to mark.
Select [Edit->Bookmar ks->Toggle Bookmark], press CTRL +F2, select [Bookmarks
->Toggle Bookmark] from the local menu or click the toggle bookmark toolbar button (3 ).

A green mark appearsin the blank on the left side of the line to indicate the presence of an active
bookmark.

2 To remove a bookmark:

1
2.

Place the insertion cursor on the marked line.
Select [Edit->Bookmar ks->Toggle Bookmark], press CTRL +F2, select [Bookmarks
->Toggle Bookmark] from the local menu or click the toggle bookmark toolbar button (2 ).
The mark will be removed and the line will return to normal text.

To jump to the next bookmark in afile:
Ensure that the insertion cursor is somewhere within the file to be searched.

Select [Edit->Bookmar ks->Next Bookmark], press F2 or select [Bookmarks->Next Bookmark] from
the local menu or click the next bookmark toolbar button ( & ).

2 Tojump to the previous bookmark in afile;

1
2.

Ensure that the insertion cursor is somewhere within the file to be searched.

Select [Edit->Bookmar ks->Pr evious Bookmark], press SHIFT+F2 or select [Bookmar ks->Previous
Bookmark] from the local menu or click the previous bookmark toolbar button ( ﬁﬁ ).

2 Toremove al bookmarksin afile:

1
2.

4.7

Ensure that the window, whose bookmarks you want to remove is the active window.
Select [Edit->Bookmarks->Clear All Bookmarks] or select [Bookmarks->Clear All Bookmarks]
from the local menu or click the clear all bookmarks toolbar button ( i ).

Printing a File

2 Toprint afile:

1
2.

70

Ensure that the window, whose contents you want to print, is the active window.
Select [File->Print...], or click the print toolbar button (&) or press CTRL +P.
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4.8 Configuring Text Layout

The following sections detail how to set-up the layout of the text within the editor windows.

481 Page Set-up

When you print afile from the High-performance Embedded Workshop editor, the settingsin the print dialog
box affect the way in which the fileis printed (e.g. double or single sided). Control over how the text is
formatted on the page can a so be controlled via the page set-up option. This allows you to specify the margins
(top, bottom, left and right) of your printouts. It is often necessary to set this because some printers cannot print
to the edges of an A4 page. Furthermore, some users have their own layout requirements (e.g. alarge left hand
margin so that code can be placed in an A4 binder).

2 To set-up the page margins:
1. Select [File->Page Setup...]. The “Page Setup” dialog will be invoked (figure 4.6).
2. Enter into the edit fields the margins required (set the “inch” or “mm” radio buttons to set the
measurements).
3. Click “OK” for the new settings to take effect.

Page Setup HE
b argin:

Lt [E Bioht o |
Top: lg— Bottam: lg—

@inch  C mm
Header:
i3
Footer:
| i3
()8 I Cancel |

Figure 4.6: Page Setup Dialog

2 To set-up the page header and footers:

1. Select [File->Page Setup...]. The “Page Setup” dialog will be invoked (figure 4.6).

2. Enter into the header and footer edit fields the text required to be displayed. All norma placeholders are
available along with page numbering, text justification and date fields. These are al expanded before
the pageisto be printed.

3. Click “OK” for the new settings to take effect.
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482 Changing Tabs

2 Tochangetab size:

1. Select [Tools->Options...]. The“Options’ dialog will be displayed. Select the “Editor” tab (figure 4.7)).

2. Enter into the“Tab size” field the number of desired tabs.
3. Click “OK” for the tab setting specified to take effect.

Options

Build  Editor |W0rkspace| Cnnfirmationl

— Spacing:

-

¥ Enable auta indentation

Tah size: I 4

— General:
W Save files before executing any tools [ Show files in noteboak:
™ Prompt before saving files ¥ Enable spntax colaring
— Extemnal editor:

™ Usze extemal editar:

o, |

ak. I Cahicel

Figure 4.7: Options Dialog Editor Tab

When aTAB key is pressed in the editor a tab character is usually stored in the file. However, sometimesit is
preferable to store spaces instead. The representation of tab characters can be controlled via the “Options” diaog.

2 To use spaces as tabs:

1. Select [Tools->Options...]. The“Options’ dialog will be displayed. Select the “Editor” tab (figure 4.7).

2. Setthe“Use spaces astabs’ check box as appropriate.
3. Click “OK” for the tab setting specified to take effect.
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4.8.3 Auto Indentation

When you press return in a standard editor the insertion cursor will move to the next line down, at the first
column (i.e. against the left hand side of awindow). Auto Indentation is afeature which, when return is pressed,
places the insertion cursor on the next line (as before) but under the first non-white space character of the
previousline. This enables you to type neat C/C++ or assembler code faster as you don't have to type leading
spaces or tabs yourself.

Figure 4.8 illustrates two examples. Thefirst (i) shows the effect of pressing return when the auto indentation
feature isdisabled - theinsertion cursor returns to the | eft-hand side of the window on the next line. When the
line “int z=20" istyped, it isnot aligned with the previous two lines. The second example (ii) shows the effect of
pressing return when auto indentation is enabled - the insertion cursor drops underneath the “i” of the previous
line. Now, when theline “int z=20" istyped, it is automatically aligned (i.e. automatically indented).

void myfunction(void)
{
int x=5;
inty=10;
=0
int z=20;

void myfunction(void)
{
int x=5;
int y=10;
=0
int z=20;

i) Auto Indentation Disabled

i) Auto Indentation Enabled

Figure 4.8: Effect of Auto Indentation

2 To enable/disable Auto Indentation:
1. Select [Tools->Options...]. The“Options’ dialog will be displayed. Select the “Editor” tab (figure 4.7).
2. Set the “Enable auto indentation” check box accordingly.
3. Click “OK" for the setting of the auto indentation check box to take effect.
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4.9 Splitting a Window

The High-performance Embedded Workshop editor allows you to split atext window into two. Figure 4.9 shows
the split bar button which islocated just underneath the maximize button at the top right hand corner of any text
window.

Figure 4.9: Split Bar Button

2 To split awindow:
Double click on the split bar button to split the window in half or click on the split bar button, keep the button
pressed, move the mouse down and then rel ease the mouse button at the point you want to split the window.
2 To adjust the position of the split bar:

Click on the split bar itself, keep the button pressed then move the bar to the new position and then release
the button.

2 Toremovethe split bar:
Double click on the split bar or move the split bar to the top or bottom of the window.
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410 Configuring Text

The following sections detail how to change the appearance of the text displayed in the editor windows.

410.1 Changingthe Editor Font

The High-performance Embedded Workshop allows you to specify the font to be used in itsinternal editor. All
editor windows, regardless of thefile type, use the same font.

2 To change the editor font:
1. Select [Tools->Format Views...]. The “Format Views’ dialog will be displayed. Select the Source icon
in the tree (figure 4.10).
2. Select the desired font from the “Font” list.
3. Select the size of the font from the “Size” list.
4. Click “OK” to confirm the new editor settings.

Format Views EHE3

Source
=3 Al
----- [ Selected Text
L) Temt
i1 Aszembly include file
i1 &szembly izt file
i1 &szembly source file Font

il A
C list file

| »

Font |

C zource file

C++ header file Gize

C+ ligt file

C+ gource file |1|:I jv
Expanded azzembly :
He:x file |-
Library information file
Linkage map file
Linkage symbol file &

o] d
| | FlEdify | Eemnowe | 0k I Cancel

HEW Sample Text

[
[
[
-
-
-
-
-
-
-
-
-
-
-

eppppooee

=5

Figure 4.10: Format Views Dialog Font Tab
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411  Syntax Coloring

To enhance code readability, the HEW editor can display specific strings (i.e. keywords) in different colors. For
instance, C source code comments could be shown in green and C types (e.g. int) could be shown in blue.

The coloring method used can be specified on afile group by file group basis. For example, you can define
different color schemesfor a C sourcefiles, text files, map files or even your own files.

2 To change exigting colors:

1. Select [Tools->Format Views...]. The “Format Views’ dialog will be displayed.

2. Select theitem underneath theicon in the tree you wish to modify the colour for. This should bethe file
type (e.g. C sourcefile) and correct keyword group (e.g. identifier or pre-processor).

3. Select the“Colour” tab.

4. Modify the “Foreground” and “Background” color lists as desired. The color “ System” refersto the
current window foreground and background settingsin control panel.

5. Click “OK” for the new colors to take effect.

2 To create new keyword groups:
1. Select[Tools->Format Views...]. The “Format Views' dialog will be displayed.
2. Select thefiletypein the tree to which you wish to add the new keyword group.
3. Click “Add...” underneath the tree. The “ Add Category” dialog box will be displayed (figure 4.11). Enter
the name of the keyword group in the “ Category Title” field, then click “OK” to create the new keyword
group.

Add Category EE
Cateqary Title: ] I

fi
Cancel |

Figure4.11: Add Category Dialog

2 To create new keywords:

1. Select[Tools->Format Views...]. The “Format Views' dialog will be displayed.

2. Select theitem underneath the source view icon in the tree you wish to modify the syntax highlighting
for. This should be thefile type (e.g. C sourcefile) and correct keyword group (e.g. identifier or pre-
processor).

3. Select the“Keywords’ tab (figure 4.12).
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(3 Clist file defaul ml
= D C zource file SEE
4 Comments For
[ Cantral goto
[ Declaration ifl
return
[ Operator suitch
[ PreProcessor wihila
C++ header file
C+ ligt file
C+ gource file
Expanded aszembly :
Hes file = HEW Sample Text
K0 »
sid | Mody | Bemove | ok | cancel |

Figure 4.12: Format Views Dialog K eywords Tab

4. Click the“Add...

" button to add a keyword. Then the “Add Keyword” dialog (figure 4.13) will be

launched. Specify akeyword in the “Keyword” field and click “OK” to close the didlog. To remove a
keyword, select the keyword and click the “Remove” button.

Add Kepword HE

Keyword:

Cancel |

Figure 4.13: Add Keyword Dialog

When you create anew file, syntax coloring will not be active as anew file does not initially have an extension
(new files are named arbitrarily by the editor without an extension). In order to activate syntax coloring, you
must save the new file with a name, which has one of the above extensions.

2 To disable/enable syntax coloring:

1. Select [Tools->Options...]. The“Options’ dialog will be displayed. Select the “Editor” tab (figure 4.7).
2. Set the “Enable syntax coloring” check box as necessary and then click “OK”.
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412 Templates

When developing software it is often necessary to enter the same text repeatedly, for instance, when typing a
function definition, for loop or acomment block for a function. The HEW editor allows you to specify a block of
text (or template) which can be inserted into the currently active editor window. Thus, once a template has been
defined, it can be automatically inserted without the need to re-enter it manually.

4121 Defining a Template

2 Todefine atemplate:

1. Select [Edit->Templates->Define Templates...], select [Templates->Define Templates...] from the
local menu, press CTRL+T or click on the define template toolbar button ( I ). Thedialog shown in
figure 4.14 will be displayed.

2. Click “Add”. A dialogisdisplayed that asksyou to enter your chosen template name. This name must
be unique otherwise a duplicated template name message will be displayed and the template will not be
added.

3. If you want to modify an existing template use the “ Template name” drop down menu to select which
template you want to modify.

4. Enter the desired text into the “ Template text” text area. Y ou can copy text from another editor window
and then pasteit into thisdialog using CTRL +V.

5. Enter the following keywords to insert specia information when the template isinserted:

Menu Entry Placeholder Replaced With

Time $(TIME) Current time

DateasDMY $(DATE_DMY) Current date, in dd/mm/yy form

Date asMDY $(DATE_MDY) Current date, in mm/dd/yy form

DateasYMD $(DATE_YMD) Current date, in yy/mm/dd form

Date as Text $(DATE_TEXT) Current date in text form

Line $(LINE) First line number of template insertion

User $(USER) Current windows user

File $(FULLFILE) Name of thefile

Filename $(FILE) Name and full path of thefile

Project Name $(PROINAME) Current project name

Workspace Name $(WORKSPNAME) Workspace name

Cursor position $(™) Insertion cursor — Positions the cursor
in this position after template has been
inserted

6. Enter the $(") character to specify where the insertion cursor is to be placed after the template has been
inserted. If thisis not specified then the insertion cursor will be placed after the last character in the
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template (asin anormal paste operation).
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Figure 4.14: Define Template Dialog

4122 Deleting a Template

2 Todedete atemplate:

1. Select [Edit->Templates->Define Templates...], select [Templates->Define Templates...] from the
local menu, press CTRL+T or click on the define template bookmark toolbar button ( I ). Thedialog
shown in figure 4.14 will be displayed.

2. Use the Template name drop down list to select the name of the template you wish to remove and then
click the “Remove” button.

3. Clicking “OK" saves the template changes and dismisses the dialog.

4123 Insertinga Template

2 Toinsert atemplate:
1. Select atemplate in the toolbar, then click the insert template toolbar button (T ), select [Edit->
Templates->Insert Template...] or select [Templates-> Insert Template...] from the local menu. The
dialog is dismissed and the chosen template is added to the current editor window.

4124 BraceMatching

Complicated source code can often become unwieldy, especially when blocks of C code are deeply nested within
each other or when complex logic statements are expressed within an ‘if’ clause. To help in such situations, the
High-performance Embedded Workshop editor provides a match brace feature which highlights text between
bracesof type{ }, () and[].

2 To find amatching brace:
1. Either highlight the open brace to match from or place the cursor beforeiit.

2. Click the match braces toolbar button ({ }), press CTRL+B, sdlect [Edit->M atch Braces] or sdlect
[Match Braces] from the local menu.

To check the structure of an entire file, place the cursor at its start and then repeatedly invoke the match brace
operation. The editor will successively highlight each pair of bracesin turn until there are no more to match.
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413  Editor Column Management

The editor in HEW has the ability to manage columns apart from the main editor column. These can be added
and used by debugger feature. Y ou can choose the column to display/undisplay.

«# tutorial ¢

0z00000a0c
0=00000al6

0z00000218
0x00000=20

0=00000a2c
0x00000a2e
0x00000a36
0x00000a38

0x00000a3a
O0x00000=44

0x00000=62
0z00000a66
0z00000a72
0x00000=274

TN

#include <no_float_h> ZI
#include <stdio.h>

#include <math.h>

#include <{stdlib.h>

void main{void);

void sort{long =a);

uvoid change(long xa);

extern void srand{unsigned int);

void main{void)

{

|

long a[18], min, max;
long j;
int i;

srand{1);
printF{ "t Data Input ##H#\R™);

For( i=8; i<1@; i++ ){
j = rand(};
if(j < 8)4
i=-is

a[i] = j;
printf(“a[%d]=%1d\n",i,a[i]);

sort{a});
printF{"==** Sorting results s==\n"};
for{ i=8; i<10; i++ ){
printf{"a[%d]=%ld\n",i,a[i]};
¥ v

P Y

Figure 4.15; Editor Columns

2 To switch off acolumnin al sourcefiles:
1. Right click on the editor window.
2. Click the “Define Column Format...” menu item.
3. The“Globa Editor Column States” dialog is displayed.
4. The"Check status’ shows whether the column is enabled or not. If it ischecked it is enabled if the
check box is gray this means that in some files the column is enabled and in other filesit isnot.
5. Click “OK” for the new column settings to take effect.

2 To switch off acolumn in one sourcefiles:
1. Right click on the editor window, which you wish to remove a column from, and the editor pop-up is

displayed.

2. Click the Columns menu item and a cascaded menu item appears. Each column is displayed in this pop-
up menu. If the column isenabled it hasatick next to itsname. Clicking the entry will toggle whether
the column is displayed or not.
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Global Editor Column States x|

[w]Cowerage
[w] Editor
[w]Source Address

Figure 4.16: Global Editor Column States Dialog
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5.  Tools Administration

Y ou control the components, which can be used by the High-performance Embedded Workshop viathe “Tools
Administration” dialog (figure 5.1), which isinvoked via[Tools->Administration...]. Modification of the
“Tools Administration” dialog box is only possible when no workspace is open, while only reference is possible
when aworkspace is open.

Tools Administration 2=l

Reqiztered compaonents: oK I
Campaonent | Yersion o~ c I
=43 Taolchains $|

HE §{ Hitachi SuperH RISC engine Standard Toolch. .. Bz
E1-3 System Taoals Lter...l
o Hitachi Mapview 1.0 Urregister |
7. Hitachi H Senies Librarian [nterface 11 —

“ Hitachi Call ‘W alker 1.0 Eaeiie |
----- 3 Utility Phazes
24 Debugger Components Expont... |

----- =] Generic Label View ECx 1.a

----- =] Monitar platform 1.0 Search disk... |
..... =| SHZ CPU 1.0 = =
..... =] Gerenc 10 Wiew ECx 1.0 Tool infarmation... |

----- =] SRecord object reader 1.0

mlﬁ F utarzing Caranmnants | _lﬂ Uninztaller. . |
4 * -

[ Show all components

Current HEW toolz databaze location;

Id: Shewhexeiwinhdebug Modify... |

Figure5.1: Tools Administration Dialog (Example)
There arefive standard types of component:

* Toolchain - aset of build phases (e.g. compiler, assembler, and linker). These components provide the build
capability.

e System Tool - an application (.EXE) which can be launched from the “Tools’ menu. They are often provided
as extra applications, which support the toolchain (e.g. an external debugger like the HDI or an interactive
graphical librarian).

» Utility Phase - a*“ready made” build phase which supports some specific build functionality (e.g. analyze
complexity of source code, count lines of source code, etc.). These components provide added functionality
to the build that is not toolchain specific.

» Debugger Component —acomponent that supports some specific debugger functionality (e.g. Target
platform, Object reader, etc).

» Extension Component —a component that provides key functionality in a certain area of the HEW system.
These components cannot be unregistered when installed (e.g. The HEW builder, debugger and flash
support).
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51 Tool Locations

The HEW maintains the locations of HEW compatible components automatically as each new tool isinstalled.
After installation, the HEW stores information about the component (including itslocation) — thisis referred to
asregigration. Although initia registration is automatic, during the course of development or if you want to
manage the tools being used in your projects more effectively, you may need to register components yourself.
The remainder of this chapter discusses registration and how it affects you.

5.2 HEW Registration Files (*.HRF)

When a HEW compatible component (i.e. toolchain, system tool or utility phase) isinstalled, part of its
installation will include afile with the extension .HRF (figure 5.2.i). Thisfile, named a“HEW Registration File”,
describes the component to the HEW. The process of registration refers to loading a component’s .HRF file into
the tools administration dialog (figure 5.2.ii).

i. INSTALL i. REGISTER

? [oR) c:\
MyTool MyTool

I:I MYTOOL.HRF _I:' MYTOOL.HRF | 3]
bin E (7= bin
etc @ etc

HEW

Figure5.2: HRF File Location and Registration

In order to use a component with HEW it must first be registered. The “Tools Administration” dialog (figure 5.1)
shows al currently registered components. To access it, ensure no workspaces are open and then select [Tools
->Administration...]. If you attempt to access tools administration when there is a workspace open the tools
administration dialog is opened but cannot be modified. When HEW isingtalled by default any new tools are
automatically registered.

HEW storestool information in atool database file. By default thisis created in the HEW application directory,
however if you are working in a network environment this directory may be set to another location. It ispossible
to change the tool directory location.

2 To change the tools location:
1. Select[Tools->Administration...].
2. Click the“Modify” button for the “ Current HEW tools database location” field.
3. Select the directory under which the new tool islocated, then click “OK”.
4. Thiswill switch the directory and change the tool |ocation to the new directory. It will be necessary to
scan for any new toolsthat may bein thislocation thisis achieved by using the scan disk or register tool
functionality.
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53 Registering Components

The HEW will automatically attempt to register any new componentsinstalled since the last time it was invoked.

However, in some circumstances you may need to register components yourself.

531 Sear ching Drives for Components

In some casesit is useful to search adrive for HEW compatible components. Thisis especialy useful if the

HEW installation was deleted or corrupted asit can recreate your tool information instantly.

2 To search for components:

1. Click the“Search Disk...” button on the “Tools Administration” dialog (figure 5.1). The “ Search Disk for

Components’ dialog will be displayed (figure 5.3).

Search Dizk for Components

Select the directony in which to begin the search:;

Ic: Whew

¥ Include subfolders

Located components:

Componet Werzsion | HRF Location

Hitachi SuperH RISC engine Standard Toole...  5.1.0 c:\hew\T oolch
Hitachi HES H8/300 Standard Toolchain 30a0  chhew\Toolck
Hitachi H Series Librarian Interface 1.0 c:\hewhToolck
Cygriuz GMUPro SH w332 ohhewhToolch
1&F ICCHE Toolchain 1.23a  cihhewh\Toolck
q | o

Search Status: 5 file(z] found

LCloze
Browsze. .

Start

Begizter

Reqizter Al

U,

Figure5.3: Search Disk for Components Dialog

2. Enter the directory in which you would like to search into the top field or browse to it graphically by

clicking the “Browse...” button.

3. Check the “Include subfolders’ check box if you would like to search the directory specified and all

directories below it.

4. Click the“Start” button to begin the search. During the search, the “ Start” button will change to a“ Stop”

button. Click the “ Stop” button to halt the search at any time.

5. Theresults of the search are shown in the “Located components” list. Select a component and click

“Register” to register an individua component or click “Register All” to register all located components.

6. Click “Close” to exit the dialog.
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5.3.2 Registering a Single Component

The HEW allows you to navigate directly to a single component in order to register it. The HEW Registration
File (*.HRF) islocated in the root directory of a component’sinstallation.

2 To register acomponent:
1. Click the“Register...” button on the “Tools Administration” dialog. A standard file open dialog will be
launched with itsfile filter set to “HEW Registration Files (*.hrf)”.
2. Navigate to the .HRF file of the component you would like to register, select it and then click “ Select”.
3. A dialog will be invoked which displays information regarding the selected tool. Click “Register” to
confirm that you want to register the tool or click “Closeg’ to abort the operation.

5.4 Unregistering Components

The components, which are registered with the HEW, affect the way in which it behaves. For example, every
compatible system tool, which isregistered, will be added to the tools menu when anew project is created.
Sometimes this may not be desirable. If so, open the “Tools Administration” dialog, select the component from
the “Registered components’ list and then click the “Unregister” button. A dialog will be invoked which asks
you to confirm thisaction. Click “Yes' to confirm the action.

Note:  Unregistering a component does not remove itsinstallation from hard disk. It ssmply removes the
information, which the HEW was storing about that component (i.e. it “disconnects’ it from the HEW).
The action can be easily reversed at anytime by registering the tool (see above). If you want to remove a
component from the hard disk (i.e. uninstall a component) then refer to the section “Uninstalling
Components” later in this chapter.
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55  Viewing and Editing Component Properties

To view information regarding a component, select it from the “ Registered components” list and then click the
“Properties’ button. The properties dialog will be displayed with the “ General” tab selected (figure 5.4). Thistab

displays the name, version and location of the selected component. None of the information on thistab is
editable.

Hitachi SuperH RISC engine Standard Toolchain 5.1.0 Properties B [E4
| Infarmation | Erviranment

MHame Hitachi SuperH RISC engine Standard
Wersion : 51.0

Lozation : cMhewsT oolchainghHitachibSHYWET0

ak. I Cancel |

Figure 5.4: Properties Dialog General Tab

Select the “Information” tab to view any information about the component (figure 5.5). This may include
copyright information, enhancements, bug fixes, user notes and so on.

Hitachi SuperH BISC engine Standard Toolchain 5.1.0 Propertie: [ E3

General Environment

Information:

Hitachi SuperH RISC engine Standard Toolchain Wer, 5.1.0

CAC++ Compiler Wer, 5.1
Azzember Wer 4.2
Optlinker  Yer. 1.1
[Likage Editar Wer. 6.0D]

El
ak. I Cahicel |

Figure5.5: Properties Dialog I nformation Tab
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Select the “Environment” tab, if it exists, to view and edit a component’ s environment settings (figure 5.6). This
dialog is most commonly used to modify the environment of atoolchain.

Hitachi SuperH RISC engine Standard Toolchain 5.1.0 Properties B [E4

General | Information  Enviranment

SHC_TMP=c:ATEMP

Figure5.6: Properties Dialog Environment Tab

To add anew environment variable, click the “Add...” button (the dialog shown in figure 5.7 will be invoked).
Enter the variable name into the “Variable” field, the variable' svalue into the “Vaue” field and then click “ OK”
to add the new variable to the “ Environment” tab. Placeholder pop-up menus are included to ensure that the
environment can be specified as flexibly as possible. For a detailed description of placeholders see appendix C,
“Placeholders’.

To modify an environment variable, select the variable that you want to modify from the “ Environment” tab and
then click the“Modify...” button. Make the required changesto the “Variable” and “Value” fields, and then
click “OK” to add the modified variable to the “ Environment” tab. To remove an environment variable, select it
and then click the “Remove’ button.

Environment ¥arnable EHE
Wariable:
= ak.
T ok |
Cancel |

> | Placeholder
21 PopUP FREnU

Walue:

Ic: wdos e mytools o windowes o temp

Figure5.7: Environment Variable Dialog

88
RENESAS




5.6 Uninstalling Components

The HEW provides abuilt in uninstaller method, which can remove unregistered components.

2 Touninstall acomponent:

1. Select[Tools->Administration...].
2. Click onthe uninstaller button. The“Uninstall HEW Tool” dialog isinvoked (figure 5.8).

Uninstall HEW Tool

Select the directary in which ta begin the zearch for tools:

v Include subfolders Start

Located Toolz which can be uninstalled:

LClose

Browsze...

Component

| Yerzion | Installation Directony Wrinetall

|

Bt

Search Status:

Idle

Figure5.8: Uninstall HEW T ool

3. Enter thedirectory in which you would like to search into the top field or browse to it graphically by

clicking the “Browse..

." button.

4. Check the “Include subfolders’ check box if you would like to search the directory specified and all

directories below it.

5. Click the“Start” button to begin the search. During the search, the “ Start” button will change to a“ Stop”
button. Click the “ Stop” button to halt the search at any time.

6. Theresults of the search are shown in the “Located Tools which can be uninstalled” list. Select a
component and click “Uninstall” to uninstall acomponent.

7. Click “Exit” to exit the dialog.

A component may only be uninstalled if it is not currently registered with the HEW. If you attempt to uninstall a
tool, which is registered, then the dialog shown in figure 5.9 will be displayed. In such a case, you must return to
the “Tools Administration” didog via[Tools->Administration...], unregister the tool and then invoke the tool

uninstaller again.
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Hitachi Embedde

]

Flease use the administration dialag to unregister the Toal,

: Hitachi SuperH RISC engine Standard Toaolchain 7.1.1.0 s currently registered; vou may not uninstall & bool that is reqisterad with HEW,

Figure5.9: Unable to Uninstall Tool

If atool is not registered with the HEW then the dialog shown in figure 5.10 will be displayed when the
“Unregister” button is clicked. This confirmation dialog displays al of the files and folders that will be deleted.
If you are certain that these files and folders can be deleted then click the “Yes” button. To abort the uninstall
click the “No” or “Cancel” buttons.

Confirmation

The following files and folders will be deleted:

o vhewt ToolchainziHitachinSHYWST 0hshe toolchain, bt
o vhewt ToolchaingsHitachibySHYWET 0N zample

o vhewt ToolchainziHitachinSHYWS T Minclude
c:hewh Toolchaing'HitachibSHYS10Mib

o vhewt ToolchainsiHitachinSHYWST 0Mbin

c:hewh T oolchaing HitachivSHYET Dhhew

o vhewt ToolchainsiHitachinSHYWSTDMbinwdwlbc iy exe
c:hewh ToolchaingHitachibSHYS1 DM binhshc. exe

o vhewt ToolchainsiHitachinSHYWST0Mbinsbicasm. exe
o vhewt ToolchaingsHitachiySHYWET0Mbinshoen meg
o vhewt ToolchainsiHitachinSHYWST 0Mbinsbcen. off
c:hewh ToolchaingHitachitSHYE1 DMbinkshofit exe
c:vhew' T oolchains ' HitachitSHYE10MBinshcgen exe
o vhevt ToolchaingyHitachibySHYWET0Mbinehchlp.meg
o vhewt ToolchainsiHitachinSHYWS T 0Mbinsbemdl exe
o vhewt Toolchaing'HitachiySHYWET0Mbintshopep.exe

Are pou sure pou want to delete the above filer and folders?

||

Cancel |
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Figure5.10: Confirmation Dialog
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5.7 Technical Support |ssues

The “Tools Administration” dialog is also capable of displaying information regarding “hidden” system
components. These are part of the HEW itself that cannot be unregistered/registered manually. If you check the
“Show all components’ check box on the tools administration dial og, extra component folders are displayed (see
figure 5.11).

Tools Administration 2=l

Reqiztered compaonents: oK I

Campaonent | Yersion B c I

-] Svstem Tools $|
[ Utility Phases .

([ Debugger Components ﬂl

-] Extension Components )

: ] b |

=43 Project Generstors ST

IR Hitachi S H Project Generator Propettiss |

[ Project Generators - Custom —

Ela Wersion Contral System Expoit,.. |

o e[m] Custom S 20 =

Ela Taolchain Support Search disk... |

b Hitachi SH T oolchain Supporter 21

-3 Definition Parser Toal infarmatiar... |

hd Uninstaller...
q - il

¥ Show all components

Current HEW toolz databaze location;

Id: Shewhexeiwinhdebug Modify... |

Figure5.11: All Components Shown

When seeking technical support, you may be asked to give details about some or al of these components. To do
S0, open the respective folder, select acomponent and click the “Properties’ button. The properties dialog that
will be invoked behavesin the same way as discussed previoudy in this chapter, with the exception that thereis
no “Environment” tab.

The HEW also has a feature, which outputs tool information regarding the registered componentsto afile. This
allows you to retrieve information on the entire HEW system. Thisinformation can then be sent to your
technical support contact if you are experiencing problems with the HEW.

2 To output tool information:
1. Click the[Tools->Administration] menu item.
2. Click the“Tool information...” button. A standard windows file save dialog is displayed.
3. Choosethefilelocation and click OK.
4. A fileiscreated in the chosen location with the current registered tool setup of the HEW 2.1.
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5.8 Custom Project Types

The [Project->Create Project Type...] menuitemin HEW allows you to create atemplate for your project.
This menu item takes the settings of the current project and then creates a project type for you. The user can
specify the name of the new type and style of the project generation wizard. Once created these project types
appear in the “Tools Administration” dialog and areinitially hidden in the system components part of the tools
administration tree. To export one of the custom project generators select the “Export” button on the “Tools
Administration” dialog. The execution environments of the custom project generators are packaged on the
execution file that can beinstalled. When thisfileis executed on the target user’s machine, the custom project
generator isinstalled.
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6. Customizing the Environment

6.1 Customizing the Toolbar

The High-performance Embedded Workshop provides 2 standard toolbars as detailed in chapter 1, “ Overview”.

In addition to these, you may also construct your own toolbars viathe “ Customize” dialog (figure 6.1).

Customize EE3

| Cnmmandsl Menu I Debuggerl Log I Help I

Toolbars:
V¥ Show Toolips Mew...

Rezet |

[w]*ferzion Control

Tioslbar name;:
Editor

ak. I Cahicel

Figure6.1: Customize Dialog Toolbars Tab

2 To create anew toolbar:
1. Select [Tools->Customize...]. The dialog shown in figure 6.1 will be displayed.
2. Click the“New...” button. The dialog shown in figure 6.2 will be displayed.
3. Enter the name of the new toolbar into the “Toolbar name” field.
4. Click “OK” to create the new toolbar.

Mew Toolbar EHE3

Taolbar narne:
IM T oolbad
Cahicel |

Figure 6.2: New Toolbar Dialog
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When anew toolbar is created it will appear undocked (i.e. “floating”) and empty.

2 To add buttons to atoolbar:

1. Select [Tools->Customize...]. The dialog shown in figure 6.1 will be displayed. Select the “ Commands’
tab (see figure 6.3).

2. Browse the available buttons by selecting the button categories from the “ Categories’ list. Select a button
from the “Buttons’ areato display information on its operation.

3. Click and drag a button from the dialog onto the toolbar.

Customize EE3
Toolbars  Commands | GET] I Debuggerl Log I Help I

Categories: — Buttonz

HE & &+ =@
# Gy | {1 T @

Bookmark z
Templates

Select a cateqary, then click a button to see itz description. Drag the buttan
to any toolbar

Description
lrﬂpen an exizting document

ak. I Cahicel

Figure 6.3: Customize Dialog Commands Tab

94
RENESAS




To remove buttons from atoolbar:

1. Select [Tools->Customize...]. The dialog shown in figure 6.1 will be displayed. Select the “ Commands’
tab (see figure 6.3).

2. Click and drag a button from the toolbar onto the “Buttons’ area.
To remove a user defined toolbar:
1. Select [Tools->Customize...]. The dialog shown in figure 6.1 will be displayed.

2. Select the user-defined toolbar from the “ Toolbars” list, and the “Reset” button in figure 6.1 changes to
the “Delete’ button. Then click the “Delete” button.

To reset a standard toolbar back to itsoriginal state:

1. Select [Tools->Customize...]. The dialog shown in figure 6.1 will be displayed.

2. Select the standard toolbar from the “Toolbars” list and then click the “Reset” button.

To show or hide toolbar tooltips:

1. Select [Tools->Customize...]. The dialog shown in figure 6.1 will be displayed.

2. Set the “Show Tooltips” check box as desired.

To modify the toolbar name of a toolbar created by a user:

1. Select [Tools->Customize...]. The dialog shown in figure 6.1 will be displayed.

2. Inthe“Toolbars’ list, select atoolbar, which has been created by a user and whose name you, want to
modify.

3. Modify the name of the toolbar in the “ Toolbar name” filed.
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6.2 Customizing the Tools Menu
The“Tools" menu can be customized to include your own menu options.

2 To add anew menu option:

1. Select [Tools->Customize...]. The dialog shown in figure 6.1 will be displayed. Select the “Menu” tab
(seefigure 6.4). Thefirst thing for you to decide is whether you are adding a global application wide
tool (“Application wide tools.”), which will be available to all of your workspaces. Or whether you wish
to add a workspace wide tool (“Workspace wide tool:”), which isonly valid for the current workspace.
Once you have made the choice choose the relevant section of the dialog.

Customize EE3

Toolbarsl Commands Menu |Debugger| Log I Help I

Application wide tools:

M arme | W ersion |

o,

Eemave

Workspace wide tools:

M arme | W ersion | B,

MEdit.

Eemove

Lt 1L

ak. | Cahicel |

Figure 6.4: Customize Dialog Menu Tab

2. Click the“Add...” button (the dialog shown in figure 6.5 will be invoked). If you would like to add an
existing system tool to the menu then select the “ Select from existing system tools” radio button, choose
the tool from the drop-down list and then click “OK”. Alternatively, if you would like to add atool of
your own then follow the remaining steps.

Enter the name of the tool into the “Name” field.

Enter the command, excluding arguments, into the “Command” field.

Enter any arguments that you would like to pass to the command into the “ Arguments’ field.
Enter an initia directory in which you would like the tool to run, into the “Initial directory” field.
Click “OK” to add the menu option to the “Tools’ menu.

N o gk w
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Add Tool

% Define new user bool

— Tool details:

i

Cancel
Hame :
IEr:pInler
Carrand :
|$MINDIF|]\E:<p|0rer.e:<e Ll ﬁmwse_,_l
Arguments :
| i3
Initial directary :
[$ITEMFDIR] ] Bgowse...l

" Select from existing system tools:

IHitachi Mapwiew [verzion 1.0] j

Figure 6.5: Add Tool Dialog

New menu options are added to the bottom of thelist (i.e. bottom of the tools menu) by default. The order of
menu optionsin the “Tools” menu can a so be modified.

2 To modify amenu option:

1. Select [Tools->Customize...]. The dialog shown in figure 6.1 will be displayed. Select the “Menu” tab
(seefigure 6.4).

2. Select the menu option that you would like to modify and then click the “Modify...” button.
3. Make the desired changes on the “Modify Tool” dialog (figure 6.6) and then click “OK”.

ModifyT ool HE
Cancel |

Command ;

[$1/INDIR)sexplorer.exe 9 | Browse... |
Argunents :

| i3

Initial directary :

[$(TEMPDIR) Ll e |

Figure 6.6: Modify Tool Dialog

2 To remove amenu option:

1. Select [Tools->Customize...]. The dialog shown in figure 6.1 will be displayed. Select the “Menu” tab
(seefigure 6.4).

2. Select the menu option that you would like to remove and then click the “Remove” button.
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6.3 Configuring the Help System

The High-performance Embedded Workshop provides context sensitive help within the editor window. In other
words, if you select some text in the editor window and then press F1, the High-performance Embedded
Workshop will attempt to locate help on that selected item. The help files, which will be searched, are listed in
the “Help” tab of the “Customize” dialog.

2 Toaddanew help file:
1. Select [Tools->Customize...]. The dialog shown in figure 6.1 will be displayed. Select the “Help” tab
(seefigure 6.7).

Customize EE3
Toolbarsl Cnmmandsl GET] I Debuggerl Log Help |
Help files:
D ezcription | File Name Add...
HEemave |
1] | ©
Ciefault help file;
INnne j
ak. I Cahicel |

Figure 6.7: Customize Dialog Help Tab

2. Click the“Add...” button. The“Add Help File” diaog will be displayed (figure 6.8).

3. Enter adescription of the help fileinto the “Title” field.

4. Enter the full path of the help file into the “ Path” field (or browse to it graphically by clicking on the
“Browse..."” button).

5. Click “OK" to define the new helpfile.

Add Help File [ 7] x|

Title:

= Ok

IF'rogramming inAMSIC 4'
Cancel |

Path:

Ic:'\fileskhelp'\ansi.hlp Browsze. I

Figure 6.8: Add Help File Dialog
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To make ahelp file the default choice, select it from the “ Default help file” drop-down list or set it to “(None)” if
you would like to be prompted for ahelp file when F1 is pressed.

6.4 Specifying Wor kspace Options

The High-performance Embedded Workshop allows you to control several aspects of a workspace viathe
“Options’ diaog (figure 6.9). To invoke it select [T ools->Options...], and select the “Workspace” tab.

Options EE3

Buld | Edter ‘Workspace | Confimation |

[ Open |ast workspace at stat-up

¥ Eestore files on opening workspace
™ Display workspace information dislog on opening workspace
[ Save workspace befare executing any toals

™ Frompt before saving workspace

Ciefault directomy for new workzpaces;

Crihew? Browse. . |

ak. I Cahicel

Figure 6.9: Options Dialog Workspace Tab

The following sections explain the options available on this tab.

6.4.1 Open last wor kspace at start-up

Set this check box if you would like the High-performance Embedded Workshop to automatically open the last
workspace you opened when it is launched.

6.4.2 Restore the files on opening wor kspace

When you close aworkspace, the HEW stores, which files were open. When you open aworkspace, the HEW
can restore (i.e. open) the same files so that you can continue your session in exactly the same state as when you
left it. If you would like the files associated with a workspace to be opened when you open a workspace then set
this check box.
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6.4.3 Display wor kspace information dialog on opening wor kspace

When many workspaces are being used, it is sometimes difficult to remember exactly what was contained within
each workspace. To help resolve this, the High-performance Embedded Workshop allows you to enter atextual
description of each workspace.

2 To enter aworkspace description:

1. Select the workspace icon from the “Projects’ tab of the " Workspace” window.

2. Click the right mouse button to invoke the pop-up menu and then select the “ Properties’ option. The
dialog shown in figure 6.10 will be displayed.

3. Enter the description into the “Information” field.

4. Check the “ Show workspace information on workspace open” check box if you want a workspace
properties dialog to be launched on opening a workspace. This check box has the same role as the
“Display workspace information dialog on opening workspace” on the “Workspace” tab of the “Options”

dialog.
5. Click “OK” to save the description on the “ Information” dialog. Click the “Cancel” button not to save the
description.
Workzpace Properties EHE
Mame; demo
Location: C:hew2hprojectyShdemot.demo. s
Lastmodified:  16:0%58, Thursday, August 16, 2001 Eancel |
CPU farnily: SuperH RISC engine
Tool chain: Hitachi SuperH Standard
Information:
Mo workspace information available ;I

¥ Show workspace information on workspace open

Figure 6.10: Workspace Properties Dialog

When aworkspace is opened, the High-performance Embedded Workshop can display thisinformation so that it
is possible to determine whether the workspace is the desired workspace. To display thisinformation on opening
aworkspace, set the “ Display workspace information dialog on opening workspace” check box.

6.4.4 Save wor kspace befor e executing any tools

To force the High-performance Embedded Workshop into saving the current workspace before executing any
build phases (i.e. build, build all or build file operations) or version control commands set the “ Save workspace
before executing any phases’ check box.

6.4.5 Prompt befor e saving wor kspace

In addition to the above check box, set thisto prompt before saving.
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6.4.6 Default directory for new wor kspaces

When anew workspace is created the High-performance Embedded Workshop invokes the “New Workspace”
dialog. One of the fields on this didog is the directory in which the new workspace will be created. By defaullt,
thisistheroot directory. However, if you would like to set this default directory to another location (e.g.
“C:\Workspaces’) then enter the desired directory into the field or browse to it graphically viathe “Browse...”
button.

6.4.7 Prompt before saving session

Checking this option will force the High-performance Embedded Workshop into displaying a prompt before the
session is saved to disk.
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6.5 Using an External Editor

The High-performance Embedded Workshop allows you to use an external editor. Once an external editor has
been specified, it will be launched when the following actions are performed:

» Double clicking on afilein the “Projects’ tab of the “Workspace” window.

» Double clicking on an entry in the “Navigation” tab of the “Workspace” window.
» Double clicking on an error/warning in the “Build” tab of the “Output” window.

» Double clicking on an entry in the“Find in Files’ tab of the “ Output” window.

* Selecting the [Open <file>] option from the “Workspace” windows pop-up menu.
* Clicking the “Launch Editor” toolbar button.

2 To specify an external editor:
1. Select [Tools->Options...]. The “Options’ dialog will be displayed. Select the “Editor” tab (figure 6.11).

Build  Editor |Workspace| Confirmationl

— Spaci

Tab size: I 4

¥ Enable auto indentation

— General:
¥ Save files before executing any toals ™ Show files in notebook
™ Prompt befare saving files ¥ Enable spntax coloring
— External editar:

™ Use gxtemal editor;

| el |

ak. I Cancel

Figure 6.11: Options Dialog Editor Tab
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2. Check the “Use external editor” check box.

The “External Editor” dialog will be displayed (figure 6.12).

External Editor

LCommand:
IE:\WINDDWS\Notepad.EHe Browsze... | Ok |

Arguments to open file: Cancel |
i3

|$[FULLFILE]

Arguments to open file at Jine:

|$[FULLFILE] |L|

Figure 6.12: External Editor Dialog

3. Enter the path of the executable (without any arguments) into the “Command” field.

4. Enter the arguments required to open afileinto the “ Argumentsto open file’ field. Use the $(FULLFILE)
placeholder to represent the path of the file to be opened.

5. Enter the arguments required to open afile at a specific line into the “ Arguments to open file at line” field.
Use the $(FULLFILE) placeholder to represent the path of the file to be opened and the $(LINE)
placeholder to represent the line number at which the cursor should be initially positioned.

6. Click “OK” to define the editor.
Note:  When using an externa editor be aware of the following issues:

« Each time you invoke the external editor, in whichever way, a separate instance of the editor will be launched.
* You must save your own files before you perform abuild file, build or build al operation.

6.6 Customizing File Save

The High-performance Embedded Workshop allows you to customize file save on the “Editor” tab of the
“Options’ dialog (figure 6.11). To open the tab, select [Tools->Options...] and click the “Editor” tab.

The following sections explain the options related to file save.

6.6.1 Save files befor e executing any tools

To force the High-performance Embedded Workshop into saving edited files before executing any build phases
(i.e. build, build al or build file operations) or version control commands, set the “ Save files before executing
any tools’ check box.

6.6.2 Prompt before saving files

In addition to the above check box, set thisto prompt before saving.
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6.7 Using an External Debugger

The High-performance Embedded Workshop can launch an external debugger tool. |f you want to use another
debugger then you must add it to the “Tools” menu.

The “Debugger” tab of the “Customize” dialog (figure 6.13) is where the HDI-related information is configured.
Y ou may wish to use an older version of the debugger if certain targets are not currently supported in the new
environment. Invoke it by selecting [T ools->Customize...] and then selecting the “ Debugger” tab.

Toolbarsl Cnmmandsl Menu  Debugger |Lng I Help I

¥ Use external debugger

HO location [W4.0 or greater):

IEZ\HEW'\HD|5'\S|M'\SH'\Hdi.EHE [ 3 | Browse. . |

Seszsion file:
|$[I:EINFIGDIFH]'\$[F'FEEIJECTNAME].hds Ll Browse. .. |

Cownload module;

I$[I:EINFIGDIFH]'\$[F'FHEIJECTNAME].ahs{ Ll Browse... |

ak. I Cahicel

Figure 6.13: Customize Dialog Debugger Tab

To use an external debugger, check the “ Use external debugger” checkbox and specify the items described below.
There are three items of information, which need to be specified. Firstly, the location of the HDI executable must
be specified. This must be version 4.0 or greater otherwise the behavior is not guaranteed. The second item of
dataisthe session file. Thistells HDI which session to load when it islaunched. Finally, the location of the
download moduleisrequired. This allows the HEW to automatically switch to HDI when the download module

changes after abuild. Click the “Launch External Debugger” toolbar button to invoke HDI with the specified
session file.

After abuild, if the download module has been updated, the HEW will switch back to HDI to enable immediate
debugging. Whilst using HDI, double clicking in any source window will switch back to the HEW with the
source file open at the line which was double clicked.
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6.8 Using Custom Placeholders

Throughout the High-performance Embedded Workshop the user can use a number of pre-defined placeholders
for directory definitions. For example the user can use the “$(PROJDIR)” variable to signify the current HEW
project directory. This makesit much easier to relocate projects and keep dl of the paths correct.

The High-performance Embedded Workshop also has the ability to define custom placeholders. This meansyou
can enter your own custom placeholder definition and decide upon its directory value. Once defined this
placeholder becomes avail able throughout the rest of the HEW system.

The placeholders can be defined on an application wide level so the placeholders are available to all workspaces
and projects that use the HEW. The other method of defining the placeholdersis using the workspace wide
custom placeholders this means the placeholders can only be used in the current workspace. Thislistisonly
available when you have a workspace open.

Customize EHE
Toolbarsl Eommandsl Menu  Placsholders | Debuggerl Log I Help I

Application wide custom placeholders:

Flaceholder | Directory |

Workspace wide custom placeholders:

Flaceholder | Directory | Add... |

()8 | Cancel |

Figure 6.14: Customize Dialog Placeholder Tab

2 To add a custom placeholder:

1. Select [Tools->Customize...]. The dialog shown in figure 6.1 will be displayed. Select the
“Placeholders’ tab (figure 6.14).

2. Choose whether you need to use an “ Application wide custom placeholder” or “Workspace wide custom
placeholder”. Click “Add” on the adjacent button to the list you reguire.

3. Thediaog, add “New Custom Placeholder” dialog is displayed. (figure 6.15)

4. Inthefields provided choose a suitable name for the placeholder and a description of what the
placeholder means.

5. Then choose a directory, which relates to this placeholder. It is possible to use placeholders that are
already defined in this field such as $(PROJDIR).
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Mew Custom Placeholder [ %]
Placehalder:
I Cancel |

Drescription:

Diirectory:

I Browse... |

Figure 6.14: New Custom Placeholder Dialog

6.9 Using Confirmation Dialog Boxes

The HEW allows users to specify many items for confirmation even in a single operation. Theseitems are
usually set by default. However, it may be annoying to handle the confirmation dialog boxesif you take the same
operation several times. Use the [Confirmation] page of the [Options] dialog box to control those confirmation
dialog boxes.

2 To view the content of [Display confirmation dialogsfor]:
1. Select [Tools->Options...]. Then select the “Confirmation” tab (figure 6.16).
2. Itemsto be confirmed are listed in the dialog box.
3. Totoggle acheckmark for an item, select the checkbox on the left of theitem’s name.

Build | Editar | Workspace Gonfirmation

— Digplay confirmation dialoes for:

wSplazh Screen = Set all |

(w|Dizplay Welcome dialog
[ |Load Program Clear All |
[ |Unload Program

[ J5ave Memary

whitialize Target

(w|Download modules after build
(w|Load memary

(w]'Werify memary

(wSave memary

(wIFill memary

(v Test memary

w|Delete All Labels

(w|Delete Label

[ ILoading Labels LI

QK. I Cancel

Figure 6.16: Confirmation Page for Optional Dialog Boxes
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7. Version Control

The High-performance Embedded Workshop provides facilities for connecting to a version control tool. Some of
the reasons why version control tools are used with a project are:

* To maintain theintegrity of a project.
» To store each stage of a project.
* Toenabledifferent users to co-develop a project by controlling revisionsto its source files.

Figure 7.1l illustrates a typica project where aversion control system isin use. This shows three users who al
use the same-shared network drive to exchange source code. The version control system provides access and
updates to the source files.

NETWORK

Figure 7.1: Version Control
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7.1 Selecting a Version Control System

Initially, the version control sub-menu will appear as shown in figure 7.2. At thistime only the [Version
Control->Select...] option is available because aversion control system isnot yet active for the current
workspace.

Window Help

Administration. . vlﬂl T J

[Ehatae iaaE chaT Yersan.,

1 Contral Select...
Customize... [EomfiauTe..,
Options... (o 3] Files]

o Lt il
)1 Canmeh Exterma Mebuggen.. [% _emo.ve fiefs]
= NEaR =]
Format Wiews. .. # [Ehenk [t EleE]

= ChecklhFilefs)
(&) Stafus of Filels]

Figure 7.2: Version Control Sub-Menu

2 To select aversion control system:
1. Select [Version Control->Select...]. The diaog shown in figure 7.3 will be displayed. Thisdialog lists
all of the supported version control systems.
2. Select the desired version control system from the “Version control systems’ list and click the “ Select”
button. The “Current version control system” is changed to reflect the new selection.
3. Click the “OK” button to confirm the selection.

Select Yersion Control System

Werzion control systems; ak
Customn YES

Cancel

Select

adil

Current verzion control system:

Mone

Figure 7.3: Select Version Control System Dialog
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Note:  Only those version control systems which have been installed with the HEW will appear in the “ Select
Version Control System” dialog (figure 7.3).

Once aversion control tool is selected you will notice that the [Version Control->Configure...] option has now
become available.

The next chapter discusses the usage of the custom version control system.
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8.  Using the Custom Version Control System

The custom version control system is a configurable addition to the High-performance Embedded Workshop,
which allows you to connect to aversion control system aready installed on your machine. To clarify further,
the High-performance Embedded Workshop does not provide a version control tool itself, only a means by
which you can integrate the version control system, which you use into your workspaces and projects.

8.1 Defining Version Control Menu Options

The custom version control system allows you to invoke aversion control command either by selecting an
option from the [Tools-> Version Control] sub-menu or by clicking aversion control toolbar button. When
either of these actions are performed, the associated commands are executed and the output is displayed in the
“Version Control” tab of the “Output” window.

2 To execute aversion control menu option or toolbar button:

1. Select whichever items you would like to apply the version control command to from the “Workspace”
window. This may include a workspace, project(s), folder(s) and file(s). When the command is selected,
all of the fileswill be extracted from the selected items and passed, in turn, to the version control
command. For example, if you select the workspace icon then all of thefilesin all of the projects will be
passed, in turn, to the version control command. Thiswill include any system files. For exampleif you
select the project item then

2. Select the required menu option from the [Tools->Version Control] sub-menu or click the desired
version control toolbar button.

The custom version control support allows you the most flexibility in specifying how aversion control system is
to be used. To configureit, select [Version Control->Configure...]. The“Version Control Setup” dialog will be
displayed (figure 8.1).
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Yersion Control Setup EHE

Commatds l F'miecls] General]

System menu options and toolbar buttons
Rt mm——
Check In File(s
Check Out File(s)
Get File(s)
Fermowve Filefz)
Status of File(s)

Madify,..

User menu options

1L

0K, I Cancel ‘ Expott... | Impeort... | .

Figure 8.1: Version Control Setup Dialog Commands Tab
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The “Commands’ tab contains two lists of menu options. The first list, “ System menu options and toolbar
buttons’, represents those menu options which always appear on the version control sub-menu. These menu
options also have an associated toolbar button on the version control toolbar. The second list, “User menu
options’, represents those additional user defined options which are added to the bottom of the version control
sub-menu. Figure 8.2 shows the structure of the version control sub-menu.

Options.. |

@: Bemove Filels]
Syaterm
% Get File(s) Diefired
& Check Out Fila(s) Opticn
B Check In Filels)
Status of Filels)
@ st N
. . User
Histary of Filels) Diefined
Undo Check out of Filels) Opticn

Figure 8.2: Version Control Sub-Menu

811 System Menu Optionsand Toolbar Buttons

In order to invoke commands from the toolbar or the system defined options of the [Tools->Version Control]
sub-menu, you must first define the associated commands that should be executed when they are activated. The
names of the options and their intended action are listed in table 8.1.

Table8.1: System Menu Option

Option Description

Add File(s) Add selected file(s) to version control system.

Remove File(s) Remove selected file(s) from version control system.

Get File(s) Get a read only local copy of the selected file(s) from version control system.

Check In File(s) Put back, i.e. update, the selected file(s) in version control system with the
local copy.

Check Out File(s)  Get a writable local copy of the selected file(s) from version control system.

Status of File(s) View the status of the selected file(s).

2 To modify asystem menu / toolbar option:
1. Select [Version Control->Configure...]. The dialog shown in figure 8.1 will be displayed.
2. Select the option to be modified from the “ System menu options and toolbar buttons” list and then click

the “Madify...” button. The dialog shown in figure 8.3 will be displayed. This figure shows a dialog
when “Add File(s)” has been selected for example.

3. Commands are added viathe “Add...” button. See the section, “ Defining Version Control Commands”’,
later in this chapter for further information.

4. Closethe“Define Command for “<command>"" dialog by clicking “OK".
5. Closethe “Version Control Setup” dialog by clicking “OK”.
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Define Commands for “Add File[s]"

Commands

Cancel

Tt
HEemayve

I EyE

LLLEAE

al iz e
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Figure 8.3: Modify System Menu Option (Example)
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8.1.2 User menu options

Y ou can create as many user defined menu options as you like, name them how you want and define their order
in the menu. User defined menu options do not appear on the version control toolbar.

2 To create anew version control menu option:
1. Select [Version Control->Configure...]. The diaog shown in figure 8.1 will be displayed.
2. Click the“Add..” button. The dialog shown in figure 8.4 will be displayed.
3. Enter the name of the menu option into the “Option” field.
4

. Commands are added to the menu option viathe “Add...” button. See the section, “ Defining Version
Control Commands”, later in this chapter for further information.

Close the “Add Menu Option” dialog by clicking “OK”.
6. Closethe“Version Control Setup” dialog by clicking “OK”.

o

Add Menu Option

Diption ;
IMprlion

Cancel
LCornrmands:

Tt
HEemayve

I EyE

LA

al iz e

Figure 8.4: Add Menu Option Dialog
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2 Toremove an existing version control menu option:

1
2.

3.

Select [Version Control->Configure...]. The didog shown in figure 8.1 will be displayed.

Select the menu option to be removed from the “User menu options” list and then click the “ Remove’
button.

Close the “Version Control Setup” dialog by clicking “OK”.

2 To modify an existing version control menu option:

1
2.

3.
4.

Select [Version Control->Configure...]. The didlog shown in figure 8.1 will be displayed.

Select the menu option to be modified from the “User menu options” list and then click the “Modify...”
button beside the list. The dialog shown in figure 8.4 will be displayed. (Thetitle of the dialog is“Maodify
Menu Option™.)

Modify the commands as necessary and then click “OK”.

Close the “Version Control Setup” dialog by clicking “OK”.

2 To change the ordering of version control menu options:

1
2.

116

Select [Version Control->Configure...]. The didog shown in figure 8.1 will be displayed.
Select the menu option to be moved and then click the “Move up” and “Move down” buttons as
necessary.

Close the “Version Control Setup” dialog by clicking “OK”.
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8.2 Defining Version Control Commands

Commands are defined when the “Add...” or “Modify...” buttons are clicked on the dialogs shown in figure 8.3
and figure 8.4. In either case, the dialog shown in figure 8.5 isinvoked.

Add Command EHE3

r— Command ;

- |
Wergion control executable ;
IVI'\VSS'\W|N32\SS.BHE Browse... |
— Cancel |

Arguments
IHistory $[YCOIR)HFILENAME] Y $USERNAME), $(PASS ﬂ

Initial directony ;

[$FILEDIF) P Bowse. |

— Executable return code

& Return code of executable is not meaningful

" Command has failed if the retun code is 1ot Equal To ﬂ ID

Figure 8.5: Add/Modify Command Dialog

2 To define acommand:
1. Enter the full path of the command into the “Version control executable” field or browse to it graphically
by clicking the “Browse...” button.
2. Enter the arguments for the command into the “ Arguments’ field.

3. Enter theinitial directory in which you would like to run the executable from into the “Initial directory”
field or browse to it graphically by clicking the “Browse...” button. In most cases this should be set to the
“$(FILEDIR)" placeholder, i.e. execute the command from the same directory asthefile.

4. Set the “Executable return code” options as described in the following section.
5. Click “OK” to define the new command.

8.2.1 Executablereturn code

If the return code of the command(s) can be used to indicate a failure then you should sel ect the “Command has
failed if the return codeis’ option and set the two fields to the right as required.

If the“Command has failed if the return codeis’ option is selected then the HEW will check the return code of
each command to determine whether a failure occurred. If so, no further commands will be executed and any
other processes which would follow the commands (e.g. build) will not be executed.

If the “Return code of tool is not meaningful” option is selected then the HEW will not check the return code of
each. Consequently, all commandswill execute regardless.
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8.3 Specifying Arguments

It is obvious that arguments must be specified correctly, otherwise the version control tool executed will not
function as intended. However, it is aso important, when using custom version control support, to specify the
argumentsin a flexible way as asingle version control command can be applied to more than one file. To
facilitate this, the “ Arguments’ field has a placeholder button (refer to appendix C, “Placeholders’, for anin
depth discussion of placeholders) which, when clicked on, invokes a pop-up menu of available placeholders
(figure 8.6). An explanation of each placeholder and how their values are derived can be found in table 8.2,
Arguments Field Placeholders.

l User login name
User login password
“ersion control directory
Camment
File path + name
Filename
File leaf
File extension
File directory
Configuration directory
Project directory
Workspace directory
Temp directary
Command directory
Windows directory
Windows system directory
Workspace name

Project name

Configuration name

Figure 8.6: Arguments Field Placeholder Pop-up Menu
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Table 8.2: Arguments Field Placeholders

Placeholder Value and How its Determined

User login name Current user login (“General” tab)

User login password Current user password (“General” tab)

Version control directory “Virtual” version control mapping (“Projects” tab)
Comment Comment specified before command execution
File path + name Full path and name of file involved in operation
Filename Filename (including extension) of file involved
File leaf Filename (excluding extension) of file involved
File extension Extension of file involved in operation

File directory Directory of file involved in operation
Configuration directory Current configuration directory

Project directory Current project directory

Workspace directory Current workspace directory

Temp directory Temporary directory

Command directory Version control executable directory

Windows directory Directory where Windows® is installed
Windows system directory Directory where Windows® system files exist
Workspace name Current workspace name

Project name Current project name

Configuration name Current configuration name

831 Specifying File L ocations

When referring to afile’ s location, be sure to use a placeholder, otherwise the command will only relateto a
hardwired file. For example, let'simagine that a version control executable has been selected which usesa-GET
command to obtain aread only copy of afile. The “Arguments’ field could be specified as:

-GET “c:\vc\files\project\main.c”

However, when executed, this command can only ever get the file MAIN.C. To resolve this problem, HEW uses
a system of placeholders and directory mappings. The latter tell the HEW which “working” directories (i.e.
where source files are being worked on) map to which “controlled” directories (i.e. where the source files are
stored in the version control system). Mappings between these two directory systems can be specified viathe
“Projects’ tab of the " Version Control Setup” dialog (figure 8.7).
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Yerzion Control Setup

Commands Frojects |Genera||

Shove details Far project : I Frojecti j

— Details ;

Yergion control directorny mappings ©

Source Directory | Werzion Control Directony d

c:wwark happlicationhprojectl = wchawhapphproject]

o mark happlicationhsrc whvwchawhapphan b iy,
o hwork hahared whwch ot zhared —

HEemayve

Ll

ol 0 | Ll

Enwironment :

Add...

e [0

i

EEmmvE

ok I Cancel Ewpont... Import. ..

Figure 8.7: Version Control Setup Dialog Projects Tab

2 To define anew mapping:

1. Select [Version Control->Configure...]. The diaog shown in figure 8.1 will be displayed. Select the
“Projects’ tab, and the dialog shown in figure 8.7 will be displayed.

2. Click the“Add...” button that is next to the “Version control directory mappings’ list. The dialog shown
in figure 8.8 will be displayed.

3. Enter the source (i.e. “working”) directory into the “ Source directory” field or browse to it graphically by
clicking the “Browse...” button.

4. Enter theversion control directory (i.e. “controlled”) directory into the “Version control directory”.

Yerzion Control Directory Mapping EHE
Source directary : Ok

Ic:'\work'\shared ﬂ Browise... I Cancel |

Yerzion control directon ©

I:-:Z wechawhshared

Figure 8.8: Version Control Directory Mapping Dialog
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2 To modify an existing mapping:
1. Select [Version Control->Configure...]. The diaog shown in figure 8.1 will be displayed. Select the
“Projects’ tab, the dialog shown in figure 8.7 will be displayed.
2. Select the mapping to be modified from the “Version control directory mappings’ list and then click the
“Modify...” button. The dialog shown in figure 8.8 will be displayed.
3. Make the necessary changes to the two directories and then click “OK” to confirm the edits.
2 To remove an existing mapping:
1. Select [Version Control->Configure...]. The diaog shown in figure 8.1 will be displayed. Select the
“Projects’ tab, the dialog shown in figure 8.7 will be displayed.

2. Select the mapping to be removed from the “Version control directory mappings’ list and then click the
“Remove’ button.

Once the mappings have been defined you can use the “Version control directory” placeholder, $(VCDIR), to
represent the directory in which the project file is stored. Consider the scenario shown in figure 8.9. Here are
three directories, which are mapped from a shared version control drive (X:\) to aloca drive where the
development is being done (C:\).

LOCAL - C:\ Mapped To NETWORK - X:\

- =

C:\work\application\project1 X:\ve\swh\app\projectl

: €

C:\work\application\src X:\ve\sw\app\src

E:

C:\work\shared

Bl

X:\vc\sw\shared

Figure 8.9: Example Mappings

Now let’simagine that a version control executable has been selected which uses a—GET command to obtain a
read only copy of afile. In order to get dl of the filesin a project we need to use the following command:

- GET “$(VCDI R)\ $( FI LENANE)”

When the HEW executes the command for a given project file, it will replace $(VCDIR) for the equivalent
version control directory in the file mapping.

For example, suppose FILEL.C islocated at:
c:\work\application\projectl\filel.c
If the get command is applied to FILEL.C then:

(2) X:\ve\sw\app\projectl is substituted for $(VCDIR) as thisis the version control directory mapping for
c:\work\application\projectl.

(2) FILEL.C is substituted for $(FILENAME).
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Project File: C:\work\application\projectl \ filel.c

Arguments: $(VCDIR) \ $(FI LENAME)

(@) @)

Command: X:\vc\swhapp\projectl \ filel.c

Figure 8.10: Example of Substitution

8.3.2 Specifying Environment
Select the “Projects” tab of the “Version Control Setup” dialog to view the current settings (figure 8.7).

To add anew environment variable click the“Add...” button beside the “ Environment” list (the diadlog shown in
Figure will beinvoked). Enter the variable nameinto the “Variable” field, the variable' s value into the “Value”
field and then click “OK” to add the new variable to the “ Environment” list.

Environment ¥ariable E E2

i.ralialgle :
Cancel |

Walue

| Placeholder
I » | PopUp MEnu

Figure 8.11: Environment Variable Dialog

To modify an environment variable, select the variable that you want to modify from the “ Environment” list and
then click the“Modify...” button beside it. Make the required changes to the “Variable” and “Vaue” fields and
then click “OK” to add the modified variable back to thelist. To remove an environment variable, select the
variable that you want to remove from the “Environment” list and then click the “Remove” button beside it.
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8.3.3 Specifying Comments

If acommand contains the placeholder “$(COMMENT)” then the HEW will request that you enter the comment
when the command is executed (viathe dialog as shown in figure 8.12).

Please Enter Comment EHE3

File: c:hewtdemohdemohsbrk. ¢

Cancel |
Comment

[ Apply comment to al files

Figure 8.12; Please Enter Comment Dialog

Y ou may specify acomment for each file or, if you would like to specify the same comment for all files, check
the “Apply comment to al files’ check box before clicking “OK”.

123
RENESAS




834

Specifying a User Name and Password

Most version control toolswill require you to pass a user name and password on the command linein order to
keep files secure and to keep a record of which files were changed by which users. The custom version control
support provides two placeholders “ User login name”, $(USERNAME), and “User login password”,
$(PASSWORD). When the command is executed, these placeholders will be replaced with the current settingsin
the “Genera” tab of the “Version Control Setup” dialog (figure 8.13).

Yersion Control Setup

Eommandsl Projects General |

— Execution :

¥ FPrompt before executing command
[ Runin DOS ‘Window

[ Use forward slash ' as version control directory delimiter

— Usger details :

zer: JHARE,

s

Password ;

— Configuration file:
Current verzion contral configuration file:

C:AHew Project1WCustomy 25 hve

ok Cancel Ewpont...

Import. ..
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Figure8.13: Version Control Setup Dialog General Tab
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In order to give the 3(USERNAME) and $(PASSWORD) fields a value you will first need to login. If you have
not logged in before acommand is executed which uses either of these placeholders then you will be prompted
to do so before the command can be executed.

2 Tologin (i.e. specify auser name and password):
1. Click the“Login...” button. The dialog shown in figure 8.14 will be displayed.
Enter your user nameinto the “User name” field.
Enter your password into the “ Password” field.
Re-type your password again into the “ Confirm password by retyping it below” field.
Click “OK” to set the new user name and password. If there is any inconsistency between the two
versions of the password which you entered then you will be requested to type your password again.

ok~ wDN

Uzer name : ok I
JHARE,
I Cancel |

Pazsword

Ixmmmm

Confirm password by retyping it belov

Figure8.14: Login Dialog
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84 Controlling Execution

The “Genera” tab of the“Version Control Setup” dialog (figure 8.13) allows you to control the way in which
the version control tool is executed. It also shows the full path to the current version control configuration file.

8.4.1 Prompt befor e executing command

If this check box is set then, before any version control commands are executed, adialog is displayed (figure
8.15) which lists al of the filesinvolved in the operation. Files may be deselected by clearing the associated
check box. Clicking “OK” will apply the command to each of the selected files. Clicking “Cancel” will abort the
operation.

History [ 7] x|

Filez

widemo.c  [c:hhewidemohdemao)

(wzbrk.c [z:\hewhdema'.demo] Cancel |

(v vectthl zrc [o:hhewdemohdemao)

KN — Il

Figure 8.15: Command Prompt Dialog (Example)

8.4.2 Run in DOS Window

By default, the output of the version control commandsis redirected to the “Version Control” tab of the “ Output”
window. If you would rather run each command in a separate DOS window then set this check box.

8.4.3 Useforward slash ‘/' asversion control directory delimiter

By default, when the HEW substitutes the placeholder $(V CDIR) it uses the backward slash character ‘\" to
divide directories. However, if the version control system you are using uses a forward slash character (e.g.
Visual SourceSafe) to divide directories then set the “Use forward slash */* as version control directory
delimiter”.

8.5 Importing and Exporting a Set-up

Each workspace can have a different version control set-up. The HEW allows you to store the version control
settings independently so that you can import them into other workspaces. This greatly reduces the amount of
timeit takes to configure the same version control settings across several workspaces.

2 To export aversion control set-up:
1. Select [Version Control->Configure...]. The diaog shown in figure 8.1 will be displayed.

2. Click the “Export..."” button. A standard file save dialog will be displayed. Browse to the directory in
which you would like to save the configuration.

3. Enter the name of the file and then click “OK”.
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2 Toimport aversion control set-up:
1. Select [Version Control->Configure...]. The diaog shown in figure 8.1 will be displayed.

2. Click the “Import..."” button. A standard file open dialog will be displayed. Browse to the * .HVC file
which you would like to import.

3. Select thefileand then click “OK".
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9. Using Visua SourceSafe

The High-performance Embedded Workshop provides specific support for the Visua SourceSafe version control
system. At the time of writing, the HEW can only attach to versions 5 and 6 of Visua SourceSafe.

The Visua SourceSafe version control system associates a project in your workspace with aproject inside a
Visual SourceSafe database. It alows you to quickly invoke the standard commands either by selecting an option
from the [T ools->Version Control] sub-menu or by clicking aversion control toolbar button.

9.1 Attaching Visual SourceSafeto aWorkspace

The following sections describe how you can associate Visua SourceSafe with your current workspace.

911 Selecting Visual SourceSafe
First, you need to select Visual SourceSafe as the version control system.

2 Touse Visua SourceSafe 5.0 or 6.0:

1. Select [Tools->Version Control->Select...]. The “Select Version Control System” dialog will be
displayed (figure 7.3) which lists all of the supported version control systems.

2. Select the“Visua SourceSafe 5.0/6.0" entry from the Version Control Systems list and click the “ Select”
button.

3. Click “OK” to confirm the selection. The SourceSafe Login dialog is displayed (figure 9.1).

4. Enter your Visual SourceSafe login into “Username” and password into “ Password”.

5. Enter into Database path the full path to the Visual SourceSafe database (i.e. SRCSAFE.INI) into which
you would like to add this project.

6. Click “OK". The“Create SourceSafe Project” dialog isinvoked (figure 9.2).

7. The“Project name” field displays the name of the project (i.e. folder) to be created in the database. If
necessary you can change this name to another.

8. Thetree underneath the “ Project name” field shows the structure of the database specified in step 6.
Select the folder into which you would like to create the folder specified in the “ Project name” field.

9. Click “OK".

10. HEW will require you to repeat steps 7-9 for as many projects as are present in the current workspace.

SourceSafe Login EHE

Uzernarne: I
Paszword: I ﬂl

Latabaze path: I Browsze. . |

Figure 9.1: SourceSafe L ogin Dialog
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Create SourceSafe Project

PBroject name: _
Iprniect

Cahicel |
$/project

-

||

Figure 9.2: Create SourceSafe Project

The HEW has now created the necessary projects within Visual SourceSafe and sets-up the version control
toolbar and menu for immediate access. However, although the Visual SourceSafe projects themselves have
been created, no files have been added to them.

912 Adding filesto Visual SourceSafe

The previous section has only established the mappings between the project directory on your hard disk (i.e. the
working directory) and the project directory in Visual SourceSafe (i.e. the controlled directory). Although the
project directory (and any subdirectories) on your hard disk may contain many source files whereas the directly
its mapped to in Visua SourceSafe will be initially empty.

Firstly, you must select Visual SourceSafe as the version control system.

2 Toaddafileor filesto Visua SourceSafe:

1. Select thefile(s), which you would like to add to Visua SourceSafe. You may also select afile folder,
project folder, aworkspace folder or combination thereof. When selecting the project or workspace
folder then the system files will be added to the selected file list. For example, selecting the project folder
will also add the project fileto thefilelist. If the project file isthen checked out and the version is newer
than when it was last |oaded you will be asked whether you want to reload the project.

2. Click the Add Files toolbar button ( @?) or select the [Tools->Version Control->Add Files] menu
option.

When you add filesto Visual SourceSafe the local versionsin your working directory will become read only. To
check that the add files operation was carried out as you expected, or to quickly review the status of all of the
filesin aproject:

1. Select the poject folder whose files you want to check.

2. Click the Status of Filestoolbar button ( @ ) or select the [Tools->Version Control->Status of Files]
menu option.

3. The status of each file will be displayed in the “Version Control” tab of the “ Output” window. The
information shown includes whether the file is added to the project, if the file is checked out and, if it is
checked out, who did so.
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9.2 Visual Sour ceSafe Commands
Thefollowing 8 operations are available:

* Add afileto version control

* Remove afile from version control

* Get aread only copy of afileor files

»  Check out aread/write copy of afileor files (i.e. for editing)

» Check inapreviously checked out file or files (i.e. update Visual SourceSafe with the edits made)
» Undo apreviously check out operation on afile or files (i.e. cancel any edits made)*

* View the status of afile

* View the history of afile*

*These commands can only be accessed viathe [Tools->Version Control] sub-menu whereas all of the other
commands can be accessed from both the toolbar and menu.

921 Removing a File from Version Control

Although files appear in your HEW project (in the “ Projects’ tab of the “Workspace” window, Visual
SourceSafeis not necessarily controlling them.

2 Toremoveafileor files from Visual SourceSafe:
1. Select thefile(s), which you would like to remove from Visual SourceSafe. Y ou may aso select afile
folder, project folder, a workspace folder or combination thereof.

2. Click the Remove Files toolbar button ( @- ) or select the [Tools->Version Control->Remove Files]
menu option.

9.2.2 Getting a Read Only Copy of a Filefrom Version Control

Visual SourceSafe protects your source files and ensures that only one user can have awritable copy of a
controlled file at any one time. However, it is possible for any user to obtain aread only copy of any file.

2 Toget aread only copy of afileor files from Visual SourceSafe:
1. Select thefile(s), which you would like to get from Visua SourceSafe. Y ou may also select afile folder,
project folder, a workspace folder or combination thereof.

2. Click the Get Filestoolbar button ( % ) or select the [Tools->Version Control->Get Files] menu
option.

9.2.3 Checking Out a Writable Copy of a File from Version Control

Visual SourceSafe protects your source files and ensures that only one user can have awritable copy of a
controlled file at any one time. The check out operation takes awritable copy of thefile from Visua SourceSafe
and placesit on your local drive. Thiscan only be done if another user does not already check out the file or files
in question.

2 To check out awritable copy of afileor files from Visual SourceSafe:
1. Select thefile(s), which you would like to check out from Visua SourceSafe. You may also select afile
folder, project folder, a workspace folder or combination thereof.

2. Click the Check Out Filestoolbar button ( 5 ) or select the [Tools->Version Control->Check Out
Files] menu option.
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9.24 Checking In a Writable Copy of a Fileinto Version Control

Visual SourceSafe protects your source files and ensures that only one user can have awritable copy of a
controlled file at any one time. The check out operation takes awritable copy of thefile from Visua SourceSafe
and placesit on your local drive. Once afileis checked out it is edited and then checked back in so that the edits
can be made available to other users.

2 Tocheck in editsmadeto afileor filesin Visua SourceSafe:
1. Select thefile(s) upon which you would like to check back into Visual SourceSafe. You may also select a
file folder, project folder, a workspace folder or combination thereof.

2. Click the Check In Filestoolbar button ( 2 ) or select the [Tools->Version Control->Check In] menu
option.

9.25 Undoing a Check Out Operation

Visual SourceSafe protects your source files and ensures that only one user can have a writable copy of a
controlled file at any one time. The check out operation takes awritable copy of thefile from Visua SourceSafe
and placesit on your local drive. Once afileis checked out it is edited and then checked back in so that the edits
can be made available to other users. However, if the check out operation was carried out by mistake, or perhaps
isno longer required, then the operation can be undone.

2 To undo acheck out of afile or files from Visual SourceSafe:

1. Select the file(s) upon which you would like to undo a previous check out operation. Y ou may also select
afile folder, project folder, a workspace folder or combination thereof.

2. Select the [Tools->Version Control->Undo Check Out] menu option.

9.2.6 Viewing the Status of a File

Although files appear in your HEW project (in the Projects tab of the Workspace window), Visual SourceSafeis
not necessarily controlling them. Of those files, which are being controlled by Visual SourceSafe, some will be
checked in and others will be checked out (i.e. being edited by a user). The status command displays the current
status of afileor file(s).

2 Toview the status of afileor filesin Visua SourceSafe:
1. Select the file(s) whose status you would like to view. You may also select afile folder, project folder, a
workspace folder or combination thereof.

2. Click the Status of Filestoolbar button ( @. ) or select the [Tools->Version Control->Status of Files]
menu option.

9.2.7 Viewing the History of a File

Visual SourceSafe controlsthe edits to the filesin its projects and allows you to view the complete history of
these edits right back to the time that the file was first added to the project.

2 Toview the history of afileor filesin Visual SourceSafe:

1. Select thefile(s) whose history you would like to view. Y ou may aso select afile folder, project folder, a
workspace folder or combination thereof.

2. Select the [Tools->Version Control->Show History] menu option.
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9.3 Visual SourceSafe Integration Options

Y ou can control the way in which the history and status commands are displayed by selecting [Tools->Version
Control->Configure...].

To display the results of a history command in a dialog box then check the “Display dialog box for history”
check box or clear it if you would rather display the output in the “Version Control” tab of the “ Output” window.
To display the results of a status command in adialog box then check the “Display dialog box for file status’
check box or clear it if you would rather display the output in the “Version Control” tab of the “ Output” window.
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Emulator Debugger Part
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Sectionl Overview

1.1 Features

The breakpoint, memory map, performance, and trace can be set through the dialog box.
O Intuitive user interface

O Online help

0 Common display and operability

Supported host interfaces

The PClI interface, PC card (PCMCIA) interface, USB interface, or LAN interface can be used for connecting
to the host computer.

Realtime emulation
Redltime emulation of the user system is enabled at the maximum operating frequency of the CPU.
Excellent operability

Using the HEW enables user program debugging using a pointing device such asamouse. The HEW
enables high-speed downloading of load module files.

Various debugging functions

Various break and trace functions enable efficient debugging. Breakpoints and break conditions can be set
by the specific window, trace information can be displayed on a window, and command-line functions can be
used.

Memory access during emulation
During emulation, the memory contents can be read and modified.
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12 Warnings

CAUTION

READ the following warnings before using the emulator product.
Incorrect operation will damage the user system and the emulator
product. The USER PROGRAM will be LOST.

1. Check al components against the component list after unpacking the emulator.

2. Never place heavy objects on the casing.

3. Do not place the emulator in places where:

*  Thetemperature becomes high such asin direct sunlight or near a heater. For details, refer to section 1.3,
Environmenta Conditions.

e Thetemperature or humidity changes greatly.

e Thereisalot of dust.

* Thereisalot of vibration. For details, refer to section 1.3, Environmental Conditions.

Protect the emulator from excessive impacts and stresses.

Only supply the specified voltage and power-supply frequency.

When moving the emulator, take care not to vibrate or damageit.

After connecting the cable, check that it is connected correctly. For details, refer to section 2, Preparation

before Use. Supply power to the connected equipment after connecting all cables. For the supplying

procedures, refer to section 2.7, System Check. Cables must not be connected or disconnected while the

power ison.

N o 0k~
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1.3 Environmental Conditions

CAUTION

Failure to do so will cause illegal operation in the user system, the
emulator product, and the user program.

Observe the conditions listed in table 1.1 when using the emulator.

Tablel.1 Environmental Conditions

Item Specifications

Temperature Operating: +10°C to +35°C
Storage: —10°C to +50°C

Humidity Operating: 35% RH to 80% RH, no condensation
Storage:  35% RH to 80% RH, no condensation
Vibration Operating: 2.45 m/s’* max.
Storage: 4.9 m/s’ max.

Transportation: 14.7 m/s* max.

Ambient gases  No corrosive gases may be present

14 Emulator External Dimensions and M ass

Table1.2 Emulator External Dimensionsand Mass

Item Specifications
Dimensions 219 x 170 x 54 mm
Mass Approximately 1,000 g
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Section 2 Preparation before Use

21 Emulator Preparation

Unpack the emulator and prepare it for use as follows:

A WARNING

the emulator product. The USER PROGRAM will be LOST.

READ the reference sections shaded in figure 2.1 before using the
emulator product. Incorrect operation will damage the user system and

Reference

Unpack the emulator Component list
I

Check the components against
the component list

Section 3
Set up the emulator

- Insert the optional board
- Install the HEW
- Connect the interface cable

Turn on the user system Section 4
(Only when the user system is connected)

Turn on the emulator
1

Start the HEW

Setup

Activation

Figure2.1 Emulator Preparation Flowchart

22 Installing Emulator’s Software

Toingtal the HEW, refer to the Setup Guide for the E6000 Emulator supplied together with the emulator.
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2.3 Connecting to the User System
To connect the emulator to a user system, proceed as follows:

e Connect the user system interface cable head to the user system.
» Plug the cable body into the emulator.
» Plug the cable body into the cable head.

For details of these steps, refer to the User System Interface Cable User's Manual.

Figure 2.2 gives details of the connectors provided on the emulator.

E6000 <« PC interface cable

connector
User system P\\_/\

interface connector

I <— Power connector

oz Y
External probe ——> <~ Power switch
connector T 75
Screw Screw

Figure2.2 E6000 Emulator Connectors

231 Example of Connecting the User System Interface Cable Head to the User System

Screw (x 4)

7N\
¥ g

1
1
1
1
| ] User system interface
1 | cable head

1

Figure2.3 Example of Connecting User System I nterface Cable Head to User System

* Ensurethat all power is off to the emulator and the user system.
* Insert the cable head into the socket on the user system.

Note: Depending upon the package, it may be possible to orientate this cable head in any position on the socket,
so care should be taken to correctly identify pin 1 on the emulator and socket when installing.
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Screw the cable head to the socket with the screws provided. Progressively tighten the screws in the sequence
shown in figure 2.4 until all are ‘finger tight’.

© 06

<]

®@ @

Figure2.4 Sequenceof Screw Tightening

Note: Be careful not to over-tighten the screws as this may result in contact failure on the user system or

damage the cable head. Where provided, use the ‘solder lugs' on the QFP socket to provide extra
strength to the emulator/user system connection.

232 Plugging the User System Interface Cable Body into the Emulator

Plug the cable body into the emulator, taking care to insert it straight, and push it firmly into place.

User system interface cable body

User system interface cable head

B , » \—
\/ = rx11 Emulator

User system interface cable

Figure2.5 Plugging User System Interface Cable Body to Emulator

233 Plugging the User System I nterface Cable Body into the Cable Head

Plug the cable body into the cable head on the user system.
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24 Power Supply

241  AC Adapter

The AC adapter supplied with the emulator must be used at all times.

242 Polarity

Figure 2.6 shows the polarity of the power-supply plug.

5V (outside)

GND (inside)

Figure2.6 Polarity of Power Supply Plug

243 Power Supply Monitor Circuit

The emulator incorporates a power supply monitor circuit which only lights the red LED when a voltage higher
than 4.75 V is supplied. If this LED isnot illuminated, you should check the emulator voltage level. An input
voltage lessthan 4.75 V could indicate that enough current cannot be supplied to the emulator.

Note: Use the provided AC adapter for the emulator.

25 SIMM Memory Module

E6000 emulator’s optional SIMM memory modules are available which provide emul ation memory for user
code without needing a user system. The optional SIMM memory modules are available in different memory
size, but all are partitioned into four equal banks. These banks can be rel ocated on page boundaries anywherein
the user area. Note that, however, some products do not support the SIMM memory module.

251 Optional SIMM Memory Module Configuration

The configuration of the optional SIMM memory module is controlled by the mapping RAM. Opening the
[Memory] sheet of the [System Status] window allows you to check which optional SIMM memory module, if
any, isinstaled and aso allows the four banks to be relocated to the required addresses from the [Memory
Mapping] dialog box.
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2.6 Hardwar e Interface

All signasaredirectly connected to the MCU in the emulator with no buffering with the exception of those
listed in section 7, Hardware Specifications Specific to This Product.

26.1 Signal Protection on the emulator
All signals are over/under voltage protected by use of diode arrays. The only exceptions being the AV and Vref.
All ports have pull-up resistors except for analog port.

All V. pins on the cable head assembly are connected together (with the exception of the AV . pin), and are
then monitored by the emulator to detect powered user system presence.

26.2 User System Interface Circuits

The interface circuit between the MCU in the emulator and the user system has a signal delay of about 8 nsdue
to the user system interface cable and it includes pull-up resistors. Therefore, high-impedance signals will be
pulled up to the high level. When connecting the emulator to a user system, adjust the user system to compensate
for propagation delays.

The following diagrams show the equivalent circuit examples of the interface signals. The interface circuits
depend on the MCU type. For details, refer to section 7, Hardware Specifications Specific to This Product.

26.3 Clock Oscillator

The oscillator circuit has been implemented on the user system interface cable head. For details on the oscillator
circuit, refer to the user's manual for each user system interface cable.

26.4 External Probe 1 (EXT1)/Trigger Output

An 8-pin connector, marked EXT1 (on the right under the user system interface cable connector), on the
emulator case accommodates four externa probe inputs and two trigger outputs. The pin assignment of this
connector is shown in figure 2.7.

1 | |
GND| GND |
Tuvce Tsv

OOO0OOO0OO | exmn
N
T 1T 1

Probe Trigger output

Figure2.7 External Probe Connector 1
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The interface circuit for the external probe 1 is shown in figure 2.8.

Vce
10 kQ
HD151015 External probe 1, 2, 3, 4

22 Q

Figure2.8 Interface Circuit for External Probe 1

The trigger output is controlled by event channel 8 and is an active low signal. The trigger output is available as
either TSV (within the range from 2.5V to 5 V; does not depend on the user V  level) or TUV  (the user V.
level).

26.5 External Probe2 (EXT2)/Trigger Output

A 6-pin connector, marked EXT2 (on the |eft under the user system interface cable connector), on the emulator
case accommodates four trigger outputs. The pin assignment of this connector is shown in figure 2.9.

OOOOO? EXT2
A
1T 11

Trigger output

Figure2.9 External Probe?2 Connector

Thetrigger output is an active high signal which is output during the read or write cycles when a trace condition
(1 to 4) of the bus monitor function is satisfied. The trigger output is available asuser V _ level. Note thét,
however, some products do not support the external probe 2 (EXT2).
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2.6.6 Voltage Follower Circuit

CAUTION

1. Do not connect the user system interface cable to the emulator
without user system connection.
2. Turn on the user system before starting up the emulator.

A voltage follower circuit isimplemented on the emulator which allows the user system voltage level from the
user system to be monitored. This monitored voltage level is automatically supplied to the logic on the emulator
and is derived from the emulator power supply unit. This means that no power istaken from the user system
board.

If no user system interface cable is connected to the emulator, the emulator will operate at a specified voltage
and al clock frequencies will be available to the user. If the user system interface cable is attached, the emulator
will match the voltage supplied to the user target in al cases; i.e. even when the user V. is below the operating
voltage for the MCU. You must be careful not to select an invalid clock frequency. When the emulator is
connected to the user system and the user system is turned off, the voltage follower circuit output voltage level is
0 V. Inthis case, the emulator will not operate correctly.

You can set auser V. threshold in the range Vcc max. —0 V by using the emulator configuration dialog box. If
the user V. drops below thisthreshold, [User System Voltage] in the [Extended Monitor] window will display
Down, otherwise OK is displayed.

threshold

User Vcc level

User Vcc oK — ... oo
threshold | |

Down - - - - - - -

3.3V

E6000
Vcc level

The user system interface
cable is not connected.

Figure2.10 Voltage Level Monitoring (Examplefor Vcc =3.3 V)
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2.7 System Check

When the software is executed, use the procedure below to check that the emulator is connected correctly. Here,
use the workspace for a tutorial provided on the product.

Refer to section 2.9, Other Methods for Activating the Emulator, for the other activating method to create a new
project or use a workspace for the HEW of the old version.

Connect the emulator to the host compuiter.

Connect the user system interface cable to the connector of the emulator.
Turn on the emulator.

Activate the HEW from the [Programs] in the [Start] menu (figure 2.11).

> wbdh e

‘Windows Update

4 |'_§Q High-performance Embedded Warkshop 2 Help
@ High-performance Embedded Workshop 2 Read Me
Ez'% High-performance Embedder z

Documents L4 ¥

Settings 4

Professional

Search 4

Help

Run...

CAR RSN T ™

Windows 200

Shut Dawn....

Figure2.11 [Start] Menu

Note: If ‘LAN Driver’ isnot selected at ingtallation, [Tools] is not displayed.
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5. The[Welcome!] dialog box is displayed.

21x
Rkt
' ‘Cieate a new project workspace Cancel |
") Mpen arecent project workspace; Administration... |
= | ]
= .
g {~ Browse to another project workspace

Figure2.12 [Welcome!] Dialog Box

To use aworkspace for the tutorial, select the [Browse to another project workspace] radio button and click the
[OK] button.

When the [Open Workspace] dialog box is opened, specify the following directory:
HEW installation destination directory\Tool s\Renesas\DebugComp\Pl atform\E6000\xxxx\Tutorial

After the directory has been specified, select the following file and click the [Open] button.

21

Lok, jr: I@ Tutarial j - IC:F -

Debug_H&5_2237_EA000_Emulator _CP
SoUrce

File name: |Tutorial.hws Open I
Files of twpe: IWorkspaces [® hws) j Cancel |
S

Figure2.13 [Open Workspace] Dialog Box
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When no compiler package or that of adifferent version isinstalled, the following message box will be displayed.

Hi|;]h-|:|Er'F|:|r'I'|'|-E|I'||IE Embedd il

Tukorial

there is no compatible koolchain available

"_\ Tool Chain 'Hitachi HES,HE300 Standard Toolchain', version oo is missing Fram the Following project(s)
L

Figure2.14 Message Box

6. The[E6000 Driver Details] dialog box isdisplayed. Thisdialog box isonly displayed at the first initiation.
When only one of interface driversis selected, this dialog box is not displayed.

Criver: IEmuIatDr PCI Card Driver j
— Details
Interface: IPOI j
Channel: IEmuIatnr PCI Card Interface j

—Configuration
Confieure., |

[~ Charnee driver in start up

Figure2.15 [E6000 Driver Details] Dialog Box

* Inthe[Driver] combo box, select the driver to connect the emulator.
» [Interface] displays the name of the interface to be connected.
e Click the [Closg] button.
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7. Set uptheemulator. During this process, the following dialog box is displayed.

Attempting to connect the emulator.
The driver program has been initializedEmulator PCI Gard Drwer)
Starting to tranzfer a firmware file.

[~ Charnee driver in start up

Cloze |

Figure2.16 [Connecting] Dialog Box

8. When "Connected" is displayed in the [Output] window of the HEW, the emulator initiation is completed.

%‘BTutDrial - High-performance Embeddet hop - [tutorial.cpp] = ||:||i|
<+ File Edit ‘iew Project Options Buld Tools Window Help ;lilil
g
- A =
E‘@ Tuterial A ~#% FILE ‘Tutorial .cpp

E-[F Tutorial <% DESCRIFTION :Main Frogran
P <% Thi=s file iz generated by Hitachi Proj
%
g

|

— extern "C"
#endif

i void abort (woid):
224 Download modules #ifdef _ cplusplus

e[ Tutorial shs = * i -
3 Projects | “_] Mavigation | < i - _PlJ

Connected

#ifdef _ cplusplus
{

L=lx

| 4[] Build £ Debug }, Find in Files f, Yersion Coniral §

Ready Read-write  [1/64 1 NS v
S

Figure2.17 HEW Window
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2.8 Communication Problems

The following message box will be displayed when the emulator power isturned off or the PC interface cableis
not correctly connected.

xxxxx E6O00 Enulaktar ﬂ

A verification error has occurred during the transfer of a Firmware File,
This is probably because the emulator has been turned of f or another emulator has been connected,

Figure2.18 Error Message

For information on other errors, refer to the Setup Guide for the E6000 Emulator.
2.9 Other Methodsfor Activating the Emulator
Refer to section 4, Preparation before Use.

2.10 Uninstalling the Emulator’s Softwar e

For details on uninstallation, refer to the Setup Guide for the E6000 Emulator.
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Section 3 E6000 Emulator Functions

31 Debugging Features

311 Breakpoints

The emulator provides a comprehensive range of alternative types of breakpoints, to give you the maximum
flexibility in debugging applications and user system.

Hardware Break Conditions: Up to 12 break conditions can be defined using the event and range channelsin
the complex event system (CES). For more information about the hardware break conditions, see section 3.2,
Complex Event System (CES).

Program Breakpoints (PC Breakpoints): Up to 256 program breakpoints can be defined. These program
breakpoints are set by replacing the user instruction by aBREAK instruction. In target ROM, only one
breakpoint (on-chip break) can be set.

312 Trace

The emulator incorporates a powerful realtime trace facility which allows you to examine MCU activity in detail.
The realtime trace buffer holds up to 32768 bus cycles, and it is continuoudy updated during execution. The
buffer is configured as arolling buffer, which can be stopped during execution and read back by the host
computer without halting emulation.

The data stored in the trace buffer is displayed in both source program and assembly languages for ease of
debugging. However, if trace filtering is used, only assembly language can be displayed.

The buffer can be set up to store all bus cycles or just selected cycles. Thisis called trace acquisition and uses the
complex event system (CES) to select the parts of the program you are interested in.

It isalso possible to store all bus cycles and then just look at selected cycles. Thisis caled trace filtering.

313 Execution Time Measurements

The emulator allows you to measure the total execution time, or to measure the time of execution between
specified eventsin the complex event system. You can set the resolution of the timer to any of the following
vaues:

20 ns, 125 ns, 250 ns, 500 ns, 1 ys, 2 s, 4 s, 8 ps, or 16 ps.

At 20 ns the maximum time that can be measured is about six hours, and at 16us the maximum time is about 200
days.

314 Performance Analysis

The emulator provides functions for measuring the performance of a program. The performance of the specified
program range can be displayed either as a histogram or in percentage form. A timer resolution of 20 ns, 40 ns,
or 160 ns can be selected. In addition, the execution count of the specified program range can be measured (1 to
65535).
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315 Bus Monitoring

The emulator incorporates a bus monitoring function that monitors and displays the contents of the accessed area
in HEW windows without stopping the program execution. Up to eight blocks of 256 bytes can be monitored.

In addition, the emulator can output trigger signals from external probe 2 (EXT2) when specified addresses (four
points max.) are accessed. Note that, however, some products do not support the bus monitoring function.

3.2 Complex Event System (CES)

In most practical debugging applications, the program or hardware errors that you are trying to debug occur
under a certain restricted set of circumstances. For example, a hardware error may only occur after a specific
area of memory has been accessed. Tracking down such problems using simple PC breakpoints can be very
time-consuming.

The emulator provides a very sophisticated system for giving a precise description of the conditions you want to
examine, called the complex event system. This allows you to define events which depend on the state of a
specified combination of the MCU signals.

The complex event system provides a unified way of controlling the trace, break, and timing functions of the
emulator.

321 Event Channels

The event channels dlow you to detect when a specified event has occurred. The event can be defined asa
combination of one or more of the followings:

* Address or address range

* Addressoutsiderange

* Read or Write or either

» Data, with an optional mask

e MCU accesstype (e.g., DMAC and instruction prefetch)

e MCU access area (e.g., on-chip ROM and on-chip RAM)
* A signal state on one or more of the four external probes

e A certain number of times that the event must be triggered
» Delay cycles after an event

Up to eight events can be combined into a sequence, in which each event is either activated or deactivated by the
occurrence of the previous event in the sequence. For example, you can cause abreak if an I/O register iswritten
to after a specified area of RAM has been accessed.

322 Range Channels
The range channels can be set up to be triggered on a combination of one or more of the following:

* Address or address range (inside the range)

* Read or Write or either

» Data, with an optional mask

* MCU accesstype (e.g., DMAC and instruction prefetch)
e MCU access area (e.g., on-chip ROM and on-chip RAM)
* A signal state on one or more of the four external probes
» Delay cycles after an event

The complex event system can be used to control the following functions of the emulator:
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323 Breaks

Use breaks to interrupt program execution when a specified event, or sequence of events, is activated. For
example, you can set up abreak to halt execution when the program reads from one address, and then writesto
another address. The break can also optionally be delayed by up to 65535 bus cycles.

324 Timing

Y ou can set up two events and then measure the execution time of the program between the activation of the first
event and second event.

33 Har dwar e Features

331 Memory

The emulator provides standard emulation memory as the substitute for on-chip ROM memory and on-chip
RAM memory. When a device type or device mode without an on-chip ROM or on-chip RAM is selected, the
standard emulation memory is disabled. When debugging with only the emulator and the user program and data
are stored in an externa address space, an optional SIMM memory module must be used. The optiona SIMM
memory modules can be separately purchased.

The emulation memory can be mapped in 64-byte units to any number of separate memory blocksin the MCU
address space. Each memory block can be specified using the memory mapping function as user (Target) or
emulator (SIMM memory module) and, in each case, the access can be specified as read-write, read-only, or
guarded.

The definition of each type of memory isasfollows:

Table3.1 Memory Types

Memory Type Description

On-chip Uses the MCU on-chip memory.

User Accesses the user system memory.

Emulator Accesses the emulator SIMM memory module.

The contents of a specified block of memory can be displayed using the memory function. The contents of
memory can be modified at any time, even during program execution and the results are immediately reflected in
all other appropriate windows.

Note that modifying memory contents during program execution has the following time requirements:

1. MCU on-chip ROM or RAM, or emulator SSIMM memory module
The emulator modifies the memory contents by temporarily switching the memory bus to the emulator side
without stopping the user program execution. Therefore, the emulator uses the memory bus for up to 80 psin
reading of 256 bytes (25 MHz, on-chip ROM).

2. MCU on-chip I/0, DTCRAM, or user system memory
The emulator stops the user program execution, then modifies the memory contents. Therefore, the user
program stops for a maximum of 2 msin reading 256 bytes (25 MHz, emulation memory).
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332 Clocks

The clock can be specified as emulator internal clock or target clock. The frequenciesthat can be specified as
the emulator internal clock depend onthe MCU. For details, refer to section 8, Software Specifications Specific
to This Product.

333 Probes

External probes 1 and 2 (EXT1 and EXT2) can be connected to the emulator, to make use of signals on the user
system for break or trace. The signal for external probe 1 can be set as the condition for the event detection
system depending on the low or highlevel. Sincethe signal for external probe 2 outputs high level when the
trigger setting (1 to 4) condition is matched in the bus monitor function, the signal can be used for the trigger
condition for such as an oscilloscope.

3.4 Stack Trace Function

The emulator uses the stack’ sinformation to display the name of the calling function for afunction at which the
program counter is currently pointing. This function can be used only when the load module that has the
Dwarf2-type debugging information is loaded. For the usage of thisfunction, refer to section 6.17, Stack Trace
Function.

3.5 OnlineHelp

An online help explains the usage of each function or the command syntax that can be entered from the
command line window.

Select [Emulator Help] from the [Help] menu to view the emulator help.
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Section 4 Preparation before Use

41 Workspaces, Projects, and Files

Just as aword processor allows you to create and modify documents, HEW allows you to create and modify
workspaces. A workspace can be thought of as a container of projects and, smilarly, a project can be though of
as acontainer of project files. Thus, each workspace contains one or more projects and each project contains one
or morefiles. Figure 4.1 illustrates this graphically.

[~

WORKSPACE

PROJECT

PROJECT

Figure4.1 Workspaces, Projects, and Files

Workspaces allow you to group related projects together. For example, you may have an application that needs
to be built for different processors or you may be developing an application and library at the same time. Projects
can aso belinked hierarchically within aworkspace, which means that when one project is built al of its“child”
projects are built first.

However, workspaces on their own are not very useful, we need to add a project to a workspace and then add
filesto that project before we can actually do anything.
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4.2 Method for Activating HEW
To activate the HEW, follow the procedure listed below.

1. Connect the emulator to the host computer.
2. Connect the user system interface cable to the connector of the emulator if you use the user system interface
cable. Thisis not necessary when you do not use the user system interface cable.

3. Turn on the emulator. Be sure to turn on the user system before supplying power to the emulator if you use
the user system.
4. Activate the HEW from [Programg] in the [Start] menu.

5. The[Welcome!] dialog box is displayed.

2|

— Dptions: ok

{* Create a new project workspace: Cancel

% " Dpen arecent project workspace: Adrninistration. .

| -

Fl

=

g " Browse to another project workspace

Figure4.2 [Welcome!] Dialog Box
[Create a new project workspace] radio button: Creates a new workspace.

[Open arecent project workspace] radio button: Uses the current workspace and displays the history of the
opened workspace.

[Browse to another project workspace] radio button: Uses the current workspace; this radio button is used when
the history of the opened workspace does not remain.

In this section, we describe the following three ways to start up the HEW:

e [Create anew project workspace] - atoolchainisnot in use

e [Create anew project workspace] - atoolchainisin use

* [Browseto another project workspace]

The method to create a new workspace depends on whether atoolchain isor isnot in use. Note that this emulator
product does not include atoolchain. Use of atoolchainis available in an environment where the H8S, H8/300

series C/C++ compiler package has been installed. For details on this, refer to the manua attached to the H8S,
H8/300 series C/C++ compiler package.
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421 Creating a New Workspace (Toolchain Not Used)

1. Inthe[Welcome!] dialog box that is displayed when the HEW is activated, select [Create a new project
workspace] radio button and click the [OK] button.

2%

— O ptionz: ok

' ‘Cieate a new project workspace Cancel

% ") Mpen arecent project workspace; Administration...

| i

Fl

g {~ Browse to another project workspace

Figure4.3 [Welcome!] Dialog Box
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2. Creation of anew workspace is started. The following dialog box is displayed.

Mew Project Workspace 2=

Wiorkspace Mame:

Isample{
Cahicel
Project MName:

Ilik

Isample Browsze.

Directaory:
IEI: WHew2\zample

CPU family:
{He5 Ha/300 |

Toal chain:

INnne et

Froject tppe:

Figure4.4 [New Project Workspace] Dialog Box

[Workspace Name] edit box: Enter the new workspace name.

[Project Name] edit box: Enter the project name. When the project name is the same as the workspace name,
it needs not be entered.

[Directory] edit box: Displaysthe directory in which the workspace will be created. Click the [Browse...]
button to select a directory name or enter adirectory name in the [Directory] edit box.

Other list boxes are used for setting the toolchain; the fixed information is displayed when the toolchain has not
been installed.
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3. Makethe required setting for the toolchain. When the setting has been completed, the following dialog box
isdisplayed.

21|

— Targets
(w]wyyy EG000 Emulator GPL 2000

AO00 Emulator SR 2600

Taraet type : I."-‘-.II Targets j

< Back I Heut » I Finizh | Cancel |

Figure4.5 [New Project —Step 7] Dialog Box

The target for the session file used when the HEW is activated must be selected here. Check the box
against the target platform and then click the [Next] button. For details on the session file, refer to section
4.4, Debugger Sessions.

159
RENESAS




4. Set the configuration file name. The configuration file saves the state of HEW except for the emulator.

Target name ;

G000 E mulatar SPU 2000

Configuration name :
|Debug_yvyy E6G000_Emulator GP

— Detail options :

Item | Walue |

T ity |

< Back I Hewt » I Finizh | Cancel |

Figure4.6 [New Project — Step 8] Dialog Box

If multiple target platforms were selected in the [New Project — Step 7] dialog box shown in figure 4.5, set
the name of a configuration file for each of them, each time pressing the [Next] button to proceed to the next
target.

Setting of the configuration file nameis the end of the emulator settings.

Click the [Finish] button to display the [Summary] dialog box. Pressing the [OK] button activates the HEW.

5. After the HEW has been activated, the emulator is automatically connected. The message “ Connected” is
displayed on the [Debug] tab in the [Output] window to indicate the completion of connection.
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4.2.2 Creating a New Workspace (Toolchain Used)

1. Inthe[Welcome!] dialog box that is displayed when the HEW is activated, select [Create a new project
workspace] radio button and click the [OK] button.

2%

— O ptionz: ok

' ‘Cieate a new project workspace Cancel

% ") Mpen arecent project workspace; Administration...

| i

Fl

g {~ Browse to another project workspace

Figure4.7 [Welcome!] Dialog Box
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2. Creation of anew workspace is started. The following dialog box is displayed.

Mew Project b e 2=

Wiorkspace Mame:

Isample{
Cahicel
Project MName:

Ilik

Isample Browsze.

Directaory:
IEI: WHew2\zample

CPU family:
{He5 Ha/300 |

Toal chain:
[ Hitachi HB5 HB/300 Standard =l

Froject tppe:

Applicatio

@ Azzembly Application
Demonstration

@ EE000 Emulator Application

@ EG000 Emulator dezembly Application

@ EE000 Emulataor Empty Application -
|

4|

Figure4.8 [New Project Workspace] Dialog Box

[Workspace Name] edit box: Enter the new workspace name. Here, enter ‘test’.

[Project Name] edit box: Enter the project name. When the project name is the same as the workspace name,
it needs not be entered.

[Directory] edit box: Displays the directory in which a workspace will be created. Click the [Browse...]

button to select a directory or enter the name of a directory in the [Directory] edit box.

[CPU family] combo box: Select the target CPU family.

[Tool chain] combo box: Select the target toolchain name when using the toolchain. Otherwise, select
[None].

[Project type] list box: Select the project type to be used.

Notes: 1. For the EG000 emulator, the following project types are the same:
[Application] and [E6000 Emulator Application]
[Empty Application] and [E6000 Emulator Empty Application]
2. When [Demonstration] is selected in the emulator, note the followings:
The [Demongtration] is a program for the simulator attached to the H8S, H8/300 compiler package.
To use the generated source file, delete the Printf statement in the sourcefile.
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3. Makethe required setting for the toolchain. When the setting has been completed, the following dialog box
isdisplayed.

21|

— Targets
(w]wyyy EG000 Emulator GPL 2000

AO00 Emulator SR 2600

Taraet type : I."-‘-.II Targets j

< Back I Heut » I Finizh | Cancel |

Figure4.9 [New Project —Step 7] Dialog Box

The target for the session file used when the HEW is activated must be selected here. Check the box against
the target platform and then click the [Next] button. For details on the session file, refer to section 4.4,
Debugger Sessions.
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4. Set the configuration file name. The configuration file saves the state of HEW except for the emulator.

d B

Target name ;

Configuration name :

|Debug_yvyy E6G000_Emulator GP

— Detail options :

Item | Walue |

T ity |

< Back I Hewt » I Finizh | Cancel |

Figure4.10 [New Project — Step 8] Dialog Box

If multiple target platforms were selected in the [New Project — Step 7] dialog box shown in figure 4.9, set
the name of a configuration file for each of them, each time pressing the [Next] button to proceed to the next
target.

Setting of the configuration file nameis the end of the emulator settings.

Complete the creation of a new workspace according to the instructions on the screen. This activates the
HEW.

5. After the HEW has been activated, connect the emulator. However, it is not necessary to connect the
emulator immediately after the HEW has been activated.
Select either of the following two ways to connect the emulator: connecting the emulator after the setting at
emulator activation or without the setting at emulator activation. For details on the connection of the
emulator, refer to section 4.5, Connecting the Emulator.
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4.2.3 Selecting an Existing Workspace

1. Inthe[Welcome!] dialog box that is displayed when the HEW is activated, select [Browse to another project

workspace] radio button and click the [OK] button.

2| x]
— O ptionz:
" Create a new project workspace Cancel |
") Mpen arecent project workspace; Administration... |
= | ]
g ¢ Browse to another project workspace

Figure4.11 [Welcome!] Dialog Box

2. The[Open Workspace] dialog box isdisplayed. Select adirectory in which you have created a workspace.
After that, select the workspace file (.hws) and press the [Open] button.

21

Lok, jr: I@ zample j = IC:F -

sample

File name: |sample.hws Open I
Files of twpe: IWorkspaces [ hwz) j Cancel |
S

Figure4.12 [Open Workspace] Dialog Box

3. Thisactivates the HEW and recovers the state of the selected workspace at the time it was saved.
When the saved state information of the selected workspace includes connection to the emulator, the
emulator will automatically be connected. To connect the emulator when the saved state information does not
include connection to the emulator, refer to section 4.5, Connecting the Emulator.
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4.3 Setting at Emulator Activation

When the emulator is activated, the command chain can automatically be executed. It isalso possible to register
multiple load modules to be downloaded. The registered load modules are displayed on the workspace window.

1. Select [Debug settings] from the [Options] menu to open the [Debug Settings] dialog box.

Debug Settings ed b
IDefauItSession | Target | Options |
------ [ sample Target:

Default Debug Farmat:

<nones j
Download Modules:
File MName | Qffzet Address | Farm: Add...

l | i

Figure4.13 [Debug Settings] Dialog Box ([Target] Page)

2. Select the product name to be connected in the [Target] combo box.

3. Select the format of the load module to be downloaded in the [Default Debug Format] combo box, then
register the corresponding download module in the [Download Modules] list box.

4. Click the[Options] tab.

166
RENESAS




*|  Target Options

Command batch file load timing:

Command Line Batch Processing:

¥ | Connect up to target of debug oo

¥ Download modules after build

Ok, I Cancel

The command chain that is automatically executed at the specified timing is registered. The following three

timings are available:

Figure4.14 [Debug Settings] Dialog Box ([Options] Page)

* At connecting the emulator
* Immediately before downloading
* Immediately after downloading

Specify the timing for executing the command chain in the [Command batch file load timing] combo box. In

addition, register the command-chain file that is executed at the specified timing in the [Command Line Batch

Processing] list box.
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44 Debugger Sessions

The HEW stores all of your builder optionsinto aconfiguration. In asimilar way, the HEW stores your
debugger optionsin asession. The debugging platforms, the programs to be downloaded, and each target
platform’ s options can be stored in a session.

Sessions are not directly related to a configuration. This means that multiple sessions can share the same
download module and avoid unnecessary program rebuilds.

Each session’s data should be stored in a separate file in the HEW project. Debugger sessions are described in
detail below.

44.1 Selecting a Session
The current session can be selected in the following two ways:

* From the toolbar
Select a session from the combo box (figure 4.15) in the toolbar.

JJ g ||Debug j ||Defau|tSession j | Jt |@ P31 ‘

Figure4.15 Toolbar Selection

* From the dialog box
1. Select [Options -> Debug Sessions...]. Thiswill open the [Debug Sessions] dialog box (figure 4.16).

Debug sessions: ok

DefaultSession
Sessionyyyy_EG000_Emulatar_CP Cancel
Sessionwecs_EB000_Emulator_CP

|x

Add...
Bemove
Save as...

Eroperties

il

Current session:
Default5ession j

Figure4.16 [Debug Sessions] Dialog Box

2. Select the session you want to use from the [Current session] combo box.
3. Click the [OK] button to set the session.
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442 Adding and Deleting Sessions
A new session can be added by copying settings from another session or deleting a session.

e Toadd anew empty session

Select [Options -> Debug Sessions...] to display the [Debug Sessions] dialog box (figure 4.16).
Click the[Add...] button to display the [Add new session] dialog box (figure 4.17).

Check the [Add new session] radio button.

Enter a name for the session.

Click the [OK] button to close the [Debug Sessions] dialog box.

This creates a file with the same name as the entered session name. If the file name already exists, an
error isdisplayed.

I A

Add new

Mame:
Cancel

21
' Add new session oK I

* Use an existing session file

M ame:

Isample
Session file path:

I Browze |

v ‘Open and maintain link to session fils

[~ Make session file link read only

Figure4.17 [Add new session] Dialog Box
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e Toimport an existing session into a new session file

1

S S

6.

Select [Options -> Debug Sessions...] to display the [Debug Sessions] dialog box (figure 4.16).
Click the[Add...] button to display the [Add new session] dialog box (figure 4.17).

Check the [Use an existing session file] radio button.

Enter a name for the session.

Browse to the existing session file location that you would like to import into the current project.

If the [Open and maintain link to session file] check box is not checked, the imported new session fileis
generated in the project directory.

If the [Open and maintain link to session file] check box is checked, anew session fileis not generated in
the project directory but islinked to the current session file.

If the [Make session file link read only] check box is checked, the linked session fileis used as read-only.
Click the [OK] button to close the [Debug Sessions] dialog box.

¢« Toremoveasesson

1
2.
3.

4.

Select [Options -> Debug Sessions...] to display the [Debug Sessions] dialog box (figure 4.16).
Select the session you would like to remove.

Click the [Remove] button.

Note that the current session cannot be removed.

Click the [OK] button to close the [Debug Sessions] dialog box.

* Toview the session properties

1
2.
3.

Select [Options -> Debug Sessions...] to display the [Debug Sessions] dialog box (figure 4.16).
Select the session you would like to view the properties for.
Click the [Properties] button to display the [Session Properties] dialog box (figure 4.18).

n Properties
Mame: Sessionxooc EE000_Emulatar_CP ] i
Location: C:"Hew2hzample! samplehS essiohxeoos EEO00 = |
Lastmodiied:  17:37:11, Thursday, December 12, 2002 _ Cancel |
[~ Eead only

170

Figure4.18 [Session Properties] Dialog Box
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To make a session read-only

1

5.

Select [Options -> Debug Sessions...] to display the [Debug Sessions] dialog box (figure 4.16).

2. Select the session you would like to make read-only.
3.
4. Check the [Read only] check box to make the link read-only. Thisisuseful if you are sharing debugger-

Click the [Properties] button to display the [Session Properties] dialog box (figure 4.18).

setting files and you do not want data to be modified accidentally.
Click the [OK] button.

To save a session with a different name

1

ok w DN

Select [Options -> Debug Sessions...] to display the [Debug Sessions] dialog box (figure 4.16).

Select the session you would like to save.

Click the [Save as] button to display the [Save Session] dialog box (figure 4.19).

Browse to the new file location.

If you want to export the session file to another location, leave the [Maintain link] check box unchecked.

If you would like the HEW to use thislocation instead of the current session location, check the
[Maintain link] check box.

Click the [OK] button.

2%

Save_in:l@ zample j - IC:F -

|_1 Debug Sessionxoo _E000_Emulatar_CP.hsf
I_1 Debug_wwwy_ES000_Emulatar_CP

|1 Debug_seees_ES000_Emulatar_CP

-1 Release

DefaultSession.hsf

Sessionyyyy_E6O00_Emulator_CP.hsf

File name: | Save I
Save as upe: ISessions [*.hsf] j Cancel |

™ Maintain link

P

4.4.3

Figure4.19 [Save Session] Dialog Box

Saving Session Information

To save a session
Select [File -> Save Session].
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4.5 Connecting the Emulator
Select either of the following two ways to connect the emulator:

(a) Connecting the emulator after the setting at emulator activation

Select [Debug settings] from the [Options] menu to open the [Debug Settings] dialog box. It ispossible to
register the download module or the command chain that is automatically executed at activation. For details
on the [Debug Settings] dialog box, refer to section 4.3, Setting at Emulator Activation.

When the dialog box is closed after setting the [Debug Settings] dialog box, the emulator will automatically
be connected.

(b) Connecting the emulator without the setting at emulator activation
Connect the emulator by simply switching the session file to one in which the setting for the emulator use has
been registered.

@samp\e - High-performance Embed op ngil

File Edit Yiew Project Options Build Tools ‘Window Help
DeHg|g|renl Tu||op @2tus z @ |[a =% & ||
R R Dt sion DR EEEE ) EEET:

Sessionzooes:_EBO00_E
DefaultSession

i 1 Proj... | <1 Navig...

x|

¥

Build £ Debug A Find in Files }, Wersion Contral //

Ready [ = —  ms [ m g

Figure4.20 Selecting the Session File

In thelist box that is circled in figure 4.20, select the session name including the character string that has been
set in the [Target name] text box in figure 4.10, [New Project — Step 8] dialog box. The setting for using the
emulator has been registered in this session file.

After the session name s selected, the emulator will automatically be connected. For details on the session file,
refer to section 4.4, Debugger Sessions.
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4.6 Ending the Emulator
When using the toolchain, the emulator can be exited by using the following two methods:

» Canceling the connection of the emulator being activated
» Exiting the HEW

(a) Canceling the connection of the emulator being activated

1. Select [Debug settings] from the [Options] menu to open the [Debug Settings] dialog box (see figure 4.13).

2. Select <None> or another product in the [Target] combo box. When another product is selected, the
connection with that product is started after canceling the connection of the emulator being activated.

3. Turnthe emulator off after canceling the connection.

(b) Exiting the HEW

1. Select [Exit] from the [File] menu.

2. A message box isdisplayed. If necessary, click the [Yes] button to save a session. After saving a session,
the HEW exits. If not necessary, click the [No] button to exit the HEW.

High-performance Embedd <5 x|
& Session has been modified - do wou want ko save it

es Mo | Cancel |

Figure4.21 [Session hasbeen modified] Message Box
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Section 5 Debugging
This section describes the debugging operations and their related windows and dialog boxes.
51 Setting the Environment for Emulation

511 Opening the [Configuration Properties] Dialog Box

Selecting [Options -> Emulator -> System...] or clicking the [Emulator System] toolbar button (IEI) opensthe
Configuration Properties] dialog box.

21x
General |
Device: |Jzer Signalz
EEICE: ¥ User Beset enable
Mode: I?' [advanced mode, single chip) j ¥ User NMI enable
¥ Sirgle chin made ™| Wser Standby enatile
g s ¥ User Bus Reguest enable
Clock: | Main10MHz, Subi32kHz =l
Tirner Resolution: |125ns j

Flash emon: Eontrol; I vl

¥ Enable read and wiite on the fly
¥ Break on access eror
™ Enable intermal ROM area write

User WECC Thisshold = 400V 4 | [ |

Diriver: |EBDDD LISE Driver
[ Change driver in start up

Ok, I Cancel |

Figure5.1 [Configuration Properties] Dialog Box ([General] Page)

This didog allows the user to set conditions for the target MCU before downloading a program to the emulator.
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[General] page

[Device] Selects the MCU to be emulated. To use an MCU not included in the list,
select CUSTOM to specify the functions required for this MCU. See the
hardware manual for details.

[Mode] Selects the MCU's operating mode.

[Clock] Selects the speed of the MCU'’s clock and sub-clock.

[Timer Resolution]

Selects the resolution of the timer for use in execution time measurement.
The value 20 ns, 125 ns, 250 ns, 500 ns, 1 us, 2 us, 4 us, 8 us, or 16 us
can be selected.

The timer for execution time measurement has a 40-bit counter.

At 20 ns the maximum time that can be measured is about six hours, and
at 16 ps the maximum time is about 200 days.

When the counter overflows, the maximum time possible for
measurement will be displayed with prompt “>” that indicates that the
counter has overflowed.

[Enable read and write on the
fly]

When this box is checked, it is possible to access the target system
memory while the user program is running. Do not check this check box if
you require realtime emulation.

[Break on access error]

When this box is checked, a break (the user program stops) occurs if
your program accesses a guarded memory area or writes to a write-
protected area.

[Enable internal ROM area write]

When this box is checked, writing to the internal ROM area is enabled.
For the result of writing, see the [Extended Monitor] window.

[User VCC Threshold]

Sets the voltage level for the user system.

[User Signals]

When this box is checked, the reset, NMI, standby, and bus request
signals from the user system are enabled.

[Driver]

Displays the E6000 driver that is currently installed.

[Change driver in start up]

When this box is checked, selection of a driver will be available next time
the emulator is connected.

Note: Theitemsthat can be set in this dialog box vary according to the emulator in use. For details, refer to
section 8, Software Specifications Specific to This Product, or the online help.
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512 Selectingan MCU Not Included in the List

Selecting [Custom] in [Device] of the [Configuration Properties] dialog box adds the [Custom Device] page to
the dialog box.

General  Custom Device

ROM: -
RéM:  |16kB |
Fin  [120128Pe |
Modules
¥ Enable DTC v Enable I A/D Converter
v
W Enable DA& Converter W Enable lICO ~ ;reg
Iz
W Enable Refresh Contraller v Enable [1C1 d
¥ Enable DMAL ¥ Enable w071 501 Select
W Enable TPU35 W Enable TMRZ-3 (" sCind
" SCI0-2
v Enable Piaitd14 " SCI0-3
W Enable MuliPracesserComunication [SCI11-4] * SCI0-4

Ok, | Cancel

Figure5.2 [Configuration Properties] Dialog Box ([Custom Device] Page)

Use this page to specify functions for an MCU not included in the list of MCUs. The items are adopted by the
device last selected.

[Custom Device] page

[ROM] Specify the internal ROM area size.

[RAM] Specify the internal RAM area size.

[Pin] Specify the product package.

[Modules] Check this box to validate on-chip peripherals.

Note: Theitemsthat can be set in this dialog box vary according to the emulator in use. Some emulators may
not support the [Custom Device] function. For details, refer to section 8, Software Specifications
Specific to This Product, or the online help.
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513 Selecting the I nterface to be Connected

Checking [Change driver in start up] on the [Configuration Properties] dialog box allows a selection of the driver
next time the emulator is connected.

EAQ00 Driver Details

Driver: (==

r— Details

Interface: IUSB interface ﬂ

Channel: IEBDDD USE Interface j

r— Configuratian

[Canfigure... |
[" Change driver in start up

Figure5.3 [Driver Details] Dialog Box
[Driver]: Selects the driver that connects the HEW and the emulator.
[Details): Sets the details of the driver being connected.

[Interface]: The name of the interface to be connected. This should not be changed in this
emulator.

[Channdl]: Channel for the selected interface. This should not be changed in this emulator.
[Configuration]: Driver setting.

[Configure...]: A dialog box for setting will be displayed when the driver supports the configuration
dialog. Note that thisitem is not available with this emulator.

[Change driver in start up]:
Checking this box selects the driver when the emulator is connected the next time.
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514 Opening the [Memory Mapping] Dialog Box

Selecting [Options -> Emulator -> Memory Resource...] or clicking the [Emulator Memory Resource] toolbar
button ) opens the [Memory Mapping] diaog box.

Mernory Mapping ﬂ J

*

Systern Memorny Resources From  To t apping Add...
SIhdbd M odule: J 00000000 - 00ZFFEE_On Chip Read-only
TMEB SikH fitted 00040000 - DOFFAFFF User Guarded
Fam Bases: OO0FFEO00 - DOFFEFBF On Chip Read-write
0 hiot wzed QOFFEFCO - OOFFFFFF User Guarded
1: nat uzed O0FFFE00 - DOFFFFFF O Chip Read-write Beset
2 not uged
3 not uged Close
[]

Target Device Configuration

00000000 - Q003FFFF Internal ROM J
DOFFEO0D - OOFFEFEF Internal RAR

DOFFF300 - QOFFFF3F Internal 10

DOFFFFG0 - DOFFFFBF Internal 10

OOFFFFCO - OOFFFFFF Internal RAM

|

Figure5.4 [Memory Mapping] Dialog Box

This diaog box displays the current memory map. The E6000 H8S or H8/300 series supports four blocks of user
memory. These can be 256 kbyte or 1 Mbyte each, depending on the SIMM fitted. Each block can be placed in
the address space on a 256-kbyte or 1-Mbyte boundary.

The memory mapping has agranularity of H'40 (D'64) bytes. Each 64-byte block can be set to the internal
(emulation) or external memory and can be guarded (access-prohibited), write-protected or read-write.

The H8/300 series EG000 generally incorporates an emulation memory.

In the memory map, the memory can be set as an internal (emulation) or external, guarded (access-prohibited),
write-protected, or read/write in a byte unit.

[Add...]: Displays the [Edit Memory Mapping] dialog box, allowing the user to modify the address
range and attributes of a memory map.

[Modify...]: Displays the [Edit Memory Mapping] dialog box, allowing the user to modify the address
range and attributes of a memory map.

[Reset]: Resets the map memory to its default settings.

[Closg]: Closes the dialog box.

The memory configuration of the device being emulated is displayed by the [Memory] sheet in the [Status]
window.

Note: Some emulators may not support the emulation memory or the memory mapping function. For details,
refer to section 8, Software Specifications Specific to This Product, or the online help.
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515 Changing the Memory Map Setting

Clicking the[Add...] button on the [Memory Mapping] dialog box or clicking the [Modify...] button after
selecting the information on the memory map setting you want to change opens the [Edit Memory Mapping]

dialog box.

Edit Memary Mapping llﬂ
Memony Mapping
i I Cancel |

To I

Setting: I On Chip Read-vwrite j

Figure5.5 [Edit Memory Mapping] Dialog Box

Use this dialog box to change the address range and attributes of a memory map.

[From]: Enter the start address of the map range.
[To]: Enter the end address of the map range.
[Setting]: Enter the memory map setting.

The choices given are listed below. The User (external memory) and Emulator (emulation
memory) attributes can be modified.
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On-chip Read-write (Cannot be changed)

On-chip Read-only (Cannot be changed)

On-chip Guarded (Cannot be changed)

User Read-write (Cannot be selected when the single chip mode is selected.)
User Read-only (Cannot be selected when the single chip mode is selected.)
User Guarded

Emulator Read-write

Emulator Read-only

Emulator Guarded
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5.2 Downloading a Program
This section describes how to download a program and view it as source code or assembly-language mnemonics.

Note: After abreak has occurred, the HEW displays the location of the program counter (PC). In most cases,
for exampleif an Elf/Dwarf2-based project is moved fromits original path, the source file may not be
automatically found. In this case, the HEW will open a source file browser dialog box to allow you to
manually locate the file.

521 Downloading a Program
A load module to be debugged must be downloaded.

To download a program, select the load module from [Debug -> Download] or select [Download] from the
popup menu opened by clicking the right-hand mouse button on the load module in [Download modules] of the
[Workspace] window.

Note: Before downloading a program, it must be registered to the HEW as aload module. For registration,
refer to section 4.3, Setting at Emulator Activation.
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522 Viewing the Source Code

Select your source file and click the [Open] button to make the HEW open the file in the integrated editor. Itis
also possible to display your source files by double-clicking on them in the [Workspace] window.

w® Tutorial.cpp =10l =]
Qx00001038 wvolid tutorial{void) j
0=00001044 i

long a[l10]:;

long 3:

int 1i:

clas=s Samnple *p_sam;
0=00001046 | 4 |hg| @ p_=amn= Sample:;
0xz0000104e | +& g for{ i=0; 1<10; i++ }{
D=00001050 |-& (|2 j = rand():
0x00001058 |2 if{j < 03
0=0000105a |2 3 e Ca| S

b

0=0000105c | o> ali] = 7:

b
0=00001070 p_sam—r=ort(a):
0=x0000107a p_samn—>change{a);
0=z00001082 p_san—:=0=a[0];
0=0000108a p_=samn—r=l=a[l]:; -

Figure5.6 Source Window
In thiswindow, the following items are shown on the left as information on lines.

*  First column (Source address column): Displays the address information for the source line
e Second column (Event column): Event information (break)

e Third column (EXT.2 Trigger column): EXT.2 Trigger information

*  Fourth column (Editor column): PC, bookmark, and breakpoint information

The Editor window is displayed in the right part of the Source window.
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Sour ce addr ess column

When a program is downloaded, an address for the current source file is displayed on the Source address column.
These addresses are hel pful when setting the PC value or a breakpoint.

Event column
The Event column displays the following items:
@ - Address condition break by an event or arange channel
*®: Starts time measurement by an event channel
“&: Ends time measurement by an event channel
= Starts a point-to-point range trace
&' Ends a point-to-point range trace
" Hatstrace
These are also set by using the popup menu.
EXT.2 Trigger column
The EXT.2 Trigger column displays the following items:
;. EXT.2-1 trigger condition
#ha: EXT.2-2 trigger condition
I EXT.2-3 trigger condition
s EXT.2-4 trigger condition
-2 Two or more EXT.2 trigger conditions
It isalso possible to set them by using the popup menu.
Editor column
Editor column displays the following items:
O: A bookmark is set.
#: A PC Break is set.
5*: PC location
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=) To switch off acolumnin al sourcefiles

Click the right-hand mouse button on the [Editor] window.

Click the [Define Column Format...] menu item.

The [Global Editor Column States] dialog box is displayed.

A check box indicates whether the column is enabled or not. If it ischecked, the column is enabled. If
the check box is gray, the column is enabled in some files and disabled in others.

5. Click the [OK] button for the new column settings to take effect.

> w NP

Global Editar Calumn Skates ﬂ

[W|E>T.2 Trigger

[w]E vent = =
[w]E ditar Cancel |
[w]Source Address

Figure5.7 [Global Editor Column States] Dialog Box

S To switch off acolumn in one sourcefile
1. Click the right-hand mouse button on the [Editor] window which contains the column you want to
remove to display the popup menu.
2. Click the [Columns] menu item to display a cascaded menu item. The columns are displayed in this
popup menu. If acolumnisenabled, it hasatick mark next to itsname. Clicking the entry will toggle
whether the column is displayed or not.

184
RENESAS




523 Viewing the Assembly-L anguage Code

Click the right-hand mouse button on the [Source] window to open the popup menu and select [Go to
Disassembly] to open the [Disassembly] window at the same address as that for the current [ Source] window.

If you do not have a sourcefile, but wish to view code in the assembly-language level, either choose [View ->
Disassembly...], or click on the [Disassembly] window’ s toolbar button ). The [Disassembly] window opens
at the current PC location and shows [Address] and [Code] (optional) which show the disassembled mnemonics
(with labels when available).

ol x]

24 while {(1){

00001036 40FC BRA @ main: 8

26 T

27

28

29: woid tutorial{wvoid)

tutorial O01006DF3 MOV . L ER3, @-ER7

0000103C O1206DF4 STH.L (ER4-ERG ), @-5F

goooiod40 79370028 SUB. W ¥H'0028,R7

30 {

00001044 OFF3 MOV . L ER7.ER3

31 long a[10]:

32 long 3

KN int 1

34 cla=s Sanple *p =an:

a5

36 p_=zan= new Sanple;
€ 00001046 1480 SUB.L ERO,ERD

goooiloda SEOODZ000 JSR @Sanple:  Sample() 24

0000104C OF86 HOV . L ERO,ERE

37 for{ i=0; 1<10; i++ 3{

0O000104E 1944 SUB. W R4 R4

3B j = randi);

00001050 SEOO11EE JSR @ _rand: 24 -
4 Y

Figure5.8 [Disassembly] Window

524 Modifying the Assembly-L anguage Code

Y ou can modify the assembly-language code by double-clicking on the instruction that you want to change. The
[Assembler] dialog box will be opened.

Addrezz Code Iremonic;
00001040 79370028

ok |

Figure5.9 [Assembler] Dialog Box
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The address, machine code, and disassembled instruction are displayed. Enter the new instruction or edit the old
instruction in the [Mnemonic] field. Pressing the [Enter] key will assemble the instruction into memory and
move on to the next instruction. Clicking the [OK] button will assemble the instruction into memory and close
the dialog box. Clicking the [Cancel] button or pressing the [Esc] key will close the dialog box.

Note: The assembly-language display is disassembled from the actual machine code in the debugging
platform's memory. If the memory contents are changed, the dialog box (and the [Disassembly] window)
will show the new assembly-language code, but the content of the [Source] window will not be changed.
Thisisthe same even if the source file contains an assembler.

525 Viewing a Specific Address

When you are viewing your program in the [ Disassembly] window, you may wish to look at another area of your
program's code. Rather than scrolling through alot of code in the program, you can go directly to a specific
address. Select [Set Address...] from the popup menu, and the dialog box shown in figure 5.10 is displayed.

Set Address 21 x|
_main
Cancel |

Figure5.10 [Set Address] Dialog Box

Enter the address or label name in the edit box and either click on the [OK] button or pressthe [Enter] key. The
[Disassembly] window will be updated to show the code at the new address. When an overloaded function or a
class nameis entered, the [Select Function] dialog box opens for you to select afunction. For details, refer to
section 5.13.3, Supporting Duplicate Labels.

526 Viewing the Current Program Counter Address

Wherever you can enter an address or value into the HEW, you can also enter an expression. If you enter a
register name prefixed by the hash character, the contents of that register will be used asthe valuein the
expression. Therefore, if you open the [Set Address] dialog box and enter the expression #pc, the [Source] or
[Disassembly] window will display the current PC address. It also allows the offset of the current PC to be
displayed by entering an expression with the PC register plus an offset, e.g., #PC+0x100.
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53 Debugging with the Command Line I nterface

Use the [Command Line] window to enter text-based commands instead of window menus and commands.

531 Opening the [Command Line] Window

Choose [View -> Command Line] or click the [Command Line] toolbar button ) to open the [Command
Line] window.

« Command Line M=l 3

>

Figure5.11 [Command Line] Window

Thiswindow allows the user to control the debugging platform by sending text-based commands. A series of
predefined command lines can be called from afile and the output can be recorded in a file. The command can
be executed by pressing the [Enter] key after the command isinput at the prompt (<) on the last line. For
information on the available commands, refer to appendix G, Command Lines, and the on-line help.

If available, the window title displays the current batch and log file names separated by colons.

Pressing the Ctrl + 1 or Ctrl + | keyson thelast line displays the command line previously executed.

5.3.2 Specifying a Command File

It is useful to use acommand file when a series of predefined command lines need to be executed. Create a
command file by atext editor and write necessary command lines. The default extension of a command file
is.hdc.

Choose [Set Batch File...] from the popup menu to open the [Set Batch File] dialog box, in which the name of a
command file (*.hdc) can be specified. Clicking the [OK] button displays the specified command file name as
the window title. Clicking the [Cancel] button closes the dialog box without changing the setting.

Set Batch File EHE3

|| [ 3 Browse,. ok

Cance| |

Figure5.12 [Set Batch File] Dialog Box
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533 Executing a Command File

Click the [Play] button in the [Set Batch File] dialog box or choose [Play] from the popup menu to execute the
command file. The [Play] menuisdisplayed in gray while the file is running and can be used when the command
file execution stops and control returns to the user.

534 Stopping Command Execution

Choose [Stop] from the popup menu to stop command execution. The [Stop] menu becomes valid during
command execution.

535 Specifyinga Log File

Choose [Set Log File...] from the popup menu to open the [Open Log File] dialog box, in which alog fileto
store the command execution results can be specified.

Open Log File

Log File:

I LI Browse,. | Q;;cel

Figure5.13 [Open Log File] Dialog Box

Enter the name of alog file (*.log). The logging option is automatically set and the name of the fileis shown on
the window title bar.

Opening apreviouslog file will ask the user if they wish to append or overwrite the current log.

5.3.6 Starting or Stopping L ogging

Choose [Logging] from the popup menu to toggle logging to file on and off. When logging is active, the button
becomes effective. Note that the contents of the log file cannot be viewed until logging is completed, or
temporarily disabled by clearing the check box. Re-enabling logging will append to the log file.

5.3.7 Entering a Full Path to the File

It is recommended that the full path to afile is specified as a file name in the [Command line] window because
the current directory can be moved. However, care must be taken to enter the correct full path to afilewhenitis
entered from the keyboard. To save thistrouble, a full path can be easily specified by browsing through files.

Choose [Browse...] from the popup menu to open the [Browse] dialog box. Select afile and click [Open] to paste
the full path to the selected file to the cursor location. This option can only be used when the cursor islocated on
thelast line.

5.3.8 Pasting a Placeholder

Select a placeholder from the [Placeholder] submenu in the popup menu to paste the selected placeholder to the
cursor location. This function is only available when the cursor islocated on the last line.
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54 Viewing the Registers

If you are debugging at assembly-language level, then you will probably find it useful to see the contents of the
CPU's generd registers. Y ou can do this by using the [Register] window.

54.1 Opening the [Register] Window

To open the [Register] window, choose [View->CPU->Registers] or click the [Register] toolbar button ).
The [Register] window opens showing all of the CPU's general registers and the values, displayed in

hexadecimal.

Register Name IRegister Value

=101.%]

[ERO
[EF.L
ERZ
[EF.S
[EF4
[EF.5
ERG
[ER7
FC

CCE.
[EXE.
M CH
MACL

] |

H'00000000
H'00000000
H'00000000
H'00000000
H'00000000
H'00000000
H'00000000
H'00000000
H'000000

—0--N---

H'00000000
H'00000000

i

Figure5.14 [Register] Window

5.4.2 Expanding a Bit Register

If aregister is used as a set of flags at the bit level for the control of state, its one-character symbol rather than its
state indicate each bit. Double-click on the register’s name to display the [Register] dialog box and switch each
bit on or off. Checking the box for any bit specifiesit as holding a 1, while removing the check specifiesit asaO.

Walue:

[ lImaszk.

[ Uzer/Imazk
[ Half-carmy
[ Uzer

-

[ |

Cahicel |

Figure5.15 Expanding a Bit Register
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543 Modifying Register Contents
To change aregister's content, open the [Edit Register] dialog box in one of the following methods:

» Double-click the register you want to change.
» Select the register you want to change, and choose [Edit...] from the popup menu.

Reqgister - [ERO] 7] x|

Walue:

|H'uuuuuuuu
Setds: Cancel |

IWhnIe Regizter j

Figure5.16 [Edit Register] Dialog Box

Y ou can enter anumber or C/C++ expression in the [Value] field. Y ou can choose whether to modify the whole
register contents, amasked area, floating or flag bits by selecting an option from the combo box (the contents of
thislist depend on the CPU model and selected register).

When you have entered the new number or expression, click the [OK] button or pressthe [Enter] key; the dialog
box closes and the new value is written into the register.

544 Using Register Contents

Use the value contained in a CPU register by specifying the register name prefixed by the “#" character, e.g.:
#R1, #PC, #R6L, or #ER3 when you are entering a value elsewhere in the HEW, for example when displaying a
specified addressin the [ Disassembly] or [Memory] windows.
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55 Operating Memory

This section describes how to look at memory areasin the CPU's address space. How to look at a memory area
in different formats, how to fill and move a memory block, and how to load and verify a memory areawith a
disk file are described.

55.1 Viewinga Memory Area

Tolook at amemory area, choose [View -> CPU ->Memory...] or click the[View Memory] toolbar button
to open the [Memory] window. Thiswill open the [Set Address] dialog box shown in figure 5.17.

|
I Cancel |
End:

Dizplay Data A=
IElyte 1) j

Figure5.17 [Set Address] Dialog Box

Enter the range you wish to display as an address vaue or an equivalent symbol in the [Begin] and [End] fields.
Select the data size for the display from the [Display Data As] combo box. Click the [OK] button or press the
[Enter] key, and the dialog box closes and the [Memory] window opens. The display can be scrolled within the
range of the entered display start and end addresses.

Mernarny EE x|
Address Data Value -
Ox00000A0C 6DF3 0120 EDF4 2372
Ox00000AR12 7937 0028 0OD74 v
Ox00000A13 7900 0001 SEOO 0z
Ox00000A1E OCEBE& 7500 1F42 227
Ox00000AZ4 6DFO  SEOO0 (OEEBE4 222
Ox00000AZA OB8B7 1955 SEOO 222
Ox00000A30 0OCB80 17F0 OFS86 227
Ox00000A36 4C02Z  17B6  ODS3 227
Ox00000A3C 1053 0943 0100 2R

Figure5.18 [Memory] Window
There are three display columns:
[Address]: Address of thefirst item in the [Data] column of this row.

[Data): Datais read from the debugging platform’s physical memory in the access width, and then
converted to the display width.

[Value]: Datadisplayed in an alternative format.
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55.2 Displaying Data in Different Formats

If you want to change the display format of the [Memory] window, select [Format] from the popup menu. The
dialog box shown in figure 5.19 is displayed.

Format Memary

Dizplay Data A=
IEly'te 1) =] =

Display Value fs:

I AMST character :I
Valug Font:
IOnurier MNew j

Figure5.19 [Format Memory Display] Dialog Box

To display and edit memory in different widths, use the [Display Data As| combo box. For example, choose the
[Byte] option and the display will be updated to show the memory area as individual bytes.

The data can be converted into different formats, as shown in the third column [Value]. The list of formats
depends on the data selection.

Thefont of the [Value] column can be different from the font used to display the data. Thisis useful for
displaying [doubl€] byte character values when the datais displayed in the [Word] format.

55.3 Splitting Up the Window Display

To vertically divide the [Memory] window display into two, select [Split] from the popup menu and move the
split-up bar. Moving the split-up bar to the top end or bottom end of the window cancels the split-up display.

554 Viewing a Different Memory Area

To change the memory area displayed in the [Memory] window, use the scroll bars. To quickly look at a new
address, use the [Set Address] dialog box. This can be opened by choosing [Start Address] from the popup menu.

Enter the new address value, and click the [OK] button or pressthe [Enter] key. The dialog box closes and the
[Memory] window display is updated with the data at the new address. When an overloaded function or a class
name is entered, the [Select Function] dialog box opens for you to select a function.
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555 Modifying the Memory Contents

The memory contents can be modified via the [Edit Memory] dialog box. Move the cursor on the memory unit
(according to the [Memory] window display choice) that you wish to change. Either double-click on the memory
unit or press the [Enter] key. The dialog box shown in figure 5.20 is displayed.

Edit Memary
Current W alue:

[HFF

LCancel |
Mew W alue:

Figure5.20 [Edit Memory] Dialog Box

A number or C/C++ expression can be entered in the [New Value] field. After you have entered the new number
or expression, click the [OK] button or press the [Enter] key. Then the dialog box closes and the new valueis
written into memory.

The memory contents can a so be modified by moving the cursor on the memory unit and entering the new value
in hexadecimal through the keyboard.

55.6 Selectinga Memory Range

If the range to be selected isin the [Memory] window, you can select the range by clicking on the first memory
unit (according to the [Memory] window display choice) and dragging the mouse to the last unit. The selected
range is highlighted.

If the memory address range islarger than or outside the [Memory] window, you can enter the start address and
byte count in the respective fields of the [Memory] diaog box.
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55.7 Finding a Valuein Memory
To find avaue in memory, open the [Memory] window and select [ Search] from the popup menu.

The [Search Memory] dialog box shown in figure 5.21 is displayed.

Data:

Search Data ds:
IEly'te 1) LI

[+ Search Egual Data I~ Search Backward

Figure5.21 [Search Memory] Dialog Box

Enter the start and end addresses of the range in which to search (if amemory area was selected in the [Memory]
window, the start and end address values will be automatically filled in) and the data value to search for, and
select the search format. If pattern search is selected as the search format, a byte string of up to 256 bytes can be
searched for. The end address can a so be prefixed by aplus (+); the end address will become the (start address)
+ (entered value).

Search conditions other than pattern search are data match/mismatch and search direction. Note that only data
match and forward direction can be selected with pattern search.

Click the [OK] button or press the [Enter] key. The dialog box closes and the HEW searches the range for the
specified data. If the datais found, the address at which the data has been found is displayed in the [Memory]
window.

If the data could not be found, the [Memory] window display remains unchanged and a message box informing
that the data could not be found is displayed.

If [Search Next] is selected from the popup menu in the state where data has been found, the search will continue
from the next address.
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55.8 Fillinga Memory Areawith a Value
A value can be st as the contents of amemory address range using the memory fill function.

To fill amemory range with the same value, choose [Fill] from the popup menu of the [Memory] window or
choose [Fill] from the [Memory] drop-down menu. The [Fill Memory] dialog box is shown in figure 5.22.

2l x|
__ Cereel |

Cancel

FEormat;
|

=

Figure5.22 [Fill Memory] Dialog Box

If an address range has been selected in the [Memory] window, the specified start and end addresses will be
displayed. Select aformat from the [Format] combo box and enter the datavalue in the [Data] field. On clicking
the [OK] button or pressing the [Enter] key, the dialog box closes and the new value is written into the memory
range.

55.9 Copying aMemory Area

Y ou can copy a memory area using the memory copy function. Select a memory range and then [Copy...] from
the popup menu. The [Copy Memory] dialog box is opened (figure 5.23).

|
Cancel |
End:
|
Degtination:
|
Format:
IEly'te 1) LI
I~ Werify

Figure5.23 [Copy Memory] Dialog Box
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The source start address and end address selected in the [Memory] window will be displayed in the [Begin] and
[End] fields. Checking the [Verify] check box enables copying while comparing the copy source and copy
destination. The copy unit can be selected in the [Format] combo box. Enter the destination start addressin the
[Destination] field and click the [OK] button or press the [Enter] key. Thiswill close the dialog box and copy the
memory block to the new address.

55.10 Savingand VerifyingaMemory Area

A memory areain the address space can be saved into a disk file using the memory save function. Open the
[Save Memory As] dialog box by choosing [File -> Save memory...].

IElinary :I
Cahcel |

File name:

|manual.bin :l _I

Start addrezs:
|D

End Address:
IH'FFFFI

Figure5.24 [Save Memory As] Dialog Box

Enter the start and end addresses of the memory block that you wish to save, and a name and format for the file.
The [File name] combo box contains the previous four file names used for saving memory.

Clicking the[...] button can open the standard [File Save As] dialog box. On clicking the [OK] button or
pressing the [Enter] key, the diaog box closes and the memory block will be saved into the disk as afile of the
specified format type.

A memory areain the address space can be verified using the memory verify function. Open the [Verify
Memory] dialog box by choosing [File -> Verify Memory...].

Yerify Memory 2=l
=
Cancel |
File name:

| =1
Offzet address:

Figure5.25 [Verify Memory] Dialog Box
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55.11 Disabling Update of the Window Contents

Automatic update of the [Memory] window contents, which is performed when user program execution stops
and in other cases, can be disabled. Thisis done by checking [Lock Refresh] in the popup menu.

5.5.12 Updating the Window Contents

The [Memory] window contents can be forcibly updated. Thisis done by checking [Refresh] in the popup menu.

55.13 Comparing the Memory Contents

The contents of two memory blocks can be compared. Open the [Compare Memory] dialog box by selecting
[Memory -> Compare...] from the main menu or by selecting [Compare...] from the popup menu of the
[Memory] window.

Catpare Memary 2 x|

Begin: Qf

I Cancel| |

Start Compare:

Format:

I Byte G1) j

Figure5.26 [Compare Memory] Dialog Box

Enter the comparison format ([Format]), the start address ([Begin]) and end address ([End]) of the source
memory area, and the start address ([ Start Compare]) of the destination memory area. If the memory block is
aready highlighted in the [Memory] window, the start and end addresses will be automaticaly filled in when the
[Compare Memory] dialog box is opened.

If there is amismatch, the address where it was found is displayed in a message box.

197
RENESAS




55.14 LoadingaMemory Areafrom aFile

A file can be loaded to the debugging platform’s memory. Select [Load...] from the popup menu of the
[Memory] window to open the [Load Program] dialog box.

Load Program 2 x|
Format: Open
IElinary j
File name:

| =]
Offget address:

Figure5.27 [Load Program] Dialog Box

Enter the file format ([Format]) and the file name ([File name]). If theload address value is to be changed, enter
the offset value in the offset field ([Offset address]), otherwise enter zero.
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5.6 Viewing the /O Memory

A microcomputer contains on-chip periphera modules. The exact number and type of peripheral modules differ
between devices but the typical modules are a DMA controller, serial communicationsinterface, A/D converter,
integrated timer unit, bus state controller, and watchdog timer. Registers that are mapped to the microcomputer’s
address space controls the on-chip peripheral modules.

The [Memory] window enables you to look at datain continuous memory addresses as byte, word, longword,
single-precision floating-point, double-precision floating-point, or ASCII values. However, registers of different
sizes are dlocated to non-continuous memory addresses in the 1/0 memory. To handle this memory, the HEW
has the [10] window to facilitate checking and setting up of these kinds of registers.

56.1 Opening the [IO] Window

To open the [I10] window, select [View -> CPU -> 10] or click the [View 1/Q] toolbar button ). Modules that
match the on-chip peripheral modules organize the 1/0O register information. When the [10] window is first
opened, only alist of module namesis displayed.

OO0FEEDE?
OO0FEEDES

#-[1] Interrupt Controller
#-[1] Bus_Controller

#-[]] Data Transfer Control
F-[1] If0 Port_1

F-[1] If0_Port_3

F-[1] If0_Port_4

H-[1] If0_Port_7

F-[1] If0_Port_3

F-[1] If0 Port R

#-[1] If0_Port_B

F-[1] If0_Port_C

.77 TAN Dot N =
1| | 2]

Figure5.28 [IO] Window

5.6.2 Expanding the I/O Register Display

To display the names, addresses, and values of the 1/0 registers, click the [+] mark at the left of the module name
or select the module name by clicking on it or using the cursor keys and press the [->] key. The module display
will expand to show theindividual registers of that peripheral module and their names, addresses, and values.
Clicking the [-] mark at the left of the expanded module name or pressing the [<-] key will close the I/O register

display.

For adisplay in the bit level, click the [+] mark at the left of the register name or select the register name by
clicking on it or using the cursor keys and pressthe [->] key. The register display will expand to show the names
of register bits and values. Clicking the [-] mark at the left of the expanded register name or pressing the [<-] key
will close the register bits display.
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5.6.3 Modifying the I/O Register Contents

To edit thevaluein an I/O register, double-click or press the [Enter] key on the register to open a dialog box to
modify the register contents. When you have entered the new number or expression, click the [OK] button or
press the [Enter] key; the dialog box closes and the new value is written into the register.

5.7 Viewing the Current Status

Choose [View -> CPU -> Status] or click the [View Status] toolbar button ) to open the [Status] window and
see the current status of the debugging platform.

- Status o =]
Item IStatus I
Target Device Configuration 00oo0000d - QO001lFFFF  Internal ROM

OOFFEBOOO — OOFFEFEF Internal RAM
OOFFF200 — 0OOFFFF3F Internal IO
OOFFFFE0 — OOFFFFEF Internal IO
OOFFFFCO — OOFFFFFF Internal RAM
System Memory Resources SIMM Module:
IME SIMM fitted
Fam Bases:
0: not used
l: not used
Z: not used
2: not used
Program Name Memory Loaded Area
...ator_cpiTutorial. abs H'00000000 - H'00000003
H'00000400 - H'000004E5
H'00001000 - H'0O00015FS
H'0000z000 - H'0000Z2139

| 4[>\ Memony £ Flatiorm } Events f

Figure5.29 [Status] Window

The [Status] window has three sheets:

e [Memory] sheet
Contains information about the current memory status including the memory mapping resources and the
areas used by the currently loaded object file.

» [Platform] sheet

Contains information about the current status of the debugging platform, typically including CPU type and
mode; and run status.

* [Events] sheet
Contains information about the current event (breakpoint) status, including resource information.

Note: Theitemsthat can be set in this dialog box vary according to the emulator in use. For details, refer to
section 8, Software Specifications Specific to This Product, or the online help.

200
RENESAS




5.8 Reading and Displaying the Emulator Information Regularly

Use the [Extended Monitor] window to know the changing information on the emulator no matter the user
program is running or halted.

Note:  The Extended Monitor function does not affect the execution of the user program since it monitors the
user system or the signal output from the MCU in the emulator by using the emulator’s hardware circuit.

58.1 Opening the [Extended Monitor] Window

Selecting [View -> CPU -> Extended Monitor] or clicking the [Extended Monitor] toolbar button displays
thiswindow. Theinterval of updating the display is approximately 100 ms during user program execution or
1,000 ms while breaking, respectively.

=10l x|
Item Value I
Uzer Standby Inactive
User NMI Inactive
User Reset Inactive
User Wait Inactive

Uzer System Voltage 0OE
Uzer System VoltageZ Dowm

User Cable Not Commected
Punning status Ereak = Ready
DOM Write No

Target Made 7

Target Clock No Clock
Target Sub Clock No Clock

Figure5.30 [Extended Monitor] Window
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5.8.2 Selecting Itemsto be Displayed

Selecting [Properties...] from the popup menu displays the [Extended Monitor Configuration] dialog box.

nided Monitor Configuration
— pdate millzecaond
Bunning: 100 Breal: I 1000
Settingz:
Item | Walue -
Uger Standby Inactive
Lzer MM Inactive
Usger Reset Inactive
1 zer W ait Inactive
Usger Syztem Yolage ok |
Uzer Syztem Voltage2 Do
Usger Cable Mot Connected
Running ztatus Break = Ready _ILI
<] | »

Figure5.31 [Extended Monitor Configuration] Dialog Box
This diaog box allows the user to set the items to be displayed in the [Extended Monitor] window.

Note: Theitemsthat can be set in this dialog box vary according to the emulator in use. For details, refer to
section 8, Software Specifications Specific to This Product, or the online help.
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5.9 Displaying Memory Contentsin Realtime

Use the [Monitor] window to monitor the memory contents during user program execution. In the Monitor
function, the realtime operation is retained since the bus monitoring circuit of the emulator sets the read/write
signal of the MCU as atrigger and holds the address bus and data bus values to update the displayed contents of
the memory.

Up to eight points can be set by using the eight monitoring channels on the bus monitoring circuit. 1 to 256 bytes
can be monitored at one point. It is possible that a part or al of monitoring ranges is overlapped.

Note: Monitoring isimpossible for an area, such as an internal timer counter, where no interna read/write
signal is generated to update avalue.

591 Opening the [Monitor] Window

To open the [Monitor] window, select [View -> CPU -> Monitor -> Monitor Setting...] or click the [Monitor]
toolbar button ) to display the [Monitor Settings] dialog box.

Manitor Setting ﬂ ﬂ
Monitor Setting |
Name: |manitart
— Optionz
Address: IH'DDFFEF&D
Size [byte]: |H'2D =]
Access [Format]: IEYTE [BSCI ﬂ

v Auto-Refresh at rate [mz) : ID'EIEIEEIU

[+ Reading the Initial ¥alus

— Color
LChange Indicator: Il:hange j
Foreground: [N |~ Background: |:||v|
[ Maptly
— Detail
IDETﬁIL HOT SUFFPORTED! Detail |
— Higtony

| [ |
Ok, I Cancel |

Figure5.32 [Monitor Setting] Dialog Box
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[Name]:

[Optiong]:

[Coalor]:

[Detail]:

[History]:

[Address]:

[Size]:

[Access):

[Auto-Refresh at rate (ms)]:

[Reading the Initia Value]:

[Change Indicator]:

[Foreground]:
[Background)]:

[Mayfly]:

Decides the name of the monitor window.

Sets monitor conditions.

Sets the start address for monitoring.

Sets the range for monitoring.

Sets the access size to be displayed in the monitor window.

Setsthe interval for acquisition by monitoring (500 ms at minimum).

Selects reading of the values in the monitored area when the monitor
window is opened.

Sets the method to update monitoring and the attribute of colors.

Selects how to display the values that have changed during monitoring
(available when [Reading the Initial Value] has been selected).
No change: No color change.

Change: Color is changed according to the [Foreground] and [Background]
options.

Gray: Those data with values that have not been changed are displayed in
gray.

Appear: A valueisonly displayed after changed.

Sets the color used for display (available when [Change] has been selected).

Sets the background color (available when [Change] has been selected).

A check in this box selects restoration of the color of those data which have
not been updated in a specified interval to the color selected in the
[Background)] option. The specified interval istheinterval for monitor
acquisition (available when [Change], [Gray], or [Appear] has been selected).

Sets the items specific to the emulator. Not used with this emulator.

Displays the previous settings.

Notes: 1. Inthisemulator, odd addressees cannot be specified as the start addresses for monitoring.
2. Selection of the foreground or background color may not be available depending on the operating

systemin use.

After setting, clicking the [OK] button displays the [Monitor] window.

204

RENESAS



- monitar: monitorl - H'OOFFEFAQ ;Iglﬂ
Address Data -
Ox0QOFFEFAO 00 00 OD B3 00 Q00 0BG FA ........

Ox00FFEFAE 00 00 00 00 00 00 00 00 ........

O0x0QOFFEFEQ 00 00 00 00 00 00 00 00 ........

Ox00FFEFEE 00 00 10 36 00 00 04 1E PR T ;I

Figure5.33 [Monitor] Window
During user program execution, the display is updated according to the setting value of the auto-update interval.

Note: Select [Refresh] from the popup menu when datais not displayed correctly after changing the address or
content of memory.

5.9.2 Changing the Monitor Settings

Selecting [Monitor Setting...] from the popup menu of the [Monitor] window displays the [Monitor Setting]
dialog box, which alows the settingsto be changed.

Colors, the size of accesses, and the display format can be easily changed from [Color] or [Access] of the popup
menu.

593 Temporarily Stopping Update of the M onitor

During user program execution, the display of the [Monitor] window is automatically updated according to the
auto-update interval. Select [Lock Refresh] from the popup menu of the [Monitor] window to stop the update of
display. The characters in the address section are displayed in black, and the update of display is stopped.

Selecting [Lock Refresh] again from the popup menu cancels the stopped state.

5.9.4 Deleting the Monitor Settings

Selecting [Close] from the popup menu of the [Monitor] window to be deleted closes the [Monitor] window and
deletes the monitor settings.

595 Monitoring Variables
Using the [Watch] window refersto the value of any variables.

When the address of the variable registered in the [Watch] window exists within the monitoring range that has
been set by the Monitor function, the value of the variable can be updated and displayed.

This function allows checking the content of a variable without affecting the realtime operation.

For the [Watch] window, refer to section 5.14.3, [Watch] Window.
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5.9.6 Hiding the [Monitor] Window

When using the Monitor function to monitor the value of a variable from the [Watch] window, hide the
[Monitor] window for the effective use of the screen.

The current monitoring information is listed as the submenu when selecting [Display -> CPU -> Monitor]. The
list consists of the [Monitor] window name and the address to start monitoring.

When the left of the list is checked, the [Monitor] window is being displayed.

Selecting items of the [Monitor] window you want to hide from the monitor setting list displays no [Monitor]
window and removes the check mark at the |eft of the list.

To display the [Monitor] window again, select the hidden the [Monitor] window.

[ 2 Monitor Setting... Shift+Chil+E

| v monitor2 - HODFFEODS
monitor] - H'OOFFEFS0

Windows Select. .

Figure5.34 Monitor Setting List

59.7 Managing the [M onitor] Window

Selecting [Display -> CPU -> Monitor -> Windows Select...] displays the [Windows Select] dialog box. In this
window, the current monitoring condition is checked and the new monitoring condition is added, edited, and
deleted in succession.

Selecting multiple monitoring conditions enables atemporary stop of update, hiding, and deletion.

Name Address
monitor2 H'00FFBODS
monitorl H'00FFEF80

Add...

Edit...

Lock Refresh?

Hide?

Bemove

Close |

Figure5.35 Selectionin the[Monitor] Window
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[Add]: Adds a new monitoring condition.

[Edit]: Changes the settings of the selected [Monitor] window (disabled when selecting multiple
items).
[Lock Refresh/Unlock Refresh]:

Automatically updates or stops updating the display of the selected [Monitor] window.
[Hide/UnHide]: Displays or hides the selected [Monitor] window.
[Remove]: Removes the selected monitoring conditions.

[Close]: Closes this dia og box.
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510 ViewingtheLabels

Symbol information isincluded in the debugging information, which is used when the HEW links the user
program source code to the actual code in the memory. Symbol information is also included in the debug object
file. Thisinformation is alist of names that indicate addresses in the program. These names are called labelsin
the HEW. The [Disassembly] window shows the first eight characters of each label instead of the corresponding
address or as apart of an instruction operand *.

Note:  When alabel value matches an operand, the corresponding instruction operand is replaced by the label.
If two or more |abels have the same value, the one that comes first in alphabetical order is displayed.
When [edit control] accepts an address or avalue, alabel can be entered instead.

5.10.1 ListingLabes

Choose [View -> Symbol -> Labels] or click the [View Labels] toolbar button ) tolist al labels defined in
the current debugger session.

e

EP I Address I Name -
H'00001000 _sbrk
H'00001034 _main
H'00001038 tutoriall)
H'00001104 _ahort
H'0o0ool1oc _ INITECT
H'0000Ll1zZ loopl
H'0000Ll1zC loopZ
H'000011ZE next_loopZ
H'00001132 next_loopl
H'00001144 loop3
H'0000Ll152 loopd
H'00001153 next_loopd
H'0000115C next_loop3
H'oooolles operator newiunsigned long!
H'0000L11EE _ CALL_INIT
H'0000L1ED _ CALL_END
H'Q00011E4 operator delete(void *)
H'0000L1EE _rand
H'0000lZze _srand
H'00001Z32 $DIVLE3
H'00001z3C not_negx -

A | v

Figure5.36 [Label] Window

Y ou can view symbols sorted either alphabetically (by ASCII code) or by address vaue by clicking on the
respective column heading.

Double-clicking in the [BP] column can set or clear a software breakpoint at the start of the function.
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5.10.2 Addingalabel

Choose [Add..] from the popup menu and open the [Add Label] dialog box to add alabel:

Add Label HE

MHame: || ;I oK I
Address: [HonAanonD =l Gancel |

Figure5.37 [Add Label] Dialog Box

Enter the new label name into the [Name] field and the corresponding value into the [Address] field and press
[OK]. The[Add Label] dialog box closes and the label list is updated to show the new label. When an
overloaded function or a class name is entered in the [Address] field, the [Select Function] dialog box opens for
you to select afunction. For details, refer to section 5.13.3, Supporting Duplicate Labels.

5.10.3 Editingalabel

Choose [Edit...] from the popup menu and open the [Edit Label] dialog box to edit alabel:

Edit Label _main

Mame: |_ma in ;I QK I

Address: [HonaaoToT2] | Gancel |

Figure5.38 [Edit Label] Dialog Box

Edit the label name and value as required and then press [OK] to save the modified version in the label list. The
list display is updated to show the new label details. When an overloaded function or a class nameis entered in
the [Address] field, the [Select Function] dialog box opens for you to select a function. For details, refer to
section 5.13.3, Supporting Duplicate Labels.
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5.104 DeletingalLabel

To delete alabdl, select the label and choose [Delete] from the popup menu. A confirmation message box
appears:

Confirmation Request

Delete Label BTEL

I~ Don't ask this question again

0K I Cancel i

Figure5.39 Message Box for Confirming L abel Deletion

If you click [OK], the label is removed from the list and the window display is updated. If the message box is not
required then do not select the [Delete Label] option of the [Confirmation] sheet in the HEW [Options] dialog
box.

5.105 Deleting All Labels

To delete al the labels from the list, choose [Delete All] from the popup menu. A confirmation message box
appears:

Confirmation Request

Delete All Labels

I Don't ask this question again

Figure5.40 Message Box for Confirming All Label Deletion

If you click [OK], al the labels are removed from the HEW system’s symbol table and the list display will be
cleared. If the message box is not required, do not select the [Delete All Labels] option of the [Confirmation]
sheet in the HEW [Options] dialog box.
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5.10.6 LoadingLabelsfrom aFile

A symbol file can be loaded and merged into the HEW's current symbol table. Choose [Load...] from the popup
menu to open the [Load Symbols] diaog box:

Load Symbols EE3

Loak jn: |¢3H83tut j gl E.-..
ttonal. spm

File narme: Im_l,l_cnde. aum Open I
Files of lwpe: IS_I,Ime| Files [*.spm)] j Cancel |

Figure5.41 [Load Symbols] Dialog Box

The dialog box operates like a standard Windows® [open file] dialog box; select the file and click [Open] to start
loading. The standard file extension for symbol filesis*.sym”. When the symbol loading is complete a
confirmation message box may be displayed showing how many symbols have been loaded (this can be switched
off in the [Confirmation] sheet on the HEW [Options] dialog box).

5.10.7 SavingLabesintoaFile

Choose [Save As...] from the popup menu to open the [Save Symbols] dialog box. The [Save Symbols] dialog
box operates like a standard Windows” [Save File As] dialog box. Enter the name for the file in the [File name]
field and click [Save] to save the HEW's current |abel list to a symboal file. The standard file extension for
symbol filesis*.sym”.

See appendix E, Symbol File Format, for the symboal file format.

Once afileis specified by the [Save As...] menu, the current symbol table can be saved in the same symbol file
just by choosing [Save] from the popup menu.

5.10.8  Searching for a Label

Choose [Find...] from the popup menu to open the [Find Label] dialog box:

Find Label ﬂ E

Mame: I j o] 4 I
™ Match Gasze I j GCancel |

Figure5.42 [Find Label] Dialog Box
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Enter al or part of the label name that you wish to find into the edit box and click [OK] or press the [Enter] key.
The HEW searchesthe label list for alabel name containing the text that you entered.

Note: Only the label is stored by 1024 characters of the start, therefore the label name must not overlap
mutually in 1024 characters or less. Labels are case sensitive.

5.109 Searching for the Next Label

Choose [Find Next] from the popup menu to find the next occurrence of the label containing the text that you
entered.

5.10.10 Viewing the Source Corresponding to a L abel

Select alabel and choose [View Source] from the popup menu to open the [Source] or [Disassembly] window
containing the address corresponding to the label.
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511  Executing Your Program

This section describes how you can execute your program's code. Y ou will learn how to do this by either running
your program continuously or stepping single or multiple instructions at atime.

5.11.1 Running from Reset

To reset your user system and run your program from the reset vector address, choose [ Debug->Reset Go], or
click the [Go Reset] toolbar button ([EL]).

The program will run until it hits a breakpoint or abreak condition is met. Y ou can stop the program manually
by choosing [Debug->Halt], or by dlicking the [Stop] toolbar button (@]).

Note: The program will start running from whatever addressis stored in the Reset Vector location. Therefore it
isimportant to make sure that thislocation contains the address of your startup code.

5.11.2 Continuing Run

When your program is stopped, the HEW will display an yellow arrow mark in the gutter of the line in the editor
and [Disassembly] windows that correspond to the CPU's current program counter (PC) addressvalue. Thiswill
be the next instruction to be executed if you perform a step or continue running.

To continue running from the current PC address, click the [Go] toolbar button , or choose [Debug->Go].

To continue running from a specified address which is not the stop address, change the PC valuein one of the
following ways, and click the [Go] toolbar button (L)) or choose [Debug->Ga.

» Change the PC vdue in the [Register] window. Refer to section 5.4.3, Modifying Register Contents.
» Place the text cursor (not the mouse cursor) to atarget linein the [Source] or [Disassembly] window, and
choose [Set PC Here] from the popup menu.

5.11.3 Running to the Cursor

Sometimes as you are going through your application you may want to run only asmall section of code, that
would require many single steps to execute. Y ou can do this using the Go To Cursor feature.

2 How to use the Go To Cursor

1. Make surethat a[Source] or [Disassembly] window is open showing the address at which you wish to stop.

2. Position the text cursor on the address at which you wish to stop by either clicking in the [Address] field or
using the cursor keys.

3. Choose [Go To Cursor] from the popup menu.

The debugging platform will run your code from the current PC value until it reaches the addressindicated by
the cursor's position.

Notes: 1. If your program never executes the code at this address, the program will not stop. If this happens,
code execution can be stopped by pressing the Esc key, choosing [Debug->Halt], or clicking on the
[Stop] toolbar button (€B)).
2. The Go To Cursor feature requires a PC breakpoint - if you have already used all those available, then
the feature will not work.
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5.11.4  Running from a Specified Address

The [Run Program] dialog box allows the user to run the program from any address. Choose [Debug -> Run...]
to open the [Run Program] dialog box.

Run Program ﬂﬂ

PBrogram Gounter:

|H'DDDDDDDD|
Beset Go
Temporary PG Breakpoints:

Cancel

iy

Figure5.43 [Run Program] Dialog Box
The following execution conditions can be specified in this dialog box:

[Program Counter]: Instruction address to start execution. Theinitial valueis
the current PC vaue.

[Temporary PC Breakpoints]: A temporary PC breakpoint. When execution started
by this dialog box stops, this breakpoint is cleared.

Note: The[Temporary PC Breakpoints] feature requires a PC breakpoint - if you have already used all those
available then the feature will not work.

Clicking the [Go] button starts execution according to the settings. Clicking the [Reset Go] button starts
execution from the reset vector. Clicking the [Cancel] button closes this dialog box without executing
ingtructions.
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5.11.5 Single Step

To debug your codeit isvery useful to be able to step asingle line or instruction at a time and examine the effect
of that instruction on the system. In the [Source] window, then a step operation will step asingle sourceline. In
the [Disassembly] window, a step operation will step a single assembly-language instruction. If the instruction
calls another function or subroutine, you have the option to either step into or step over the function. If the
instruction does not perform a call, then either option will cause the debugger to execute the instruction and stop
at the next instruction.

e Stepping Into a Function
If you choose to step into the function the debugger will execute the call and stop at the first line or instruction of
the function. To step into the function either click the [Step In] toolbar button (), or choose [Debug->Step In].

e Stepping Over a Function Call

If you choose to step over the function the debugger will execute the call and all of the code in the function (and
any function callsthat that function may make) and stop at the next line or instruction of the calling function. To
step over the function either click the [Step Over] toolbar button ), or choose [Debug->Step Over].

*  Stepping Out of a Function

There are occasions when you may have entered a function, finished stepping through the instructions that you
want to examine and would like to return to the calling function without tediously stepping through al the
remaining code in the function. Or aternatively you may have stepped into a function by accident, when you
meant to step over it and so want to return to the calling function without stepping all the way through the
current function. Y ou can do this with the Step Out feature.

To step out of the current function either click the [Step Out] toolbar button (), or choose [Debug->Step Out].
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5116 Multiple Steps

You can step severd instructions at atime by using the [Step Program] dialog box. The dialog box aso provides
an automated step with a selectable delay between steps. Open it by choosing [Debug-> Step...].

The [Step Program] dialog box is displayed:

Step Prozram x|

Steps:

H 00000001

Delay (zeconds)

|1 - 25 geconds j
[~ Step Ower Galls

[~ Source Level Step

814 I Cancel |

Figure5.44 [Step Program] Dialog Box

[Steps): Number of steps to be executed.

[Delay (seconds)]: Delay between steps when the program is automatically stepped.
Value 0 to 6 can be specified where value O indicates the longest delay.

[Step Over Callg]: Selecting this box steps over function calls.

[Source Level Step]: Selecting thisbox steps the program at the source level.

Clicking the [OK] button or pressing the [Enter] key starts step execution.
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512  Stopping Your Program

This section describes how you can halt execution of your application's code. This section describes how to do
thisdirectly by using the [Stop] button and by setting breakpoints at specific locationsin your code.

5.12.1  Stoppingthe Program by the [Stop] Toolbar Button

When your program is running, the [Stop] toolbar button is enabled (ared STOP sign), and when the
program has stopped it is disabled (I:l) (the STOP sign is grayed out). Click on the [Stop] toolbar button, or
choose [Debug->Halt Program].

When the program has been stopped by [Stop], “Stop" is displayed in the [Debug] sheet of the [Output] window.

5.12.2 Standard Breakpoints (PC Breakpoints)

When you are trying to debug your program you will want to be able to stop the program running when it
reaches a specific point or pointsin your code. You can do this by setting a PC breakpoint on the line or
instruction at which to want the execution to stop. The following instructions will show you how to quickly set
and clear simple PC breakpoints. If more complex breakpoint operation is required, use the [Event] window,
which can be opened by clicking the () button or choosing [View -> Code -> Eventpoints]. For details, refer
to section 5.15, Using the Event Points.

* To set aPC breskpoint in the [Source] window

1. Make surethat the [Disassemble] or a[Source] window is open at the place you want to set a PC
breakpoint.

2. Choose [Toggle Breakpoint] from the popup menu, or press F9, at the line showing the address at which
you want the program to stop.

3. Youwill seeared circle appear in the gutter to indicate that a PC breakpoint has been set.

4. The current breakpoint set can be enabled or disabled by using [Enable/Disable Breakpoint] in the popup
menu.

Now when you run your program and it reaches the address at which you set the PC breakpoint, execution halts
with the message "PC Break" displayed in the [Debug] sheet of the [Output] window, and the [Source] or
[Disassembly] window is updated with the PC breakpoint line marked with an arrow in the gutter.

Note:  When abreak occurs, the program stops just beforeiit is about to execute the line or instruction at which
you set aprogram PC breakpoint. If you choose Go or Step after stopping at the PC breakpoint, then the
line marked with an arrow will be the next instruction to be executed.
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e Toset aPC breakpoint by using the [Breakpoints] dialog box
Selecting [Edit -> Source Breakpoint...] displaysthe [Breakpoints] dialog box.

Cancel |
Edit Code |
Remaove |
Remaove All |

Figure5.45 [Breakpoints] Dialog Box

The [Breakpoints] dialog box allows the user to view the current breakpoints set. Clicking the [Edit Code] button
displays the source where each breakpoint is set. The [Remove] or [Remove All] button deletes one or all
breakpoints, respectively. The check box of each breakpoint enables or disables the breakpoint.

» Totoggle PC breakpoints
It is possible to toggle the [PC Breakpoints] setting by either double-clicking in the [BP] column of the line
where the PC breakpoint is set or placing the cursor on the line and pressing the [F9] key. The setting to be
toggled depends on the debugging platform.
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513 Elf/Dwarf2 Support

The HEW supports the Elf/Dwarf2 object file format for debugging applications written in C/C++ and assembly
language for Renesas microcomputers. It provides a powerful way of accessing, observing and modifying the

symbolic level debugging information about the user application that is running.
Key Features

* Source level debugging

e C/C++ operators

» C/C++ expression (casting, pointers, references, etc.)
* Ambiguous function names

* Overlay memory loading

» Watch - locals, and user defined

»  Stack Trace

5131 C/C++ Operators
The C/C++ language operators are available:
55L& N>, <%, (), <, >, <5, 05, =5, 15, &&, |

Buf fer_start + 0x1000

#R1 | B 10001101

((pointer + (2 * increment_size)) & H FFFF0000) >> D 15
I (flag N #ER4)

5.13.2 C/C++ Expressions

Expression Examples

oj ect . val ue /ISpecifies direct reference of amember (C/C++)
p_oj ect - >val ue /ISpecifies indirect reference of amember (C/C++)
Cl ass: :val ue //Specifies reference of a member with class (C++)
*val ue //Specifies apointer (C/C++)

&val ue /ISpecifies areference (C/C++)

array|[ 0] /ISpecifies an array (C/C++)

oj ect . *val ue /ISpecifies reference of a member with pointer (C++)
;i g_val ue /ISpecifies reference of aglobal variable (C/C++)

Cl ass::function(short) //Specifiesamember function (C++)

(struct STR) *val ue //Specifies cast operation (C/C++)

RENESAS

219



5.13.3  Supporting Duplicate Labels

In some languages, for example C++ overloaded functions, alabel may represent more than one address. When
such alabel nameisentered in adialog box, the HEW will display the [Select Function] dialog box to display
overloaded functions and member functions.

Seleck Funckion ﬂﬂ

Select Function Mame Set Function Mame

{5 ample::sortilong 1 N
{Sample:sort{lang #, shart] |

— Counter
All Function Select Function Set Function

|2 Functions |2 Functions ID Functions

Cahicel

Figure5.46 [Select Function] Dialog Box

Select overloaded functions or member functionsin the [Select Function] dialog box. Generally, one function
can be selected at one time; only for setting breakpoints, multiple functions can be selected. This dialog box has
three areas.

[Select Function Name]: Displays the same-name functions or member functions and
their detailed information.

[Set Function Name]: Displays the function to be set and their detailed information.

[Counter]: [AIl Function] Displays the number of same-name functions
or member functions.
[Select Function] Displays the number of functions displayed
in the [Select Function Name] list box.
[Set Function] Displays the number of functions displayed
in the [Set Function Name] list box.

Selecting a Function

Click the function you wish to select in the [Select Function Name] list box, and click the [>] button. Y ou will
see the selected function in the [Set Function Name] list box. To select all functionsin the [Select Function
Name] list box, click the [>>] button.

Deselecting a Function

Click the function you wish to deselect from the [Set Function Name] list box, and click the [<] button. To
deselect all functions, click the [<<] button. The deselected function will be moved from [Set Function Name]
list box back to the [Select Function Name] list box.
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Setting a Function

Click the [OK] button to set the functions displayed in the [Set Function Name] list box. The functions are set
and the [Select Function] dialog box closes.

Clicking the [Cancel] button closes the dialog box without setting the functions.

5.13.4 Debugging an Overlay Program
This section explains the settings for using the overlay functions.
Displaying Section Group

When the overlay modeis used, that is, when several section groups are assigned to the same address range, the
address ranges and section groups are displayed in the [Overlay] dialog box.

Open the [Overlay] dialog box by choosing [Memory->Configure Overlay].

2l
Addreszs; Section Mame:
QOFFES0N - OOFFEADE oK I
Cancel |

Figure5.47 [Overlay] Dialog Box (at Opening)
This didog box has two areas: the [Address] list box and the [Section Name] list box.

The [Address] list box displays the address ranges used in the overlay mode. Click to select one of the address
ranges in the [Address] list box.

Section Mame:

R_zample K |
RA_zart

R_change Cancel |

Figure5.48 [Overlay] Dialog Box (Address Range Selected)

The [Section Name] list box displays the section groups assigned to the selected address range.
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< Setting section group

When using the overlay function, the highest-priority section group must be selected in the [Overlay] dialog box;
otherwise the HEW will operate incorrectly.

First click one of the address ranges displayed in the [Address] list box. The section groups assigned to the
selected address range will then be displayed in the [Section Name] list box.

Click to select the section group with the highest-priority among the displayed section groups.

21

Addreszs; Section Mame:

Cancel

DKI
==

Figure5.49 [Overlay] Dialog Box (Highest-Priority Section Group Selected)

After selecting a section group, clicking the [OK] button stores the priority setting and closes the dialog box.
Clicking the [Cancel] button closes the dialog box without storing the priority setting.

Note:  Within the address range used by the overlay function, the debugging information for the section
specified in the [Overlay] dialog box isreferred to. Therefore, the same section of the currently loaded
program must be selected in the [Overlay] dialog box.
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514  ViewingtheVariables

This section describes how you can look at variablesin the source program.

5.14.1 Tooltip Watch
The quickest way to look at avariablein your program isto use the Tooltip Watch feature.
2 To use Tooltip Watch:

Open the [Source] window showing the variable that you want to examine.
Rest the mouse cursor over the variable name that you want to examine - atooltip will appear near the variable
containing basic watch information for that variable.

& o_=am= Sample;
=3 for{ 1=0; i<10; i4++ 3 {
i = rand(): [H'OOD3]
(3 ¢ 03]
1 = -1

al1] = 3.

Figure5.50 Tooltip Watch

5.14.2 Instant Watch

Open the [Source] window showing the variable that you want to examine.
Rest the mouse cursor over the variable name that you want to examine and choose [Instant Watch...] from the
popup menu; the [Instant Watch] dialog box will appear and display the variable at the cursor location.

Inztant Watch

st {0x7c000088 | istruct strB)

Figure5.51 [Instant Watch] Dialog Box

“+” shown to the | eft of the variable name indicates that the information may be expanded by clicking on the
variable name, and “-” indicates that the information may be collapsed. Clicking [Add] registersthe variable in
the [Watch] window. Clicking [Close] closes the window without registering the variable in the [Watch] window.

223
RENESAS




5.143 [Watch] Window
Y ou can view any vaue in the [Watch] window.
Opening a [Watch] Window

To open a[Watch] window, choose [View->Symbol->Watch] or click on the [Watch] toolbar button ifitis
vishble. A [Watch] window opens. Initially the contents of the window will be blank.

- Watch ;IQI ll
Mame I Walue I Twpe
o-R a { 0=7c000024 | tint[T0]}

..... R [0 H'O0000000 { Ox7c000024 | {int}

..... R[] H'O0000000 { Ox7c000028 | {int}

..... R [ H'O0000000 { Ox7c00002c | {int}

..... R [A] H'O0000000 { Ox7c000030 | {int}

..... R [4] H'O0000000 { Ox7c000034 | {int}

..... R [E] H'O0000000 { Ox7c000038 | {int}

..... R [5] H'O0000000 { Ox7c00003c | {int}

..... R [7] H'O0000000 { Ox7c000040 | {int}

..... R [E] H'O0000000 { Ox7c000044 | {int}

..... R [ H'O0000000 { Ox7c000048 | {int}
...... B max H'OO0A0000 { 0=7=00004c } tint}

Figure5.52 [Watch] Window

Thiswindow allows the user to view and modify C/C++-source level variables. The contents of this window are
displayed only when the debugging information available in the absolute file (*.abs) includes the information on
the C/C++ source program. The variable information is not displayed if the source program informationis
excluded from the debugging information during optimization by the compiler. In addition, the variables that are
declared as macro cannot be displayed.

Thefollowing items are displayed.
[Name]: Name of the variable

[Value]: Value and assigned location.
The assigned location isenclosed by { }.

[Type]: Type of the variable
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The [R] mark shows that the value of the variable can be updated during user program execution.

For updating of the content of the variable that has been registered in the [Watch] window, there are the
following three methods:

1. Usethe Monitor function without halting the user program
The read/write signa of the MCU is set as atrigger and holds the address bus and data bus values to update the
value of the variable.

Note:  Although the realtime operation is retained, the size and number points to be monitored are limited. For
the Monitor function, refer to section 5.9, Displaying Memory Contentsin Realtime.

2. Read the memory content directly from the HEW to update the values without halting the user program since
the bus mastership is owned by the emulator

Note:  While the emulator reserves the bus mastership, the realtime operation is disabled because the CPU stops
operation. This method is only available for accessing the interna ROM, internal RAM, and emulation
memory.

The area used here or this method may not be available depending on the emulator in use. For details,
refer to section 8, Software Specifications Specific to This Product, or [Enable read and write on the fly]
on the [General] page of the [Configuration Properties] dialog box in the online help.

3. Temporarily stops the user program and reads the memory contents

Note: The realtime operation is disabled because the user program is stopped temporarily. This method is only
available for accessing the areas (internal 1/0, DTCRAM, and user memory) other than thosein item 2
mentioned above.

It is possible to recognize the method for updating the value during user program execution according to the
color of the [R] mark.

Blue-outline[R]:  The variable's address is within the range that has been set for the monitoring function and
the dataiis readable by using the monitoring function.

Blue [R]: An updated value of the data at this |ocation has been read by the monitoring function.

Black-outline[R]: The variable's addressis outside the range that has been set for the monitoring function and
the dataiis not readable by using the monitoring function.

Black [R]: A value has been updated by reading the normal data.

Notes: 1. Thisfunction can be set per variable or per element or body for structures of data.
2. Thecolor of an [R] in the [Name] column changes according to the trace and monitoring settings.

3. Theinformationislost when it is scrolled out of the [Watch] window and when the window is
closed.

4. A variablethat is alocated to aregister cannot be selected for monitoring.
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Adding a Watch Item
Use the [Add Watch] dialog box in the [Watch] window to add Watch items to the [Watch] window.
2 To use Add Watch from a [Watch] window:

Open the [Watch] window.
Choose [Add Watch] from the popup menu.
The [Add Watch] dialog box opens:

Add Wiatch 21

Wariable or expression;

f

a Cancel

Figure5.53 [Add Watch] Dialog Box

Enter the name of the variable that you wish to watch and click [OK]. The variable is added to the [Watch]
window. A variable can be dragged from the [Source] window and dropped into the [Watch] window.

Note: If the variable that you have added isalocal variable that is not currently in scope, the HEW will add it
to the [Watch] window but its value will be blank, or set to a question mark, '?.

Expanding a Watch Item

If awatch itemisapointer, array, or structure, then you will see aplus sign (+) expansion indicator to left of its
name, this means that you can expand the watch item. To expand a watch item, double click on it. Theitem
expands to show the elements (in the case of structures and arrays) or data vaue (in the case of pointers)
indented by one tab stop, and the plus sign changesto aminussign (-). If the elements of the watch item also
contain pointers, structures, or arraysthen they will aso have expansion indicators next to them.

Expansion
indicater
, |

Expardeduatch | | = 7 R [0 FOT00E { QAOUITEIZ0 ) flang)
----- R 0] H'000015b { 0x00ef34 } flong]
----- R [ H'0000167e { Dx00ffef8s } flong]
----- R [ H'00001 cfb { 0x00fefBc } flong]
----- R [ H'00002781 { D400ffef30 } flong]
----- R [ H'00003454 { 0x00ff=f34 } flong]
----- R [ H'000041 06 { D40Dffef35 } flong]
----- R [7] H'0000446b { Dx0DffefSc } flong]
----- R [ H'000058.2 { Dx00ffefal } flong]
----- R [ H'0000734b { Dx00ffefad } flong]

Collapsectwatch F-E a { D=00ffef80 } long[10]]

1| | LI

Figure5.54 Expanding a Watch Item

To collapse an expanded watch item, double click on the item again. The item's elements will collapse back to
the single item and the minus sign changes back to a plus sign.
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Editing a Watch Item's Value

Y ou may wish to change the value of awatch variable, e.g. for testing purposes or if the value isincorrect due to
abug in your program. To change a watch item's val ue use the Edit VValue function.

< Editing awatch item's value:
Enter avalue directly in the window.

In another way, select the item to edit by clicking on it, you will see a flashing cursor on the item.
Choose [Edit Value] from the popup menu.
The [Edit Value] dialog box opens:

Expression: I[D]

Current H'00000KE { 0+00ffefa0

Wallue ok I
Mew ' alue: I

LCancel

Figure5.55 [Edit Value] Dialog Box

Enter the new vaue or expression in the [New Value] field and click [OK]. The [Watch] window is updated to
show the new value.
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Deleting a Watch Item

To delete awatch item, select it and choose [Delete] from the popup menu. The item is deleted and the [Watch]
window is updated.

To delete all watch items, choose [Delete All] from the popup menu. All items are deleted and the [Watch]
window is updated.

Specifying Realtime Update

The R mark shown to the left of each variable indicates whether the variable is updated in real time. Whenan R
mark is displayed in bold face, the value of the corresponding variable will be updated in realtime during user
program execution.

A popup menu containing the following optionsis available in the [Watch] window:

e Auto Update
Marks the selected variable with abold R and updates the variable in real time.
* Auto Update All
Marks al variables with bold Rs and updates al variablesin real time.
» Delete Auto Update
Marks the sel ected variable with an outlined R and cancels realtime update.
» Delete Auto Update All
Marks all variables with outlined Rs and cancels reatime update.

M odifying the Radix
The radix for the selected variable display can be modified by choosing [Radix] from the popup menu.
Saving the [Watch] Window Contentsin a File

To save the contents of the [Watch] window, choose [Save As...] from the popup menu; the Save As dialog box
opens. It allows the user to specify the name of afile and to save the contents of the [Watch] window in thefile.
If the [Append] check box is selected, the window contents are appended to the existing file, and if it is not
selected, the exigting file is overwritten.

Opening a [Memory] Window

The contents of the memory area to which the selected variable is assigned can be displayed in the [Memory]
window. Choose [Go To Memory...] from the popup menu; the [Set Address] dialog box opens, showing the
information (start address, end address, and size) of the selected variable as default. Clicking [OK] opensthe
[Memory] window.
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5.144 [Locals] Window
Thelocal variables and their values can be displayed in the [Locals] window.
Opening the [Locals] Window

To open the [Locals] window, choose [View->Symbol->Locals] or click the [Locals] toolbar button .

-1l =

i H'00ffefE0 { ERS } Iong]

-------- : H'000a { Fid } fint)
""" p_zam Ox00ffL0dS § ERE } [class Sample”)

Figure5.56 [Locals] Window

If alocal variableis not initialized when defined, then the value of the local variable will be incorrect until
another value is assigned to the local variable.

Thelocal variable values and the radix for local variable display can be modified in the same manner asin the
[Watch] window.
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515 Usingthe Event Points

The emulator has the event point function that performs breaking, tracing, and execution time measurement by
specifying higher-level conditions along with the PC breakpoints standard for the HEW.

5.15.1 PC Breakpoints
When the instruction of the specified address is fetched, the user program is stopped. Up to 256 points can be set.

Note that, however, only one PC breakpoint can be set in the ROM area of the user system. This particular
breakpoint is called the on-chip breakpoint, which stops the user program after executing the instruction of the
specified address.

When it is necessary to set two or more PC breakpoints to the external ROM area of the user system, allocate
this area to the emulation memory, copy the code, and then set the PC breakpoints.

5.15.2 Event Points

Event points can be used for higher-level conditions such as the data condition as well as specification of the
single address. Up to 12 event points can be set by using event channels and range channelsin the event
detection system.

When the condition is satisfied, event points are also used as the start/end conditions for execution time
measurement or trace acquisition in addition to halting the user program. Several event points can be used to set
more complex conditions.

Note: Event points acquire the data, test conditions, and execute an action (such as halting the user program)
by the hardware circuit of the emulator. Therefore, adelay of severa cycleswill occur from the
satisfaction of the condition to the execution of an action.

5.15.3 Event Detection System

In addition to the 4 range channels, the emulator also has 8 event channels. The event channels have more
functions (such as sequencing or counting) than the range channels.

Event Channels (Ch1to Ch8):

The emulator has 8 event channels. The event channel can be defined as a combination of one or more of the
followings:

e Anaddress or an address range

e QOutside of an addressrange

* A read, awrite, or either

»  Datawith amask specification

* Busstate

e Area

e Thevalue of four external probe signas

»  Thenumber of timesthe event has occurred

e Thenumber of delay cycles after the event has occurred

A maximum of eight points can be used as a combination in a sequence. The program is activated or halted by an
occurrence of the previous event in each sequence.
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Range Channels (Ch9 to Ch12):
The emulator has 4 range channels. The range channel can be defined as a combination of one or more of the
followings:

e Anaddress or an address range

e QOutside of an address range

* Aread, awrite, or either

«  Datawith amask specification

* Busdtate

* Area

e Thevalue of four external probe signas

e Thenumber of delay cycles after the event has occurred

5.154 Signalsto Indicate Bus Statesand Areas

In the event detection system, signals indicating the MCU'’ s bus states and the accessed areas can be specified as
the event detection condition.

These signals are output from the MCU on the emulator; the signals to be acquired will vary according to the
emulator in use.

The signals to indicate bus states and areas are used to set the [Bus/Area] condition of the event point. They can
also be acquired as the trace information.

The bus state signals are al'so used to set the condition not to acquire the trace ([Suppress] option) and in the
Access Count Of Specified Range Measurement mode for measuring the hardware performance ([Access Type]
option).

For the trace function, refer to section 5.16, Viewing the Trace Information. For the hardware performance
function, refer to section 5.20, Analyzing Performance.

The following tables show examples of signalsto indicate the bus states and areas that can be acquired by the
emulator.

Table5.1 Bus State Signals Acquired by the Emulator

Bus State Trace Display (Status) Description

CPU Prefetch PROG CPU prefetch cycles
CPU Data DATA CPU data access cycles
Refresh REFRESH Refresh cycles

DMAC DMAC DMAC cycles

DTC DTC DTC cycles

Other OTHER Others
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Table5.2 AreaSignals Acquired by the Emulator

Area Trace Display (Status) Description
On-chip ROM ROM ROM

On-chip RAM RAM RAM

On-chip 1/0O 16bit 1/0-16 16-bit 1/0

On-chip 1/O 8bit 1/10-8 8-bit I/0

External /0 16bit EXT-16 16-bit EXT (external)
External 1/0 8bit EXT-8 8-bit EXT (external)
DTC RAM RAM/DTC DTCRAM

Note: The signals to indicate the bus states and areas vary according to the emulator in use. For details, refer to
section 8, Software Specifications Specific to This Product, or the online help.

5.155 Opening the [Event] Window

Select [View -> Code -> Eventpoints] or click the [Eventpoints] toolbar button to open the [Event] window.

The [Event] window has the following three sheets:

[Breakpoint] sheet: Displays the settings made for PC breakpoints. It is also possible to set, modify, and
cancel PC breakpoints.

[Event] sheet: Displays or sets event points.

[Trigger] sheet: Displays or setstrigger points.

5.15.6  Setting PC Breakpoints

It is possible to display, modify, and add PC breakpoints on the [Breakpoint] sheet.

1ol x]
Type State Condition Action

Program Enable PC=H'O000105CiTutorial.cpp/dz) Break

Program Enable PC=H'OOOOlO0CETutorial.cpp/53) EBreak

Program Enable PC=H'OO001772 Break

s |
A [+ [, Breakpoint £ Event i Trigger f

Figure5.57 [Event] Window ([Breakpoint] Sheet)
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Select [Add...] or the PC breakpoint displayed in this window and then select [Edit...] from the popup menu to
display the [Breakpoint/Event Properties] dialog box.

Brealpoink/Event Properties 21|
General |
~Tupe Addrezs
€ Don'tCare ¢ Addiess € Bange
Address Lo [
£ Event = . |H00000000
Address H 00000000
[ Outside Fange
r Data Compare Direction—
[ Compare [T Lze bask " Head
Walue [
- IHD £ wite
% Bute £ wiod
Mask IH,D g ElthEl

ak I Cancel |

Figure5.58 [Breakpoint/Event Properties] Dialog Box (Setting a PC Break)
In this dialog box, select the address condition to set PC breakpoints.

[Typel: Select the type of a breakpoint. Note that the [Breakpoint/Event Properties] dialog box is used
for setting PC breakpoints and event points. Selecting a particular type of breakpoint enables
or disables other pages and parts of the dialog according to the options available to that type of
breakpoint.

[PC Break]: Only asingle address with a program fetch can be selected. Other options are invalid.

[Event]: Set conditionsin detail with other options on this page, or on the [Bus/Ared],
[Signalg], or [Action] page.

[Address]: Set address conditions.

[AdderessLo]: Select asingle address where a PC breakpoint will be set.
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5.15.7  Setting Event Points

On the [Event] sheet, the settings for event points are displayed, modified, and added.

ol
Ty¥pe dtate Condition I Action -
Chl (E) Enable Address=H'0000106&4 (Tutorial.cpp/37) address bus prefetch  Trace

Chz (E) Enahle Address=H'0O000107E (Tutorial.cpp/45) address bus prefetch  Trace

Ch3 (E) Enahle Address=H'00001040 (Tutorial.cpp/49) address area ROM Trace

Chd (E) Enable Address=H'00001140 address area ROM Trace

Chs (E) Enpty

Chiés (E) Eunpty

Ch7 (E) Enpty

Chi (E) Enpty

Ch9 (R) Eunpty

Chld(R) Enpty -
4| | 3|
4|+ ' Breakpoint p Event A Trigger f

Figure5.59 [Event] Window ([Event] Sheet)

Select [Add...] or the event point displayed in this window and then select [Edit...] from the popup menu to
display the [Breakpoint/Event Properties] dialog box.

The conditions for the event point are set on the [General], [Bus/Area], [Signas], and [Action] pages. The search
condition for the event point is set by multiple conditions set on these pages.

Notes: 1. Channel 8 hasthe trigger output function. When the condition on channel 8 is satisfied, the low-level
signal will be output from the external probe 1 (EXT1) for abus cycle.

2. When the event point is used as the condition for acquiring the trace information, select [Trace
Acquisition...] from the popup menu. For the trace function, refer to section 5.16, Viewing Trace
Information.

3. If acondition that is unavailable for arange channel is set in editing of the range channels (Ch9 to
Ch12), the selected channel is automatically replaced by an unused event channel (Chl to Ch8).

Table5.3 Conditions Unavailable for a Range Channel

Condition Related Options

Selecting outside the [Outside Range] on the [General] page
specified address range

Selecting the start or [Start Timer] and [Stop Timer] on the [Action] page
end of the execution
time measurement

Specifying the count [Required number of event occurrences] on the [Action] page
when an event occurs
(twice or more)

Specifying sequencing [Enable Sequencing] on the [Action] page
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(1) [General] page

The address and data conditions are set.

Ereakpaint/Event Properties 2 x|
General |Bus / twea | Signals | Action |
— Type Address
" PC Break " Don't Care © Addrezs ¢ Range
AddressLe |H 00000000
Address Hi [H 00000000
[T Outside Fange
— Data Compare Direction——
™ Compare = Wse Mask " Read
Walue [
- IHD € Write
¢ Bute & Word
Mask IH'D * Either
Ok, I Cancel |

Figure5.60 [Breakpoint/Event Properties] Dialog Box ([General] Page)

[Type]: Select the type of a breakpoint. Note that the [Breakpoint/Event Properties] dialog box is used
for setting PC breakpoints and event points. Selecting a particular type of breakpoint enables
or disables other pages and parts of the dialog according to the options available to that type of

breakpoint.

[PC Break]: Only asingle address with a program fetch can be selected. Other options are invalid.

[Event]: Set conditionsin detail with other options on this page, or on the [Bus/Ared],
[Signalg], or [Action] page.
[Address]: Sets the address condition.
[Don't care]: Sets no address condition.
[Address]: Allows asingle address to be selected.
[Range]: Allows an address range to be selected.

[AdderessLo]: Setasingle address or the start of an address range (available when [Address] or
[Range] has been selected).

[AdderessHi]:  Set the end of an address range (available when [Range] has been selected).

[Outside Range]: Used to negate the range (i.e., the event will occur when the addressis outside the
range). Thisis available when [Address] or [Range] has been selected.
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[Data Compare]: Sets the data condition.
[Compare]: Checking this box compares data.
[Use Mask]: Sets amask condition (available when [Compare] has been selected).

[Value]: Specifies the data bus value as numerics. The size of data for access can also be
selected (available when [Compare] has been selected).

[Byte]: Sets access in bytes as the condition (available when [Compare] has been selected).
[Word]: Sets access in words as the condition (available when [Compare] has been selected).
[Mask]: Sets avalue to be masked. Thisvalue will be ANDed with the value of the data bus

and data condition. The result will be used to compare data (available when [Use
Mask] has been sel ected).

[Direction]: Selects a condition with read or write cycles.

[Read]: Sets read cycles as the condition.

[Write]: Sets write cycles as the condition.

[Either]: Sets either read or write cycles as the condition.
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(2) [Bug/Area] page

Use this page to set the bus status and the memory area being accessed.

Breakpoint/Event Properties 2|
General Bus/Area | Signalsl Actionl
— Bus State —hrea
I~ CFU Frefetch = On-chip BOK
[T CRU Data [ On-chip Bat
[ Befiesh [™ | On-chip 40 16 bit
[T DHMAC [T Or-chip 14008 kit
[~ DIc [™ External 16 bit
™ Other = Esternal & bit
I~ DL Rk
¥ Don't Care
’TI Cancel |

Figure5.61 [Breakpoint/Event Properties] Dialog Box ([Bug/Area] Page)

[Bus State]: Sets the bus status as the condition. When the [Don't care] check box is checked, the event will
be satisfied with any bus status.
[Area]: Specifies the area for searching. When the [Don't care] check box is checked, the event will be

satisfied in any area.

Note: Items set for the bus state and memory access area vary according to the emulator in use. For details,
refer to section 5.15.4, Signalsto Indicate Bus States and Areas.
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(3) [Signals] page

Use this page to set external signals.

Breakpoint/Event Froperties 2 x|

General I Bus /évea  Signals |.t’-‘n.cti0n|

— Probe 4 — Probe 3
" High " High
 Low  Low
i (¢ Don't Care
~Probe 2 —Probe 1
" High " High
 Low  Low
& Don't Care & Don't Care

Ok, I Cancel |

Figure5.62 [Breakpoint/Event Properties] Dialog Box ([Signals] Page)

[Probed]: Detects the status of the input probe signal 4
[High]: Detects the high level of the input probe signal
[Low]: Detectsthe low level of the input probe signal

[Don't care]: The status of the input probe signal is not detected

[Probe3]: Detects the status of the input probe signal 3
[High]: Detects the high level of the input probe signal
[Low]: Detectsthe low level of the input probe signal

[Don't care]: The status of the input probe signal is not detected

[Probe2]: Detects the status of the input probe signal 2
[High]: Detects the high level of the input probe signal
[Low]: Detectsthe low level of the input probe signal

[Don't care]: The status of the input probe signal is not detected
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[Probel]: Detects the status of the input probe signal 1
[High]: Detects the high level of the input probe signal
[Low]: Detectsthe low level of the input probe signal

[Don't care]: The status of the input probe signal is not detected

(4) [Action] page

Use this page to decide what action the emulator takes when the defined event occurs.

Breakpoink/Event Properties 2 x|

General | Bus / &rea | Signaks  Action

Actions
~ &

[ élarlTimer
[ Stop Tirmer

Delay after detection before break occurs
oo

bus cycles

Required number of event ocourences
|01

[~ Enable Sequencing |

Ok, | Cancel

Figure5.63 [Breakpoint/Event Properties] Dialog Box ([Action] Page)

[Action]: Selects an action that occurs when the event is satisfied. This cannot be used for an
event point being used as the trace acquisition condition.
[Break]: Causes abreak (stop) in the user program when the event occurs. Thisis the
default action.
[Start Timer]: Starts the run timer (the run timer value is displayed in the [Status] window).
[Stop Timer]: Stops the run timer (the run timer value is displayed in the [Status] window).

[Delay after detection before break occurs):
Sets a 16-bit delay (in bus cycles) after the event has occurred before the action is
taken. The delay is only applicable to break events and thereis only one delay counter
in hardware, therefore only one breakpoint can have a non-zero delay. The range of
valuesis D’0to D’65,535 (only available when [Break] has been selected). This
cannot be used for an event point being used as the trace acquisition condition.
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[Required number of event occurrences):
Allows a 16-hit pass count to be set. The event must occur the specified number of
times before the action istaken. The range of valuesis D’0 to D’65,535.

[Enable Sequencing]: Allows the event to take part in a sequence of events (setting this requires the event to
use an event detector).

[Configure Sequence...]: Displays the [Event Sequencing] dialog box to allow the event sequencing to be
configured (only available when [Enable Sequencing] has been selected).

(5) [Event Sequencing] dialog box

This diaog box alows the user to define which events are triggered by other events. If thisdialog box is
accessed (directly or indirectly) from [Trace Acquisition...], only those events assigned to the trace subsystem
are displayed. If accessed from the [Eventpoint] window, only the breakpoint or timer events are shown.

Event Sequencing

Event

" |3 Beset By The fallowing events: Cahicel |

%' |3 Armed By [~ Mo occurence of

[ 1 [E]H1038 address

[~ 2 [EJH105C address count D10
[~ 3[EJH10FE address count D'2
™ 4 [E]H10FC address

™| undefined arunavaiable

™| undefined arunavaiable

™| undefined arunavaiable

™| undefined or unayailatble

O

Figure5.64 [Event Sequencing] Dialog Box

[Event]: Selects an event point to be set.

[Is Armed By]: Arms the selected event.

[Is Reset By]: Resets the selected event.

[No occurrence of]: Arms an event when the set of events being selected does not occur (only available

when [Is Armed By] has been selected).

The test of conditions on event pointsis started with the execution of the user program. The conditions on event
points have not been satisfied immediately after the execution of the user program is started.

Satisfaction of the condition on an event point allows a transition of the state to that where the conditionis
satisfied.
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The state where the condition is satisfied is retained until the user program is stopped or the event point is reset.

When the condition on the event point is satisfied, no action will be taken even if the condition is satisfied again.
If you want the action to be taken again, reset the event point so that the state transits to that where no condition
is satisfied.

When the user program is stopped, the states of al the event pointstrangit to that where no condition is satisfied.

When an event point must be in the state where its condition is satisfied or not (when [No occurrence of] is
selected) as the satisfaction condition of another event point, this event point is called the arm event.

An event point can reset the tested states of conditions of other event points or itself by satisfying the condition.
Thisevent point is called areset event.

A reset event resets event points regardless of their states where the condition is satisfied or not (e.g., resetting
the pass count).

Select an event point from the [Event] combo box. To set an arm event on the selected event point, select [Is
Armed By] and check the box corresponding to each event. The [No occurrence of] check box isused to set a
condition that the arm event isin the state where its condition is not satisfied.

To set areset event on the selected event point, select [Is Reset By] and check the box corresponding to each
event.

At the bottom of the screen is a diagram showing the current sequencing of the events (figure 5.64). The Sinput
sets (arms) an event and the R input resetsit. The legend ~S indicates the event is set (armed) by the non-
occurrence of the input events.

Figure 5.64 is an example that Chl isthe arm event for Ch2, Ch3, and Ch4. Ch3 isthe arm event for Ch4. Ch2
and Ch4 are the reset events for Chl and Ch2, respectively.

To satisfy the condition of the event point having an arm event, the arm event must be in the state where the
condition is satisfied or not (when [No occurrence of] is selected). When multiple arm events exist on one event
point, one of the arm events must be in the state where the condition is satisfied or not (when [No occurrence of]
selected) to satisfy the condition of the event point.

As the condition of the arm event on one event point, either of the states where the condition is satisfied or not
should be set.

To reset an event point with areset event, the condition of the reset event must be satisfied. While the condition
of thereset point is satisfied, no event point is reset even if the condition of the reset event is satisfied again.

When multiple reset events exist on one event point, the event point is reset when the condition of one of reset
eventsis satisfied.
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5.15.8  Setting Trigger Points

Thetrigger point is an event to output a trigger when the specified address has been accessed. Up to four trigger
points can be set by using the trigger outputs (four channels) on the bus monitoring circuit of the emulator.

The settings of the trigger point are displayed and modified on the [Trigger] sheet.

_{o)x]
Type I state I Condition | Action

[EXT.Z-1 Enahle Address=H'O0FFDEEQO Trigger ocutput

[ExT.2-2 Enahle Address=H'O0FFD404 Trigyger ocutput

[ExT.2-3 Enahle Address=H'00001140 Trigger output

[EXT.Z-4 Enahle Address=H'O0FFEFSC Trigger ocutput

| | I
A | k% Breakpoint 4 Event 4 Trigger

Figure5.65 [Event] Window ([Trigger] Sheet)

Selecting [Add...] or the event point and [Edit...] from the popup menu in this window displays the [Set Address
For Trigger] dialog box.

Set Address For Trigger

Address

¥ Trigger: IH'DDFFDEED Carcel |

¥ Trigger: IH'DDFFD4D4

v TriggerZ: IH'DDDD‘I 140

I¥ Triggers: [Ho0FFEFaC

Figure5.66 [Set AddressFor Trigger] Dialog Box

This dialog box allows the user to specify the address to be accessed as the trigger output condition during the
user program execution. Enable or disable the trigger output point by checking the check box on the left in the
screen.

[Triggerl]: Enables the output of trigger channel 1.
[Trigger2]: Enables the output of trigger channel 2.
[Trigger3]: Enables the output of trigger channel 3.
[Triggerd]: Enables the output of trigger channel 4.
[Address]: Sets the address condition of the channel.
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Notes: 1. When the condition set for the trigger output (1 to 4) is satisfied, the high-level signal will be output
from the corresponding pin (1 to 4) of the external probe 2 (EXT2) during reading or writing.

2. Some emulators may not support the trigger point. For details, refer to section 8, Software
Specifications Specific to This Product, or the online help.

5.15.9 Editing Event Points

Handlings for settings other than PC breakpoints, event points, and trigger points are common. The following
describes examples of such handling.

5.15.10 Modifying Event Points

Select an event point to be modified, and choose [Edit...] from the popup menu to open the dialog box that
corresponds the event, which alows the user to modify the event conditions. The [Edit...] menuisonly available
when one event point is selected.

5.15.11 Enabling an Event Point

Select an event point and choose [Enable] from the popup menu to enable the selected event point.

5.15.12 Disabling an Event Paint

Select an event point and choose [Disable] from the popup menu to disable the selected event point. When an
event point is disabled, the event point will remain in the list, but an event will not occur when the specified
conditions have been satisfied.

5.15.13 Deleting an Event Point

Select an event point and choose [Delete] from the popup menu to remove the selected event point. To retain the
event point but not have it cause an event when its conditions are met, use the [Disable] option (see section
5.15.12, Disabling an Event Point).

Note: No trigger point can be deleted. Use the [Disable] option to clear the settings.

5.15.14 Deleting All Event Points
Choose [Delete All] from the popup menu to remove all event points.

Note: No trigger point can be deleted. If [Delete All] is selected, the settings of all channels become disabled.

5.15.15 Viewing the SourceLinefor an Event Point

Select an event point and choose [Go to Source] from the popup menu to open the [Source] or [Disassembly]
window at address of event point. The [Go to Source] menu is only available when one event point that has the
corresponding source file is selected.
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516  Viewingthe Trace Information

The emulator acquires the results of each instruction execution into the trace buffer as trace information and
displaysit in the [Trace] window. The conditions for the trace information acquisition can be specified in the
[Trace Acquisition] dialog box.

Since trace information in bus-cyclesis acquired by the hardware circuit and stored in the trace buffer, the
realtime operation is retained. The [Trace] window displays the content of the trace buffer, which records up to
32,768 bus cycles from the last program run and is aways updated.

5.16.1 Openingthe[Trace] Window

To open the [Trace] window, choose [View -> Code -> Trace] or click the [Trace] toolbar button .

5.16.2 Acquiring Trace Information

When the emulator does not set the acquisition condition of the trace information, all bus cycles are acquired by
default without any condition (free trace mode).

In the free trace mode, trace acquisition is started with the execution of the user program and stopped by halting
the user program. The acquired trace information is displayed in the [ Trace] window.

33 | Instruction Data | R/U | Area Status | Clock | Probes | NMT | TRQ7-0 | Time... Source Label i‘

100400 #H'00FFEFCO ER7 07 1 1 11111111
-055658 000402 00ff  RD ROM PROG 1 1111 1 11111111
-05567 000404 efcd RD ROM PROG 1 1111 1 11111111
-05566 000406 MOV. L ERG,B-ER7 0l00 ED RO PROG 1 1111 1 11111111
-05565 000408 6df6  ERD RO PROG 1 1111 1 11111111
-05564 00040a  MOV.L ER7,ERE 0ff& RD RO PROG 1 1111 1 11111111
-05563 ffefbe 00ff WR  RAM/DTC DATA 1 1111 1 11111111
-05562 ffefbe efbd WR  RAM/DTC DATA 1 1111 1 11111111
-05561 00040¢ ORC.EB #H'80,CCR 0480 ED RO PROG 1 1111 1 11111111 set_imas,
—05560 00040e JER B__INITSCT:Z24 5e00 RD RO PROG 1 1111 1 11111111 _INITSCT(
-05559 000410 1llc2 RD ROM PROG 1 1111 1 11111111
-05558 0011cZ MOV. W RZ,B-ER7 6dfZ  RD ROM PROG 1 1111 1 11111111 __INITSCT
-05557 £fefbi 0000 WE  RAM/DTC DATA 1 1111 1 11111111
-05556 £fefba 0412 WR  RAM/DTC DATA 1 1111 1 11111111
-05555 0011c4 ETM.L (ER4-ERE) ,B-5P 0120 RD ROM PROG 1 1111 1 11111111
-05554 ffefba aon0 WR - RAM/DTC DATA 1 1111 1 11111111 j
Figure5.67 [Trace] Window
Thiswindow displays the following trace information items:
[PTR]: Cycle number in the trace buffer. When the most recent record is record O, earlier record

numbers go backwards (-1, -2, ...). If adelay count has been set, the cycle number where the
trace stop condition has been satisfied is record 0. For the cycle (during delay) executed until
the trace has stopped, earlier record numbers go forward (+1, +2, ...) the most recent record.

[Address]: Address (6-digit hexadecimal)

[Instruction]: Disassembled code of the executed instruction

[Data]: Data bus value, displayed as 2-digit or 4-digit hexadecimal

[RIW]: Whether access was read (RD) or write (WR)

[Area]: Memory area being accessed; ROM, RAM, 8- or 16-hit I/O, 8- or 16-bit EXT (external), or

DTC RAM (not available when atime stamp is acquired)
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[Status]:

[Clock]:

[Probes]:

[NMI]:
[IRQ7-0]:

[Timestamp]:

[Source]:

[Label]:

Bus status during this cycle; DTC operation, PROG (prefetch), Data (CPU data access cycle),
Refresh (refresh cycle), or DMAC (DMAC cycle) (not available when atime stamp is
acquired)

Number of clock cyclesin buscycleas 1 to 8. To indicate more clock cycles, “OVR" is
displayed (not available when atime stamp is acquired).

A 4-bit binary number showing the four probe pinsin the order of Probe 4, Probe 3, Probe 2,
and Probe 1 from the left (not available when atime stamp is acquired).

Status of the NMI input (not available when atime stamp is acquired)
Status of eight IRQ inputs (not available when atime stamp is acquired)

Time stamp of the record. Time stamps start from zero each time the user program is executed.
The timer resol ution depends on the time stamp clock rate selected in the trace acquisition
(only available when atime stamp is acquired).

Source program

Label information that corresponds to the address (if defined)

Note: Itemsother than [PTR], [Address], [Instruction], [Data], [R/W], [Area], [Status], [Probes], [Timestamp],
[Source], and [Label] vary according to the emulator in use. For details, refer to section 8, Software
Specifications Specific to This Product, or the online help.

It is possible to hide any column not necessary in the [Trace] window. Selecting a column you want to hide from
the popup menu displayed by clicking the right-hand mouse button on the header column hides that column. To
display the hidden column, select the column from the said popup menu again.
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5.16.3  Specifying Trace Acquisition Conditions

The capacity of the trace buffer islimited. When the buffer becomes full, the oldest trace information is
overwritten. Setting the trace acquisition condition allows acquisition of useful trace information and effective
use of the trace buffer. The condition is enabled by the event point to control starting, stopping, and ending the
trace acquisition. For event points, refer to section 5.15, Using the Event Points.

The trace acquisition condition is set in the [Trace Acquisition] dialog box that is displayed by selecting
[Acquisition...] from the popup menu.

The [Trace Acquisition] dialog box has the following pages:

Table5.4 [TraceAcquistion] Dialog Box Pages

Page Item

[General] Sets trace acquisition conditions.

[Stop] Sets trace stop conditions (without a delay).

[Delayed Stop] Sets trace stop conditions (with a delay).

[1] to [4] Sets the range trace (only available when the free trace mode is
disabled).

(1) [General] page

Sets trace acquisition conditions.

Trace Acquisition ﬂll
Geneal |Stop | DelayedStop] 1 |2 |3 |4 ]
~Suppresz—————— Time Stamp
™ Free Trace

Cliock:

[ DIC Cycles IDisabIed vI

[ Eefresh Cpcles

— Trace Events
Event:
[10(R)H1092 address |
Add. | Ed. Sequence.. Delete |  Delan |

QK. I Cancel |

Figure5.68 [Trace Acquisition] Dialog Box ([General] Page)
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[Suppress): Acquires no trace information of the specified types of bus cycle.

[Time Stamp]:  Setsacondition for time stamping.

[Clock]:

Select either from Disabled, 125 ns, 250 ns, 500 ns, 1 us, 2 us, 4 us, 8 us, 16 us, or
100 us as the resolution for time stamping. A time stamp has a 32-bit counter. At 125
ns the maximum time that can be measured is about 9 minutes, and at 100 ps the
maximum time is about 5 days.

When the counter overflows, its content will be cleared to continue counting. No time
stamp information will be acquired when Disabled is selected.

[Free Trace]: Checking this box enables the free trace mode.

When the free trace mode is enabled: Starts acquiring the dataimmediately after program
execution has been started. Only the trace halt condition is available. Therangetraceis
unavailable and four range-trace pages (1 to 4) become disabled.

When the free trace mode is disabled: Setsthe start and halt conditions of trace acquisition.

[Trace Events]: Setsevent pointsto be used as trace acquisition conditions.

[Event]:
[Add...]:
[Edit...]:

[Sequence...]:

[Delete]:

[Del All]:

Liststhe event points to be used as trace acquisition conditions.
Adds anew event point.
Changes the setting for the selected event point.

Configures an event sequence for the event point being used as a trace acquisition
condition. To set up the sequence, an event must have been set.

Deletes the selected event point.

Deletes all event points.

Notes: 1. The bus cyclesthat can be specified by the [Suppress] option vary according to the emulator in use.
For details, refer to section 5.15.4, Signals to Indicate Bus States and Areas.
2. Thetrace buffer is used for the time stamp information and some of the trace information. Therefore,
when the time stamp is acquired, it isimpossible to acquire the trace information other than PTR,
Address, Instruction, Data, R/'W, Source, Label, and Timestamp.
3. If an event that is used for the range trace or trace stop function is deleted, that function becomes

disabled.
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(2) [Stop] page

Setstrace stop conditions. It is possible to set trace stop conditions with and without delay, with both allowed

simultaneoudly.

Trace Acquisition

General Stop | Delayed Stopl 1

— Stop Withaut Delay

— Events
[T undefined ar unavailable

[T undefined ar unavailable
[T undefined ar unavailable
[T undefined ar unavailable
[T undefined or unavailable
[T undefined or unavailable
[~ 7[EJH107E address
[ 8(E]H1084 address
[T undefined or unavailable
W 10[R]H'1092 address
[T undefined or unavailable
[T undefined or unavailable

o |

Cahicel |

[Stop Without Delay]: Defines atrace stop condition.
[Enable]:
[Events]:
selected).
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Figure5.69 [Trace Acquisition] Dialog Box ([Stop] Page)

Checking this box enables atrace stop.

Liststhe event points where trace acquisition conditions have been set. If the
box that corresponds to an event point is checked, trace acquisition will be
stopped when that event is satisfied (only available when [Enable] has been
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(3) [Delayed Stop] page

Setstrace stop conditions. It is possible to set trace stop conditions with and without delay, with both allowed
simultaneoudly.

Trace Acquisition ﬂﬂ

General I Stop  Delaped Stop |1 I 2 I 3 I 4 I

— Stop with Delay

Delay Count ID"I

— Events
I™ 1 [E]H'D address

I= 2 [E]HD address

= 3 (E]HD address

= 4 [E]HD address

[T B(E]HD address

[T EB(E]HD address

[~ 7 [EJH107E address
[ 8(E]H1084 address
[T undefined or unavailable
[T undefined or unavailable
[T undefined or unavailable

[T undefined or unavailable

ak. I Cahicel |

Figure5.70 [Trace Acquisition] Dialog Box ([Delayed Stop] Page)

[Stop With Delay]: Defines atrace stop condition.

[Enable]: Checking this box enables atrace stop.

[Delay Count]: Setsthe delay count (in bus cycles, range 1 to 65535). This function alows
you to acquire anumber of trace records after any of the specified events
occur.

[Events]: Liststhe event points where trace acquisition conditions have been set. If the

box that corresponds to an event point is checked, trace acquisition will be
stopped when that event is satisfied (only available when [Enable] has been
selected).
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(4) [1] to [4] pages

Setsarange trace. Thisisonly available when the free trace mode is disabled. Select either of the following four
modes: [Disabled], [Point to Point], [Range], and [Event].

* Disabled

Disables arange trace.

Trace Acquisition e

General I Stop I Delayed Stop 1 |2 I 3 I 4 I

— Conditions

* Dizahled € Paint to Point " Range € Ewent

Figure5.71 Range Trace Setting (Disabled)
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¢ Point to Point

Acquires trace information in the specified range.

Trace Acquisition ﬂﬂ

Gerneral I Stop I Delayed Stop 1 |2 I 3 I 4 I
— Conditions

" Disabled & Puint to Point " Range " Ewent

Start Addrezs

H'0000107E

Stop Address

|H'DDDD‘I 084,

¥ Cyclic

Cahicel
Figure5.72 Range Trace Setting (Point to Point)
[Start Address]:  Address where trace acquisition starts
[Stop Address]:  Address where trace acquisition stops
[Cydlic]: When this box is checked, the event sequencing is configured so that the events reset

themsel ves which causes tracing to be restarted when the start event occurs after the stop event.

Sets the event points that are required to start or stop trace acquisition when the start or end address is accessed,
respectively.

Point to Point mode is an easy method to set up the event mode. The event to start or sop trace acquisition isan
access to asingle address.

Select [Cyclic] to continue acquisition of the trace information only in the specified address range.

Note: Thisfunction automatically configures a sequence of event points. Note, however, that an unexpected
result may arise. In such cases, modify the setting of the sequence in the [Event Sequencing] dia og box.
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* Range

Only acquires the trace information that satisfies the specified condition.

Trace Acquisition 71 x|
Gerneral I Stop I Delayed Stop 1 |2 I 3 I 4 I
— Conditions

" Disabled " Puint to Point & Range " Ewent

Range Event Edi... |

|7 [EYH'107E address =l

Cahicel

Figure5.73 Range Trace Setting (Range)

[Range Event]:  Selects an event point for which atrace acquisition condition has been set.
[Edit...]: Changes the setting for the selected event point.

Only acquires trace information from all bus cycles that matches the condition set in the selected event. This
mode uses one event channel or range channel.

252
RENESAS




e Event

Acquires trace information, controlling the start and end of trace acquisition with the specified condition.

Trace Acquisition 71 x|
Gerneral I Stop I Delayed Stop 1 |2 I 3 I 4 I
— Conditions

" Disabled " Puint to Point " Range & Event

[

|7 [EYH'107E address

Start Event Edit... |
_ e |

Staop Event Edi...

|2 [E)H'108& address =l

¥ Cyclic

Cahicel

Figure5.74 Range Trace Setting (Event)

[Start Event]: Selects the event point for which the condition to start trace acquisition has been set.

[Stop Event]: Selects the event point for which the condition to stop trace acquisition has been set.
[Edit...]: Changes the setting for the selected event point.
[Cyclic]: When thisbox is checked, the event sequencing is configured so that the events reset

themsel ves which causes tracing to be restarted when the start event occurs after the stop event.

Starts and stops trace acquisition when the conditions for starting and ending are satisfied, respectively. Selecting
[Cyclic] alows a continuous acquisition of trace information that can be acquired with the specified condition.
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5.16.4  Searching for a Trace Record

Use the [Trace Find] dialog box to search for atrace record. To open this dialog box, choose [Find...] from the
popup menu.

The [Trace Find] dialog box has the following options:

Table5.5 [TraceFind] Dialog Box Pages

Page Description

[General] Sets the range for searching.

[Address] Sets an address condition.

[Data] Sets a data condition.

[R/W] Selects the type of access cycles.

[Area] Selects the area being accessed (not available when a time stamp is
acquired).

[Status] Selects the status of a bus (not available when a time stamp is acquired).

[Probes] Selects the status of four probe signals (not available when a time stamp
is acquired).

[IRQ7-0] Selects the status of eight probe input signals (not available when a time

stamp is acquired).

[Timestamp] Specify the time stamp value for bus cycles (only available when a time
stamp is acquired).
Note: Items other than [General], [Address], [Data], [R/W], [Area], [Status], [Probes], and [Timestamp] vary
according to the emulator in use. For details, refer to section 8, Software Specifications Specific to This
Product or the online help.

Clicking the [OK] button after setting conditions in those pages stores the settings and starts searching. Clicking
the [Cancel] button closes this dialog box without setting of conditions.

When atrace record that matches the search conditionsis found, the line for the trace record will be highlighted.
When no matching trace record is found, a message dialog box will appear.

Only the trace information that satisfies all the conditions set in above pages will be searched.

If afind operation is successful, selecting [Find Next] from the popup menu will move to the next found item.
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(1) [General] page
Set the range for searching.

x

Status I Frobes I IRQ7-0
General | Address I Data I R I Area
Trace search rangs
N ri [ Upward search
Start PTR : |-32767
EndFTR: ID

0k I Cancel | Apply |

Figure5.75 [TraceFind] Dialog Box ([General] Page)
[Trace search range]: Sets the range for searching.

[Not designation]: Searches for information that does not match the conditions set in other
pages when this box is checked.

[Upward search]: Searches upwards when this box is checked.
[Start PTR]: Enters a PTR vaue to start asearch.
[End PTR]: Enters a PTR value to end a search.

Note:  Along with setting the range for searching, PTR values to start and end searching can be set in the [Start
PTR] and [End PTR] options, respectively.
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(2) [Address] page
Set an address condition.

x
Status | Prabes I IRGT-0
General Address | Data I R I Area

Setting
’7Ealue 2 IH'FFEFBD

0k I Cancel | Apply |

Figure5.76 [TraceFind] Dialog Box ([Address] Page)
[Don't care]: Detects no address when this box is checked.
[Setting]: Detects the specified address.

[Value]: Enter the address vaue (not available when [Don’t care] has been checked).
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(3) [Data] page

Set adata condition.
x
Status I Frobes I IRQ7-0
General I Address Data | R I Area

Setting
(Ealue : |H'DDDD

0k I Cancel | Apply |

Figure5.77 [Trace Find] Dialog Box ([Data] Page)
[Don't care]: Detects no data when this box is checked.
[Setting]: Detects the specified data.

[Value]: Enter the data value (not available when [Don't care] has been checked).
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(4) [RIW] page
Select the type of access cycles.

x

Status I Prabes | IRGT-0
General I Address I Data R | Area
I Dont care
Setting
Strirg : I RD j

0k I Cancel | Apply |

Figure5.78 [Trace Find] Dialog Box ([R/W] Page)

[Don't care]: Detects no read/write condition when this box is checked.
[Setting]: Detects the specified read/write condition.
[String]: Select a read/write condition (not available when [Don't care] has been checked).
RD: Read cycle
WR: Write cycle
258
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(5) [Area] page
Select the area being accessed. The selection is not available when atime stamp is acquired.

x

Status I Prabes I IRGT-0 |
General I Address I Data I R Area
I Dont care
Setting
String : I ROM j

0k I Cancel | Apply |

Figure5.79 [TraceFind] Dialog Box ([Area] Page)

[Don't care]: Detects no area condition when this box is checked.
[Setting]: Detects the specified area condition.
[String]: Select an area condition (not available when [Don't care] has been checked).

Note: Available areas vary according to the emulator in use. For details, refer to section 5.15.4, Signalsto
Indicate Bus States and Areas.
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(6) [Status] page
Select the status of a bus. The selection is not available when atime stamp is acquired.

x

Gerneral | Address I Data I R M I Area
Stas | Probes | IRG70
I Dont care
Setting
String : I PROG j

0k I Cancel | Apply |

Figure5.80 [TraceFind] Dialog Box ([Status] Page)

[Don't care]: Detects no bus condition when this box is checked.
[Setting]: Detects the specified bus condition.
[String]: Select abus condition (not available when [Don’t care] has been checked).

Note: Available bus conditions vary according to the emulator in use. For details, refer to section 5.15.4,
Signals to Indicate Bus States and Aress.
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(7) [Probes] page
Select the status of four probe signals. The selection is not available when atime stamp is acquired.

x

Gerneral I Addressz | Data | R M I Area
Status Probes | IRGF-0

— Setting

Probed IDnn'l care'l Probe3 IDon'l care'l
Probe2 IDon'l care 'I Prabel IDnn't cale'l

0k I Cancel | Apply |

Figure5.81 [TraceFind] Dialog Box ([Probes] Page)
[Don't care]: Detects no probe signal condition when this box is checked.
[Setting]: Detects the specified probe signal condition.
[Probed] to [Probel]: Select probe conditions (not available when [Don't care] has been checked).
Don't care: Detects no selected probe condition.
High: The status of the probe signal is high.

Low: The status of the probe signal islow.
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(8) [IRQ7-0] page

Select the status of IRQ signals. The selection is not available when atime stamp is acquired.

Trace Filter x|
Gerneral I Addressz I Data R M | Area |
Status I Frobes IRE7-0
IRE7 IDon't care "I IRQE Daon't care ™
IRQ5 IDon't care "I IRO4 IDDn't care 'I
IRQ3 IDnn'l care 'I IRE2 IDDn't care 'I
IR IDnn'l care 'I [=Twli] IDon't care "I
QK I Cancel | Apply |

Figure5.82 [Trace Find] Dialog Box ([IRQ7-0] Page)

[Don't care]: Detects no IRQ input condition when this box is checked.
[Setting]: Detects the specified IRQ input condition.
[IRQ7] to [IRQQ]: Select IRQ input conditions (not available when [Don't care] has been
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checked).
Don't care: Detects no selected IRQ input condition.
High: The status of the IRQ input is high.

Low: The status of the IRQ input islow.
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(9) [Timestamp] page
Specify the time stamp value for bus cycles. The specification is not available when atime stamp is acquired.

x
Generall .t’-‘n.ddlessl Data I Ry Timestamp |

0k I Cancel | Apply |

Figure5.83 [TraceFind] Dialog Box ([Timestamp] Page)

[Don't care]: Detects no time stamp value when this box is checked.
[Setting]: Detects the specified time stamp value. (Every field must be filled in.)
[Value]: Enter the time stamp value.

Theformat is as follows:
hour: h, minute: min, second: s, millisecond: ms, microsecond: us, nanosecond: ns

(Not available when [Don't care] has been checked.)

5.16.5 Clearingthe Tracelnformation

Select [Clear] from the popup menu to empty the trace buffer that stores the trace information. If severa [Trace]
windows are open, al [Trace] windows will be cleared as they all access the same buffer.

5.16.6  Savingthe Trace Information in aFile

Select [Save...] from the popup menu to open the [Save Ag] file dialog box, which allows the user to save the
information displayed in the [Trace] window as atext file. A range can be specified based on the [PTR] number
(saving the complete buffer may take several minutes). Note that this file cannot be reloaded into the [Trace]
window.

Note: In filtering of trace information, the range to be saved cannot be selected. All the trace information
displayed in the [Trace] window after filtering will be saved. Select afiltering range on the [General]
page in the [Trace Filter] dialog box if you want to save the selected range. For details on the filtering
function, refer to section 5.16.12, Extracting Records from the Acquired Information.
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5.16.7 Viewing the [Source] Window
The [Source] window corresponding to the selected trace record can be displayed in the following two ways:

» Select atrace record and choose [View Source] from the popup menu.
» Double-click atrace record

The [Source] or [Disassembly] window opens and the selected line is marked with a cursor.

5.16.8 Trimming the Source
Choose [Trim Source] from the popup menu to remove the white space from the | eft side of the source.

When the white space is removed, a check mark is shown to the left of the [Trim Source] menu. To restore the
white space, choose [Trim Source] while the check mark is shown.

5.16.9  Acquiring a Snapshot of the Trace Information

A snapshot can be acquired when you need to check the trace information during execution of the user program.
Thisisuseful for checking time stamping or probe input signals. To acquire a snapshot of trace information,
select [Snapshot] from the popup menu. Trace acquisition istemporarily stopped to display arecord of the latest
trace information, and then restarted. A snapshot of trace information is only acquired during execution of the
user program.

5.16.10 Temporarily Stopping Trace Acquisition

To temporarily stop trace acquisition during execution of the user program, select [Halt] from the popup menu.
This stops trace acquisition and updates the trace display. Use this method to check the trace information without
stopping execution of the user program.

5.16.11 Restarting Trace Acquisition

To restart trace acquisition being stopped during execution of the user program, select [Restart] from the popup
menu.
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5.16.12 Extracting Recordsfrom the Acquired I nformation

Use thefiltering function to extract the records you need from the acquired trace information. The filtering
function allows the trace information acquired by hardware to be filtered by software. Unlike the settings made
inthe [Trace Acquisition] dialog box for acquiring trace information by conditions, changing the settings for
filtering severa timesto filter the acquired trace information allows easy extraction of necessary information,
whichisuseful for analysis of data. The content of the trace buffer will not be changed even when the filtering
function is used. Acquiring useful information as much as possible by the [Trace Acquisition] settingsimproves
the efficiency in analysis of data because the capacity of the trace buffer islimited.

Use thefiltering function in the [ Trace Filter] dialog box. To open the [Trace Filter] dialog box, select [Filter...]
from the popup menu.

The [Trace Filter] dialog box has the following pages:

Table5.6 [TraceFilter] Dialog Box Pages

Page Description

[General] Selects the range for filtering.

[Address] Sets address conditions.

[Data] Sets data conditions.

[R/W] Selects the type of access cycles.

[Area] Selects the area being accessed (not available when a time stamp is
acquired).

[Status] Sets the status of a bus (not available when a time stamp is acquired).

[Probes] Selects the states of four probe signals (not available when a time stamp
is acquired).

[IRQ7-0] Selects the states of eight IRQ input signals (not available when a time

stamp is acquired).

[Timestamp] Specifies the time stamp value for bus cycles (only available when a time
stamp is acquired).
Note: Items other than [General], [Address], [Data], [R/W], [Area], [Status], [Probes], and [Timestamp] vary
according to the emulator in use. For details, refer to section 8, Software Specifications Specific to This
Product or the online help.

Set filtering conditions and then press the [OK] button. This starts filtering according to the conditions. Clicking
the [Cancel] button closes the [Trace Filter] dialog box, which holds the settings at the time when the dialog box
was opened.

In filtering, only the trace information that satisfies one or more filtering conditions set in the above pages will
be displayed in the [ Trace] window.

Filtering conditions can be changed several times to analyze data because the content of the trace buffer is not
changed by filtering.
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(1) [General] page
Set the range for filtering.

Trace Filter x|
Status I Frobes I IRQ7-0

General | Addiess | Data | Rew | fea

I i [ Enabls Filter

™ Mot designation
Trace display range
Start PTH: I

End FTR :

QK I Cancel | Apply |

Figure5.84 [TraceFilter] Dialog Box ([General] Page)

[Don't care other pages]: Only selects the cycle number when this box is checked. Other options become

invaid.

[Enable Filter]: Enables the filter when this box is checked.

[No]: Filters information that does not match the conditions set in those pages when this
box is checked.

[Trace display range]: Sets the range for filtering.
[Start PTR]: Enters a PTR value to start filtering.
[End PTR]: Entersa PTR value to end filtering.

Note:  Along with setting the range for filtering, PTR valuesto start and end filtering can be set in the [Start
PTR] and [End PTR] options, respectively.
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(2) [Address] page
Set address conditions.

Trace Filter x|

Status | Prabes I IRGT-0
General Address | Data I R I Area
[ Don't care

Setting
& Point © Bange

From ; IH'

To: I

QK I Cancel | Apply

Figure5.85 [TraceFilter] Dialog Box ([Address] Page)

[Don't care]: Detects no address when this box is checked.
[Setting]: Detects the specified address.
[Point]: Specifies asingle address (not available when [Don’t care] has been checked).
[Range]: Specifies an address range (not available when [Don't care] has been checked).
[From]: Enter asingle address or the start of the address range (not available when [Don’t
care] has been checked).
[To]: Enter asingle address or the end of the address range (only available when [Range]

has been selected).

Note:  Along with setting the address range, the start and end of the address range can be set in the [From] and

[To] options, respectively.
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(3) [Data] page
Set adata condition.

Trace Filter x|
Status I Frobes I IRQ7-0

General I Address Data | R I Area

Setting
& Point © Bange

From ; IH'

To: I

QK I Cancel | Apply |

Figure5.86 [TraceFilter] Dialog Box ([Data] Page)

[Don't carel: Detects no data when this box is checked.

[Setting]: Detects the specified data.
[Point]: Specifies single data (not available when [Don't care] has been checked).
[Range]: Specifies adata range (not available when [Don't care] has been checked).
[From]: Enter single data or the minimum value of the data range (not available when [Don’t

care] has been checked).

[To]: Enter the maximum value of the datarange (only available when [Range] has been
selected).

Note:  Along with setting the data range, the minimum and maximum vaues can be set in the [From] and [To]
options, respectively.
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(4) [R/W] page

Select the type of access cycles.

Trace Filker

Status I Prabes | IRGT-0
General I Address I Data R | Area

— Setting

[IRD
[TwhR

QK I Cancel | Apply

[Don't carel:

[Setting]:

Figure5.87 [TraceFilter] Dialog Box ([R/W] Page)
Detects no read/write condition when this box is checked.

Detects the specified read/write condition.

RD: Detects read cycles when this box is checked (not available when [Don't care] has

been checked).

WR:  Detects write cycles when this box is checked (not available when [Don’t care] has

been checked).
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(5) [Area] page
Select the area being accessed. The selection is not available when atime stamp is acquired.

Trace Filter x|

Status I Prabes I IRGT-0 |
General I Address I Data I Rifws Area

IS
— Setting
[JROM -
[CIRaM

1016

I8

[JEXT-16

[JExT-2

[IRAM/DTC hd|

QK I Cancel | Apply |

Figure5.88 [TraceFilter] Dialog Box ([Area] Page)
[Don't carel: Detects no area condition when this box is checked.
[Setting]: Detects the specified area condition (not available when [Don't care] has been checked).

Note: Available area conditions vary according to the emulator in use. For details, refer to section 5.15.4,
Signals to Indicate Bus States and Aress.
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(6) [Status] page
Select the status of a bus. The selection is not available when atime stamp is acquired.

Trace Filter x|
Gerneral | Address I Data I R M I Area
Status | Probes I IRET-0
i :

— Setting
[IPROG
[ IDATA
[ |REFRESH
[ ]DMALC
[DTC
[JOTHER

QK I Cancel | Apply |

Figure5.89 [TraceFilter] Dialog Box ([Status] Page)
[Don't care]: Detects no bus condition when this box is checked.
[Setting]: Detects the specified bus condition (not available when [Don’t care] has been checked).

Note:  Available bus conditions vary according to the emulator in use. For details, refer to section 5.15.4,
Signals to Indicate Bus States and Aress.
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(7) [Probes] page
Select the status of four probe signals. The selection is not available when atime stamp is acquired.

Trace Filter x|
Gerneral I Addressz | Data | R M I Area
Status Probes | IRGF-0

— Setting

Probed IDnn'l care'l Probe3 IDon'l care'l
Probe2 IDon'l care 'I Prabel IDnn't cale'l

QK I Cancel | Apply |

Figure5.90 [TraceFilter] Dialog Box ([Probes] Page)
[Don't carel: Detects no probe signal condition when this box is checked.
[Setting]: Detects the specified probe signal condition.
[Probed] to [Probel]: Select probe conditions (not available when [Don't care] has been checked).
Don't care: Detects no selected probe condition.
High: The status of the probe signal is high.

Low: The status of the probe signal islow.
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(8) [IRQ7-0] page

Select the status of IRQ signals. The selection is not available when atime stamp is acquired.

Trace Filter x|
Gerneral I Addressz I Data R M | Area |
Status I Frobes IRE7-0
IRE7 IDon't care "I IRQE Daon't care ™
IRQ5 IDon't care "I IRO4 IDDn't care 'I
IRQ3 IDnn'l care 'I IRE2 IDDn't care 'I
IR IDnn'l care 'I [=Twli] IDon't care "I
QK I Cancel | Apply |

Figure5.91 [Trace Filter] Dialog Box ([IRQ7-0] Page)

[Don't carel: Detects no IRQ input condition when this box is checked.
[Setting]: Detects the specified IRQ input condition.
[IRQ7] to [IRQQ]: Select IRQ input conditions (not available when [Don’t care] has been

checked).
Don't care: Detects no selected IRQ input condition.
High: The status of the IRQ input is high.

Low: The status of the IRQ input islow.
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(9) [Timestamp] page
Specify the time stamp value for bus cycles. The specification is not available when atime stamp is acquired.

Trace Filker x|

Generall .-’-‘«ddressl Data I FAw  Timestamp

Setting
¢ Paint ¢ Range

Bom [ b [ e[ I_msl_usl_ns
o ™ e

S

s

E]

To ng

0k I Cancel | Apply |

Figure5.92 [TraceFilter] Dialog Box ([Timestamp] Page)
[Don't care]: Detects no time stamp value when this box is checked.
[Setting]: Detects the specified time stamp value.
[Point]: Specifies asingle time stamp (not available when [Don't care] has been checked).
[Range]: Specifies atime stamp range (not available when [Don't care] has been checked).

[From]: Enter a single time stamp value or the minimum vaue of the time stamp range.
Theformat is asfollows:
hour: h, minute: min, second: s, millisecond: ms, microsecond: us, nanosecond: ns
(Not available when [Don't care] has been checked.)

[To]: Enter the maximum value of the time stamp range.
Theformat is as follows:
hour: h, minute: min, second: s, millisecond: ms, microsecond: us, nanosecond: ns
(Only available when [Range] has been selected.)

Note:  Along with setting the time stamp range, the minimum and maximum time stamp values can be set in the
[From] and [To] options, respectively.
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5.16.13 Calculating the Differencein Time Stamping

Select [Timestamp Difference...] from the popup menu to calculate the time difference between the two points
selected by the result of tracing in acquisition of time stamp information.

Timestarmp Difference 2 x|

— Select 2 line

Firzt PTR - |'32?54 Second PTR : ID

[Timestamp difference information :

Timeztamp Difference

0000k 000rmin 000z 003ms 897us B75ns Get Difference
Clear |

( | ] o |

Figure5.93 [Timestamp Difference] Dialog Box
[Select 2 lin€]: Select trace records to calculate the time stamp difference.

[First PTR]: Specifies the first pointer to measure the difference. The pointer of the line
selected on the Trace window is displayed by default.

[Second PTR]: Specifies the second pointer to measure the difference.

[Timestamp Difference]: Displays the results of calculation.

[Get Difference]: Calculates the difference between the specified two points and display itsresult in the
[Timestamp Difference] list.

[Clear]: Clears all theresultsin the [Timestamp Difference] list.

[OK]: Closes the dialog box. All the results in the [Timestamp Difference] list are cleared.
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5.16.14 Analyzing Statistical I nformation

Choose [Statistic] from the popup menu to open the [Statistic] dialog box and analyze statistical information
under the specified conditions.

c 21x
— Statiztic Analysis
= Default © Fanoe get
Item |<None> ﬂ
Hew
Start I
Eesult |
End :I
Clear |
Result :
Condition | Amount | FTR
N I i
Close |

[Statistic Andysis]:
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[Default]:
[Range]:
[Item]:

[Start]:

[End]:

[Set]:
[New]:
[Result]:
[Clear]:

[Close]:

Figure5.94 [Statistic] Dialog Box
Setting required for analysis of statistical information.
Setsasingle input value or character string.
Sets the input value or character string as arange.
Setstheitem for analyss.

Setsthe input value or character string. To set arange, the start value must be
specified here.

Specify the end value if arange has been set (only available when [Range] has been
selected).

Adds anew condition to the current one.

Creates a new condition.

Obtains the result of statistical information analysis.

Clears all conditions and results of statistical information analysis.

Closes thisdialog box. All the results displayed in the [Result] list will be cleared.
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This diaog box alows the user to analyze statistical information concerning the trace information. Set the target
of analysisin [Item] and the input value or character string by [Start] and [End)]. Click the [Result] button after
setting a condition by pressing the [New] or [Add] button to analyze the statistical information and display its
result in the [Result] list.

Note: In thisemulator, only [PTR] can be set asarange. Each of other items must be specified as a character
string. In analysis of statistical information, character strings are compared with those displayed in the
[Trace] window. Only those that completely match are counted. Note, however, that thistest is not case
sensitive. The number of blankswill not be cared either.

5.16.15 Extracting Function Callsfrom the Acquired Trace Information

To extract function calls from the acquired trace information, select [Function Call...] from the popup menu.
The [Function Call Display] dialog box will be displayed.

Furiction Call Display x|
Setting
Enable ta dizplay trace information with function
call only 7
o g " Dizable
0K | LCancel |

Figure5.95 [Function Call Display] Dialog Box

[Setting]: Selects whether or not to extract function calls.
[Enable]: Extracts function calls.
[Disable]: Does not extract function calls.

When [Enable] is selected, only the cycles that include function calls are extracted for display from the acquired
trace information. The content of the trace buffer is not changed by extraction of function cals. Using this
function for the result of the free trace or the trace information that includes function calls allows the user to
know the order of function calls.
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5.17  Viewingthe Function Call History

The [Stack Trace] window shows the function call history.

5.17.1 Openingthe[Stack Trace] Window

To open the [Stack Trace] window, choose [View -> Code -> Stack Trace] or click the [Stack Trace] toolbar

button ().

Eind| Name VYalue

F func3 {short *) { 000000094 1}

P param 3 000003 ffa { O0x00003£d8 } (short*)
L local 3 '3 { Ox00003fd4 } {unsigned long)
F funcs (short *) { Ox0O0000072

=] param Z 0x00003ffa { 0x00003fed } (short*)
L local Z D'Z { Ox00003fed } {unsigned long)
F funcl {short *) { 00000003 }

=] param 1 0x00003ffa { Ox00003£f0 } (short*)
L local_1 D'l { 0x00003fez } (unsigned long)
F mainf) { O0x0000001Z }

L start D"103 { 0xx00003ffa } {=zhort)

Figure5.96 [Stack Trace] Window

Thefollowing items are displayed.

[Kind]: Indicates the type of the symbol.
F: Function
P: Function parameter
L: Local variable
[Name]: Indicates the symbol name.
[Value]: Indicates the value, address, and type of the symbol.

5.17.2  Viewing the Source Program

Select afunction and choose [Go to Source] from the popup menu to display, in the [Source] window, the source
program corresponding to the selected function.
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5.17.3  Specifying the View

Choose [View Setting...] from the popup menu to open the [Stack Trace Setting] dialog box, which alows the
user to specify the [Stack Trace] window settings.

Mest level (1-64) Iim =

— Display =vmbol
[~ Parameter
[~ Local Variable

— Diaplay Radix
* Hexadecimal
" Decimal
" Octal QK
" Binary

Cancel |

Figure5.97 [Stack Trace Setting] Dialog Box
[Nest level]: Specifies the level of function call nesting to be displayed in the [Stack Trace] window.
[Display symbol]:  Specifies the symbol typesto be displayed in addition to functions.

[Display Radix]: Specifies the radix for displaysin the [Stack Trace] window.
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518 Displaying Memory Contentsas an | mage

The memory contents can be displayed as an image in the [Image View] window.

5.181 Openingthe[Image View] Window

Choose [View -> Graphic -> Image...] or click the [Image] toolbar button (EI) to open the [Image Properties]
dialog box shown in figure 5.98.

Image Properties 21 x|

— Colar Information:

Eit/Fise! IBbil[|nde:-: Color’ 'I
Sarmpliti: I‘Hi‘1r 'I
Format: I chunky e I

r— Buffer Infomation:

Data Address: IH'UUUUUDDD j
Palette Address: IH'DDDDDUUD j
wWidth/Height Size[Fixel]:

widih I— Buffer Size;
LA | H'00000000 Bute
Height; I

—Wiew [nformation;
—Yiew Mode:——— — Fosition;

* Full Size 2 Position: I 0
" Part Size ' Positicr: I 0

— Start Pozition: - idth/Heght Size(Fizell—————

& Top widke |
" Bottom Height: I

OF. I LCancel |

Figure5.98 [Image Properties] Dialog Box

The [Image Properties] dialog box is used to specify the display method of the [Image View] window.
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The following items are to be specified:

[Color Information]:

[Mode]:

[Bit/Pixel]:

[Sampling]:
[Format]:
[Buffer Information]:

[Data Address]:

[Palette Address):

Specifies the color information of theimage to be displayed.

Specifies the format.

[MONOCHROME]: Displaysin black and white.

[RGB]: Displayed in R (red), G (green), and B
(blue)

[BGR]: Displayed in B (blue), G (green), and R
(red)

[YChCr]: Displayed by Y (brightness), Cb (color
differencein blue), and Cr (color difference
in red)

Specifies Bit/Pixel according to the selected [Mode]. (Valid when
RGB or BGR is selected)

Specifies the format of sampling. (Valid when Y ChCr is selected)
Specifies Chunky/planar. (Vaid when Y CbCr is selected)
Specifies the area to store data, size, and the address of the palette.

Specifies the start address of the memory where image dataisto
be displayed. (Displayed in hexadecimal)

Specifies the start address of the memory of color palette data.
(Displayed in hexadecimal) (Valid when 8Bit is selected for RGB or BGR)

[Width/Height Size]: Specifies the width and height of the image.

[View Information]:

[View Mode]:

[Start Position]:

[Width (Pixel)]: Specifies the width of the image.
(When aprefix is omitted, the values are
input and displayed in decimal.)

[Height (Pixel)]: Specifies the height of the image.
(When aprefix is omitted, the values are
input and displayed in decimal.)

[Buffer Size): Displays the buffer size of the image
from the width and height
(Displayed in hexadecimal)

Specifies the location, size, and data start location of the part to be
displayed among the entireimage.

Specifies the entire/part to be displayed in theimage.

[Full Size]: Displays the entireimage.

[Part Size]: Displays part of the image.
[Top]: Displays data from the upper left.
[Bottom]: Displays data from the lower left.
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[Position]: Specifies the start position of the image where part of theimageis
to be displayed. (Valid when [Part Size] is selected)
[X Position]: Specifies the X axis of the start location.
(When aprefix is omitted, the values are
input and displayed in decimal.)
[Y Position]: Specifiesthe Y axis of the start location.
(When aprefix is omitted, the values are
input and displayed in decimal.)

[Width/Height Size]: Specifies the height and width of the image to be displayed partly.
[Width (Pixel)]: Displays the width of display.
(When aprefix is omitted, the values are
input and displayed in decimal.)
[Height (Pixel)]: Displays the height of display.
(When aprefix is omitted, the values are
input and displayed in decimal.)

After the settings have been made in the [Image Properties] dialog box, clicking the [OK] button opens the
[Image View] window.

Even after the [Image View] window is displayed, the display contents can be modified by opening thisdialog
box by choosing [Properties...] from the popup menu.

Figure5.99 [Image View] Window

The memory content is displayed as an image.

5182 Automatically Updating the Window Contents

Checking [Auto Refresh] in the popup menu will alow the window contents to be automatically updated when
user program execution stops.
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5.183 Updating the Window Contents

Selecting [Refresh Now] from the popup menu immediately updates the window contents.

5.18.4 Displaying the Pixel Information

Double-clicking within the window displays information on the pixel on which the mouse pointer islocated in
the [Pixel Information] dialog box.

Pixel Information 21 x|
Color mode: I Index Colar
Fixel: I Index Mo.195
Foszition I— I—
Buffer Size ‘width: I— Height: I—
Image Size ‘width: I— Height: I—

Figure5.100 [Pixe Information] Dialog Box

This dialog box displays pixel information on the cursor location.

[Color Mode]:

[Pixe]:

[Position]:

[Buffer Size]:

[Image Size]:

Displays the format of theimage.
Displays color information of the cursor location. (Displayed in decimal)

Displaysthe cursor location in X and Y axis. (Displayed in decimal)
[X]: Displays the X axis of the cursor location.
[Y]: Displaysthe Y axisof the cursor location.

Displays the buffer size. (Displayed in decimal)
[Width]: Displays the buffer width.
[Height]: Displays the buffer height.

Displays the width and height of the display. (Displayed in decimal)
[Width]: Displays the width.
[Height]: Displays the height.
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519 Displaying Memory Contents as Waveforms

Memory contents can be displayed aswaveformsin the [Waveform View] window.

5.19.1 Opening the Waveform View Window

Choose [View -> Graphic -> Waveform...] or click the [Waveform] toolbar button to open the [Waveform
Properties] dialog box shown in figure 5.101.

Wavefarm Properties
Data Address:  [H'0000000D |
DataSize:  ahit ] Cancel |
LChannel:
’7 £ Mono " Stereo
Buffer Size:  [H'D0000000 4

Figure5.101 [Waveform Properties] Dialog Box
Specifies the waveform format. The following items can be specified.
[Data Address]: Specifies the start address of datain memory (displayed in hexadecimal).
[Data Size]: Selects 8Bit or 16Bit.
[Channd]: Selects Mono or Stereo.
[Buffer Size]:  Specifies the buffer size of data (displayed in hexadecimal).

After the settings have been made in the [Waveform Properties] dialog box, clicking the [OK] button opens the
[Waveform View] window.

Even after the [Waveform View] window is displayed, the display contents can be modified by opening this
dialog box by choosing [Properties...] from the popup menu.
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i Wavefarm Wiew -|of x|

L H‘HH]I;““
HULRm =

Figure5.102 [Waveform View] Window

Displays the memory contents as waveforms. The X axis shows the number of sampling dataand the Y axis
shows the sampling value.

5.19.2 Automatically Updating the Window Contents

Checking [Auto Refresh] in the popup menu will allow the window contents to be automatically updated when
user program execution stops.

5.19.3 Updating the Window Contents

Selecting [Refresh Now] from the popup menu immediately updates the window contents.

5.19.4  Zoom-In Display

Selecting [Zoom In] from the popup menu displays the waveforms with the horizontal axis enlarged.

5.195 Zoom-Out Display

Selecting [Zoom QOut] from the popup menu displays the waveforms with the horizontal axis reduced.

5.19.6 Resetting the Zoom Display

Selecting [Reset Zoom] from the popup menu displays the waveformsin its original size.

5.19.7  Setting the Zoom M agnification

In the [Zoom Magpnification] submenu of the popup menu, the zoom magnification can be selected from 2, 4, or
8.

5.19.8  Setting the Horizontal Scale

In the [X Scale] submenu of the popup menu, the size of the X axis can be selected from 128, 256, or 512 pixels.
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5.19.9 Non-Display of Cursor

Selecting [Clear Cursor] from the popup menu hides the cursor display.

5.19.10 Displaying the Sampling I nfor mation

Selecting [Sample Information...] from the popup menu displays the [Sample Information] dialog box.

Sample Information i 3

Data Size: I Bhit
Channel: I fdono

¥ | H'0000310
Walue

v | H'23

Figure5.103 [Sample Information] Dialog Box

Displays the sampling information of the cursor location in the [Waveform View] window. The following
information is displayed.

[Data Size]:
[Channd]:

[Value]: [X]
[Y]

286

Displays 8bit or 16hit.
Displays the data channel.

Displaysthe X axis of cursor location.

Displaysthe Y axis of cursor location (displays Y axes for both the upper and
lower plots when Stereo is selected).

RENESAS




520

Analyzing Performance

Use the performance analysis function to measure the rate of execution time. The performance analysis function
does not affect the realtime operation because it measures the rate of execution time in the specified range by
using the circuit for measurement of hardware performance included in the emulator.

Select either of the following five modes according to the purpose of measurement.

Table5.7

Mode

Available M easurement Modes

Description

Purpose

Time Of Specified Range
Measurement

Measures the execution time and
execution count in the specified
range.

Measurement of time taken for
processing of functions except for
that required for child functions
called from the functions.

Start Point To End Point
Measurement

Measures the execution time and
execution count between the
specified addresses.

Measurement of time taken for
processing of functions.

Start Range To End
Range Measurement

Measures the execution time
from a specified range to another
specified range.

Measurement of execution time
spent from calling of any of
sequential subroutines to calling of
any of another sequential
subroutines in a program that
includes subroutines in sequence,
such as an assembly program.

Access Count Of
Specified Range
Measurement

Measures the number of times a
specified range is accessed from
another specified range.

Measurement of the number of
times a global variable is accessed
from a specific function.

Called Count Of
Specified Range
Measurement

Measures the number of times a
specified range has called
another specified range.

Measurement of the number of
times a function is called from a
specific function.

Use eight performance channelsinstalled on the circuit for measurement of hardware performance in the
emulator for setting of conditions for measurement. Up to eight points can be set.

Note, however, that up to four points can be set in Start Range To End Range Measurement, Access Count Of
Specified Range Measurement, or Called Count Of Specified Range M easurement because two sequentia points
are used for setting a condition in these modes.
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Table5.8 Mode Settingsfor Measurement

Point

Page

Time Of Specified Range [e) [e) (e} (e} (e} (e} (e} (e}
Measurement

Start Point To End Point o) [e) [e) (o] (0] (@] (@] O
Measurement

Start Range To End 0 n] 0 O (0] n] (0] O
Range Measurement

Access Count Of 0] O e} O (e} O (e} 0O
Specified Range

Measurement

Called Count Of [e) 0O (e} 0 (e} O (e} 0O
Specified Range

Measurement

Note: O: Available
0 : Not available

Note:  Only one point is used in Time Of Specified Range Measurement and Start Point To End Point
Measurement, while two sequential points are used in Start Range To End Range M easurement, Access
Count Of Specified Range Measurement, and Called Count Of Specified Range Measurement. The
conditions that have been set will be canceled when switching these modes of different types.
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5.20.1 Opening the [Performance Analysis] Window

Choose [View -> Performance -> Performance Analysis] or click the [PA] toolbar button ) to open the
[Select Performance Analysis Type] dialog box.

Performance dnalysiz EE000 Perfarmanc

Figure5.104 [Select Performance Analysis Type] Window

Select [E6000 Performance Analysis] and then click the [OK] button to open the [Performance Analysis]
window.

- Performance & =10l x|
No Nauwe | Condition | Rate | RUN-TIME MAX-NIN-TIME | Count |
1 PAl  Renge H'0000103& H'00001105 9% OOk OOnin 005 O55us 764us 160ns 1234
2 P2z  ProP H'0000Z068 H'000020DA  25% OOk OOmin 005 147us 682us 880ns OOk OOwin... 1234
3 PAS  RtoR H'00001036 H'O0001105 65% OOk OOmin 005 35lms 580us 480ns 2468
4 + H'00002065 H' 00002138

5

6

7

8

Figure5.105 [Performance Analysis] Window

Thiswindow displays the rate of execution time in the area selected by the user during the last program runin
percentages, histogram, or numerical values.

It is possible to hide any column not necessary in the [Performance Analysis] window. Selecting a column you
want to hide from the popup menu displayed by clicking the right-hand mouse button on the header column
hides that column. To display the hidden column, select the column from the said popup menu again.
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5.20.2  Setting Conditionsfor Measurement

Conditions for measurement can be displayed and changed in the [Performance Analysis] window. Select a point
where a condition isto be set, and then select [Set...] from the popup menu to display the [Performance Analysis
Properties] dialog box.

Select either from the following five modes as the condition by the [Measurement Method] option:

Table5.9 Conditionsfor Measurement (Measurement Method)

[Measurement Method] Option

Time Of Specified Range Measurement

Start Point To End Point Measurement

Start Range To End Range Measurement

Access Count Of Specified Range Measurement

Called Count Of Specified Range Measurement

Set a condition for measurement according to the mode being selected. The parameters to be set depend on the
modes.

The [Performance Analysis] window has a support function to enter the address range of afunction
automatically if the name of the function is entered to set an address range. Entering a function name in the
[Input Function Range] dialog box displayed by clicking the[...] button on the [Performance Analysis
Properties] dialog box automatically enters the address range of the function.

Inpuk Function Range

2l
Function

Sample:: Cancel

Figure5.106 [Input Function Range] Window

Notes: 1. Entering the name of an overload function or aclass opens the [Select Function] dialog box. Select a
function in this dialog box. For details on the dialog box, refer to section 5.13.3, Supporting
Duplicate Labels.

2. The addresses figured out are just for reference. In some cases, the end address of a function may be
different. Check the last instruction of the function in the [Disassembly] window to correct the value
set in [End Address] so that it will be the address of the last instruction (in general, the last instruction
of afunctionisaRTS instruction). A label name or an expression can be entered instead of an
address value in boxes where an address should be entered.
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(1) Time Of Specified Range M easurement

Performance Andl roperties

Measurement Method PAT: Time Of Specifie

Fange Hame IF'M
Range

Start Address IH'DDDDDDDD _I
End Address IH'DDDDDDDD

— Common Settings of Pelformance(Pa1-8)

Addresz Contral Mode: PC Settings... |
Time Measurement Unit: 160ns
Cancel |

Figure5.107 Time Of Specified Range Settings

[Range Name]: The name of the range to be measured

[Range]: The range for the Time Of Specified Range M easurement
[Start Address]: Address to start measurement
[End Address]: Address to end measurement

M easures the execution time and the execution count in the range between the start address and end address.
Starts measurement with a detected program prefetch in the range specified between the start and end addresses,
and then stops with a detected program prefetch out of the specified range. M easurement can be restarted with a
detected program prefetch in the specified range. The execution count isincremented every time the program is
prefetched at the end address of the specified range. The execution time measured does not include the time
spent while being called from the specified range.
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(2) Start Point To End Point Measurement

Performance Analysis Properties 2=l

teazurement bethod PAT:

Start Point To End Paint b

Fairt

Count

Fange Hame IF'M

Start Address IH'DDDDDDDD _I
End Address IH'DDDDDDDD

Time Out : IIJIJh 00rmir 00z 000rn: 000us 000ns

Jo

— Common Settings of Pelformance(Pa1-8)

Addresz Contral Mode: PC Settings... |

Time Measurement Unit: 160ns

Cancel |

Figure5.108 Start Point To End Point Measurement Settings

[Range Name]:

[Point]:
[Start Address]:
[End Address]:

[Time Out]:

[Count]:

The name of the range to be measured

The range for the Start Point To End Point Measurement
Address to start measurement
Address to end measurement

The timeout value to finish measurement. When the minimum time for measurement
is160 ns, 40 ns, or 20 ns, enter the value as follows.
Example: 1h 2min 3s 123ms 456us 789ns

If the CPU operating mode is target, enter a hexadecimal number in 10 digits.
Example: 123456789A

A break occurs every time avalue measured in the specified range exceeds the
timeout value (not the tota time). Thisisonly available for channel 1.

The count-up value used in measurement of the execution count. A break occurs
every time the execution count exceeds the count-up vaue. Thisisonly available for
channel 1.

Measures the execution time and the execution count in the range between start address and end address. Starts
measurement with a detected program prefetch at the start address, and then stops with a detected program
prefetch at the end address. The execution count isincremented every time the program is prefetched at the end
address of the specified range. The execution time measured includes the time spent while being called from the
specified range. When either from one to four pointsis selected, the maximum and minimum time in the
specified range can be measured.
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Notes: 1. When [Time Out] is selected in the Start Point To End Point M easurement mode, the execution time
will not be measured correctly.
2. When [Time Out] and [Count] are selected, satisfaction of either of these options stops execution of
the user program (performance break).
3. Only channd 1 can be used for [Time Out] and [Count]. Use other channelsif you do not want to
select [Time Out] or [Count] in the Start Point To End Point M easurement mode.
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(3) Start Range To End Range Measurement

Performance Andl roperties

Measurement Method PAT: Start Fange To End Bange Measurement

Fange Hame IF'M
Start Range End Range

Start Address IH'DDDDDDDD _I Start Address IH'DDDDDDDD _I
End Address IH'DDDDDDDD End Addrezs : IH'DDDDDDDD

— Common Settings of Pelformance(Pa1-8)

Addresz Contral Mode: PC Settings... |
Time Measurement Unit: 160ns
Cancel |

Figure5.109 Start Range To End Range M easurement Settings

[Range Name]: The name of the range to be measured

[Start Range]: The start range for the Start Range To End Range M easurement
[Start Address]: Start address
[End Address]: End address

[End Range]: The end range for the Start Range To End Range M easurement
[Start Address]: Start address
[End Address]: End address

Starts measurement with a detected prefetch cyclein the specified start address range, and then stops with a
detected prefetch cycle in the specified end address range. The execution count is incremented every time the
program passes the end address range.
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(4) Access Count Of Specified Range Measurement

Performance Andl roperties

tMeasurement Method P41 unt Of S pecified Fange Measurement

Fange Hame |F'A1

Range Arcess Area Fange

Start Address . |H'00000000 J Start Address H'00000000 J
End Address H'00000000 End Addrezs : H'00000000

Accesz Tupe
[¥ Don't Care

r I r I r

Common Settings of Performance(Pd1-8)

Addrezs Control Mode: Prefetch Seftings...
Time Measurement Unit: 160ns
Cancel

Figure5.110 Access Count Of Specified Range M easurement Settings

[Range Name]: The name of the range to be measured
[Range]: The range for the Access Count Of Specified Range Measurement
[Start Address]: Start address
[End Address]: End address
[Access Area Range]: The access range for the Access Count Of Specified Range Measurement
[Start Address]: Start address
[End Address]: End address
[Access Type]: The bus cycle on the access range to be measured

Measures the number of times the range specified as the access range is accessed from the range specified by the

start and end addresses. The execution count in the range is measured with Time Of Specified Range
Measurement mode.

Note:  Available bus cycle conditions vary according to the emulator in use. For details, refer to section 5.15.4,

Signals to Indicate Bus States and Aress.
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(5) Called Count Of Specified Range M easurement

Performance Andl roperties

teasurement Method PAT: Called Count OF 5

Fange Hame IF'M
Range Call Fange

Start Address IH'DDDDDDDD _I Start Address IH'DDDDDDDD _I
End Address IH'DDDDDDDD End Addrezs : IH'DDDDDDDD

— Common Settings of Pelformance(Pa1-8)

Addresz Contral Mode: PC Settings... |
Time Measurement Unit: 160ns
Cancel |

Figure5.111 Called Count Of Specified Range M easurement Settings

[Range Name]: The name of the range to be measured
[Range]: The range for the Called Count Of Specified Range M easurement
[Start Address]: Start address
[End Address]: End address
[Call Range]: The range for the Called Count Of Specified Range Measurement. Asthe call range,
specify the start and end addresses of the selected subroutine.
[Start Address]: Start address
[End Address]: End address

Measures the number of times the range specified as the call rangeis called from the range specified by the start
and end addresses. The execution time in the specified range can be measured with Time Of Specified Range
Measurement mode. Asthe call range, specify the start and end addresses of the selected subroutine.
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5.20.3  Selecting the Address Detection Mode and Resolution

In measurement of hardware performance, there are two types of address detection modes:. prefetch address
detection mode and PC address detection mode. Select the appropriate address detection mode according to the
measurement mode in use. The resolution can also be selected here.

To select an address detection mode and resolution, click the [Settings...] button on the [Performance Analysis
Properties] dialog box. The [Common Settings of Performance(PA1-8)] dialog box will be displayed.

Comman Settings of Performance(PAl-8)
Address Contral Mode Prefetch

Time Measurement Unit 160ns j Caticel |

Figure5.112 [Common Settings of Perfor mance(PA1-8)] Dialog Box
[Address Control Mode]: Select the method to detect addresses for the rate of execution time.

PC: PC address detection mode
Prefetch: Prefetch address detection mode

[Time Measurement Unit]: Select the timer resolution to be used for measurement from 160ns, 40ns,
20ns, or Target. The timer for execution time measurement has a 40-bit
counter. At 20 ns the maximum time that can be measured is about six hours,
and at 160 ps the maximum time is about two days. When the counter
overflows, “Timer Overflow” is displayed as the result of measurement.
When Target is selected, the counter isincremented by an input clock. The
result of measurement is displayed as 10 digitsin hexadecimal.

Select the prefetch address detection mode in Access Count Of Specified Range Measurement, and PC address
detection mode in other measurement modes. Otherwise, the result of the measurement will be incorrect.

5.20.4  Starting Performance Data Acquisition

Executing the user program clears the result of previous measurement and automatically starts measuring the rate
of execution time according to the conditions that have been set. Stopping the user program displays the result of
measurement in the [Performance Analysis] window.

5.20.5 Deleting a Measurement Condition

Select [Reset] from the popup menu with a measurement condition selected to del ete the condition.

5.20.6  Deleting All Measurement Conditions

Choose [Reset All] from the popup menu to delete all the conditions that have been set.
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Section 6 Tutorial

6.1 Introduction
The following describes the main functions of the emulator by using atutorial program.

Thetutorial program is based on the C++ program that sorts ten random dataitemsin ascending or descending
order. Thetutorial program performs the following actions:

* Thenai n function repeatedly callsthet ut ori al function to repeat sorting.

e Thetutorial function generatesrandom datato be sorted and callsthesort andt ut ori al functions
in order.

e Thesort function entersthe array where the random data generated by thet ut or i al function are stored,
and sorts them in ascending order.

* Thechange function then sorts the array, which was sorted in ascending order by thesor t function, in
descending order.

Thefilet ut ori al . cpp contains source code for the tutorial program. Thefile Tut ori al . abs isa
compiled load module in the Dwarf2 format.

Notes: 1. After recompilation, the addresses may differ from those given in this section.

2. Thissection describes general usage examples for the emulator. For the specifications of particular
products, refer to section 8, Software Specifications Specific to This Product, or the online help.

3. Theoperation address of Tut ori al . abs attached to each product differs according to products.
Replace the address used in this section with the relevant address in each product after checking that
it is placed on the corresponding line of the source program.

4. Inthistutorial, the H8S/2633 E6000 emulator is taken as an example. File paths or the appearance of
figures differs according to products.
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6.2 Runningthe HEW

Open aworkspace by following the procedure listed in section 4.2.3, Selecting an Existing Workspace.

Select the following directory:
HEW install ation destination directory\Tool s\Renesas\DebugComp\Platform\E6000\2633\ T utorial

Note: Thefile path differs depending on the product. Refer to section 8.2.1, Environment for Execution of the
Tutorial Program.

Then select the file indicated below.

21

Lok, jr: I@ Tutarial j - IC:F -

Debug_H&5_2237_EA000_Emulator _CP
SoUrce

File name: |Tutorial.hws Open I
Files of twpe: IWorkspaces [® hws) j Cancel |
S

Figure6.1 [Open Workspace] Dialog Box

Opening this workspace automatically connects the emulator.
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6.3 Downloading the Tutorial Program

6.3.1 Downloading the Tutorial Program
Download the object program to be debugged.

»  Select [Download module] from the popupmenu opened by clicking the right-hand mouse button on
[Tutorial .abs] of [Download modules].

=53 Tutorial
E-[E Tutorial
=23 C source file
. E] dbsct.c
2] shrk.c
C++ zource file
2] resetprg. cpp
2] sort.cpp
- 2] Tutarial.cpp
Ela Download modu

Ea Depender ownload rodule
: % shirk.h Unlzad module

§| zort.h

Configure Yigw...

’7 Allovs Dacking
Hide

Figure6.2 Downloading the Tutorial Program
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6.3.2 Displaying the Sour ce Program
The HEW allows the user to debug a user program at the source level.

» Double-click [Tutorial.cpp] under [C++ source fil€].

==l woid main(woid)
: {
=G Tutorial 0=00001036 while (1){
= Tutorial N=00001034 tutorial();
=53 Esnurce fil i
L
O0=00001038 vold tutorial{wvoid)
0=x00001044 {
long a[lD]
long J:
int 1i;
claz=s Samnple *p _=sam;
0xz00001046 p_san= Sanple;
0z0000104e for{ i=0; 1<10; i++ {
0xz00001050 j = rand():
0=z00001058 if{3 ¢ 03
0=z0000105a jo= —=3:
1
0=z0000105c ali] = 3:
O0=00001070 p_sam—:=ort{a);
0=0000107a p_=sam->change(a):
0=z00001082 p_=an—:=0=a[0]:
0=z0000108a p_=an—:=l=a[1]:
0=z00001096 p_=an—r=2=a[2]:
0=z000010a2 p_=an—rx=3=a[3d]:
0z000010as p_=an—:=d=a[4]:
0=z000010ba p_=amn—:=h=a[5];
0=z000010ck F_=an—:=sb=al[&];
0=z00001042 F_=an—r=7=al[7]:
0z000010de p_=an—r=8=a[8];
0z000010ea E_=an—rx=9=a[9];
0=z000010f6 p_=am;
0=z000010fc }

Figure 6.3 [Source] Window (Displaying the Sour ce Program)

* Select afont and size that are legible if necessary. For details, refer to section 4, Using the Editor in the HEW
part.

Initially the [Source] window shows the start of the user program, but the user can use the scroll bar to scroll
through the user program and look at the other statements.
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6.4 Setting a PC Breakpoint

A PC breakpoint is a simple debugging function.

The [Source] window provides avery simple way of setting a PC breakpoint at any point in a program. For

example, to set a PC breakpoint at thesor t function call:

» Select by double-clicking the [Editor] column on the line containing the sor t function call.

Emﬁngmw
Ell@ Tutorial

B-E3 C source file
dbschc
shrk.c
424 C++ source file
resetpra cpp
sort.cpp
Tutorial.cpp
=23 Download modules

0=00001038
0=00001044

0=00001046
0=0000104e
0=00001050
0=00001058
0=0000105a

0=0000105cz

0=00001070 L ]
0=0000107a

0=000D1082
O=0000108a
0=00001096
0=000010a2
0z000010as
0=000010ba
0=000010c6
Oz000010d2
0=z000010de
0z000010=a
0=000010f6
O=z000010fc

wold tutorial({woid)

long a[10];

long 3:

int i:

cla==s Sanple *p_=am;

p_=am= Sample;
for( i=0; 1i<10; i++ 3§
7 = rand():
if{j ¢ 0){
T B
Yo .
ali] = 3:

p_=am—rzort{al;
p_=am-:change{a) ;

p_=amn—->=0=a[0]
p_=samn—rzl=all]
P sam—r=2=all]
p_=sam—:=3=al[3];
p_=amn—->=z=d=al4];
p_=am—->=5=a[5]:
p_samn—r»zb=alb]
P sam—r=7=al?]
p_=sam—:=8=a[8]
p_=amn—->z=9=a[9]
p_Sam;

I

Figure6.4 [Source] Window (Setting a PC Breakpoint)

The symbol « will appear on the line containing the sor t function. This shows that a PC breakpoint has

been set.
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6.5 Setting Registers
Set avalue of the program counter before executing the program.

* Select [Regigters] from the [CPU] submenu of the [View] menu. The [Register] window is displayed.

eqister 10l =l

|Register Hamel Register Valuel

RO H'oooooooo

Rl H'0ooooooo

RZ H'oooooooo

R3 H'0ooooooo

R4 H'oooooooo

RS H'0ooooooo

RE H'oooooooo

R7 H'0ooooolo

PC H'ooo40o

CCR I0--=---

b 111

Figure6.5 [Register] Window

» To change the value of the program counter (PC), double-click the value areain the [Register] window with
the mouse. The following dialog box is then displayed, and the value can be changed. Set the program
counter to H’00000400 in thistutorial program, and click the [OK] button.

Reqgister - [PC] 2=

Walue

|H'uuu4uu
Setds: Cancel |

IWhnIe Regizter j

Figure 6.6 [Register] Dialog Box (PC)
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6.6 Executing the Program

Execute the program as described in the following:

» To execute the program, select [Go] from the [Debug] menu, or click the [Go] button on the toolbar.

Figure6.7 [Go] Button

While the program is executing, the current address bus value and the operating state of the MCU are displayed

on the status bar.

The program will be executed up to the breakpoint that has been inserted, and an arrow will appear on the
[Editor] column in the [Source] window to show the position that the program has halted, with the message

[ Br eak = PCBr eak] in the status bar.

Note:  When the sourcefile is displayed after abreak, a path of the source file may be inquired. The location of

the sourcefileisasfollows:

HEW installation destination directory\Tool s\Renesas\DebugComp\Platform

\E6000\2633\Tutorial\source

Thefile path differs according to products. If necessary, replace \2633 with another name.

0x00001038
O=00001044

0=00001046
0=0000104=
0=00001050
0=00001058
0=0000105=

0=0000105<

O0=00001070 L=
00000107

0=z00001082
0=z0000108a
0=z00001096
O=z000010=2
0=z000010a=
0=z000010ba
0=z000010cz6
O=z00001042
0=z000010de
0=z000010=a
0=z000010f6
0=z000010fc }

wold tutorial (woid)

long a[10]:

long 3

int 1

cla=s Sanple *p =an:

po=am= Sanple;
for({ 1=0; 1<10; i++ )9
i = randi):
1f03 <« 0){
1 = 1.
ali] = 3:

p_=an—=zort(a):
p_=amn—rchangel(al;

p =am—r=0=a[0]
p o=am—r=l=a[l]
p =am—r=2=al2]
p o=amn—r=3=al 3]
p =am—r=4=a[4];
p_=an—>=5=a[5]:
p =am—r=h=al[6];
p o=amn—r=7=al[7]
p =am—r=d=a[8]
p o=amn—r=9=a[9]
p_=amn;

Figure 6.8 [Source] Window (Break Status)
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The user can see the cause of the break that occurred last time in the [Status] window.

Select [Status] from the [CPU] submenu of the [View] menu. After the [Status] window is displayed, open
the [Platform] sheet, and check the St at us of Cause of | ast break.

_ (O] x|
Iten I Status I
Connected To: H2S5/2EZ37 ES000 Ewmulator CPU Z000 (Ewulator PCI Card Driver)
CPUT Ha5/ 2237

Mode 7

Clock =zource Main: 10MH=, Subk:3ZkHz

Dun status Ereak

Cause of last break PC EBreak

Event Time Count 00k O0min 00s 000ms 000us 000ns

Purn Time Count 00k O0min 00s 000ms 9EZ5us £Zfns

4] :IH Wemary  Platform £ Events J

Figure6.9 [Status] Window

Note: Theitemsthat can be displayed in this window differ depending on the product. For the itemsthat can
be displayed, refer to section 8, Software Specifications Specific to This Product, or the online help.
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6.7 Reviewing Breakpoints
The user can see dl the breakpoints set in the program in the [Event] window.

*  Select [Eventpoints] from the [Code] submenu of the [View] menu. The [Event] window is displayed. Select
the [Breakpoint] sheet.

1=
Type State | Condition I Action I

Program Enabhle PC=H'O0001070iTutorial.cpp/4d)] Break

| 4[> Breakpoint £ Event }, Trioger /

Figure6.10 [Event] Window

The popup menu, opened by clicking the [Event] window with the right-hand mouse button, allows the user
to set or change breakpoints, define new breakpoints, and del ete, enable, or disable breakpoints.
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6.8 Referringto Symbols
The [Label] window can be used to display the information on symbolsin modules.

Select [Label] from the [Symbol] submenu of the [View] menu. The [Label] window is displayed so that the user
can refer to the addresses of symbolsin modules.

=10 x|
EP Ija.ddress IName I -

H'ooooog00 PowerON_Reset i)

H'Oooolooo _sbrk

H'O0O001034 _main

H'O0O001038 tutorial )

H'O0OO001104 _abort

H'Oooolloc _ INITECT

H'OOO011Ez loopl

H'O0OO011ZC loopz

H'OOO0O11ZE next_loopZ

H'0000113z next_loopl oo

H'O0O001144 loop3

H'OO0O0l1&z loopd

H'O00o0llss next_loopd

H'Oooollsc next_loop3

H'Oo00lles operator new{unsigned lorng)

H'O0OO011EBE _ CALL_TNIT

H'OOOO11EO _ CALL_END

H'OOOOl1E4 operator delete{woid *)

H'O0OO011EE _rand

H'OOO0lzZ& _srand

H'O00O0lz3z $DIVLES

H'Ooooolz3c not_negk

H'oooolz44 not_neg¥

H'00O0124E not_negs LI

Figure6.11 [Labe] Window
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6.9 Viewing Memory

When the label name is specified, the user can view the memory contents that the label has been registered in the
[Memory] window. For example, to view the memory contents corresponding to _nai n in byte size:

e Select [Memory ...] from the [CPU] submenu of the [View] menu to enter _nmai n in the [Start address] edit
box and +# f inthe [End address] edit box, respectively, and to select Byt e in the [Format] combo box.

St Address llil
_mairn
I LCancel |
End:
|+
FEormat;
IBNEMH :J

Figure6.12 [Set Address] Dialog Box

e Click the [OK] button. The [Memory] window showing the selected area of memory is displayed.

I _ioix
Address Data YValue =
0x00001034 K5 02 40 FC 01 00 &6D F3 U.&...m.
0x0000103Cc 01 20 6D F4 72 37 00 28 LomL¥T L
0x00001044 OF F3 1a 80 5’5E 00 20 00 S
0x0000104C OF 86 192 44 5E 00 11 EE A + LA
0x00001054 17 FO OF 85 4Cc 02 17 BS PR AR
0x0000105¢ 17 F4 OF CO 10 70 o0& BO  ..... P--
0x00001064 01 00 69 85 OB 5h4 7% 24 LAl TS
0x0000106C 00 OA 4D EO OF EBS OF D1 LML L.
0x00001074 OF EO bBKE 00 20 &8 OF D1 AR S T
0x0000107C OF EO KE 00 20 D& 01 00 P
0x00001084 6% 50 01 00 &2 EO 01 00 iP..i...
0x0000108C 6F 50 00 04 01 00 BF EO oPF....o.
0x000010%4 00 04 01 00 &F 50 00 08 ....0P. .
0x00001092C 01 00 6F EO 00 08 01 00 A - T —
0x00001084 &6F K0 00 OC 01 00 &F EOQ oP....o0.
0x0000108C 00 OC 01 00 &F 50 00 10 ....0P..
0x00001084 01 00 6F EO 00 10 01 00 N T :J

Figure6.13 [Memory] Window
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6.10 Watching Variables

Asthe user steps through a program, it is possible to watch that the values of variables used in the user program
are changed. For example, set awatch on the long-type array a declared at the beginning of the program, by
using the following procedure:

» Click the left of displayed array a in the [Source] window to position the cursor.

e Select [Instant Watch...] with the right-hand mouse button.

Thefollowing dialog box will be displayed.

Instant Wakeh ﬂ ﬂ
- a § 0x00ffef80 } [long(10]] Cloze I
Add

Figure6.14 [Instant Watch] Dialog Box

e Click the [Add] button to add a variable to the [Watch] window.

Figure6.15 [Watch] Window (Displaying the Array)
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The user can also add a variable to the [Watch] window by specifying its name.

* Click the [Watch] window with the right-hand mouse button and select [Add Watch...] from the popup menu.

The following dialog box will be displayed.

Add ‘watch 2=
Wariable or expression; ak.

i Cancel |

Figure6.16 [Add Watch] Dialog Box

e Input variablei to[Variable or expression] edit box and click the [OK] button.

The [Watch] window will now also show the int-type variablei .

HITI00% { Fid }

Figure6.17 [Watch] Window (Displaying the Variable)
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The user can click mark ‘+' at the | eft side of array a in the [Watch] window to watch all the elements.

a
- [0] H'0000471c6 { D=00¢fef30 } flong]
R 1] H'00001 67 { Dw00ffefBd } flang)
R [ H'00002781 { 0w00ffefaR } (long]
B[ H'O000446b { 0x00ffef8c } (lang)
R4 H'DO00734b { 0<00ffef30 } flong)
B [5] H'00001 5fb | 0<00fef34 } {lang)
B [E] H'000059e2 { 0w00ff38 } flang)
N H'0000 b { 0xO0fefSc } (long]
B9 H'00003f54 { 0x00fefal ¥ (lang)
B9 H'00000FE § D«00ffefad } (lang]

i H'000a { R4 } [int]

Figure6.18 [Watch] Window (Displaying Array Elements)

312
RENESAS




6.11 Displaying Local Variables

The user can display locd variablesin a function using the [Locals] window. For example, we will examine the
local variablesinthet ut ori al function, which declaresfour local variables: a,j ,i ,and p_sam

* Select [Locals] from the [Symbol] submenu of the [View] menu. The [Locals] window is displayed.
The [Locals] window shows the local variablesin the function currently pointed to by the program counter,

along with their values. Note, however, that the [Locals] window isinitially empty because local varigbles are
yet to be declared.

i H'00fefa0 { ERS } flang)
-------- i H'O00a { R4 } (irt)
- p_sam 0+00ffb0d8 { ERE } [class Sample”)

Figure6.19 [Locals] Window

e Click mark ‘+' at the left side of array a in the [Locals] window to display the elements.
» Refer to the elements of array a before and after the execution of the sor t function, and confirm that
random data is sorted in descending order.
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6.12 Stepping Through a Program
The HEW provides arange of step menu commands that allow efficient program debugging.

Table6.1 Step Option

Menu

Command Description

Step In Executes each statement, including statements within functions.

Step Over Executes a function call in a single step.

Step Out Steps out of a function, and stops at the statement following the statement in the
program that called the function.

Step... Steps the specified times repeatedly at a specified rate.

6.12.1 Executing the [Step In] Command
The [Step In] command steps into the called function and stops at the first statement of the called function.

* To sep throughthesort function, select [Step In] from the [Debug] menu, or click the [Step In] button in
the toolbar.

™

Figure6.20 [Step In] Button
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Qx00002000 Sample: (Sample()
i

0=00002006
0x0000201c =0=0;
0=00002026 =s1=0;
0x0000202c =2=0;
0=00002032 s3=0;
0x00002038 =4=0;
0=z0000203e =5=0;
0x00002044 =h=0;
0=z0000204a =7=0;
O0x00002050 =8=0;
0=00002056 =9=0;
O0x00002060 1
0x000020643 orvold Sample: i=ortilong *a)
0=00002070 i
long t:
int i, j. k. gap:
0=00002072 gap = &;
0x=00002078 while{ gap » 0 }{
0=00002078 for{ k=0; k<gap: k++)q
0x0000207c for{ i=k+gap: 1<10; i=i+gap }{
0=00002080 for{j=i-gap: jr=k; j=j—gap)q
Ox00002084 if{aljlsalj+gapl i
t =al1]:
0x000020=4 alj]l = alj+gap]:
0=000020a8 al[j+gap] = t:
b
=l==
break;
¥
b
¥
0=000020c0 gap = gap-2;
0x000020cc 1

Figure6.21 [Source] Window (Step In)

* Thehighlighted line moves to the first statement of the sor t function in the [Source] window.
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6.12.2 Executing the [Step Out] Command

The [Step Out] command steps out of the called function and stops at the next statement of the calling statement
inthe mai n function.

» Tostepout of thesort function, select [Step Out] from the [Debug] menu, or click the [Step Out] button in
the toolbar.

19

Figure6.22 [Step Out] Button

=10 x|
2% Elle Edit Wiew Project Options Buld Debug Memory Tools Window Help - |E' 5[
DERd| &)=t oo @t 2ol E|w =1 &
oo e |“| Debug_Hes_2237_E6000 7 || [Sessioniies_a2a7_Eston x| | 74 4 | () [ | o i 8 o5 m CefBr & & 2 @ |
EFe+sBaaly|esalsen|mss||Gfulanees:.
| x| int 1; j
E@Wutmial— class Sanple *p_sam:
E-IF Tutorial 0=00001046 p_san= Sanple:
E\--a C source file 0=z0000104e for{ i=0; 1i<10; i++ ){
dbsct.c 0=00001050 3] = randi}:
ke 0x00001058 1f(3 < 034
- O0x0000105a J o= -3:
-+ zource file 3
%] resetprg.cpp 00000105 al1] = 3
sart.cpp ¥
s Ox00001070 L ] p_=san—>sort(a);
E‘a Dosrioad moles 0=z0000107a (53 r_san—:changesia):
o (4] Tutorial abs 000001082 p_san—3sl=a[0]
0=0000108a p_=an—:sl=all]
0x00001096 p_sam—:s2=al2]
0=z000010a2 p_=amn—:s3=al3]
0=000010&as p_san—>=zd=al[4]:
0=z000010ba p_san—>=5=a[5]:
0x000010c6 p_sam—:sb=a[6]
O=z000010d2 p_=zamn—:s7=al?]
O=000010de p_san—>=s8=a[8];
0=z000010sa p_san—:=z9=a[9]:
£ 0x000010£6 p_sam: -
L@ijeutsI@:Ilkla\figa.. 4 »
I Walue | Type I
E-B e { Dx00fFefB0 } [lomag[10])
LB HO0000fE { 0x00ffef80 (lang)
~R 0 H'000015¢b { 0x00fef34 [larg)
- H'0000167¢ { Dx00ifelg8 } [lang]
‘B3 H'00001 ofb { Ok00ffef3: [lag]
R[4 H'00002781 { 0x00ffef30 [larg)
‘R’ [ H'00003f54 { Dx00ifef34 } [long)
‘B K| H'000041 6 { 0x00ffef35 [larvg]
‘B [ H0000446b { Dx00fefde {long)
‘B ® H'00005%e2 { Dx00ffefal } [long]
SROME H'0000734b { 0x00ffefad [larvg]
i H'000a { R4} [int)
Break = Stepping Completed [Read-write  [45/64 1 s HUM 2

Figure6.23 [HEW] Window (Step Out)

The data of variable a displayed in the [Watch] window is sorted in ascending order.
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6.12.3 Executing the [Step Over] Command
The [Step Over] executes afunction call as a single step and stops at the next statement of the main program.

* To step through all statementsin the change function at asingle step, select [Step Over] from the [Debug]
menu, or click the [Step Over] button in the toolbar.

[0

Figure6.24 [Step Over] Button

{3 Tutorial - High-p nice Embeds [tutarial.cpp] N [=[Es]

< File Edit Miew Project Options Build Debug Memary Tools Window Help _|5|i|
Nedd(gsenoTal|lera@sco: 2 D@+ |H|w I &
oo e ® |“|Debug_H35_2237_EquU_j ||SewonHes_2237_Esuuu_j | 2 ‘@ = | £ B HJ& B & & & @ |
ERe+4 B8 a7 a|sen|m= || Gfeuaaneeo:.
= zl
[5& T O=00001046 D_san= Sanple;
@ Tuorisl 00000104 For( i=0: i<10: it++ }{
=-F Tutorial 0=00001050 i = rand():
23 T sourcs file 0=00001058 ifcj < 034
dbsct.c 0x0000105a J o= -3:
shik.c I .
. 0x0000105c alil = 3:
C++ source file T
Iesetpig.cpp 0x00001070 & p_san—:szort(a):
soi.cpp O=0000107a p_=zan->changeia);
cpp
: O=00001082 o p_=an—:=0=a[0]
£33 Download modules 0%00001085 Psam—isl=al[1]
b Tutorial abs 0=00001096 p_sam—:s2=al[2]
0=000010a2 p_sam—»=3=a[3]:
0=z000010as p_=an—:sd=ald];
0x000010ba p_sam—:s5=a[5]
0=z000010c6E p_=amn—:sh=alf]
0x000010d42 p_sam—:s7=al7]
0=z000010de p_=zan—:s8=a[8]
0x000010ea p_sam—:s9=a[9]
O=z000010f6 D_Sam:
0x0000104fc ¥
N EProjects I =1 Naviga... A _.l_l
5! Name I Walue | Type
T E-R e { 0w00ifef80 [long[10])
R0 H'0000754b { 0x00fef50 | {long)
-R M) H'00005%e2 { 0x00ffel34 } [long)
R [2 H'0000446b { 0x00ffef35 [long)
‘R[] H'000047 6 { Dx00feffe | [long)
‘B H'00003¢54 { 0+00ffef30 } [long)
B [ H'00002781 { 0x00ffef34 [long)
R [6] H'00001 fb { Dx00fef9a [lotg]
‘B[ H'00001 67e { 0x00ffefdc } [lonag)
B @ H'000015fb { 0x00ffefal [long)
-G H'0DOOOKE { Ox00ffefad } [long]
i H'000a { R4 } [irt]
Ready Read-write (4764 [ s WMz

Figure6.25 [HEW] Window (Step Over)
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6.13 Forced Breaking of Program Executions
The HEW can force a break in the execution of a program.
* Cancd all the breaks.

» To execute the remaining sections of thet ut ori al function, select [Go] from the [Debug] menu or the
[Go] button on the toolbar.

Ell

Figure6.26 [Go] Button

» The program goes into an endless loop. To force abreak in execution, select [Halt] from the [Debug] menu
or the [Stop] button on the toolbar.

Figure6.27 [Stop] Button

6.14 Resettingthe MCU

Resetting the MCU initializes the internal 1/0 registers and makes the program counter jump to the address set in
the reset vector.

To reset the MCU, select [Reset CPU] from the [Debug] menu or the [Reset CPU] button on the toolbar.

Ejj

Figure 6.28 [Reset CPU] Button

To execute the program from the reset vector, select [Reset Go] from the [Debug] menu or the [Reset Go] button
on the toolbar.

Figure6.29 [Reset Go] Button

Note: Thistutorial program is executable from the reset vector.
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6.15 Break Function

The emulator’s break functions are of two types: PC breaks and breaks at event points. PC breakpoints and
event points are set in the HEW' s [Event] window.

An overview and setting of the break function are described below.

6.15.1 PC Break Function
The emulator can set up to 256 PC breakpoints.

» Select [Eventpoints] from the [Code] submenu of the [View] menu. The [Event] window is displayed.
* Select the [Breakpoint] sheet.

ol Event —|O0]| x
wevet =10l x|

Tvpe dtate | Condition I Action I

[ 4]+ ] Breakpoint £ Event }, Trigger /

Figure6.30 [Event] Window (Before Setting a PC Breakpoint)

e Click the [Event] window with the right-hand mouse button and select [Add...] from the popup menu.
* The[Breakpoint/Event Properties] diaog box is displayed.

RENESAS
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Breakpoint/Event Properties

General

— Tupe
" P[EBreak

" Evert

21

Address
 Donb Care %) &ddrezs © Hange

bddress Lo 400001082
Address il 400000000

[T Outside Range

- Data Compare [irection—;
[ Compare = Wse ask | Bead
Walue [

- IHD 1 wiite
& Bute. £ wiod
Hask IH'D * Either

o]

Cancel

Figure6.31 [Breakpoint/Event Properties] Dialog Box

»  Check the [PC Break] radio button in the [ Type] group box.

» Usethe[Source] window to refer to the address on the line that has‘p_sam->s0=a[0];" within the
tutorial functionand enter thisaddressin the [Address Lo] edit box of the [Address] group box. In this

example, enter H 00001082.

Note: Thisdiaog box differs according to the product. For theitems of each product, refer to section 8,

Software Specifications Specific to This Product, or the online help.

e Click the [OK] button.

The PC breakpoint that has been set is displayed in the [Event] window.

Type State Condition

Program Enable

PC=H'00001082 (Tutorial.cpp/47)

| 4] =T Breakpoint /£ Event ) Trigger J

Figure6.32 [Event] Window (PC Breakpoint Setting)

Note: Theitemsthat can be displayed in this window differ depending on the product. For the itemsthat can
be displayed, refer to section 8, Software Specifications Specific to This Product, or the online help.
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* Close the [Event] window.

* To stop thetutorial program at the breakpoint, select [Reset Go] from the [Debug] menu.

The program runs until it stops at the breakpoint that has been set.

0=00001038
0x00001044

0=00001046
0=0000104e
0=00001050
O0=00001058
0x0000105&a

0=0000105z

0=00001070
0=0000107a

Ox00001082
0=0000108a
0x000010%96
0=000010a2
0x000010as
0=000010ba
0x000010ce
0=000010d2
0x000010de
0=z000010ea
0x000010fe
0=000010f=

wvolid tutorial{void)

1

¥

long a[l10]:;

long 3:

int 1i:

clas=s Samnple *p_sam;

p_=amn= Sample:;
for{ i=0; 1<10; i++ }{
] = rand():
1f(3 < 03{
1 = -1
ali1] = 3:

p_sam—r=ort(a):
p_samn—>change{a):

p_san—>=0=a[0]:
p_=samn—r=l=a[l]:;
p_san—:=2=al[2]:
p_samn—r=3=al[3]:
p_san—r=d=ald]:
p_=sam—:r=5=a[5]:
p_san—rzb=al[b]:
p_samn—:=7=a[7]:
p_san—>=8=a[8]:
p_samn—:=9=a[9]:
P_sam;

Figure 6.33 [Source] Window at Execution Stop (PC Break)

The [Status] window displays the following contents:

- Status

=0l x|

Ttem IStatus I

Connected To:

Mode 7
Clock source
Dun status Break

Event Time Count
Dun Time Count

Main: 10MH=,

Cause of last break PC Break
00k O0min O00s O00Oms O0COus O000ns
00k O0min O0s O0lms O02Zus S00ns

H22/2237 E&E000 Emulator CPU 2000 (Emulator PCI Card Driver)
CPTT HES/ 2237

Sub: 3ZkH=

4] Memary }, Platform # Events f

Figure 6.34 Displayed Contents of the [Status] Window (PC Break)

Note: Theitemsthat can be displayed in this window differ depending on the product. For the itemsthat can
be displayed, refer to section 8, Software Specifications Specific to This Product, or the online help.
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6.15.2 Breaking Execution at Event Points

Setting up of an event point on event channel 1 (Ch1) such that abreak is triggered when the event point’s
conditions have been satisfied five timesis explained as an example of the use of event points.

* Select [Eventpoints] from the [Code] submenu of the [View] menu. The [Event] window is displayed.

» Thebreakpoint that has been previously set must be deleted. Click the [Breakpoints] window with the right-
hand mouse button and select [Delete All] from the popup menu to delete all the breakpoints that have been
Set

e Click the [Event] tab.

Up to 12 event points (eight event channels and four range channels) can be set up as independent conditions. In
this example, we are setting the condition for event channel 1.

=1

Ch% (R) Eupty
Chlo(R) Ewpty
Chll (R} Eupty
Chlz (R) Ewpty

4[> T, Breakpoint ), Event /£ Trigoer f

Figure6.35 [Event] Window (Event Channel 1 [Ch1])

* Select thelinefor Chlin the [Event] window. Double-click on thisline that is highlighted.

* The[Breakpoint/Event Properties] diaog box is displayed.

* Make the following settingsin the boxes on the [General] page:
Select the [Event] radio button in the [Type] group box.
Select the [Address] radio button in the [Address] group box. Then use the [Source] window to refer to the
address on the linethat has ‘g[i]=j;" withinthet ut ori al function and enter this addressin the [Address
Lo] edit box. In this example, enter H 0000105c.

* Enter D' 5 asthe number of times the event condition isto be satisfied in the [Required number of event
occurrences] edit box on the [Action] page.
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Breakpoint/Event Froperties 2=

General |Bus / twea | Signals | Action |

— Type Address
" PC Break " Don't Care @ Addiess ¢ Fange

Address Lo [
& Evert = . | H'00001 05

Address B [H00000000

[T Outside Fange

— Data Compare Direction——
[ Compare 7| Wse Mask " Read
Walue [
- IHD £ Wdrite
¢ Bute € Word
pask IH'D * Either

Ok, I Cancel |

Figure6.36 [General] Page ([Breakpoint/Event Properties] Dialog Box)

* Click the [OK] button. The [Event] window is displayed, as shown below.

_lglx
Type State Condition I Action I
Chl (E) Enable Address=H'0000105C (Tutorial.cpp/d2) address count 'S Break

Chz (E) Enpty

Chi (E) Enpry

Chd (E) Enpty

Chs (E) Enpty

Cht (E) Enpry

Ch7? (E) Enpty

Chi (E) Enpty

ChY (R] Enpry

Chl0(R) Enpty

Chll (R} Eupty

ChlZ (R} Eupty

A>T Breakpaoint p Event £ Trigoer f

Figure 6.37 [Event] Window (Setting Completed)

Note: Theitemsthat can be displayed in this window differ depending on the product. For the items that can be
displayed, refer to section 8, Software Specifications Specific to This Product, or the online help.

Select [Reset Go] from the [Debug] menu to stop the tutorial program at breakpoints.

The program runs then stops at the condition specified under Ch1.
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0=00001038

0=z00001044

long a[107]:

long 3@

int 1

claz=z Sanple *p _=am;
0=00001046 D_=am= Sample;
0=z0000104e for{ i=0; 1<10; i++ ){
0=z00001050 i = randi):
O=z00001058 if{3 < 03
0=z0000105& i = =3

1

0=z0000105: | d o> al[i] = 3:

wold tutorial{void)

0=00001070 p =am—r=ortia);
0=0000107a p_=zan—:>change(a);
O=z00001082 p_=zan—:=0=a[0];
0=0000108a p =am—r=l1=a[l]:
0=00001096 p_=zan—:=2=al[2];
0=000010a2 p =am—r=3=al[3];
0=z000010as p_=zan—>sd=ald];
0=000010ba p =am—r=5=a[5];
0=z000010ck p_=zan—:s=6=al&];
O0=000010d2 p =am—r=7=al[7].
0=z000010de p_=zan—:>=8=a[8]:
0=000010ea p =am—r=9=a[9];
0=z000010f6 p_=amn;
0=z000010fc ¥

Figure 6.38 [Source] Window at Execution Stop

The [Status] window displays the following contents.

Ttem IStatus

=101 x|

Connected To:
CPUT

Mode

Clock source
Lun status

Event Time Count
Lun Time Count

H22,72227 E6000 Emulator CPU 2000 (Emulator PCI Card Driwver)

H35/ 2237

7

Main:10MH=, Sub:3ZkH=
Ereak

Canse of last break Complex Ewvent Svystem

O0h O0min 00s 000ms O000us O000ns
O0h O0min 00s 000ms 738us 750ns

AT Memaory ) Platform f Events /

Figure 6.39 Displayed Contentsof the [Status] Window

Refer to the [Watch] window for the value of variablei . Thevalueis 4, indicating that the break occurred after
the condition had been satisfied five times.

Note: Theitemsthat can be displayed in this window differ depending on the product. For the items that can be
displayed, refer to section 8, Software Specifications Specific to This Product, or the online help.

Remove the event point. Clicking the right-hand mouse button on the [Event] window displays a popup menu.

Select [Remove All] from this menu to remove all event points.
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6.16 Trace Functions

The trace functions of the emulator use the realtime trace buffer, which is able to store the information on up to
32,768 bus cycles. The content of this buffer, which is constantly updated during execution, is displayed in the
[Trace] window.

Select [Trace] from the [Code] submenu of the [View] menu to display the [Trace] window.

=]

PTR Address | Tnatruction |Data |R/U |Area ‘Status Clock | Probes ‘N]{I |IRO?*D Tinestaup | Source |Lahel |

Figure6.40 [Trace] Window

When trace information is displayed in the [Trace] window, clicking the right-hand mouse button on the [Trace]
window displays a popup menu. Select [Clear] from this menu to clear the trace information.

The following sections give an overview of the trace functions and methods for setting them.
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6.16.1 Displaying a Trace (when Time Stamping isnot Available)

The method used to specify an address as an event condition for the tracing of read/write cycles and display the
traceis described below.

(2) Clicking the right-hand mouse button on the [ Trace] window displays a popup menu. Select [Acquisition...]
from this menu to display the [Trace Acquisition] dialog box.

Trace Acquisition il il

General IStop I Delayed Stopl

—Suppress—————— Tirme Stamp
¥ Free Trace

Clock:

[~ DIC Cycles I Dizabled - l

[~ Befrash Cycles

r Trace Ewent:

Exwent:

~

add.. | Edi. Semuence.. Delee | | Dl |

ak. I Cancel

Figure6.41 [Trace Acquisition] Dialog Box
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(2) Regigter an address as an event condition for trace acquisition. Click the [Add...] button in the [Trace
Events] group box on the [General] page to display the [Breakpoint/Event Properties] dialog box.

Breakpoint/Event Properties 2=

Gieneral |Bus / twea | Signals | Action |

— Type Address
) EC Break " Don't Care @ Address ¢ Range
............... Address Lo [

& Evert . |H00000000

Address B [H00000000

[T Outside Fange

— Data Compare Direction——
[ Compare 7| Wse Mask " Read
Walue [
- IHD £ Wdrite
¢ Bute € Word
pask IH'D * Either

Ok, I Cancel

Figure6.42 [Breakpoint/Event Properties] Dialog Box

(3) Use the [Source] window to refer to the address on the line that has ‘g[i]=j;’ withinthet ut ori al function
and enter this addressin the [Address L o] edit box of the [Address] group box on the [General] page of the
[Breakpoint/Event Properties] dialog box. In this example, enter H 0000105c. This address has thus been
set. Click the [OK] button to close the [Breakpoint/Event Properties] dialog box.

Breakpoint/Event Properties 2=

Gieneral |Bus / twea | Signals | Action |

~ Twpe Address
) EC Break " Don't Care @ Address ¢ Range

AddressLa |H'0000 05C

{* Ewent .
Address B [H00000000
[T Outside Fange
— Data Compare Direction——
[ Compare 7| Wse Mask " Read
Walue IH'D

£ Wdrite

¢ Bute € Word
bask|HD

Ok, I Cancel |

Figure 6.43 [Breakpoint/Event Properties] Dialog Box (after Setting an Event)
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(4) The event that has been set is now displayed in the [Event] combo box of the [Trace Events] group box on
the [General] page of the [Trace Acquisition] dialog box.

Trace Acquisition ﬂﬂ
General | Stop | Delayed Stop |
—Suppress————— Time Stamp
¥ Eree Trace
[~ DMAL Cycles Clack:
I DIC Cycles IDisabIed M|
[ Eefresh Cycles
— Trace Events
Ewent:
{3 (R] H105C address |
Edit... Sequence,.. Delete | Del &l |
ak. | Cahicel |

Figure6.44 [Trace Acquisition] Dialog Box (Adding an Event)
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(5) To enable the event condition that has been set, uncheck the [Free Trace] check box on the [General] page.
Thiswill add pages[1] to [4] to the [Trace Acquisition] dialog box.

Trace Acquisition ilil
General |Stop | DelapedStop| 1 |2 |3 |4 |
—Suppress———————— Time Stamp

[~ DMAC Cycles Clack:

[~ DIC Cycles IDisabIed 'l

[ Refresh Cycles

 Trace Events

Exent:
|9 [R] H'105C address =]
bgd.. | Ed. Sequence.. Delte | Delal |

0K I Cancel |

Figure6.45 [Trace Acquisition] Dialog Box (Pages Added)
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(6) Select page [1] and click the [Range] radio button in the [Conditions] group box. Thiswill display the [Range
Event] combo box and the [Edit...] button.

Trace Acquisition 2l x|
General | Stop I Delayed Stop 1 |2 I 3 I 4 I

r— Conditions

" Disabled " Paint to Point

Fianae Ewent

0K I Cancel |

Figure6.46 [Trace Acquisition] Dialog Box (Displaying Page [1])
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(7) Select the event you have registered from the [Range Event] combo box. The event is now enabled. Click the
[OK] button to complete the trace setting.

Trace Acquisition 2=
Gerneral I Stop I Delayed Stop 1 |2 I 3 I 4 I

r— Conditions

" Disabled " Puint to Point ' Range " Ewent

Range Event Edi... |

ak. I Cahicel |

Figure 6.47 [Trace Acquisition] Dialog Box (Setting Completed)

(8) Make the setting such that the break occurs after the instruction at the address on the line that has *&i]=j;’
withinthet ut ori al function (H 0000105C in this example) has been executed five times (for details on
this, refer to section 6.15.2, Breaking Execution at Event Points).

(9) Select [Reset Go] from the [Debug] menu. Processing stops when the break condition is satisfied, and the
[Trace] window then displays the following content.

o Generic Trace =10 5[
FTR ‘ Address | Instruction | Data | R/ ‘ Area ‘ Status | Clock Probes | NMI | IRQ7-0 Tinestamp | Source ‘ Label ‘
-00004 00105c EXTS.L ERd 174 RD ROM FROG 1 1111 1 11111111 af[il = 37
-00003 00105c EXTS.L ER4 17f4 RD ROM FROG 1 1111 1 11111111 a[i] = 3;
-00002 00105c EXTS.L ER4 17f4 ERD ROM PROG 1 1111 1 11111111 af[i] = 3:
-00001 0010%5c EXTS.L ER4 174 FRD ROM PROG 1 1111 1 11111111 alil = 3!
400000 00105c EXTS.L ER4 17f4 RD ROM FROG 1 1111 1 11111111 a[i] = 3;

Figure6.48 [Trace] Window (Displaying the Result)

If you have trouble viewing a column, drag the header (vertical) bars below the title bar to adjust the width
of the column.

(10) Remove the event points that have been set and clear the trace information. Click the right-hand mouse
button on the [Event] window to display a popup menu. Select [Delete All] from this menu to remove all of
the event points that have been set. Click the right-hand mouse button on the [Trace] window to display a
further popup menu. Select [Clear] from this menu to clear the trace information.
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6.16.2 Displaying a Trace (when Time Stamping is Available)

The following procedure is for obtaining and displaying, with time stamps, trace information on cycles of
writing to memory locations in the specified address range.

(1) Clicking the right-hand mouse button on the [ Trace] window displays a popup menu. Select [Acquisition...]
from this menu to display the [Trace Acquisition] dialog box (see figure 6.41, [Trace Acquisition] dialog
box).

(2) Register the address range for trace acquisition as an event condition. Click the [Add...] button in the [Trace
Events] group box on the [General] page to display the [Breakpoint/Event Properties] dialog box (see figure
6.42, [Breakpoint/Event Properties] dialog box).

(3) Click the [Range] radio button in the [Address] group box on the [General] page of the [Breakpoint/Event
Properties] dialog box. Use the [Locals] window to refer to the address on the line where variable a, which is
defined withinthet ut ori al function, isallocated (H OOFFEF80 in this example) and enter this address
in the [Address Lo] edit box. Then enter an address, which is H' 27 added to that entered in the [Address L o]
edit box (H O0FFEFAY in thisexample), in the [Address Hi] edit box. This procedure sets the memory
range for variable a of thet ut ori al function.

(4) Click the [Write] radio button in the [Direction] group box to set awrite cycle for the specified range. This
completes the setting of a memory range. Click the [OK] button to close the [Breakpoint/Event Properties]
dialog box.

oint/Event Properties 2=

General |Bus / twea | Signals | Action |

~ Twpe Address
) EC Break " Don't Care ¢ Address  Range

Address L |H'0OFFEFAD

{* Ewent .
AddiessHi - [H'ODFFEF&7
[ Outside Fange
— Data Compare Direction——
[ Compare 7| Wse Mask " Read
Walue IH'D

¢ Bute € Word
bask|HD

" Either

Ok, I Cancel |

Figure 6.49 [Breakpoint/Event Properties] Dialog Box (after Setting an Event)
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(5) The event that has been set in the [Event] combo box of the [Trace Events] group box on the [General] page

of the[Trace Acquisition] dialog box is displayed.

Trace Acq

General I Stop I Delayed Stopl
— Suppress Tirme Stamp
[~ DMAC Cycles
[~ DIC Cycles

[~ Befrash Cycles

Clock:

IDisabIed 'l

¥ Free Trace

2|

r Trace Ewent:

Exwent:

IS [R) H'FFEF20 range to H'FFEFAT write

Edit... Seguence,..

Delete |

pelal |

~

ok |

Cancel |

Figure6.50 [Trace Acquisition] Dialog Box (Adding an Event)

(6) To enable time stamping, select 125ns from the [Clock] combo box of the [ Time Stamp] group box.

Trace Acq

General I Stop I Delayed Stopl
— Suppress Tirme Stamp
[~ DMAC Cycles
[~ DIC Cycles

[~ Befrash Cycles

Clock:

¥ Free Trace

2|

r Trace Ewent:

Exwent:

IS [R) H'FFEF20 range to H'FFEFAT write

~

sdd.. | Ede. Semuence.. Delte | Delal |
Ok I Cancel |

Figure6.51 [Trace Acquisition] Dialog Box (Time Stamping is Available)

RENESAS

333




(7) To enable the event condition that has been set, uncheck the [Free Trace] check box on the [General] page.
Thiswill add pages[1] to [4] (see figure 6.45, [Trace Acquisition] dialog box).

(8) Select page [1] and click the [Range] radio button in the [Conditions] group box. Thiswill display the [Range
Event] combo box and the [Edit...] button (see figure 6.46, [Trace Acquisition] dialog box).

(9) Click the [Range Event] combo box to select the event you have registered. The event is now enabled. Click
the [OK] button to complete the trace setting.

ce Acquisition ﬂ ll

General I Stop I Delayed Stop 1 |2 I 3 I 4 I

— Conditions

" Dizabled = Paint to Point {* Hange " Ewent

Fange Ewvent Edit... |

QK. I Cancel |

Figure6.52 [Trace Acquisition] Dialog Box (Setting Completed)

(10) Make the setting such that the break occurs after the instruction at the address on the line that has ‘p_sam-
>30=g[0];" withinthet ut ori al function (H 00001082 in thisexample) (for details on this, refer to
section 6.15.1, PC Break Function).

(11) Select [Reset Go] from the [Debug] menu. Processing stops when the break condition is satisfied, and the
[Trace] window then displays the following content.

o Generic Trace g [= 3]

PTR | Address | Instruction | Data ‘ BT | Area | status | Clock | Probes ‘ HMT | IRQ7-0 | Timestamp | Sour &

-00087 ffefan aoog R 0000h000nin000s000ns738us575ns

-00086 ffefsz 4lce R 0000k000Rin000s0000s735u3000ns

-00085 f£fefdd aooo WR 0000k000Rin00050000s755u537 508

-00084 ffefad 167e TR 0000h000nin000s000ns755%us500ns

-00083 f£fefdd aooo R 0000k000Rin000s000Rs775Us6750s

-00082 ffefda 278l WR 0000h000Rin000s000ns760us000ns

-00081 ffefac aoog R 0000h000nin0005000ns800U3375ns

-00080 ffefie 4d6b  WR 0000k000Rin00050000s800us500ns

-00079 f£fefan oooo WR 0000h000nin000s000ns820uss75ns

-00078 ffefsz 794h TR 0000h000Rin0005000ns821us000ns

-00077 ££ef3d aooo WR 0000k000Rin000s0000s84lus375ns

-00076 ffef9s 15fh TR 0000h000nin000s000ns841us375ns

-00075 £Eefds aooo WR 0000k000Rin000s000Rs861us875ns

—‘EIIUEI'}HI ffeffa a9e2  WR UEIUEIhEIUUmanUUSEiUUmSEGluSB?SnS . i
v

Figure6.53 [Trace] Window (Displaying the Result)

If you have trouble viewing a column, drag the header (vertical) bars below the title bar to adjust the width
of the column.
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(12) Remove the event points that have been set and clear the trace information. Clicking the right-hand mouse

button on the [Breakpoints] window displays a popup menu. Select [Delete All] from this menu to remove
all the event points that have been set. Clicking the right-hand mouse button on the [ Trace] window
displays afurther popup menu. Select [Clear] from this menu to clear the trace information. To disable time
stamping, select Disabled in the [Clock] combo box of the [Time Stamp] group box on the [General] page
of the[Trace Acquisition] dialog box.

6.16.3 Statistics

The number of times the internal RAM has been written to can be included in the acquired trace information.

(@)

@

(©)

Make the setting such that a break occurs at the address on the line that has ‘p_sam->s0=a[0];" within the
tutorial function (H 00001082 in thisexample) (for details on this, refer to section 6.15.1, PC Break
Function).

Select [Reset Go] from the [Debug] menu. Processing stops when the break condition is satisfied, and the
[Trace] window then displays trace information.

Select [Statistic...] from the popup menu that is displayed when you click the right-hand mouse button on
the [Trace] window. A message box appears, indicating that the trace datais being loaded, and the
[Statistic] dialog box will be displayed.

Skatistic

= (s
x

Eiesult
[Clear
Result :
Condition | ArnoLint | PTR
KN I

Cloze

L.

Figure6.54 [Statistic] Dialog Box
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(4) Select R/W in the [Item] combo box and enter WR in the [Start] edit box. After that, click the [New] button.
“R/W=WR”" is now displayed in the [Condition] column of the [Result] list box.

! 21x
— Statiztic Analysis
{* Default © Fange Set
ltem IF!N\-" ﬂ
Start : IWH
Bezult |
End :I
Clear |
Result :
Condition | Amount | FTR
R =R
KN I i
Close |

Figure6.55 [Statistic] Dialog Box (New Condition)
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(5) Then, select Areafrom the [Item] combo box and enter RAM in the [Start] edit box. After that, click the
[Add] button; the new condition is now added to the “R/W=WR” display in the [Condition] column of the
[Result] list box, so that it now shows*“R/W=WR & Area=RAM". This completes setting of the condition.

— Statiztic Analysis

{* Default © Fange

ltem : farea |
Start : IHAM

End |

Result:

Candition | Amount | PTR

RAw'=wR & Area=RaM

K i
Close |

Figure6.56 [Statistic] Dialog Box (Condition Added)
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(6)

To start statistical analysis of the specified condition, press the [Result] button. The number of write
operations that satisfy the condition and the PTR values will be displayed.

: 21x]
— Statiztic Analysis
¢ Default © Hanoe Set
ltem I.&rea ﬂ
Start : IHﬂM
End : |
Clear |
Result :
Condition | Amount | FTR
RAw'=w R Area=RAM 1114 -09063,-09058,-0905:
N I i
Close |

U]
®)

338

Figure6.57 [Statistic] Dialog Box (Result of Analysis)

Click the [Close] button to close the [Statistic] dialog box.

Remove the event points that have been set and clear the trace information. Clicking the right-hand mouse
button on the [Event] window displays a popup menu. Select [Delete All] from this menu to remove al the
event points that have been set. Clicking the right-hand mouse button on the [Trace] window displays a
further popup menu. Select [Clear] from this menu to clear the trace information.
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6.16.4 Function Calls
This mechanism is used to only collect trace information on the function calls.

(1) Make the setting such that a break occurs at the address on the line that has ‘p_sam->s0=a[0];” within the
tutorial function (H 00001082 in thisexample) (for details on this, refer to section 6.15.1, PC Break
Function).

(2) Select [Reset Go] from the [Debug] menu. Processing stops when the break condition is satisfied, and the

[Trace] window then displays trace information.
(3) Select [Function Call...] from the popup menu displayed by clicking the right-hand mouse button on the
[Trace] window. The [Function Call Display] diaog box will be displayed.

Furiction Call Display e |
Setting

Enable ta dizplay trace information with function
call only 7

{~ Enable

0K | LCancel |

Figure 6.58 [Function Call Display] Dialog Box

(4) Click the [Enable] radio button and then the [OK] button. Only the information on function callsis now
displayed in the [Trace] window (the [Label] column’s right-side boundary has been moved to the left in the
[Trace] window to show the function calls).

Wl GEneric Trace _I_I— o 5'
Label | PR | add...| Instruction | pata| /| Area| Status | Clock | Probes | mmMr | IRo7-0 |-
PowerOl_Reseti) -09108 000400 MOV.L #H'00FFEFCO,ER? 7a07 FD EROM  PROG 1 1111 1 11111111
_main -03582 001034 BSR Btutorialij:s 550z FD EROM  PROG 1 1111 1 11111111
tutorial|) -03578 001038 MOV.L ER3,B-ER7 0100 R ROM  PROG 1 1111 1 11111111
Sample: :Sauple(] ~03558 002000 MOV.L ERZ,B-ER7 0100 RD ROM  PROG 1 1111 1 11111111
_shrk 03369 001000 STHLL (ER2-ER3),B-5P 0Ll0 RD ROM PROG 1 1111 1 11111111
Sawple::sortilong *) -01667 002068 STM.L (ERZ-ER3) ,@-5P 0110 ED ROM PROG 1 1111 1 11111111
Sawple: :change (long %) -00469 002046 MOV.L ER3,B-ER7 0lo0 RD ROM PROG 1 1111 1 11111111
4 I

Figure6.59 [Trace] Window (Function Calls)

(5) Toreturnthedisplay in the [Trace] window to its previous state, follow the procedurein (3) to display the
[Function Call Display] dialog box. Click the [Disable] button and then the [OK] button.

(6) Remove the event points that have been set and clear the trace information. Clicking the right-hand mouse
button on the [Breakpoints] window displays a popup menu. Select [Delete All] from this menu to remove
all the event points that have been set. Clicking the right-hand mouse button on the [ Trace] window displays
a further popup menu. Select [Clear] from this menu to clear the trace information.
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6.17 Stack Trace Function
The emulator uses the stack’ sinformation to display the function call history.

Notes: 1. Thisfunction can be used only when the load module that has the Dwarf2-type debugging
information isloaded. Such load module is supported in H8S, H8/300 C/C++ compiler V4.0 or later.

2. For details on the stack trace function, refer to the online help.

* Double-click the [Editor] columninthesort function and set a PC breakpoint.

0=00002068 wold Sample: isortlong *a)
O=00002070 i
long t;
int 1., j. k. gap:
Oxz00002072 gap = 5:
0=x00002076 while{ gap > 0 )4
0=00002078 for{ k=0: k<gap: k++){
0x000020%7c for{ i=k+gap; 1<10; i=i+gap }{
0z00002080 for{j=i—gap; j:=k. j=j-gap){
0=z00002084 » if{aljlrali+gapli{

t = aldil:
0x000020a4 ali] = alj+gapl:
0x000020a8 alj+gap] = t;

h

else

brealk
1
h
H

0=z000020=0 Jqap = gaps2:
0=z000020cc T

Figure 6.60 [Source] Window (PC Breakpoint Setting)

* Select [Reset Go] from the [Debug] menu.

» After the break in program execution, select [Stack Trace] from the [Code] submenu of the [View] menu to
open the [Stack Trace] window.

=10l x|
Kind |Name |Value |
F Sanple: sort(long *) { 0=00002084 %
F tutorial() { 0=x0000107a 7}
F maini) { 0=00001036
F PowverON_Re=et () { 0=0000041e

Figure6.61 [Stack Trace] Window

Figure 6.61 shows that the position of the program counter is currently at the selected line of thesor t ()
function, and that thesor t () functioniscaled fromthet ut ori al () function.

To remove the PC breakpoint, double-click the [Editor] columninthesort function again.
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6.18 Performance M easurement Function
Performance measurement by the emulator isin the following modes:

e Time Of Specified Range Measurement

e Start Point To End Point Measurement

. Start Range To End Range Measurement

e Access Count Of Specified Range Measurement
e Called Count Of Specified Range M easurement

In thistutorial, we describe the Time Of Specified Range Measurement.

6.18.1 Time Of Specified Range M easur ement

(1) Select [Performance Analysis] from the [Performance] submenu of the [View] menu to display the [Select
Performance Analysis Type] dialog box.

Select Performance Analysis Tvpe

Perfarmance Analysis: EE000 Perfarmance Analysis

LCancel

Figure6.62 [Select Performance Analysis Type] Dialog Box

(2) Select “E6000 Performance Analysis’ from the [Performance Analysis] combo box in the [Select
Performance Analysis Type] dialog box and click the [OK] button. The [Performance Analysis] window will
be displayed.

4 Performance Analysis (=] 3]
No Name | condition |pare | pw-TImE | max-nrH-TINE Count | o---10---20---
1
2
3
a
5
6
7
8
4 | |

Figure6.63 [Performance Analysis] Window
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(3) Select the line of the [Performance Analysis| window that has 1 in its [No] column and click the right-hand
mouse button to display a popup menu. Select [Set...] from this popup menu to display the [Performance
Analysis Properties] dialog box.

Performance fnal Properties

tMeasurement Method PaT: Tirme OF 5

Range Mame : |PA1
Range

Start Address : IH'DDDDDDDD _I
End Address IH'DDDDDDDD

r— Cormmon Settings of Performance[Pal-8)

Addrezz Control Mode: Prefetch Settings... |
Time Meazurament Unit: 160ns
Cancel |

Figure6.64 [Performance Analysis Properties] Dialog Box

(4) Select Time Of Specified Range Measurement from the [Measurement Method PA1] combo box.
(5) The parameter settings are as follows.

Enter “sort” in the [Range Name] edit box.

Click the[...] button to the right of the [Start Address] edit box to display the [Input Function Range]
dialog box. Enter the function name “sort” in the [Function] edit box of this dialog box and then click
the [OK] button. The corresponding addresses for the function “sort” will now be set in the [Start
Address] and [End Address] edit boxes.

Inpuk Function Range

2l
Function

zort Cancel

Note:

342

Figure6.65 [Input Function Range] Dialog Box

The addresses figured out in the [Input Function Range] dialog box are just for reference. In some cases,
the end address of a function may be different. Check the last instruction of the function in the
[Disassembly] window to correct the value set in [End Address] so that it will be the address of the last
instruction (in general, the last instruction of a functionisa RTS instruction). A label name or an
expression can be entered instead of an address value in boxes where an address should be entered.
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(6) Click the [Settings...] button in the [Common Settings of Performance(PA1-8)] group box to display the
[Common Settings of Performance(PA1-8)] dialog box. Select [PC] from the [Address Control Mode] combo
box and then click the [OK] button. PC is now displayed in the [Address Control Mode] text field of the
[Common Setting of Performance(PA1-8)] dialog box.

Common Settings of PerformanceiPal-g) ﬂ il

Address Control Mode PC -
Time Measurement Unit |1BDns j T |

Figure6.66 [Common Setting of Performance(PA1-8)] Dialog Box

(7) Click the [OK] button to display the content that has been set for line 1 of the [No] column in the
[Performance Analysis] window. This completes the settings for a Time Of Specified Range Measurement.

< Performance Analysis ;IEIEI
No Neme | Condition |rate | pmw-TDE | 1 mIn-TIHE | Count | 0-—-10-——z0-——30-—
1 sort Range H'OD002068 H'000020D4 D% D0k D0min 0Dz 000ms O00us 000ns

2

3

P

5

6

7

8

4 | |

Figure6.67 [Performance Analysis] Dialog Box (Setting Completed)

(8) Set an event point at the address on the line that has ‘p_sam->change(a);’ withinthet ut ori al function
(H 0000107 inthisexample) so that a break occurs when the specified sor t function has been executed
three times (refer to section 6.15.2, Breaking Execution at Event Points).

(9) Select [Reset Go] from the [Debug] menu. Processing stops when the break condition is satisfied, and the
[Performance Analysis] window then displays the information shown below. The vaue shown in the [Count]
columnis 3, which indicates that the sor t function has been executed three times and the execution time.

- Performance Analysis o =[]
Ho Hame | Condition | Rate RIN-TINE | muc-mrn-TonE | coune | 0---10---20---30---
L sort Renge H'OOD0Z068 H'0000Z0D4  18% 00h 00min 00s O0Oms 352us 480ns 3 FREEEEEEE

2

3

a

5

6

7

8

1| | i

Figure 6.68 [Performance Analysis] Dialog Box (Displaying the Result)

(10) Delete the setting for performance analysis and remove the event point. Click the right-hand mouse button
on the [Performance Analysis] window to display a popup menu. Select [Reset All] from this popup menu to
delete all of the settings. Clicking the right-hand mouse button on the [Event] window also displays a popup
menu. Select [Delete All] from this popup menu to remove all the event points that have been set.

343
RENESAS




6.19 Monitor Function

The emulator allows monitoring of the content of specified addresses in memory during execution of the user
program. In this example, we monitor the content of the address range where variable a of thet ut ori al
function is stored.

(1) Select the [CPU] submenu from the [View] menu. Then selecting [Monitor Setting...] from the [Monitor]
submenu displays the [Monitor Setting] dialog box.

21|
Manitor Setting I
Mame: |rnonitor1
— Dptiohz
Address: |H'DDDDDDDD
Size [byte): |Hzn =]
Access [Eormat): I BYTE [ASLCI) ﬂ

[V Auto-Refresh at rate [ms] : ID'DDEDD

[V Reading the Initial alue

r— Colar
Change Indicatar: I Change j
Foreground: [N |~ Backgound: [ ] IvI
[ gy
— Detail
lDETAIL MWOT SUPPORTED! Detail |
— Histary

Ok I Cancel |

Figure6.69 [Monitor Setting] Dialog Box
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(2) Set theitemsin the [Monitor Setting] dialog box as follows:
e Enter monitorl in the [Name] edit box.
e Setthe parametersin the [Options] group box as follows:
(@) Usethe[Locas] window to refer to the address on the line where variable a, which is defined within

thet ut ori al function, isdlocated and enter this address in the [Address] edit box. In this example,
enter H OOFFEF80.

(b) Enter H 50 inthe[Size] edit box.
(c) Select BYTE (HEX) from the [Access| combo box.
(d) Check the [Auto-refresh at rate (ms)] check box and enter D' 00500.
(e) Check the [Reading the Initial Vaue] check box.
e Setthe parametersin the [Color] group box as follows:
(a) Select Change from the [Change Indicator] combo box.
(b) Select red and white in the [Foreground] and [Background] combo boxes, respectively.
(c) Check the [Mayfly] check box.

Note: Depending on the operating system in use, the foreground and background colors may not be selectable.

Monitor Setking 2x|
M anitar Setting |
Mame: Imonitnr'l
— Optionz
Address: |H'DDFFEF8IZI
Size (byte]: [H'50 =]
Aecess [Fomat]: IBYTE HEX] j

¥ Auto-Refresh at rate [ms) : ID'DDEDD

[¥ Reading the Initial Yalue

— Colar
Change Indicator: IEhange ﬂ
Foreground: _Ivl B ackground: |:||v|
v Maptly
— Detail
lDETﬁIL MOT SUPPORTED! [Deta |
— Histary

| |
ak I Cancel |

Figure6.70 [Monitor Setting] Dialog Box (Setting Completed)
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(3) Click the [OK] button to open the [Monitor] window.

«# monitar; monitorl - H'OOFFEFS0

Addre=ss

0x00FFEFB0
0x00FFEF &8
0x00FFEFS0
0x00FFEF 38
Ox00FFEFAQ
0xQ00FFEFAB
Ox00FFEFBO
0xQ00FFEFEB
Ox00FFEFCO
0xQ00FFEFCSB

Data

Q0
00
Q0
00
Q0
00
Q0
00
ah
6h

00
00
00
00
00
FF
00
00
18
18

19
44
3F
ic
15
BO
Q0
10
ah
6h

4B
aB
54
FB
FB
D8
oa
34
18
18

Q0
00
Q0
00
Q0
00
Q0
00
ah
6h

00
00
00
00
00
FF
FF
00
18
18

=101 %]

59
41
27
14
oF
EF
EF
04
ah
6h

E2
Ccé
81
7E
Fa
80
80

18
18

| ¥
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Figure6.71 [Monitor] Window
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(4) Select [Reset Go] from the [Debug] menu. When the content of the address range changes with execution,

the updated values are red (i.e. the color that was selected in the [Foreground] and [Background] combo
boxes). Valueswill be displayed in black if they have not been updated or a certain period of time has

elapsed since the last update.

«# monitar; monitorl - H'OOFFEFS0

Addre=ss

0x00FFEFB0
0x00FFEF &8
0x00FFEFS0
0x00FFEF 38
Ox00FFEFAQ
0xQ00FFEFAB
Ox00FFEFBO
0xQ00FFEFEB
Ox00FFEFCO
0xQ00FFEFCSB

Data

Q0
00
Q0
00
Q0
00
Q0
00
ah
6h

00
00
00
00
00
FF
00
00
18
18

08
27
38
49
a8
BO
Q0
10
ah
6h

39
4D
cl
EE
70
D8
00
34
18
18

Q0
00
Q0
00
Q0
00
Q0
00
ah
6h

00
00
00
00
00
00
FF
00
18
18

16

4E
a7
10
41
EF
04
ah
6h

=101 %]

54
08
3F
5C
iF
Ccé
80

18
18

| ¥

=l

Figure6.72 [Monitor] Window (during Execution)

(5) After you have finished checking the statesin the [Monitor] window, select [Halt Program] from the [Debug]

menu to halt the program’s execution.
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6.20 What Next?
Thistutorial has described the mgjor features of the emulator and the use of the HEW.

Sophisticated debugging can be carried out by using the emulation functions that the emulator offers. This
provides for effective investigation of hardware and software problems by accurately isolating and identifying
the conditions under which such problems arise.
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Section 7 Hardware Specifications Specific to This Product

This section describes the hardware specifications on the H8S/2268 E6000 emulator.

7.1 H8S/2268 E6000 Emulator Specifications

The H85/2268 E6000 emulator supports the system devel opment using the following microcomputers:

* H8S5/2268 group
* H8S/2264 group

711 Supported MCUsand User System Interface Cables

See the development support tool catalog for the MCU type names and packages supported by the E6000
emulator and for the combination of the E6000 user system interface cables and optiona boards.

712 Operating Voltage and Frequency Specifications

Table 7.1 shows the MCU operating voltage and frequency specifications supported by the EG000 emulator. If
the emulator is used in an environment that exceeds the operating voltage range and operating frequency range

guaranteed for the MCU operation, normal emulator operation is not guaranteed.

Table7.1 Operating Voltage and Frequency Specifications

Operating Frequency

MCU Types Operating Voltage (V) (@ (MHz)
H8S/2268 group 4.0-5.5 2-20.5
H8S/2264 group 2.7-4.0 2-135

NOTE

For details on the operating voltage and frequency specifications,
refer to the MCU’s hardware manual.
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7.2 User System Interface

All user system interface signals are directly connected to the MCU in the emulator with no buffering except for
those listed below which are connected to the MCU through control circuits:

* NMI

* RESET

* MD2 MD1
« XTAL

« EXTAL

« OSC1

» 0OSC2

» STBY

721 Signal Protection

All user system interface signals are protected from over- or under-voltage by use of diode arrays except for the
AVcc and Vref.

The Vcc pins (except for the AVcc pin) at the head of the user system interface cable are connected together.
The emulator monitors the voltage level of the Vcc pins and displays the power-supply status in the [Extended
Monitor] Window.

722 User System Interface Circuits

The interface circuit between the MCU in the emulator and the user system has a signal delay of about 8 nsdue
to the user system interface cable and it includes pull-up resistors. Therefore, high-impedance signals will be
pulled up to the high level. When connecting the emulator to a user system, adjust the user system hardware to
compensate for propagation delays.

Default:

47 kQ

MCU User system
interface cable

Figure7.1 Default User System Interface Circuit

Mode Pins (MD2 and MD1) and NMI: The NMI signal isinput to the MCU through the emulator control
circuit. The rising/falling time of the NMI signal must be 8 ng/V or less. The mode pins are only monitored. The
CPU mode depends on the configuration settings of the HEW.

Vce
47 kQ
Emulator 47 Q
control User system
circuit interface cable

Figure7.2 User System Interface Circuit for MD2, MD1, and NM|
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RESET:

Emulator
control
circuit

Vce

interface cable

47 kQ % ;S- 470
é mn——>0 User system

Figure7.3 User System Interface Circuit for RESET

ANO-AN9, SEG1-SEG40, C1, C2, COM1-COM4, TONED, V1-V3, AVcc, AVssand Vref:

AVce

MCU

User system

ANO-AN9 interface cable

AVss SEG1-SEGA40,

MCU

00 C1, C2, V1-V3, yser system
———wWv—>0 coM1-COM4 |
TONED interface cable

0.022uF

MCU

O AVce
User system
9—O Vref

< 1 interface cable

—_—— <
127
T kQT O AVss

0.022iF 77 0.022 uF

Figure7.4 User System Interface Circuit for ANO-AN9, SEG1-SEGA40, C1, C2, COM1-COM4, TONED,

V1-V3, AVcc, AVssand Vref Signals
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7.3 Differ ences between M CU and Emulator

When the emulator isturned on or initialized, or the system is reset, there are some differencesin theinitial
valuesin some of the general registers between the MCU and the emulator as shown in table 7.2.

Table7.2 Initial Value Differences between MCU and Emulator

Status Register E6000 Emulator MCU
Power-on/ PC Reset vector value Reset vector value
initialized EROt0 ER6  Undefined Undefined
ER7 (SP) H'10 Undefined
CCR The | mask is set to 1 and the The | mask is set to 1 and the
other bits are undefined other bits are undefined
Reset command PC Reset vector value Reset vector value
EROto ER6  Undefined Undefined
ER7 (SP) H'10 Undefined
CCR The | mask is set to 1 and the The | mask is set to 1 and the
other bits are undefined other bits are undefined

731 A/D Converter and D/A Converter

Dueto the use of auser system interface cable, thereis a slight degradation in the A/D and D/A conversion than
that quoted in the Hardware Manua for the MCU being emulated.
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Section 8 Software Specifications Specific to This Product

This section describes the software specifications of the H8S/2268 E6000 emul ator.

8.1 Softwar e Specifications of the H852268 E6000 Emulator

Information specific to this emulator is given below.

811 Target Hardware

This emulator software conforms to the H8S/2268 E6000 emulator (HS2268EPI61H).

8.1.2 Selectable Platform
The debugging platform selectable in this emulator is as follows.

Table8.1 Selectable Target Platform

Debugging Platform Remark

H8S/2268 E6000 Emulator CPU 2000  For emulation of the MCUs that have the H8S/2000 CPU as the
core.
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8.1.3

[Configuration Properties] Dialog Box ([General] Page)

Items that can be set in this dialog box are listed below.

2=l
General |
Device: lUger Signals
HEVICE: [v User Beset enable
Mode: I'." (advanced mode, sinele chip) :I [ User NMI enable
[ Sirele chin mode ¥ lzer Standby enable
- zer Bus Request enable
= Bus Re bl
Clock:  [Main: 10MHz, Subs 32kHz =l
Timer Resolution: |125ns ;I
Flash Memaory. Gantrol: | j
[+ Enable automatic re—execution from interrupt break
[+ Enable read and write on the flv
[+ Break on access errar
[~ Enable internal ROM area write
User YOG Threshold = 250w 4] I i
Driver: |Emulat-:|r PCI Gard Driver
[~ Chanee driver in start up

Ok, I Cancel

354

Figure8.1 [Configuration Properties] Dialog Box ([General] Page)
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[General] page

[Device] Selects the MCU to be emulated. To use an MCU not included in the list,
select [Custom] to specify the functions required for this MCU. See the
hardware manual for details.

[Mode] Selects the MCU's operating mode.
[Clock] Selects the speed of the MCU'’s clock and sub-clock.
[Timer Resolution] Selects the resolution of the timer for use in execution time measurement.

The value 20 ns, 125 ns, 250 ns, 500 ns, 1 us, 2 us, 4 us, 8 us, or 16 us
can be selected.

The timer for execution time measurement has a 40-bit counter.

At 20 ns the maximum time that can be measured is about six hours, and
at 16 ps the maximum time is about 200 days.

When the counter overflows, the maximum time possible for
measurement will be displayed with prompt “>” that indicates that the
counter has overflowed.

[Enable automatic re-execution When this box is checked and the execution of the user program is

from interrupt break] terminated by one of the causes listed below, the user program is re-
executed automatically only when the high-speed mode or medium-
speed mode (LSON = 0) is entered after resuming from the interrupt.

This function allows emulation of the state transition by interrupts. Note,
however, that the timing in the emulator from the occurrence of an
interrupt to the state transition is different from that of the actual MCU.

There are the following limitations on using the emulator due to the
restrictions of the emulator hardware.

1. When a wakeup interrupt (WKPO to 7) occurs in the software
standby mode, the software standby mode cannot be cancelled.
When the wakeup interrupt occurs, the user program is forcibly
terminated.

2. When an 8-bit reload timer (TMR_4) overflow interrupt (OVI14 to
7) or a wakeup interrupt (WKPO to 7) occurs in the watch mode,
the watch mode cannot be cancelled. When the interrupt occurs,
the user program is forcibly terminated.
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[General] page (cont)

[Enable read and write on the
fly]

When this box is checked, it is possible to access the target system
memory while the user program is running. Do not check this box if you
require realtime emulation.

- When accessing the internal ROM or internal RAM

HEW accesses the memory directly as the bus mastership is released to
the emulator without breaking the user program.

- When accessing the internal I/O or DTCRAM

Memory is accessed with breaking the user program. This pause is
approximately 2 ms while operating at 20 MHz.

When the internal RAM is disabled, an access to this area is not available
during the user program execution.

Note:

When the content of the memory is modified during the user program
execution (e.g. modification in the [Memory] window or by the
MEMORY_EDIT command), HEW reads the content to update the value.

HEW also reads the memory content when the content has been updated
by operations such as selecting [Memory -> Refresh]. In this case, the
content of memory is read and then updated in each of the windows.

To prevent unnecessary reading of the memory content, close the
window displaying the memory content (such as the [Memory] or
[Disassembly] window) or make the settings so that the content will not
be updated.

The [Monitor] window, or the [Watch] window that satisfies the conditions
listed below displays the memory content. Note that, however, opening
these windows does not prevent realtime operation because the method
of updating the memory content in these windows is different.

Conditions:
1. Registered symbols are only allocated to general-purpose registers.

2. Registered symbols are only allocated to the monitor range set by the
[Monitor] function (the mark R is colored in blue).

3. Registered symbols are comprised of those with the conditions 1 and 2
listed above.

[Break on access error]

When this box is checked, a break (the user program stops) occurs if
your program accesses an access-prohibited area or writes to a write-
protected area.

[Enable internal ROM area write]

When this box is checked, writing to the internal ROM area is enabled.
For the result of writing, see the [Extended Monitor] window.

[User VCC Threshold]

Sets the voltage level for the user system. [Down] will be displayed in
[User System Voltage] of the [Extended Monitor] window when the actual
user VCC of the target system is lower than the specified value.

[User Signals]

When this box is checked, the reset and NMI signals from the user
system are enabled. Note that the standby signal is always invalid
because the hardware standby function is not supported. However, the
status of the signal can be checked in the [Extended Monitor] window.

[Driver]

Displays the E6000 driver that is currently installed.

[Change driver in start up]

When this box is checked, selection of a driver will be available next time
the emulator is connected.
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The MCUs selectable by the [Device] option and options that depend on the MCUs are listed below. To emulate
an MCU with a description in the Expansion Hardware column, connect the correct expansion hardware.

Table8.2 Environment for the H85/2268 E6000 Emulator CPU 2000 Debugging Platform

[Device] Option  [Mode] Option [Clock] Option Expansion Hardware
Custom The MCU previously selected
H8S/2268 7 (advanced mode, single chip) Main: 10 MHz, Sub: 32 kHz None
H8S/2266 Target Main: 20 MHz, Sub: 32 kHz
H8S/2265 Main: 10 MHz, Sub: Target
H8S/2264 Main: 20 MHz, Sub: Target
H8S/2262 Main: Target, Sub: Target

Main: Target/2, Sub: Target
Notes: 1. Target in [Mode] is only available when the target system is connected.

2. Target and Target/2 in [Clock] are only available when the target system is connected.
357
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8.14

[Configuration Properties] Dialog Box ([Custom] Page)

Items that can be set in this dialog box are listed below.

nfiguration Properties

2%

[~ Enable DMAC
[~ Enable TPU3-5
[~ Enable P14

[¥ Enable D& Converter
[~ Enable Refresh Gaontraller

¥ Enable IC0

[+ Enable IZ1

[+ Enable WDT1
¥ Enable TMRZ-3

[¥ Enable MultiProcessorComunication (SGT1-4)

General Custom Device
RO | 256K B =l [T Enable Flash memory
RAM:  [16kE ]
Fin: {120/128PinB =]
— Modules
[v Enable DTG [~ Enable kD& —&/D Converter ——

e dree
{~ Bree

—aCl Select
 SGI0-1
 5CI0-2
v ZGI0-3
 5CI0-4

Cancel |
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Figure8.2 [Configuration Properties] Dialog Box ([Custom Device] Page)
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[Custom Device] page

[ROM]

Specify the internal ROM area size.
None: -

64kB: Sets the internal ROM area to be 64 kbytes (H'000000 to
H'00FFFF).

96kB: Sets the internal ROM area to be 96 kbytes (H'000000 to
H'017FFF).

128kB: Sets the internal ROM area to be 128 kbytes (H'000000 to
H'O1FFFF).

192kB: Sets the internal ROM area to be 192 kbytes (H'000000 to
H'02FFFF).

256kB: Sets the internal ROM area to be 256 kbytes (H'000000 to
H'03FFFF).

384kB: Sets the internal ROM area to be 384 kbytes (H'000000 to
H'O5FFFF).

512kB: Sets the internal ROM area to be 512 kbytes (H’'000000 to
H'O7FFFF).

[RAM]

Specify the internal RAM area size.

2kB: Sets the internal RAM area to be 2 kbytes (H'FFE800 to H'FFEFBF

and H'FFFFCO to H'FFFFFF).

4kB: Sets the internal RAM area to be 4 kbytes (H'FFE000 to H'FFEFBF

and H'FFFFCO to H'FFFFFF).

6kB: Sets the internal RAM area to be 6 kbytes (H'FFD800 to H'FFEFBF

and H'FFFFCO to H'FFFFFF).

8KkB: Sets the internal RAM area to be 8 kbytes (H'FFD000 to H'FFEFBF

and H'FFFFCO to H'FFFFFF).

12kB: Sets the internal RAM area to be 12 kbytes (H'FFC000 to
H'FFEFBF and H'FFFFCO to H'FFFFFF).

16kB: Sets the internal RAM area to be 16 kbytes (H'FFB0O0O to
H'FFEFBF and H'FFFFCO to H'FFFFFF).

24kB: Sets the internal RAM area to be 24 kbytes (H'FF9000 to
H'FFEFBF and H'FFFFCO to H'FFFFFF).

32kB: Sets the internal RAM area to be 32 kbytes (H'FF7000 to
H'FFEFBF and H'FFFFCO to H'FFFFFF).

[Pin]

Specify the product package.

80/84Pin: Enables ports 1, 4, 7, PAO to PA3, B to D, and PF3 to PF7.

100PinA: Enables ports 1, 4, P70 to P73, PAO to PA3, and B to G.
120/128PinA: Enables ports 1 to 4, 7, PAO to PA3, and B to G.
144PinA: Enables ports 1 to 8 and A to G.

120/128PinB: Enables ports 1, 3, 4, 7, 9, PAO to PA3, and B to G.
144PinB: Enables ports 1 to 5 and 7 to G.
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[Custom Device] page (cont)

[Modules]

Check this box to validate on-chip peripherals.
Enable DTC: Uses a part of the internal RAM as DTCRAM.

Enable D/A Converter: Displays registers of the D/A converter in the [IO]
window. The D/A converter is always available.

Enable Refresh Controller: Enables the refresh controller.
Enable DMAC: Enables DMAC.

Enable TPU3-5: Enables TPU3 to TPU5. TPUO to TPU2 are always
available.

Enable PWM14: Enables the 14-bit PWM.

Enable MultiProcessorCommunication (SCI1-4):
Uses all SCI channels to support the multiprocessor
communication and the smart card interface. SCI2 is
always used for this support.

Enable IrDA: Enables IrDA.
Enable IICO: Enables IICO.
Enable IIC1: Enables IIC1.
Enable WDT1: Enables WDT1.

Enable TMR2-3: Enables TMR2 and TMR3. TMRO and TMR1 are always
available.

A/D Converter: Selects the specifications of the A/D converter.

4reg: 10-bit resolution, four data registers, and conversion time in 134-
state cycles

8reg: 10-bit resolution, eight data registers, and conversion time in 20-
state cycles

SCI Select: Selects the number of SCI channels.

SCI0-1: Enables SCIO0 and SCI1.
SCI0-2: Enables SCIO to SCI2.
SCI0-3: Enables SCI0 to SCI3.
SCI0-4: Enables SCIO to SCl4.
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8.15 Memory Mapping Function

The memory map cannot be changed with this emulator.

8.1.6 [Status] Window

Selecting [View -> CPU -> Status] or clicking the [Status Display] toolbar button displays the [Status] window.
The [Status] window has three sheets. This emulator displays the following items.

(1) [Memory] Sheet
Selecting the [Memory] tab on the [Status] window displays this sheet.

Table8.3 [Memory] Sheet Items

[Item] Column [Status] Column
Target Device Configuration Displays memory mapping.
System Memory Resources Displays the memory resource of the emulator hardware (however,

‘None’ is always displayed here because this item is not available when
emulating the H8S/2268).

Program Name Displays the program file name.
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(2) [Platform] Sheet

Selecting the [Platform] tab on the [Status] window displays this sheet.

Table8.4 [Platform] Sheet Items

[Item] Column

[Status] Column

Connected To:

Displays emulator name (driver used).

CPU

Displays the target MCU name.

Mode

Displays the selected mode.

Clock source

Displays the selected clock.

Run status

Displays the execution status.
Break: The user program breaks
Running: The user program is running

Cause of last break

Displays the cause of the emulator stopped at a break. If a program
breaks in the sub-active state, '(SubActive)' will be displayed after the
cause of the break.

Ready: User program not executed (immediately after starting the HEW)
User Break: Break by the user

PC Break: Break by program breakpoint

On Chip Break A: Break by hardware PC Break

Complex Event System: Break by complex event system

Stepping Completed: Break by stepping completed

Stepping Aborted: Break by stepping aborted

ROM Write Access Break: Break by writing to ROM

Write-protect Access Break: Break by writing to a read-only memory
Unused Area Access Break: Break by accessing to a guarded memory
Performance Break: Break by Performance Analysis

Invalid breakpoint: Break by a break instruction without PC Break

OVI4-7 or WKPO-7 Interrupt Break: Break by an 8-bit reload timer
(TMR_4) overflow interrupt (OVI4 to 7) or a wakeup interrupt (WKPO to 7)

Event Time Count

Displays the measured result of the timer between events.

Run Time Count

Displays the total execution time of the program.

(3) [Events] Sheet

Selecting the [Events] tab on the [Status] window displaysthis sheet.

Table85 [Events] Sheet Item

[Item] Column

[Status] Column

Resources

Displays the resource information and the information on events such as
the breakpoint.
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8.1.7 Extended Monitor Function

Selecting [View -> CPU -> Extended Monitor] or clicking the [Extended Monitor] toolbar button displays the
[Extended Monitor] window. This emulator displays the following items.

Table8.6 [Extended Monitor] Window Items

[Item] Column

[Value] Column

User Standby

Displays the status of the standby pin.

User NMI

Displays the status of the NMI pin.

User Reset

Displays the status of the reset pin.

User System Voltage

Displays whether or not the user VCC is equal to or exceeds the value set by
[User VCC Threshold] on the [General] page of the [Configuration Properties]
dialog box.

User Cable

Displays whether or not the user cable is connected.

Running status

Displays the address bus value in the MCU and the status of the CPU while
the user program is running, and the cause of a break while the user program
is halted.

Break = <Cause of break>: Displays the cause of a break.

Address = <Address bus value>:
Displays the address bus value during the user program execution. While in
subactive mode, (SubActive) is displayed after the address bus value.

Status = <Status of the CPU>: Displays the status of the CPU.

PREFETCH: CPU instruction prefetch cycles
DATA: CPU data access cycles

DTC: Operation of DTC

SLEEP: Sleep mode

STANDBY: Standby mode

WATCH: Watch mode

SUBSLEEP: Subsleep mode

ROM Write

Displays whether or not the ROM has been written to during the user program
execution.

Once the ROM has been written to, the state is retained until the Configure
Platform is set again.

Target Mode

Displays the mode to be input from the user system.

Target Clock

Displays whether or not there is a clock signal to be input from the user
system.

Target Sub Clock

Displays whether or not there is a sub-clock signal to be input from the user
system.

Note: In this emulator, the update interval in the [Extended Monitor] window cannot be selected or changed.
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8.1.8 Signalsto Indicate Bus States and Areas

The following tables show examples of signalsto indicate the bus states and areas that can be acquired by the
emulator.

Table8.7 Bus State Signals Acquired by the Emulator
Bus State Trace Display (Status) Description
CPU Prefetch PROG CPU prefetch cycles
CPU Data DATA CPU data access cycles
DTC DTC DTC cycles
Other OTHER Others

Table8.8 AreaSignalsAcquired by the Emulator

Area Trace Display (Area) Description
On-chip ROM ROM ROM
On-chip RAM RAM RAM
On-chip 1/0 16bit 1/0-16 16-bit I/0
On-chip 1/O 8bit 1/10-8 8-bit I/0
DTC RAM RAM/DTC DTCRAM

Note: The signalsto indicate bus states and areas are used to set the [Bus/Area] condition of the event point.
They can also be acquired as the trace information. The bus state signals are also used to set the
condition not to acquire the trace ([ Suppress] option) and in the Access Count Of Specified Range
M easurement mode for measuring the hardware performance ([Access Type] option).

8.1.9 Monitoring Function

This emulator incorporates the bus monitoring circuit as the standard, which thus allows a use of the monitoring
function to update the content of memory without affecting the realtime operation.

8.1.10 Trigger Points

This emulator incorporates the bus monitoring circuit as the standard, which thus allows a use of trigger points
that can be set on the [Trigger] sheet in the [Event] window.
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8.1.11 Tracelnformation

Selecting [View -> Code -> Trace] or clicking the [Trace] toolbar button displays the [Trace] window. Trace

information that can be acquired by the emulator and trace information items to be displayed are as listed below.

[PTR] Cycle number in the trace buffer. When the most recent record is record 0,
earlier record numbers go backwards (-1, -2, ...). If a delay count has been
set, the cycle number where the trace stop condition has been satisfied is
record 0. For the cycle (during delay) executed until the trace has stopped,
earlier record numbers go forward (+1, +2, ...) the most recent record.

[Address] Address (6-digit hexadecimal)

[Instruction] Disassembled code of the executed instruction

[Data] Data bus value, displayed as 2-digit or 4-digit hexadecimal

[R/W] Whether access was read (RD) or write (WR)

[Area] Memory area being accessed; ROM, RAM, 8- or 16-bit I/O, 8- or 16-bit EXT
(external), or DTC RAM (not available when a time stamp is acquired)

[Status] Bus status during this cycle; DTC operation, PROG (prefetch), or Data
(CPU data access cycle) (not available when a time stamp is acquired)

[Clock] Number of clock cycles in bus cycle as 1 to 8. To indicate more clock
cycles, “OVR” is displayed (not available when a time stamp is acquired).

[Probes] A 4-bit binary number showing the four probe pins in the order of Probe 4,
Probe 3, Probe 2, and Probe 1 from the left (not available when a time
stamp is acquired).

[NMI] Status of the NMI input (not available when a time stamp is acquired)

[IRQ] Status of five IRQ inputs. ‘11111’ is displayed. The digits indicate the status
of IRQ5, IRQ4, IRQ3, IRQ1, and IRQO from the left, respectively (not
available when a time stamp is acquired).

[Timestamp] Time stamp of the record. Time stamps start from zero each time the user
program is executed. The timer resolution depends on the time stamp
clock rate selected in the trace acquisition (only available when a time
stamp is acquired).

[Source] Source program

[Label] Label information that corresponds to the address (if defined)
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8.1.12  Searching for a Trace Record

While using the emulator, the [Trace Find] dialog box has the following pages:

Table8.9 [TraceFind] Dialog Box Pages

Page Description

[General] Sets the range for searching.

[Address] Sets an address condition.

[Data] Sets a data condition.

[R/W] Selects the type of access cycles.

[Area] Selects the area being accessed (not available when a time stamp is
acquired).

[Status] Selects the status of a bus (not available when a time stamp is acquired).

[Probes] Selects the status of four probe signals (not available when a time stamp
is acquired).

[IRQ] Selects the status of five IRQ input signals IRQO, IRQ1, IRQ3, IRQ4, and
IRQ5 (not available when a time stamp is acquired).

[Timestamp] Specify the time stamp value for bus cycles (only available when a time

stamp is acquired).

The [IRQ] page is specific to this emulator. The description is given below.

+ [IRQ] page

Select the status of IRQ signals. The selection is not available when atime stamp is acquired.

x
Gerneral I Addressz I Data I R M | Area |
Status I Probes IRQ
— Setting
IRQ5 IDnn'l care 'I IRG4 IDon'l care 'I
IRG3 IDDn'l care 'I |IRE1 IDnn't care 'I
RGO IDnn'l care 'I
0k I Cancel | Apply |

Figure8.3 [TraceFind] Dialog Box ([IRQ] Page)
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[Don't care]: Detects no IRQ input condition when this box is checked.

[Setting]: Detects the specified IRQ input condition.
[IRQ5] to [IRQQ]: Select IRQ input conditions (not available when [Don’t care] has been
checked).

Don't care: Detects no selected IRQ input condition.
High: The status of the IRQ input is high.

Low: The status of the IRQ input islow.

8.1.13 TraceFiltering Function
While using the emulator, the [Trace Filter] dialog box has the following pages:

Table8.10 [TraceFilter] Dialog Box Pages

Page Description

[General] Selects the range for filtering.

[Address] Sets address conditions.

[Data] Sets data conditions.

[R/W] Selects the type of access cycles.

[Area] Selects the area being accessed (not available when a time stamp is not
acquired).

[Status] Sets the status of a bus (not available when a time stamp is not
acquired).

[Probes] Selects the states of four probe signals (not available when a time stamp
is not acquired).

[IRQ] Selects the states of five IRQ input signals IRQO, IRQ1, IRQ3, IRQ4, and

IRQ5 (not available when a time stamp is not acquired).

[Timestamp] Specifies the time stamp value for bus cycles (only available when a time
stamp is acquired).

The [IRQ] page is specific to this emulator. The description is given below.
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* [IRQ] page

Select the status of IRQ signals. The selection is not available when atime stamp is acquired.

]
I

Trace Filker
Gerneral I Addressz I Data R M | Area
Status I Probes IRQ

i :

— Setting
IRQ5 IDnnTcam 'I IRG4 IDonTcam 'I
IRO3 IDonTcam 'I IRE1 IDonTcam 'I
IR0 IDmﬂcme'l

Apply

[ o |

Cancel |

[Don't carel:
[Setting]:

[IRQ5] to [IRQO]:
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Figure8.4 [TraceFilter] Dialog Box ([IRQ] Page)

Detects no IRQ input condition when this box is checked.

Detects the specified IRQ input condition.

Select IRQ input conditions (not available when [Don'’t care] has been

checked).

Don't care: Detects no selected IRQ input condition.

High: The status of the IRQ input is high.

Low: The status of the IRQ input is low.
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8.2 Notes on Usage of the H852268 E6000 Emulator

There are the following notes on usage of the emulator.

821 Environment for Execution of the Tutorial Program

To execute the tutorial program, specify “ Tutorial.hws’ stored in the following directory:
HEW install ation destination directory\Tool s\Renesas\DebugComp\Platform\E6000\2268\ T utorial

8.2.2 1/0 Register Differences between the Actual M CU and the Emulator

In the E6G000 emul ator, one evaluation chip emulates several types of MCU. Therefore, there are some
differencesin 1/0O registers between an actual MCU and the emulator. Note these differences when accessing the
1/0 registers.

1/0 port isin theinput state at default. The 1/0 register contents indicate the emulator port status. When the user
system interface cable is not connected, the read value is 1 due to pull-up resistors.

In the emulator, accesses to the following registers for controlling the flash memory are invalid.

* RAM emulation register (RAMER: H'FEDB)

* Flash memory control register 1 (FLMCR1: H'FFAS)

» Flash memory control register 2 (FLMCR2: H'FFA9)

* Block register 1 (EBR1: H'FFAA)

* Block register 2 (EBR2: H'FFAB)

» Flash memory power control register (FLPWCR: H'FFAC)

Note: The addresses indicate the lower 16 bits.

8.2.3 Accessto the Reserved Area
When accessing the reserved area, note the following:

If the reserved areais used, the operation in the actual MCU cannot be guaranteed. If the user program extends
to the reserved area during debugging, select the MCU having the largest ROM capacity (for example, debug the
H8S/2266 program in the H8S/2268 mode).

8.24 Using the Internal RAM Area as External Addresses

When the RAME bit in SYSCRis O, theinterna RAM area can be used external addresses. Note that, however,
the only memory that can be accessed is User (external), not Emulator (emulation memory). In this case, the On-
Chip Read-write (Internal RAM) setting is applied for memory mapping.

8.25 Support of Flash Memory

This emulator does not emulate the flash memory in the MCU.

8.2.6 Hardwar e Standby

This emulator does not support the hardware standby function. Therefore, checking [User Standby enable] in the
[Configuration Properties] dialog box isinvalid.
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8.2.7 Interruptsin Watch Mode and Softwar e Standby Mode
There are the following limitations on using the emulator due to the restrictions of the emulator hardware.

1 When awakeup interrupt (WKPO to 7) occurs in the software standby mode, the software standby mode
cannot be cancelled. When the wakeup interrupt occurs, the user program is forcibly terminated. On
termination, the emulator enters the active mode.

2. When an 8-bit reload timer (TMR_4) overflow interrupt (OV14 to 7) or awakeup interrupt (WKPO to 7)
occursin the watch mode, the watch mode cannot be cancelled. When the interrupt occurs, the user
program is forcibly terminated. On termination, the emulator enters the active mode regardless of the
LSON value.

When the [Enable automatic re-execution from interrupt break] check box has been checked in the
[Configuration Properties] dialog box and the execution of the user program isterminated by one of the above
causes, the user program is re-executed automatically only when the high-speed mode or medium-speed mode
(LSON = 0) isentered after resuming from the interrupt.

When the [Enable automatic re-execution from interrupt break] check box is not checked, the user programiis
not re-executed automatically.

nfiguration Properties 7] x|
General I
Device: ldzer Sighals
EEVICE [# User Beset enable
Mode: I'." {advanced mode, single chip) =l [¥ User HMI enable
[ Sl chip mode [ lser Standby enable
- [~ lUser Bus Reguest enable

Clock: IMain: 10MHz, Sub: 32kHz

Timer Reszalution: |1 2hnz

Lef L] Led

Elash Memary Contral: I

v Enable automatic re—execution from interrupt break,
[+ Enable réa = 1 1
[¥ Break on access errar

[~ Enable internal ROM area write
User VGG Threshold = 2508 4] o |

Diriver: |Emu|atc-r PCI Card Driver
[~ Chanee driver in start up

QK. I Cancel

Figure 8.5 [Enable automatic re-execution from interrupt break] Check Box
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Appendix A Troubleshooting

| have a text file in the editor but it does not show any syntax coloring.

Ensure that you have named the file (i.e. saved it) and that the [Enable syntax coloring] check box is set on
the [Editor] tab of the [Options] dialog, which islaunched via[Tools->Options...]. HEW checks afile group
to which the file’ s extension belongs and decides whether the fileis colored. To view the current defined
extensions and their file groups, use the [File Extensions] dialog which islaunched via[Project->File
Extensions...]. To view coloring information, select [ Tools->Format] to display the [Format] dialog, click the
item to view its color under icons in the tree, and see the [Color] tab. (See the “ Syntax Coloring” section in
chapter 4, Using the Editor of the HEW Part for details.)

| opened a workspace from my PC, and one of my colleagues opened the same workspace simultaneousy
from another PC. | changed the settings of the workspace and saved it. He or she saved the workspace
after me. | opened the workspace again and found that the settings of the workspace differed from what |
had set before.

The settings saved last are enforced. Once HEW opens aworkspace, it is updated inside the memory. HEW
does not save the settings into a file until a user saves the workspace intentionally.
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Appendix B Regular Expressions

The HEW editor allows you to include special charactersin search strings when performing afind or replace
operation. These characters arelisted in table B.1 and are detailed in the following pages.

TableB.1 Regular Expression Characters

Character Function

? Matches any single character (except a newline)

* Matches any number of occurrences (0 or more) of any character except a

newline

\n Matches a new line character

\t Matches a tab character

[] Matches any one character or range listed within the brackets

\ Overrides any following regular expression character

e Symbol: ?
Meaning:  This character matches any single character, except the newline character.
Example:  t?p matches“top”, “tip” but not “trap”.

e Symbol: *

Meaning:  This character matches any number of occurrences (0 or more) of any character except a
newline. Thus, this character will not match across new lines. The* character will match as few
occurrences as are necessary to make the rest of the pattern match.

Example 1: t*o matchesthe “to” of “too”, the “tro” of “trowel” and the “ty 0" of “sporty orange”
but not “ smart orange” because the* character does not match across anew line.

e Symbol: \n

Meaning:  This character matches the newline character.

\n would be used to search for line endings or in patterns that cross line boundaries.

Example 1: ;\n
matches every occurrence of anewline following a semicolon

Example 2: ;\nif

searches for a semicolon, anew line and aline beginning with “if”.
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e Symbol: \t
Meaning:  This character matches the tab character.
Example 1: \t8
Finds every occurrence of a tab character followed by an 8.
Example 2: init\t
Finds every occurrence of a tab character following “init”.

e Symbol: [1
Meaning:  This matches any one character or arange of single characters listed within the brackets.
Brackets cannot be nested.

[-] specifiesarange of characters e.g. [a-Z] or [0-9]. The beginning character in the range must
have alower ASCII value than the ending character of the range.

[~] matches asingle character if it isnot any one of the characters between
[~and]. This pattern also matches newline characters, unless the newline character isincluded
within the brackets.

Example 1: [AEIOU]

Finds every uppercase vowel.
Example2: [<>7]

Findsaliteral <, > or ?.
Example3: [A-Zaz0-9 ]

Matches an upper or lowercase letter, a digit or an underscore.
Example 4: [~0-9]

Matches any character except a digit.
Example 5: [ \t\n]

Matches a space, atab or newline.
Example 6: [\]]

Matchesalitera ] if ] isplaced after \.

e Symbol: \

Meaning:  Thisisthe regular expression override character. If the character following the backdash is a
regular expression character, it istreated as anormal character. The backslash isignored if it is
followed by anormal (non-regular expression) character.

Example 1: \*

Searches for every occurrence of an asterisk.

Example2: \\

Searches for every occurrence of a backdash.
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Appendix C Placeholders
This appendix describes how to use the placeholders, a feature provided by several of the HEW components.

ci1 What is a Placeholder ?

A placeholder isa special string, inserted into text, which is replaced at some subsequent time for the actual
vaue. For example, one of the HEW placeholdersis $(FULLFILE) which represents afile with afull path.
Suppose that you have an editor in c:\myedit\myeditor.exe, which can take the file to edit as a parameter. When
invoking the editor the following shortcut could be made, e.g.:

c:\myeditimyeditor.exe c:\files\filel.c

if you wanted to open FILEL.C from the directory c:\files. However, what happensif you want the HEW to open
any file through this editor? The problem isthat the command above is specific to “c:\files\filel.c”. What we
want to be able to do isto tell the HEW to use the editor specified but to open the file that | have chosen at that
time. To do this, you can replace the specific name of thefile for ageneral placeholder, i.e.:

c:\myedit\myeditor.exe $(FULLFILE)

Now whenever the HEW launches the editor with afile, it knowsthat it has to replace $(FULLFILE) with the
file you have selected.

Cc.2 Inserting a Placeholder

Placeholders can only be entered into three specific edit fields within the HEW (figures C.1, C.2 and C.3). There
are four ways a placeholder can be entered:

In thefirst example, place the insertion cursor at the point you would like to insert the placeholder and then
select the required placeholder from the popup menu to the right of the edit field.

File:
o projectymyprojecthouputhfile 7 out [ 3 |

FigureC.1 Placeholder Popup Menu

In the second example, select the required placeholder other than [Custom directory] from the combo box and
specify a sub-directory relative to the directory shown by the placeholder. If you select [Custom directory],
specify an absolute directory path in the [Sub-Directory] field.

Relative to :

ICnnfiguralion directary ﬂ

Sub-Directory :

FigureC.2 Placeholder Combo Box and Sub-Directory Field
Note: The[Sub-Directory] field may be written as the [File path] field.

In the third example, place the insertion cursor at the point you would like to insert the placeholder, select the
required placeholder from the combo box and then click the [Insert] button.
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Placeholder:

Configuration directony j Inzert |

Figure C.3 Placeholder Combo Box

In the fourth example, type the placeholder into the field directly. Ensure that you type the placeholder namein
uppercase and that it is preceded by $( and followed by ), i.e.

Thisis correct:
$(FILEDIR)

These are incorrect:
$(Filedir)

$( FILEDIR )
$FILEDIR
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Cc3 Available Placeholders

Table C.1 lists the placeholders and their meanings.

TableC.1 Placeholders

Placeholder Meaning
$(FULLFILE) Filename (including full path)
$(FILEDIR) File directory

$(FILENAME)

Filename (excluding path and including extension)

$(FILELEAF)

Filename (excluding path and extension)

$(EXTENSION)

File extension

$(WORKSPDIR)

Workspace directory

$(WORKSPNAME) Workspace name
$(PROJDIR) Project directory
$(PROJECTNAME) Project name

$(CONFIGDIR)

Configuration directory

$(CONFIGNAME)

Configuration name

$(HEWDIR) HEW installation directory

$(TCINSTALL) Toolchain install directory (on option dialog)
$(TOOLDIR) Tool installation directory (Tools Administration)
$(TEMPDIR) Temp directory

$(WINDIR) Windows® directory

$(WINSYSDIR) Windows® system directory

$(EXEDIR) Command directory

$(USERNAME) User login (Version control)
$(PASSWORD) User password (Version control)

$(VCDIR) “Virtual” version control directory
$(COMMENT) Comment (Version control)

$(LINE) Line number of an error/warning
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For example, the placeholders will be expanded as shown in table C.2.

TableC.2 Placeholder Expansions (Example)

Placeholder Expanded placeholder (example)
$(FULLFILE) c:\hew\workspace\project\file.src
$(FILEDIR) c:\hew\workspace\project
$(FILENAME) file.src

$(FILELEAF) file

$(EXTENSION)

src

$(WORKSPDIR)

c:\hew\workspace

$(WORKSPNAME) workspace

$(PROJDIR) c:\hew\workspace\project
$(PROJECTNAME) project

$(CONFIGDIR) c:\hew\workspace\project\debug
$(CONFIGNAME) debug

$(HEWDIR) c:\hew

$(TCINSTALL) c:\hew\toolchains\hitachi\sh\511
$(TOOLDIR) c:\hew\toolchains\hitachi\sh\511
$(TEMPDIR) c\Temp

$(WINDIR) c:\Windows

$(WINSYSDIR) c:\Windows\System

$(EXEDIR) v:\ve\win32

$(USERNAME) JHARK

$(PASSWORD) 214436

$(VCDIR) “c:\project” is mapped to “x:\vc\project”
$(COMMENT) “Please Enter Comment” dialog is invoked
$(LINE) 12

In table C.2, we are assuming that

afile path is*“c:\hew\workspace\project\file.src”.

aworkspace named “workspace” islocated at “c:\hew\workspace”.

aproject named “project” islocated at “c:\hew\workspace\project”.

a configuration named “debug” has a configuration directory located at “c:\hew\workspace\project\debug”.
HEW.EXE isinstalled in “c:\hew".

a*.HRF file of atoolchain (i.e. compiler, assembler, linker) islocated at “c:\hew\tool chain\hitachi\sh\511".
Thisisreferred to as $(TCINSTALL) on the option setting dialogs of the [Options] menu and as
$(TOOLDIR) on the “ Tools Administration” dialog.

the Windows® operating system isinstalled in “c:\Windows” and the Windows® system directory is
“c:\Windows\System”.

aversion control executable path is “v:\wcl\win32\ss.exe”, auser name and its password to login the version
control system are “JHARK” and “214436” respectively, (COMMENT) is specified in acommand line to
the version control executable, and “c:\project” is mapped to “x:\vc\project” on the “ Projects” tab of the
“Version Control Setup” dialog, which isinvoked via[Tools->Version Control->Configure...].

an error of compiler or assembler occurred at line 12.
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Note:  Not all of the placeholders are relevant in every field. For example, the $(LINE) placeholder has no
meaning when specifying a dependent files location. $(USERNAME), $(PASSWORD), $(VCDIR), and
$(COMMENT) placeholders are acceptable only in version contral. If you enter a placeholder into an
edit field where it is not acceptable you might be informed.

(o] Placeholder Tips
Placeholders are there to allow you to create flexible paths to the various files used by the system.

* If thereis aplaceholder popup menu (k) next to an edit field into which you are about to enter a path or file,
you should consider how you can use a placeholder to make that path or file definition flexible.

 If you use several configurations, then the §(CONFIGDIR) placeholder is very useful to ensure that files can
be written to and from the current configuration’s directory.

*  Wherever possible, use a placeholder. They can always be removed or added later so don't be afraid to
experiment.
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Appendix D 1/0 File Format

HEW formats the [IO] window based on information it findsin an I/O Register definition file. When you select a
debugging platform, HEW will look for a“<device>.10" file corresponding to the selected device and load it if

it exigts. Thisfileisaformatted text file that describes the 1/0 modules and the address and size of their registers.
Y ou can edit thisfile, with atext editor, to add support for memory mapped registers or peripherals you may
have specific to your application (e.g. registersin an ASIC device mapped into the microcomputer's address

space).

The following describes two formats of the “<device>.10” file that supports or not the bit field.

D.1 Fileformat (Bit Field Not Supported)

Each module name must be defined in the [M odules] definition section and the numbering of each module must
be sequential. Each module corresponds to a register definition section and within the section each entry defines
an |/O regigter.

The [BaseAddress] definition is for devices where the location of 1/0 registers moves in the address space
depending on the CPU mode. In this case, the [BaseAddress] value is the base address of the 1/O registersin one
specific mode and the addresses used in the register definitions are the address locations of the registersin the
same mode. When the 1/0O register file is actually used, the [BaseAddress] value is subtracted from the defined
register address and the resultant offset added to the relevant base address for the selected mode.

The [Register] definition entry is entered in the format <name> = <address> [<size> [<absolute>]].
1. <name> register name to be displayed.
2. <address> address of the register.
3. <size> which may be B, W or L for byte, word, or longword (default is byte).

4. <absolute> which can be set to A if the register is at an absolute address. Thisis only relevant
if the 1/0 area address range moves about on the CPU in different modes. In this case, if a
register is defined as absol ute the base address offset calculation is not performed and the
specified addressis used directly.

Comment lines are dlowed and must start with a*“;” character.

An example is shown below.
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Example:

; H8S/2655 Series 1/0 Register Definitions File

[Modules]

BaseAddress=0

Module Modulel=Power_Down_Mode_Registers
definition Module2=DMA_Channel_Common

Module3=DMA_Channel_0

Comment

Module42=Bus_Controller
Module43=System_Control
Module44=Interrupt_Controller

[DMA_Channel_Common]
DMAWER=0xffff00 B A
DMATCR=0xffff01 B A
DMACROA=0x{fff02 B A
DMACROB=0xffff03 B A
DMACR1A=0xffff04 B A
DMACR1B=0xffff05 B A
DMABCRH=0x{fff06 B A
DMABCRL=0Xffff07 B A

Register
definition

[DMA_Channel_0]
MAROAH=0xfffeeO W A
MAROAL=0xfffee2 W A
IOAROA=0xfffeed W A
ETCROA=0xfffee6 W A
MAROBH=0xfffee8 W A
MAROBL=0xfffeea W A
I0OAROB=0xfffeec W A

Register name
ETCROB=0xfffeee W A

Address
Size
Absolute address flag
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D.2 Fileformat (Bit Field Supported)

Each module name must be defined in the [M odules] definition section and the numbering of each module must
be sequential. Each module corresponds to a register definition section and within the section each entry defines
an |/O regiter.

The user must define “FileVersion=2" at the start of the section. It meansthat this 1/O register file is described
with the version that supports the bit field.

The [BaseAddress] definition isfor devices where the location of 1/0 registers moves in the address space
depending on the CPU mode. In this case, the [BaseAddress] value is the base address of the 1/0O registersin one
specific mode and the addresses used in the register definitions are the address locations of the registersin the
same mode. When the 1/0O register file is actually used, the [BaseAddress] value is subtracted from the defined
register address and the resultant offset added to the relevant base address for the selected mode.

Each module has a section that defines the registers forming it along with an optional dependency. The
dependency is checked to seeif the module is enabled or not. Each register name must be defined in the section
and the numbering of each register must be sequentia. The dependency is entered in the section as dep=<reg>
<bit> <value>.

1. <reg>istheregister id of the dependency.
2. <bit> isthe bit position within the register.
3. <vaue> isthe value that the bit must be for the module to be enabled.

The [Register] definition entry is entered in the format id=<name> <address> [<size>
[<absolute>[<format>[<bitfields>]1]].

1. <name> register name to be displayed.
2. <address> address of the register.
3. <size>which may be B, W or L for byte, word, or longword (default is byte).

4, <absolute> which can be set to A if the register is at an absolute address. Thisisonly relevant
if the 1/0 area address range moves about on the CPU in different modes. In this case, if a
register is defined as absol ute the base address offset calculation is not performed and the
specified addressis used directly.

5. <format> format for register output. Valid values are H for Hexadecimal, D for decimal, and
B for binary.

6. <bitfields> section defining the bits within the register.

Bitfield sections define the bits within aregister each entry is of the type bit<no>=<name>.
1. <no>isthebit number.
2. <name> isasymbolic name of the bit.

Comment lines are allowed and must start with a*;” character.

An example is shown below.
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Example:
Comment ; H8S/2655 Series 1/0 Register Definitions File
I [Modules]
FileVersion=2
BaseAddress=0
Modulel=Power_Down_Mode_Registers
Module2=DMA_Channel_Common
Module3=DMA_Channel_0
Module
Module42=Bus_Controller
Module43=System_Control
Module44=Interrupt_Controller

[DMA_Channel_Common]
reg0=regDMAWER
regl=regDMATCR
MOF’P'? reg2=regDMACROA
definition reg3=regDMACROB
reg4=regDMACR1A
reg5=regDMACR1B
reg6=regDMABCRH
reg7=regDMABCRL
L dep=regMSTPCRH 7 0

Register name

Bit

Value

Register [regDMAWER]

__definition id=DMAWER 0xffff00 B A H dmawer_bitfields

Register name |

Address

Size

Absolute address flag

Format

Bit field
[dmawer_bitfields]

Bit-field bit3=WE1B

definition bit2=WE1A
bit1=WEOB
bitO=WEOA
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Appendix E  Symbol File Format

In order for HEW to be able to understand and decode the symbal file correctly, the file must be formatted asa
Pentica-B file:

1. Thefile must be aplain ASCII text file.
2. Thefile mugt start with the word “BEGIN”.

3. Each symbol must be on a separate line with the vaue firgt, in hexadecimal terminated by an
“H”, followed by a space then the symbol text.

4. Thefile must end with theword “END”.
Example:

BEG N

11FAH Synbol _nane_1
11FCH Synbol _nane_2
11FEH Synbol _nane_3
1200H Synbol _nane_4
END
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Appendix F Menus

Table F.1 shows GUI menus.

TableF.1 GUI Menus

Toolbar
Menu Option Shortcut  Button Remarks
View Disassembly Ctrl + D Opens the [Disassembly]
window.
Command Line Ctrl + L Opens the [Command Line]
window.
Workspace Alt + K Opens the [Workspace]
window.
Output Alt+U Opens the [Output] window.
CPU Registers Ctrl + R Opens the [Registers] window.
Memory... Ctrl + M Opens the [Memory] window.
10 Ctrl + 1 Opens the [I0] window.
Status Ctrl + U Opens the [Status] window.
Extended Monitor . Opens the [Extended Monitor]
=5 .
window.
Monitor  Monitor Shift + " Opens the [Monitor] window.
Setting... Ctrl+E
Windows Opens the [Windows Select]
Select... dialog box to list, add, or edit
the [Monitor] window.
Ec)]llm Labels (S::lriIft:A Opens the [Labels] window.
Watch Ctrl + W Opens the [Watch] window.
Locals Shift + Opens the [Locals] window.
Ctrl + W
Code  Eventpoints Ctrl+ E Opens the [Eventpoints]
iy .
window.
Trace Ctrl+T Opens the [Trace] window.
Stack Trace Ctrl + K Opens the [Stack Trace]
window.
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TableF.1 GUI Menus (cont)

Menu

Option

Toolbar
Shortcut  Button

Remarks

View
(cont)

Gra- Image...
phic

Shift + E
Ctrl+ G

Opens the [Image] window.

Waveform...

Shift +
Ctrl +V

Opens the [Waveform]
window.

Per- Performance
form-  Analysis
ance

Shift +
Ctrl + P

Opens the [Performance
Analysis] window.

Options

Debug Sessions...

Opens the [Debug Sessions]
dialog box to list, add, or
remove the debug session.

Debug Settings...

Opens the [Debug Settings]
dialog box to set the
debugging conditions or
download modules.

Radix  Hexadecimal

Uses a hexadecimal for
displaying a radix in which the
numerical values will be
displayed and entered by
default.

Decimal

&

Uses a decimal for displaying
a radix in which the numerical
values will be displayed and
entered by default.

Octal

Uses an octal for displaying a
radix in which the numerical
values will be displayed and
entered by default.

Binary

Uses a binary for displaying a
radix in which the numerical
values will be displayed and
entered by default.

Emu-  System...
lator

E

Opens the [Configuration]
dialog box allowing the user to
modify the debugging platform
settings.

Memory
Resource...

Opens the [Memory Mapping]
dialog box allowing the user to
view and edit the debugging
platform's current memory
map.
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TableF.1 GUI Menus (cont)

Menu

Option Shortcut

Toolbar
Button

Remarks

Debug

Reset CPU

Resets the target hardware and
sets the PC to the reset vector
address.

Go F5

Starts executing the user
program at the current PC.

Reset Go Shift + F5

Resets the target hardware and
executes the user program from
the reset vector address.

Go To Cursor

Starts executing the user
program at the current PC until
the PC reaches the address
indicated by the current text
cursor position.

Set PC To Cursor

Sets the PC to the address at
the row of the text cursor.

Run...

Launches the [Run Program]
dialog box allowing the user to
enter the PC or PC breakpoint
during executing the user
program.

Step In F11

Executes a block of user
program before breaking.

Step Over F10

Executes a block of user
program before breaking. If a
subroutine call is reached, then
the subroutine will not be
entered.

Shift +
F11

Step Out

Executes the user program to
reach the end of the current
function.

Step...

Launches the [Step Program]
dialog box allowing the user to
modify the settings for stepping.

Step Auto
Mode

Steps only one source line when
the [Source] window is active.
When the [Disassembly] window
is active, stepping is executed in
a unit of assembly instructions.

Assembly Executes stepping in a unit of
assembly instructions.
Source Steps only one source line.
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TableF.1 GUI Menus (cont)

Menu Option

Toolbar

Shortcut  Button

Remarks

Debug Halt Program
(cont)

Stops the execution of the user
program.

Initialize Disconnects the debugging
platform and connects it again.
Disconnect Disconnects the debugging

platform.

Download Modules

Downloads the object program.

Unload Modules

Unloads the object program.

Memory  Search...

Searches for the specified value
from the specified memory area.

Copy... Copies the specified memory
area to the specified address.
Compare... Compares the specified two
memory areas.
Fill... Fills the specified value in the
specified memory area.
Test... Tests the specified memory
area.
Refresh Forces a manual update of the

contents of all the [Memory]
windows open.

Configure Overlay...

Selects the target section group
when the overlay function is
used.
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Appendix G Command Lines

Table G.1 liststhe HEW commands.

TableG.1 HEW Commands

No. Command Name

Abbreviation Function

1 ! - Comment

2 ANALYSIS AN Enables or disables performance analysis

3  ANALYSIS_RANGE AR Sets or displays a performance analysis range

4  ANALYSIS_RANGE_ AD Deletes a performance analysis range
DELETE

5 ASSEMBLE AS Assembles instructions into memory

6  ASSERT - Checks if an expression is true or false

7  BREAKPOINT BP Sets a breakpoint at an instruction address

8 BREAKPOINT_CLEAR BC Deletes breakpoints

9 BREAKPOINT_ BD Displays a list of breakpoints
DISPLAY

10 BREAKPOINT_ENABLE BE Enables or disables a breakpoint

11 BREAKPOINT_ BS Sets sequential breakpoints
SEQUENCE

12 CHANGE_ CcC Sets the current configuration
CONFIGURATION

13 CHANGE_PROJECT CP Sets the current project

14 CLOCK CK Set the CPU clock rate in the emulator

15 CONFIGURE_ CPF Sets the debugging environment for the emulator
PLATFORM

16 DEFAULT_OBJECT_ DO Sets the default object (program) format
FORMAT

17 DEVICE_TYPE DE Selects a device type to emulate

18 DISASSEMBLE DA Disassembles memory contents

19 ERASE ER Clears the [Command Line] window

20 EVALUATE EV Evaluates an expression

21 EXMONITOR_DISPLAY EXMD Displays the content of the expansion monitor

22 EXMONITOR_SET EXMS Selects whether or not to display the items in the

expansion monitor

23 EXMONITOR_ EXMSR Sets the time to update the expansion monitor during
SETRATE emulation or a break

24  FILE_LOAD FL Loads an object (program) file

25 FILE_SAVE FS Saves memory to a file

26 FILE_VERIFY FV Verifies file contents against memory
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TableG.1 HEW Commands (cont)

No. Command Name Abbreviation Function

27 GO GO Executes user program

28 GO_RESET GR Executes user program from reset vector

29 GO_TILL GT Executes user program until temporary breakpoint

30 HALT HA Halts the user program

31 INITIALIZE IN Initializes the debugging platform

32 LOG LO Controls command output logging

33 MAP_DISPLAY MA Displays memory mapping

34 MAP_SET MS Sets memory mapping

35 MEMORY_COMPARE MC Compares memory contents

36 MEMORY_DISPLAY MD Displays memory contents

37 MEMORY_EDIT ME Modifies memory contents

38 MEMORY_FILL MF Modifies the content of a memory area by specifying
data

39 MEMORY_MOVE MV Moves a block of memory

40 MEMORY_TEST MT Tests a block of memory

41 MODE MO Sets or displays the CPU mode

42 MODULES MU Sets up or displays the on-chip peripheral functions

43 MONITOR_CLEAR MOC Deletes a monitor point

44 MONITOR_DISPLAY MOD Displays the content of the monitor

45 MONITOR_REFRESH MOR Controls an automatic update of the content of the
monitor

46 MONITOR_SET MOS Sets or displays a monitor point

47 OPEN_WORKSPACE OW Opens a workspace

48 QUIT QU Exits HEW

49 RADIX RA Sets default input radix

50 REFRESH RF Updates windows related to memory

51 REGISTER_DISPLAY RD Displays CPU register values

52 REGISTER_SET RS Sets CPU register contents

53 RESET RE Resets CPU

54 SLEEP - Delays command execution

55 STEP ST Steps program (by instructions or source lines)

56 STEP_MODE SM Sets the step mode

57 STEP_OUT SP Steps out of the current function

58 STEP_OVER SO Steps program, not stepping into functions

59 STEP_RATE SR Sets or displays rate of stepping
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TableG.1 HEW Commands (cont)

No. Command Name Abbreviation Function

60 SUBMIT SuU Executes a command file

61 SYMBOL_ADD SA Defines a symbol

62 SYMBOL_CLEAR SC Deletes a symbol

63 SYMBOL_LOAD SL Loads a symbol information file

64 SYMBOL_SAVE SS Saves a symbol information file

65 SYMBOL_VIEW SV Displays symbols

66 TCL - Enables or disables the TCL

67 TIMER TI Sets or displays the timer resolution
68 TRACE TR Displays trace information

69 TRACE_ACQUISITION TA Sets or displays trace acquisition parameters

70 TRACE_BINARY_ TBC Compares a trace binary file with the current trace
COMPARE information

71 TRACE_BINARY_SAVE TBV Outputs trace information into a binary file

72 TRACE_STATISTIC TST Analyzes statistic information

73 TRIGGER_CLEAR TGC Deletes the trigger output condition for EXT.2

74 TRIGGER_DISPLAY TGD Displays the trigger output condition for EXT.2

75 TRIGGER_SET TGS Sets the trigger output condition for EXT.2

76 USER_SIGNALS us Enables or disables the user signal information

For the syntax of each command, refer to the online help.
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Appendix H Diagnostic Test Procedure

This section describes the diagnostic test procedure using the E6000 test program.

H.1  System Set-Up for Test Program Execution

To execute the test program, use the following hardware; do not connect the user system interface cable and user
system.

ok w DN

E6000 emulator (HS2268EPI61H)

Host computer

The E6000 PC interface board (Select one interface board or card from the foll owing depending on the PC
interface specifications.):

PCI businterface board (HS6000EIC01H or HS6000EI CO2H)

PCMCIA interface card (HS6000EIPO1H)

Install the E6000 PC interface board in the host computer and connect the supplied PC interface cable to the
board.

Connect the PC interface cable to the emulator.

Connect the supplied AC adapter to the emulator.

Initiate the host computer to make it enter DOS prompt command input wait state.
Turn on the emulator power switch.
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H.2 Diagnostic Test Procedure Using Test Program

Insert the CD-R (HS2268EPI61SR supplied with the emulator) into the CD-ROM drive of the host computer,
move the current directory to <Drive>:\Diag with acommand prompt, and enter one of the following commands
according to the PC interface board used to initiate the test program:

1. PCI bus interface board (HS6000EICO1H or HS6000EICO2H)
> TM2268 —PCI (RET)

2. PCMCIA interface card (HS6000EI PO1H)
> TM 2268 -PCCD (RET)

The HEW must be installed before the test program is executed.

Be sureto initiate the test program from <Drive>:\Diag. Do not initiate it from a directory other than
<Drive>:\Diag, such as > <Drive>:\Diag\TM2268 —PCI (RET). If thetest program isinitiated when the current
directory is not <Drive>:\Diag, the test program will not operate correctly.

When -Sis added to the command line such as >TM2268 —PCI —S (RET), steps 1 to 20 will be repeatedly
executed. To stop the execution, enter Q.

Notes: 1. <Drive>isadrive name for the CD-ROM drive.
2. Do not remove the CD-R from the CD-ROM drive during test program execution.
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The following messages are displayed during test. Thistest consists of steps 1 to 20.

M essage
E6000 HBS/ 2268 EMULATI ON BOARD Tests VX. X

Loading driver ................... K (Use PCl)
Initializing driver............... K
Searching for interface card...... K

Checking emulator is connected ......... (0.4

Enul at or Board | nformation:

Mai n Board |D: H 5
Enmul ation Board |D: H od
SUB Board I D: H6

01) Testing Register

A) IDRO Register.................. K
B) PAGE Register.................. K
C) TRACE G A Register............. (03¢
D) PERFM G A Register............. (0.4
E) CES GAregister ............... K
F) IDRL Register.................. (03¢
G IDR2 Register.................. (0.4

2) Test DPRAM
A) Decode Test .................... K
B) Marching Test .................. (03¢

3) Test Firmware RAM

A) Decode Test page[H 700 - H 71f] .......... (03¢

B) Marching Test page[H 700 - H 71f] ......... K

RENESAS

Description

Test program start
message. Vx.x shows the
version nunber.

Shows that the PC
interface board is
correctly installed in
the host conputer.

Shows that the E6000 is
correctly connected to
the host conputer.

Shows the I D nunber of
the I ower board of the
E6000 (al ways 5).

Shows the I D nunber of
the middle board of the
E6000 (al ways 0d).

Shows the revision nunber
of the upper board of the
E6000 (al ways 6).

Shows the check results
for the registers in the
E6000 (nor mal
conpl etion).

Shows the results of
decodi ng test and
marching test for the
dual -port RAMin the
E6000 ( nor mal

conpl etion).

Shows the results of
decoding test for the
firmware RAMin the E6000
(normal conpl etion).

Shows the results of
marching test for the
firmware RAMin the E6000
(normal conpl etion).
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4) Test Trace nenory

A) Decode Test page[H 000 - H 04f] (Lower 32K)
B) Marching Test page[H 000 - H 04f] (Lower 32K)
C) Decode Test page[H 000 - H 04f] (Upper 32K)
D) Marching Test page[H 000 - H 04f] (Upper 32K)
5) Test Map control menory

A) Decode Test page[H 200 - H 27f] ........
B) Marching Test page[H 200 - H 27f] ........
6) Test Internal ROM and RAM

A) Decode Test (Internal ROM ............ (0.6
B) Marching Test (Internal ROV ............ K
C) Decode Test (Internal RAM ............ (0.4
D) Marching Test (Internal ROV ............ (03¢
7) RESEVED

8) Test Emul ation
A) Step Operation

9) Test Keybreak

A

Key Break ....

RAM STEP Operati on

10) Test Emul ati on RAM Har dwar e Break

A
B)

GRD Break ....
WPT Break ....
C) WPT(ROM Break
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Shows the results of
decoding test for the
trace RAM (first half) in
t he E6000 (nor nal

conpl etion).

Shows the results of
marching test for the
trace RAM (first half) in
t he E6000 (nor nal

conpl etion).

Shows the results of
decoding test for the
trace RAM (last half) in
t he E6000 ( nor nal

conpl etion).

Shows the results of
marching test for the
trace RAM (last half) in
t he E6000 ( nor nal

conpl etion).

Shows the results of
decoding test for the
mappi ng RAM i n the E6000
(normal conpl etion).

Shows the results of
marching test for the
mappi ng RAM in the E6000
(normal conpl etion).

Shows the results of
decodi ng test and
marching test for
internal ROM and RAM in
t he E6000 ( nor nal

conpl etion).

Shows the check results
for the step execution
controlling circuits in
t he E6000 ( nor nal

conpl etion).

Shows the check results
for the forced break
controlling circuits in
t he E6000 (nor nal

conpl etion).

Shows the check results
for the illegal access
break controlling
circuits in the E6000
(normal conpletion).



11) Test Internal ROM Wite-Protect

A) Wite-Protect ......................

12) Test Hardware Break

A)Break Point Initialized ............
B) Event Detectors CES channel 1-12 ...
C) Test Sequencing 1 ..................
D) Check Range Break ..................
E) Range Break Test for Data ..........
F) Check Conpare Either ...............

13) Test Emul ati on RAM Trace

A)Free Trace .........................
B)Range Trace ................oou.unn
C)Point to Point Trace ...............
D) Start and Stop Event Trace .........
E) Trace menory Overflow ..............
F) Time STAMP Trace (20MHz) ...........
G Time STAWP Trace (10MHz) ...........
H) Ti me STAMP Trace (TEST node)........

14) Test Runtine counter

A)Runtime counter (20.0MHz) ..........
B) Runtime counter (10.0MHz) ..........

O Runtine counter (SUB:32.768kHz)

15) Test Emul ation Monitor

AVENA23-EMAD . . oottt e
B) ACST2- ACSTO ..ottt e e e
C) ASEST3-ASESTO . ..\ ooeeee e
D) ASEBRKACK . . ..o\ttt
E) ONN ottt

16) Test PERFM G A

ATime MeASUre ...t e
B)RESERVED . ...\t e e
C) Subroutine Count Measurement ..............
D) Ti meout Function (TIMOT Bit) ..............
E) Ti meout Function (TIMOP Bit) ..............

17) Test Bus Monitor

A) Register.................... .. ..
B) Parallel RAM ........ ... .. ...,
€ SPRSEL2......... ...t
D) RAMmonitor................... i,

RENESAS

Shows the check results
for the internal ROM
Wite-protection
controlling circuits in
t he E6000 (nor nal

conpl etion).

Shows the check results
for the hardware break
control circuits in the
E6000 ( nor mal
conpl etion).

Shows the check results
for the trace controlling
circuits in the E6000
(normal conpl etion).

Shows the check results
for the run-tine counter
in the E6000 (normal
conpl etion).

Shows the check results
for the enulation nonitor
controlling circuits in
t he E6000 (nor nal

conpl etion).

Shows the check results
for the perfornmance
anal ysis controlling
circuits in the E6000
(normal conpl etion).

Shows the check results
for the bus nonitor
controlling circuits in
t he E6000 (nor nal

conpl etion).
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18) Test Parallel Access Shows the check results
for the parallel access

A)Internal ROM Parallel Read Access(WORD) ....... (04 ¥ . N N

B)Internal ROM Parallel Wite Access(WORD) ...... K controlling circuits in

C)Internal ROM Parallel Wite Access(H gh Byte) .OK the IEeo,OO (nor mal

D) Internal ROM Parallel Wite Access(Low Byte) ..OK conpl etion).

E)Internal RAM Paral l el Read Access(WORD) ....... K

F)Internal RAM Parallel Wite Access(WORD) ...... (04

G lInternal RAM Parallel Wite Access(H gh Byte) .OK

H Internal RAM Parallel Wite Access(Low Byte) ..OK

|') RESERVED

J) RESERVED

K) RESERVED

L) RESERVED

19) Test H8S/ 2268 Regi ster Read/Wite Shows the check results

A) Regi Ster Real. .. .....ooooeeeeeeeee i X forSlthereg|ster |ntlhe

B) Register Decode Test...................... K H8 2268 group (norna

C) LCDRAM Marching Test...................... K conpl etion).

D) Register Reset...............oiiiiiunn... K

E) Medi um speed npde Register access......... K

20) Test Bus Monitor Shows the check results

A) REGI SLET. .o X for the TMR4 r egi ster

B) Parallel RAM ..............oiiiiininnnn... oK (nor nmal COITp| eti On) .

C SPRSEL2......... .. i (0.8

D) RAMIMONIi tOr. ...t (04

Tests run for xH xM xS Shows the check tine.

0 total errors Total nunber of errors.

Tests passed, emulator functioning correctly Shows that the E6000 is
correctly operating.
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