
Microcontroller Development Tools

www.softecmicro.com C
op

yr
ig

ht
 ©

 2
00

7 
So

fT
ec

 M
ic

ro
sy

st
em

s™
. D

C
01

27
8

D
es

ig
ne

d 
by

So
fT

ec
 M

ic
ro

sy
st

em
s™

 a
nd

 th
e 

So
fT

ec
 M

ic
ro

sy
st

em
s 

lo
go

 a
re

 tr
ad

em
ar

ks
 o

f S
of

Te
c 

M
ic

ro
sy

st
em

s 
S.

p.
A

.
Fr

ee
sc

al
e™

 a
nd

 th
e 

Fr
ee

sc
al

e 
lo

go
 a

re
 tr

ad
em

ar
ks

 o
f F

re
es

ca
le

 S
em

ic
on

du
ct

or
 In

c.
 

A
ll 

ot
he

r p
ro

du
ct

 o
r s

er
vi

ce
 n

am
es

 a
re

 th
e 

p
ro

p
er

ty
 o

f t
he

ir 
re

sp
ec

tiv
e 

ow
ne

rs
. 

SK-S12XDP512-A
Quickstart Tutorial
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Install CodeWarrior
Development Studio

The Starter Kit comes with a free version of CodeWarrior Development Studio 
Special Edition. 

CodeWarrior Development Studio is a powerful and easy-to-use tool suite 
designed to increase your software development productivity. Its Integrated 

Development Environment (IDE) provides unrivaled fea-
tures such as Processor Expert application design 

tool, full chip simulation, Data Visualization and 
project manager with templates to help you 

concentrate on the added value of your 
application.

To install the CodeWarrior Develop-
ment Studio Special Edition, insert 
the CodeWarrior CD-ROM into 
your computer’s CD-ROM drive. A 
startup window will automatically 
appear. Follow the on-screen 
instructions.

Note: the Starter Kit requires that 
a CodeWarrior version equal to or 

greater than 4.5 is present on your 
system. If you have an earlier version 

on your system, you must uninstall it and 
install the new CodeWarrior version which 

comes with the Starter Kit. If you purchased an 
earlier CodeWarrior version, we advise you to con-

tact Freescale to have your license extended to the new 
version.

Install Additional 
Components

 
Power up the Board

The power connector accepts a 12 V DC, wall plug-in power supply with a 2.1 
mm pin and sleeve plug with positive in the center and sleeve as ground. 
Make sure the “VDD ENA” jumper is inserted. The voltage is internally regu-
lated to 5.0 V DC.

The green “POWER” LED on the board should turn on.

Make sure that all of the Starter Kit’s jumpers are set to their factory position.

Start CodeWarrior Development Studio by selecting Start > Programs 
> Freescale CodeWarrior > CW for HC12 > CodeWarrior IDE. The 
CodeWarrior IDE will open.

 From the main menu, choose “File > Open”.

Select the “Demo.mcp” workspace file that is located under the “\Program 
Files\Freescale\CW for HC12\(CodeWarrior_Examples) \HCS12X\SofTec 
Microsystems\SK-S12XDP512-A\Demo” directory.

Click “Open”.

The C code of this example is 
contained in the “main.c” file. 
Double click on it to open it.

Found New
Hardware Wizard

Run CodeWarrior and
Open the Example

The first time the Starter Kit is connected to the PC, Windows recognizes the in-
strument and starts the “Found New Hardware Wizard” procedure, asking you 
to specify the driver to use for the instrument. 

The procedure is slightly different on each version of Windows. On Windows XP, 
select the “Install the software automatically” option and click on the “Next” 
button.

Be sure not to specify any drive or optional location where to look for the driver, 
since it has already been installed on your hard disk by the SK-S12XDP512-A 
Starter Kit Additional Components setup.

Note: both Windows 2000 and Windows 
XP may issue a warning during the “Found 
New Hardware Wizard” procedure. This 
warning is related to the fact that the USB 
driver used by the Starter Kit is not digital-
ly signed by Microsoft, and Windows con-
siders it to be potentially malfunctioning 
or dangerous for the system. However, you 
can safely ignore the warning, since every 
kind of compatibility/security test has been 
carried out by SofTec Microsystems. 

Connect the Board
to the PC

Insert one end of the USB cable into a free USB port.

Insert the other end of the USB cable into the USB connector on the Starter Kit 
board.

Start a Debugging
Session

From the main menu, choose “Project > Debug”. This will compile the source 
code, generate an executable file and will download it to the demo board.

A new debugger environment will open. 

 
Run the Example

From the main menu, choose “Run > Start/Continue”. The program will be 
executed in real-time.

Press the “PB4” push-button. The output of the light sensor will be displayed 
on the two dot-matrix displays, in a graphic way. The light sensor is placed on 
the right of the “PB4” push-button. Cover the sensor with a finger and see the 
effect on the displays.

Congratulations!

For the latest software releases,
new products, new supported devices, 

discussion forums and FAQs,
log on to

http://www.softecmicro.com/

You have successfully completed this tutorial! You can 
continue to experiment with the CodeWarrior user interface 
and discover by yourself its potentialities.

For an in-depth guide of all of the user interface features, 
select Help > CodeWarrior Help from the CodeWarrior IDE’s 
main menu.

Please also read carefully all of the Starter Kit documenta-
tion.

The SofTec Microsystems Additional Components install all of the other re-
quired components to your hard drive. These components include the Starter 
Kit USB driver, the software plug-in for CodeWarrior, examples and documen-
tation in PDF format.

To install the SofTec Microsystems Additional Compo-
nents, insert the SofTec Microsystems “System 

Software” CD-ROM into your computer’s 
CD-ROM drive. A startup window will auto-

matically appear. Choose “Install Instru-
ment Software” from the main menu. 

A list of available software will appear. 
Click on the “SK-S12XDP512-A 
Starter Kit Additional Compo-
nents” option. Follow the on-
screen instructions.

Note: to install the SK-S12XDP512-A 
Starter Kit Additional Components 
on Windows 2000 or Windows XP, you 

must log in as Administrator.

USB TO BDM

USBUSB

RESET ENARESET ENA

BKGD ENABKGD ENA

BDM

BDMBDM

GNDGND

ATD REF

VDDAVDDA

USERUSER

VRH SELVRH SEL

GNDGND

USERUSER

VRL SELVRL SEL

MCU SET

MODA=1MODA=1 MODB=1MODB=1

11

00

MODCMODC

11

00

VREGENVREGEN

SERIAL SETTINGS

LINLIN

RS-232RS-232

RS-232_0/
LIN0 SEL
RS-232_0/
LIN0 SEL

LINLIN

RS-232RS-232

RS-232_1/
LIN1 SEL
RS-232_1/
LIN1 SEL

LINLIN

CANCAN

CAN3/
LIN3 SEL
CAN3/
LIN3 SEL

RS-232

RS-232_0RS-232_0 RS-232_1RS-232_1

GND

DCEDCE

DTEDTE

SCI0 DTE/
DCE SEL
SCI0 DTE/
DCE SEL

DCEDCE

DTEDTE

SCI1 DTE/
DCE SEL
SCI1 DTE/
DCE SEL

RESETRESET

LVD
ENA
LVD
ENA

RESET

OUTPUTS

R
O
W
 
E
N
A

R
O
W
 
E
N
A

PA6PA6

COL ENACOL ENA

PA5PA5
PA4PA4
PA3PA3
PA2PA2
PA1PA1
PA0PA0

P
D
4

P
D
4

P
D
3

P
D
3

P
D
2

P
D
2

P
D
1

P
D
1

P
D
0

P
D
0

P
C
4

P
C
4

P
C
3

P
C
2

P
C
2

P
C
1

P
C
1

P
C
0

P
C
0

PB3PB3
PB2PB2
PB1PB1
PB0PB0LE

D
 
E
N
A

LE
D
 
E
N
A

LIN SUPPLY
ENA
LIN SUPPLY
ENA

LIN2_TX
ENA
LIN2_TX
ENA

LIN2_RX
ENA
LIN2_RX
ENA

LIN4_TX
ENA
LIN4_TX
ENA

LIN4_RX
ENA
LIN4_RX
ENA

LIN5_TX
ENA
LIN5_TX
ENA

LIN5_RX
ENA
LIN5_RX
ENA

12V12V

LIN
NETWORK
LIN
NETWORK

TRANSCEIVER
SUPPLY SEL
TRANSCEIVER
SUPPLY SEL LIN

MASTER
NODE5 ENA
MASTER

NODE5 ENA
MASTER

NODE3 ENA
MASTER

NODE3 ENA

MASTER
NODE4 ENA
MASTER

NODE4 ENA
MASTER

NODE2 ENA
MASTER

NODE2 ENA
MASTER

NODE0 ENA
MASTER

NODE0 ENA

MASTER
NODE1 ENA
MASTER

NODE1 ENA

LIN0LIN0

LIN1LIN1 LIN3LIN3 LIN5LIN5

LIN2LIN2 LIN4LIN4

I/OI/O

LOGICLOGIC

FLEXRAY

Freescale code:
EVB9S12XDP512
Freescale code:
EVB9S12XDP512

SofTec Microsystems code:
SK-S12XDP512-A
SofTec Microsystems code:
SK-S12XDP512-A

GNDGND RESETRESET

JTAGJTAG
PROTOTYPE AREA

GNDGND

12
V

12
V

VDDVDD

MC9S12XDP512

XCLKS#=0XCLKS#=0
CRYSTALCRYSTAL

MCU

CRYSTALCRYSTAL

CLOCKCLOCK

OSC SELOSC SEL

LOOP
FILTER
LOOP
FILTER

USERUSER
XFC SELXFC SEL

GNDGND

CLOCKCLOCK

CAN

CAN0CAN0

CAN1CAN1 CAN3CAN3 CAN4CAN4CAN2CAN2

CAN0_TX ENACAN0_TX ENA

CAN0_RX ENACAN0_RX ENA

CAN1_TX ENACAN1_TX ENA

CAN1_RX ENACAN1_RX ENA

CAN4_TX ENACAN4_TX ENA

CAN4_RX ENACAN4_RX ENA

CAN2_RX ENACAN2_RX ENA

CAN2_TX ENACAN2_TX ENA

GNDGND

U401U401

U406U406

CANL0 SELCANL0 SEL

U401

U406U406

CANH0 SELCANH0 SEL

U402U402

U407U407

CANH1 SELCANH1 SEL

U402U402

U407U407

CANL1 SELCANL1 SEL

INPUTS

PAD10 PB7 PB6 PB5 PB4

ENA

PAD11ENA

POWER 
SUPPLY

VDD ENAVDD ENA

GNDGND

12V12V POWERPOWER

USB TO BDM

USBUSB

RESET ENARESET ENA

BKGD ENABKGD ENA

BDM

BDMBDM

GNDGND

ATD REF

VDDAVDDA

USERUSER

VRH SELVRH SEL

GNDGND

USERUSER

VRL SELVRL SEL

MCU SET

MODA=1MODA=1 MODB=1MODB=1

11

00

MODCMODC

11

00

VREGENVREGEN

SERIAL SETTINGS

LINLIN

RS-232RS-232

RS-232_0/
LIN0 SEL
RS-232_0/
LIN0 SEL

LINLIN

RS-232RS-232

RS-232_1/
LIN1 SEL
RS-232_1/
LIN1 SEL

LINLIN

CANCAN

CAN3/
LIN3 SEL
CAN3/
LIN3 SEL

RS-232

RS-232_0RS-232_0 RS-232_1RS-232_1

GND

DCEDCE

DTEDTE

SCI0 DTE/
DCE SEL
SCI0 DTE/
DCE SEL

DCEDCE

DTEDTE

SCI1 DTE/
DCE SEL
SCI1 DTE/
DCE SEL

RESETRESET

LVD
ENA
LVD
ENA

RESET

OUTPUTS

R
O
W
 
E
N
A

R
O
W
 
E
N
A

PA6PA6

COL ENACOL ENA

PA5PA5
PA4PA4
PA3PA3
PA2PA2
PA1PA1
PA0PA0

P
D
4

P
D
4

P
D
3

P
D
3

P
D
2

P
D
2

P
D
1

P
D
1

P
D
0

P
D
0

P
C
4

P
C
4

P
C
3

P
C
2

P
C
2

P
C
1

P
C
1

P
C
0

P
C
0

PB3PB3
PB2PB2
PB1PB1
PB0PB0LE

D
 
E
N
A

LE
D
 
E
N
A

LIN SUPPLY
ENA
LIN SUPPLY
ENA

LIN2_TX
ENA
LIN2_TX
ENA

LIN2_RX
ENA
LIN2_RX
ENA

LIN4_TX
ENA
LIN4_TX
ENA

LIN4_RX
ENA
LIN4_RX
ENA

LIN5_TX
ENA
LIN5_TX
ENA

LIN5_RX
ENA
LIN5_RX
ENA

12V12V

LIN
NETWORK
LIN
NETWORK

TRANSCEIVER
SUPPLY SEL
TRANSCEIVER
SUPPLY SEL LIN

MASTER
NODE5 ENA
MASTER

NODE5 ENA
MASTER

NODE3 ENA
MASTER

NODE3 ENA

MASTER
NODE4 ENA
MASTER

NODE4 ENA
MASTER

NODE2 ENA
MASTER

NODE2 ENA
MASTER

NODE0 ENA
MASTER

NODE0 ENA

MASTER
NODE1 ENA
MASTER

NODE1 ENA

LIN0LIN0

LIN1LIN1 LIN3LIN3 LIN5LIN5

LIN2LIN2 LIN4LIN4

I/OI/O

LOGICLOGIC

FLEXRAY

Freescale code:
EVB9S12XDP512
Freescale code:
EVB9S12XDP512

SofTec Microsystems code:
SK-S12XDP512-A
SofTec Microsystems code:
SK-S12XDP512-A

GNDGND RESETRESET

JTAGJTAG
PROTOTYPE AREA

GNDGND

12
V

12
V

VDDVDD

MC9S12XDP512

XCLKS#=0XCLKS#=0
CRYSTALCRYSTAL

MCU

CRYSTALCRYSTAL

CLOCKCLOCK

OSC SELOSC SEL

LOOP
FILTER
LOOP
FILTER

USERUSER
XFC SELXFC SEL

GNDGND

CLOCKCLOCK

CAN

CAN0CAN0

CAN1CAN1 CAN3CAN3 CAN4CAN4CAN2CAN2

CAN0_TX ENACAN0_TX ENA

CAN0_RX ENACAN0_RX ENA

CAN1_TX ENACAN1_TX ENA

CAN1_RX ENACAN1_RX ENA

CAN4_TX ENACAN4_TX ENA

CAN4_RX ENACAN4_RX ENA

CAN2_RX ENACAN2_RX ENA

CAN2_TX ENACAN2_TX ENA

GNDGND

U401U401

U406U406

CANL0 SELCANL0 SEL

U401

U406U406

CANH0 SELCANH0 SEL

U402U402

U407U407

CANH1 SELCANH1 SEL

U402U402

U407U407

CANL1 SELCANL1 SEL

INPUTS

PAD10 PB7 PB6 PB5 PB4

ENA

PAD11ENA

POWER 
SUPPLY

VDD ENAVDD ENA

GNDGND

12V12V POWERPOWER

USB TO BDM

USBUSB

RESET ENARESET ENA

BKGD ENABKGD ENA

BDM

BDMBDM

GNDGND

ATD REF

VDDAVDDA

USERUSER

VRH SELVRH SEL

GNDGND

USERUSER

VRL SELVRL SEL

MCU SET

MODA=1MODA=1 MODB=1MODB=1

11

00

MODCMODC

11

00

VREGENVREGEN

SERIAL SETTINGS

LINLIN

RS-232RS-232

RS-232_0/
LIN0 SEL
RS-232_0/
LIN0 SEL

LINLIN

RS-232RS-232

RS-232_1/
LIN1 SEL
RS-232_1/
LIN1 SEL

LINLIN

CANCAN

CAN3/
LIN3 SEL
CAN3/
LIN3 SEL

RS-232

RS-232_0RS-232_0 RS-232_1RS-232_1

GND

DCEDCE

DTEDTE

SCI0 DTE/
DCE SEL
SCI0 DTE/
DCE SEL

DCEDCE

DTEDTE

SCI1 DTE/
DCE SEL
SCI1 DTE/
DCE SEL

RESETRESET

LVD
ENA
LVD
ENA

RESET

OUTPUTS

R
O
W
 
E
N
A

R
O
W
 
E
N
A

PA6PA6

COL ENACOL ENA

PA5PA5
PA4PA4
PA3PA3
PA2PA2
PA1PA1
PA0PA0

P
D
4

P
D
4

P
D
3

P
D
3

P
D
2

P
D
2

P
D
1

P
D
1

P
D
0

P
D
0

P
C
4

P
C
4

P
C
3

P
C
2

P
C
2

P
C
1

P
C
1

P
C
0

P
C
0

PB3PB3
PB2PB2
PB1PB1
PB0PB0LE

D
 
E
N
A

LE
D
 
E
N
A

LIN SUPPLY
ENA
LIN SUPPLY
ENA

LIN2_TX
ENA
LIN2_TX
ENA

LIN2_RX
ENA
LIN2_RX
ENA

LIN4_TX
ENA
LIN4_TX
ENA

LIN4_RX
ENA
LIN4_RX
ENA

LIN5_TX
ENA
LIN5_TX
ENA

LIN5_RX
ENA
LIN5_RX
ENA

12V12V

LIN
NETWORK
LIN
NETWORK

TRANSCEIVER
SUPPLY SEL
TRANSCEIVER
SUPPLY SEL LIN

MASTER
NODE5 ENA
MASTER

NODE5 ENA
MASTER

NODE3 ENA
MASTER

NODE3 ENA

MASTER
NODE4 ENA
MASTER

NODE4 ENA
MASTER

NODE2 ENA
MASTER

NODE2 ENA
MASTER

NODE0 ENA
MASTER

NODE0 ENA

MASTER
NODE1 ENA
MASTER

NODE1 ENA

LIN0LIN0

LIN1LIN1 LIN3LIN3 LIN5LIN5

LIN2LIN2 LIN4LIN4

I/OI/O

LOGICLOGIC

FLEXRAY

Freescale code:
EVB9S12XDP512
Freescale code:
EVB9S12XDP512

SofTec Microsystems code:
SK-S12XDP512-A
SofTec Microsystems code:
SK-S12XDP512-A

GNDGND RESETRESET

JTAGJTAG
PROTOTYPE AREA

GNDGND

12
V

12
V

VDDVDD

MC9S12XDP512

XCLKS#=0XCLKS#=0
CRYSTALCRYSTAL

MCU

CRYSTALCRYSTAL

CLOCKCLOCK

OSC SELOSC SEL

LOOP
FILTER
LOOP
FILTER

USERUSER
XFC SELXFC SEL

GNDGND

CLOCKCLOCK

CAN

CAN0CAN0

CAN1CAN1 CAN3CAN3 CAN4CAN4CAN2CAN2

CAN0_TX ENACAN0_TX ENA

CAN0_RX ENACAN0_RX ENA

CAN1_TX ENACAN1_TX ENA

CAN1_RX ENACAN1_RX ENA

CAN4_TX ENACAN4_TX ENA

CAN4_RX ENACAN4_RX ENA

CAN2_RX ENACAN2_RX ENA

CAN2_TX ENACAN2_TX ENA

GNDGND

U401U401

U406U406

CANL0 SELCANL0 SEL

U401

U406U406

CANH0 SELCANH0 SEL

U402U402

U407U407

CANH1 SELCANH1 SEL

U402U402

U407U407

CANL1 SELCANL1 SEL

INPUTS

PAD10 PB7 PB6 PB5 PB4

ENA

PAD11ENA

POWER 
SUPPLY

VDD ENAVDD ENA

GNDGND

12V12V POWERPOWER



M
ic

ro
co

n
tr

o
lle

r 
D

ev
el

o
p

m
en

t T
o

o
ls

w
w

w
.s

o
ft

ec
m

ic
ro

.c
o

m


